mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ladegerät LPC3625 Schaltplan oder Reparaturtipps


Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LPC3625, Ladegerät mit Mikrocontroller-Steuerung 36V/25A für Blei-Akkus.

Schaltregler pumpt ca. alle 2 Sekunden, dann erreicht Ausgangsspannung 
kurzzeitig 2V und fällt dann wieder ab. Das kurze Zirpen würde ich im 
Trafo der PFC vermuten.

Obligatorisches, wie nachlöten, Elkos und alle großen MKT-Kondensatoren 
ausgelötet und nachgemessen/getauscht habe ich schon gemacht. Auch die 5 
Mosfets IRF740 habe ich ausgelötet und mit einer einfachen LED-Schaltung 
geprüft, sind i.O., Dioden scheinen auch ok zu sein.

Gerät ist eigentlich solide augebaut und war sehr teuer. Hat aktive PFC, 
PWM-Schaltregler und ST62 als µC. Kann Akkus genau nach Ladekennlinie 
laden.

Würde es gerne wieder flott kriegen. Bin aber erstmal nicht weiter 
gekommen. Hat jemand einen Tipp, oder den Schaltplan, auch von ähnlichen 
Geräten, die im Bootsbau gerne eingesetzt werden.

Hersteller ist Lovanger Elektronk AB in Schweden.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias K. schrieb:
> nachlöten, Elkos
z.B.
1. bucklige Elkos sollte man sehen
2. normale Elkos altern auch / Low ESR=?
3. LPC3625+Google=?

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>bucklige Elkos sollte man sehen

sehen normal aus, und alle (außer die SMD) geprüft/ersetzt

>3. LPC3625+Google=?

Nichts brauchbares gefunden, habe auch google.se bemüht, aber ich kann 
nicht mal eine Homepage der Firma finden.

Autor: bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Akkus kaputt?

Versuche mal je die 12 V mit einem Autoladegerät zu laden (in 3 Etappen)
und vergleiche die Ströme.
Gruss Bernd

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias K. schrieb:
> Elkos geprüft/ersetzt
-Wie geprüft? Nur Kapazität reicht nicht. Evtl. sind sie hochohmiger 
geworden?
-Durch 105-Grad-Elkos ersetzt?

Wiki: RESR, der Äquivalente Serienwiderstand, er fasst die ohmschen 
Verluste des Bauelementes zusammen. Dieser Wirkwiderstand wird allgemein 
nur „ESR“ (Equivalent Series Resistance) genannt.

-Evtl. Foto machen ob einer Deine Kiste kennt oder Fehler sieht?

Autor: frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> -Evtl. Foto machen ob einer Deine Kiste kennt oder Fehler sieht?

Gute Idee, Ladegeräte werden gern umgelabelt (zumindest in D.)
frank

Autor: Matthias K. (matthiask)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ist wahrscheinlich ein LEAB Typ.

Hier paar Bilder.

In den rot markierten Bereich der PFC ist es zumindest mal sehr warm 
gewurden. Die 4 Widerstände sind aber ok. In Applicationen zum UC3854 
finde ich leider so einen Schaltungsteil nicht.

Könnte man die PFC versuchsweise komplett deaktivieren?

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die PFC deaktivieren braucht nicht unbedingt zum erfolg führen, ich hab 
das mal mit einem pc-netzteil probiert um die zwei FETs im primärkreis 
des wandlers nutzen zu können (die waren nämlich gestorben) aber der 
regler-ICs fand es nicht toll, daß dann 70V primärspannung fehlen. mit 
zwei neuen FETs alles ok.

auf jeden fall würde ich mal mein interesse an dem ding anmelden wenn du 
es nicht repariert kriegst. schmeiß es also nicht weg und (wenns geht) 
verbastel es nicht zu sehr! :)

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am MIC4427 ist rechts eine Leiterbahn unterbrochen?

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alex schrieb:
> Am MIC4427 ist rechts eine Leiterbahn unterbrochen?

Das war schon, ist gefräst. Vermutlich ein LP-Fehler. Die Verbindung 
schaltet auch nur die beiden Mosfet-Treiber des MIC4427 parallel.

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du mal die spannung des zwischenkreises nach der PFC gemessen?
VORSICHT, 400Vdc!!

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Zwischenkreisspannung ist stabil bei ca. 340V an den beiden großen 
Elkos. Ich habe auch schon den MOSFET der PFC ausgelötet. Dann hört das 
pumpen aller 2s auf, bringt aber keine Änderung.

Autor: frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias K. schrieb:
> Schaltregler pumpt ca. alle 2 Sekunden, dann erreicht Ausgangsspannung
> kurzzeitig 2V und fällt dann wieder ab.

Das kannst Du ja nur ohne angeschlossener Batterie gemessen haben. 
Ladegeräte mit µC Steuerung machen vor dem Laden aber recht umfangreiche 
Prüfungen: Batterie angeschlossen? Batterie nicht teifentladen? etc. Was 
genau wie gemessen wird ist sehr unterschiedlich. Erst nach der 
Initphase wird geladen. Ein Ladegerät ist eben nicht einfach ein 
Netzteil. Ich denke Du kommst nur mit einer garantiert nicht 
tiefentladenen und nicht (ganz) vollgeladen Batterie am Ausgang weiter. 
Aber wahrscheinlich weißt Du das alles selbst und ich habe die 
Fehlerbeschreibung fehlinterpretiert.
frank

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Batterie habe ich nicht dran.

Es müsste auch so wenigestens eine LED leuchten. Der µC-Teil bekommt ja 
nicht mal die Versorgungsspannung um überhaupt die Gelegenheut zur 
Anwesenheitsprüfung der Batterie zu haben.

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm so wie ich das sehe funktioniert die PFC-schaltung schon mal nicht. 
340V sind die gleichgerichtete netzwechselspannung, bei laufender PFC 
müßten es mindestens 380-400V sein.

der hauptwandler ist auch ein recht komplexes teil, dem steuer-IC und 
gleich zwei IR2113 zufolge ein ZVS-vollbrückenwandler.

Autor: frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei älteren Ladegeräten mit konventionellen Trafo wurde die 
Ladesteuerung meist aus der zu ladenden Batterie gespeist. Ich meine, 
dass das bei SNT-Ladegeräten eigentlich nicht mehr üblich ist, aber man 
weiß es ja nicht. Was passiert denn mit angeschlossener Batterie?
frank

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
glaube ich nicht, dann würde das ding keine startversuche im 2s-takt 
machen.

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was passiert denn mit angeschlossener Batterie?

Mit Batterie ging auch nichts mehr.

Der PWM-Wandler ist eine Vollbrücke mit 4x IRF740 und 2 Haupttrafos, 
Zweiweggleichrichtung sekundärseitig mit Schottky-Doppeldiode.

Leider gestaltet sich bei dem Teil auch das nachmessen schwierig, da 
alles mit einen Isolierlack überzogen ist.

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du eigentlich die nötige messausrüstung dafür? trenntrafo und oszi?

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Natürlich am Trenntrafo. Hat leider nur 250W, aber zum testen reicht 
das.

Oszitests habe ich daran noch nicht gemacht, bleibt mir wohl nicht 
erspart.

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schau dir mit dem oszi mal die versorgungsspannung des PWM-controllers 
und des PFC-controllers an.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.