mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem Blinkschaltung TLC555 (von hier)


Autor: Manu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich wollte mir eine Blinkschaltung mit einem NE555 bauen, die Frequenz 
sollte 1/12 Hz (T = 12 s) sein und das an-/aus-Verhältnis 1:1. Dabei 
habe ich einen Thread hier entdeckt, der die Verwendung der 
CMOS-Variante empfiehlt. Also habe ich mit einem TLC555 die Schaltung 
aus diesem Beitrag nachgebaut (linke Seite des angehängten Bildes):
Beitrag "Re: NE556 Blinkschaltung bauen"

Leider funktioniert das nicht wie geplant. Die erste an-Zeit ist länger 
als die folgenden an-Zeiten, und die aus-Zeit ist kürzer als die 
an-Zeiten.

Mein Elko hatte zuerst 470 µF und der Widerstand ca. 18 kΩ. Nach der 
ersten an-Zeit mit etwa 12 s ergaben sich dann aber 8 s/6 s. Ich dachte 
mir nun, die Kapazität ist möglicherweise zu groß und habe sie auf 47 µF 
reduziert und den Widerstand erhöht, das Problem blieb aber.

Betriebsspannung ist übrigens 12 V, und am Ausgang hängt über einen 
Widerstand von 22 kΩ nur die Basis eines BC547.

Wie kann ich das Problem lösen?

Danke im Voraus,
Manu

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manu schrieb:
> Leider funktioniert das nicht wie geplant. Die erste an-Zeit ist länger
> als die folgenden an-Zeiten,

Ist normal und prinzipbedingt.

Manu schrieb:
> Wie kann ich das Problem lösen?

Aufladung und Entladung über Dioden trennen.
Oder:

http://home.cogeco.ca/~rpaisley4/LM555HalfNg.GIF

oder durch die verschiedenen Datenblätter schauen, da sind Beispiele 
drin.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manu schrieb:
> Die erste an-Zeit ist länger als die folgenden an-Zeiten,

Nach dem Einschalten muss der Kondensator erst einmal auf ein Drittel
der Versorgungsspannung aufgeladen werden. Um diese Zeitdauer ist der
erste High-Impuls länger als die folgenden.

> und die aus-Zeit ist kürzer als die an-Zeiten.

Vermutlich macht sich bei der großen Zeitkonstante der Leckstrom des
Elkos bemerkbar, der schon einmal in die µA reichen kann. Dadurch wird
die Ladezeit länger und die Entladezeit kürzer, das Ausgangssignal also
asymmetrisch. Probier mal den größten Nicht-Elko (Folie oder Keramik),
den du herumliegen hast, mit einem entsprechend angepassten Widerstand.

Autor: Manu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhh schrieb:
> Aufladung und Entladung über Dioden trennen.
> Oder:
>
> http://home.cogeco.ca/~rpaisley4/LM555HalfNg.GIF

Hmm... das ist doch genau die Schaltung, die ich verwendet habe, oder 
seh ich das falsch?


Yalu X. schrieb:
> Nach dem Einschalten muss der Kondensator erst einmal auf ein Drittel
> der Versorgungsspannung aufgeladen werden. Um diese Zeitdauer ist der
> erste High-Impuls länger als die folgenden.

Danke für die Erklärung! Ich schätze, das lässt sich auch nicht 
irgendwie umgehen?

Yalu X. schrieb:
> Probier mal den größten Nicht-Elko (Folie oder Keramik),
> den du herumliegen hast, mit einem entsprechend angepassten Widerstand.

Einen WIMA MKS hätte ich mit 1 µF (und passend ein 1 MΩ-Poti). Ist zwar 
vergleichsweise ein riesen Teil, aber Kondensatoren habe ich nur eine 
Hand voll zur Auswahl, die verwende ich zu selten. Also mit dem werde 
ich es mal probieren - danke für deinen Tipp!

Autor: Manu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Habe mich in der Kommastelle für den Widerstand vertan, es 
müssten 10 MΩ sein (nur zur Klarstellung).

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manu schrieb:
> Hmm... das ist doch genau die Schaltung, die ich verwendet habe, oder
> seh ich das falsch?

Sorry, hatte das in Klammern mit linker Schaltung übersehen.

Manu schrieb:
> es
> müssten 10 MΩ sein (nur zur Klarstellung).

Mit welcher Betriebsspannung arbeitest Du? Bei 5V ist das zu hochohmig.

Du kannst auch Anschluss 7 mit PullUp als Ausgang zum Transistor (über 
Basiswiderstand) benutzen. Dadurch hast Du keinerlei Einfluss mehr auf 
die Zeitkonstanten (bei niedrigen Widerstandswerten entscheidens).

Autor: Manu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhh schrieb:
> Mit welcher Betriebsspannung arbeitest Du? Bei 5V ist das zu hochohmig.

12 V, wie im ersten Beitrag vermerkt.

mhh schrieb:
> Du kannst auch Anschluss 7 mit PullUp als Ausgang zum Transistor (über
> Basiswiderstand) benutzen.

Das ist eine gute Idee! Werde ich mit umsetzen.


Gibt es vielleicht, um die Überlänge des ersten Impulses zu begrenzen, 
eine bessere Idee als einen zweiten 555 als Einschaltverzögerung dazu zu 
gesellen?

Autor: Yalu X. (yalu) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Manu schrieb:
> Gibt es vielleicht, um die Überlänge des ersten Impulses zu begrenzen,
> eine bessere Idee als einen zweiten 555 als Einschaltverzögerung dazu zu
> gesellen?

Das kommt darauf an: Die Länge des ersten Impulses hängt vom Ladezustand
des Kondensators beim Einschalten ab. Wenn du davon ausgehen kannst,
dass der Kondensator anfangs immer entladen ist, hilft die Schaltung
oben.

Gegenüber der usprünglichen Schaltung ist das untere Ende des Kondensa-
tors nicht an GND, sondern an einen Spannungteiler zwischen VCC und GND
angeschlossen. Die Dimensionierung erfolgt folgendermaßen:

R3 kann in weiten Grenzen frei gewählt werden. Für R2 muss gelten:

R1 errechnet sich zu

Die Periodendauer ist dann

Wählt man für R2 bspw. die Mitte zwischen R3 und 2·R3, also

dann muss

sein und die Periodendauer ist

Da du eine ziemlich lange Periodendauer brauchst, bietet es sich an, R2
in der Nähe von 2·R3 zu wählen. Das ergibt ein großes R1, so dass du mit
einem kleineren Kondensator auskommst.

Der erste Impuls nach dem Einschalten ist immer ein High-Impuls. Sollte
das Flipflop des 555 nach dem Einschalten zufälligerweise im Low-Zustand
starten, steht der TRIG/THRS-Eingang auf 1/3 der Versorgungsspannung
(also an der unteren Schaltschwelle), so dass das Flipflop direkt nach
dem Einschalten nach High kippt.

Alles Geschriebene ist jedoch blanke Theorie, ich habe die Schaltung
nämlich nicht aufgebaut ;-)

In der Simulation hat sie allerdings genau wie vorgesehen funktioniert.
Falls du auf Probleme stößt, melde dich einfach wieder, dann werde ich
noch einmal darüberschauen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.