mikrocontroller.net

Forum: Compiler & IDEs codeblocks, avr-gcc, Linker-Probleme


Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe heute auf meinem Ubuntu 10.04 codeblocks, avr-gcc und das 
notwendige Zubehör installiert.

Wenn ich ein AVR-Projekt erstelle, funktioniert das auch alles sehr 
schön, aber eine Merkwürdigkeit gibt es doch. Ich poste mal den 
"build-log" aus Codeblocks:
-------------- Build: Debug in cbv4 ---------------

Compiling: main.c
Linking console executable: bin/Debug/cbv4.elf
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libm.so when searching for -lm
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libm.a when searching for -lm
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
Output size is 6,47 KB
Running project post-build steps
avr-size bin/Debug/cbv4.elf
   text     data      bss      dec      hex  filename
    160        0        0      160       a0  bin/Debug/cbv4.elf
avr-objcopy -O ihex -R .eeprom -R .eesafe bin/Debug/cbv4.elf bin/Debug/cbv4.elf.hex
avr-objcopy --no-change-warnings -j .eeprom --change-section-lma .eeprom=0 -O ihex bin/Debug/cbv4.elf bin/Debug/cbv4.elf.eep.hex
avr-objdump -h -S bin/Debug/cbv4.elf > bin/Debug/cbv4.elf.lss
Process terminated with status 0 (0 minutes, 0 seconds)
0 errors, 0 warnings (0 minutes, 0 seconds)

Offensichtlich versucht der avr-linker, mit den (natürlich 
inkompatiblen) Bibliotheken meines Systems zu linken, also 
/usr/lib/libm.so etc.

Ich finde aber nicht raus, wo in codeblocks das definiert ist. Ich habe 
schon alle Options und Preferences abgegrast, nichts zu machen. Zuvor 
hatte ich auch ~/.codeblocks sicherheitshalber gelöscht, keine Änderung.

Wenn ich normal mit dem emacs hantiere, und den avr-gcc mit M-x compile 
aufrufe, ist alles in Butter. Es scheint also wirklich an Codeblocks zu 
liegen. Die Version ist 'svn 6840', 'Build: Nov 7 2010 11:58:36 ...'

Wie an meinem Nick unschwer zu erkennen ist, bin ich hardcore-emacser, 
und werde künftig wahrscheinlich ohnehin nur mit emacs und avr-gdb 
direkt arbeiten - weil mich das IDE-Geraffel eher nervt. Aber es 
beunruhigt mich einfach, wenn es via Codeblocks nicht richtig läuft.

Wer kann mir denn da mal einen Tipp geben ?

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mann Mann Mann! Jetzt hab ich es gefunden. Komisch, dass man sowas immer 
erst findet, wann man wo rumgeheult hat ...

Also für die, die es interessiert:

Beginnend in der Menüleiste oben 'Settings->Compiler and Debugger' 
anwählen.

Dort in der oberen Dropdown-Liste 'GNU AVR GCC Compiler' auswählen.
Den Tab 'Search Directories' anwählen
Den Untertab 'Compiler' anwählen, dann den Button 'Clear' wählen und 
bestätigen.
Dann den Untertab 'Linker' anwählen und wieder den Button 'Clear' wählen 
und bestätigen.

Es ist auf beiden Untertabs übrigens eine Option 'Policy' zu sehen, die 
man aber nicht anwählen kann: 'Use Project options only'. Das wäre 
sicher das Richtige, aber ich weiß im Moment nicht, wie das aktiviert 
werden kann.

Jetzt funktioniert es wie es soll.

Allerdings sind nun die globalen Compilerflags für alle Compilertypen 
geändert, was so eigentlich nicht ganz perfekt ist. Mich stört's nicht, 
weil ich für reguläre, auch sehr große Projekte ansonsten nur den emacs 
nehme.

Vielleicht kennt ja jemand die richtige Lösung für Codeblocks.

Autor: Torsten K. (ago)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter Code::Blocks 10.05 ist es in den Projekteigenschaften:

Menü "Project" -> "Build Options..." - hier kannst du für jedes Projekt 
die Compiler(-eigenschaften) setzen.

Und: Hier kannst du auch die Policy für die verschiedenen Targets wählen 
(Release, Debug, ... was man halt so nicht braucht).

Nachtrag: Da es in den globalen Einstellungen keine Targets gibt, fehlt 
dort ja auch die Policy.

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp, das mit der Policy ist mir jetzt klar. Aber weiter 
komme ich immer noch nicht: Ich habe ein neues Projekt angelegt, und in 
'Project->Properties->Build Targets->Build options' das Target 'Debug' 
ausgewählt, und dort für "Search Directories" für Compiler und Linker 
jeweils "Use target options only" angegeben.

Wenn ich das komplette Compiler Kommando loggen lasse, sieht das so aus:
-------------- Build: Debug in cbv5 ---------------

avr-g++ -L/usr/lib  -o bin/Debug/cbv5.elf obj/Debug/main.o    
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libm.so when searching for -lm
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libm.a when searching for -lm
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: avr:107 architecture of input file `obj/Debug/main.o' is incompatible with avr output
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings (0 minutes, 0 seconds)
 

Wie man sieht, durchsucht der Linker /usr/lib, was falsch ist.

Welche Einstellung müsste ich nach Deiner Anleitung denn genau ändern?

Autor: E. Hermanns (emax)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch mal ein Foto des Dialogs.

Autor: Torsten K. (ago)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nun mal bei mir ein neues Projekt erstellt (Prozessor atmega8), 
und direkt die Einstellungen bei "Search Directories" so eingestellt wie 
du es sagst und das default main.c gebaut. Siehe Bild - alles i.O.

Irgendwie wird bei Dir auch kein avr-gcc aufgerufen wenn ich das richtig 
sehe? Und ich vermisse Angaben wie "-mmcu=atmega8 
-Wl,-Map=bin/Debug/test.elf.map,--cref 
-L/usr/x86_64-pc-linux-gnu/avr/lib -L/usr/avr/lib"

Welche Codeblocks-Version ist denn das bei Dir?

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thorsten,

danke dass Du Dir die Möhe machst. Ich konnte nicht eher anworten, weil 
ich gestern zwischen allen Stühlen hing da div. Flüge sorniert wurden.

> Welche Codeblocks-Version ist denn das bei Dir?

Steht oben:

> Es scheint also wirklich an Codeblocks zu
> liegen. Die Version ist 'svn 6840', 'Build: Nov 7 2010 11:58:36 ...'

also ziemlich "frisch".

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab hier mal die Projektdatei cbv5.cbp angehängt, vielleicht siehst 
Du etwas, was bei Dir anders ist.
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<CodeBlocks_project_file>
  <FileVersion major="1" minor="6" />
  <Project>
    <Option title="cbv5" />
    <Option pch_mode="2" />
    <Option compiler="avrgcc" />
    <Build>
      <Target title="Debug">
        <Option output="bin/Debug/cbv5.elf" prefix_auto="1" extension_auto="0" />
        <Option object_output="obj/Debug/" />
        <Option type="1" />
        <Option compiler="avrgcc" />
        <Option projectLinkerOptionsRelation="1" />
        <Option projectIncludeDirsRelation="1" />
        <Option projectLibDirsRelation="1" />
        <Compiler>
          <Add option="-g" />
        </Compiler>
      </Target>
      <Target title="Release">
        <Option output="bin/Release/cbv5.elf" prefix_auto="1" extension_auto="0" />
        <Option object_output="obj/Release/" />
        <Option type="1" />
        <Option compiler="avrgcc" />
        <Option projectIncludeDirsRelation="0" />
        <Option projectLibDirsRelation="0" />
        <Compiler>
          <Add option="-Os" />
        </Compiler>
      </Target>
    </Build>
    <Compiler>
      <Add option="-Wall" />
      <Add option="-mmcu=atxmega128a1" />
      <Add option="-DF_CPU=16000000UL" />
    </Compiler>
    <Linker>
      <Add option="-mmcu=atxmega128a1" />
      <Add option="-Wl,-Map=$(TARGET_OUTPUT_FILE).map,--cref" />
    </Linker>
    <ExtraCommands>
      <Add after="avr-size $(TARGET_OUTPUT_FILE)" />
      <Add after="avr-objcopy -O ihex -R .eeprom -R .eesafe $(TARGET_OUTPUT_FILE) $(TARGET_OUTPUT_FILE).hex" />
      <Add after="avr-objcopy --no-change-warnings -j .eeprom --change-section-lma .eeprom=0 -O ihex $(TARGET_OUTPUT_FILE) $(TARGET_OUTPUT_FILE).eep.hex" />
      <Add after="avr-objdump -h -S $(TARGET_OUTPUT_FILE) &gt; $(TARGET_OUTPUT_FILE).lss" />
    </ExtraCommands>
    <Unit filename="main.c">
      <Option compilerVar="CC" />
    </Unit>
    <Extensions>
      <envvars />
      <code_completion />
      <lib_finder disable_auto="1" />
      <debugger />
    </Extensions>
  </Project>
</CodeBlocks_project_file>

Autor: Torsten K. (ago)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also erster Test. Ich habe alle Einstellungen aus Deinem Projektfile 
übernommen. Die einzigen Unterschiede bei mir sind:

1) "-mmcu=atxmega128a1" -> bei mir atmega8.

2) "cbv5" heißt bei mir "test"

Und was soll ich sagen... kein Fehler.

Ich habe allerdings eine defekte Toolchain so wie's aussieht, denn mein 
avr-gcc kann atxmega128* nicht.

Ich werde das später noch auf meiner Ubuntu-Möhre testen.

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, vielen Dank für Dein Engagement.

Ich muss mal ein wenig wühlen, bei mir ist das eine Linux-Plattform. 
Vielleicht habe ich irgendwelche Konfigurationsdateien übersehen.

Komisch ist auch, hab ich eben erst bemerkt, dass bei mir

"avr-g++ -L/usr/lib -o bin/Debug/cbv5.elf obj/Debug/main.o"

erscheint, also der C++ Compiler ... :-o
Nur: C++ Konstrukte lehnt er trotzdem ab.

Autor: Torsten K. (ago)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Edgar Hermanns schrieb:
> Ich muss mal ein wenig wühlen, bei mir ist das eine Linux-Plattform.

Bei mir auch (gentoo + ubuntu auf zwei verschiedenen Rechnern)

Edgar Hermanns schrieb:
> "avr-g++ -L/usr/lib -o bin/Debug/cbv5.elf obj/Debug/main.o"

"avr-g++" ist nicht das Problem (erscheint bei mir auch) aber irgendwie 
fehlt bei Dir davor der avr-gcc aufruf, und außerdem steht bei dir 
"-L/usr/lib" das muß aber "-L/usr/avr/lib" sein.

Dir fehlt irgendwie die avrlibs (evtl.)

apt-get install avr-libc binutils-avr

Edit: Bei Ubuntu muß es wohl "-L/usr/lib/avr" sein

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, das ist alles installiert:
# apt-get install avr-libc binutils-avr
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
avr-libc ist schon die neueste Version.
binutils-avr ist schon die neueste Version.
binutils-avr wurde als manuell installiert festgelegt.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 8 nicht aktualisiert.
# 

Autor: Torsten K. (ago)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf dem Ubuntu-Rechner habe ich codeblocks, avrgcc usw. frisch 
installiert und ein neues Projekt erstellt:

-------------- Build: Debug in test ---------------

Compiling: main.c
Linking console executable: bin/Debug/test.elf
/usr/lib/libm.so: file not recognized: File format not recognized
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

So, in Codeblocks unter "Settings" > "Compiler and Debugger..."
Oben Selected Compiler "GNU AVR GCC Compiler" auswählen
unter "Search directories" das "/usr/include" in "/usr/lib/avr/include" 
ändern.

Wie in Beitrag "Code blocks debug Problem" beschrieben dann noch 
unter "Project->Build Options -> Search directories -> Linker" 
sicherstellen, das "/usr/lib/avr/lib" hier hinterlegt ist.

Nun läuft es bei mir auch unter Ubuntu....
Was für ein K(r)ampf

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jou, man muss schon hartnäckig bleiben, das stimmt.

Deine Änderungen habe ich hier so nachvollzogen, und nun sieht auch der 
gcc-Befehl besser aus. Aber es scheint so aus, als hätte ich eine "nicht 
passende" avr-libc:

avr-gcc -L/usr/lib/avr/lib  -o bin/Debug/cbv7.elf obj/Debug/main.o   -mmcu=atxmega128a1 -Wl,-Map=bin/Debug/cbv7.elf.map,--cref -Wl,--section-start=.data=0x801100  
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: skipping incompatible /usr/lib/avr/lib/libc.a when searching for -lc
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: address 0x801100 of bin/Debug/cbv7.elf section `.data' is not within region `data'
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: bin/Debug/cbv7.elf section `.bss' will not fit in region `data'
/usr/lib/gcc/avr/4.3.4/../../../avr/bin/ld: address 0x801100 of bin/Debug/cbv7.elf section `.data' is not within region `data'

Ich muss jetzt mal sehen, ob ich in die /etc/apt/sources.list ein 
bestimmtes Repository für die avr-libc setzen muss.

Hast Du dazu vielleicht eine Information?

Autor: Torsten K. (ago)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Edgar Hermanns schrieb:
> Ich muss jetzt mal sehen, ob ich in die /etc/apt/sources.list ein
> bestimmtes Repository für die avr-libc setzen muss.

Ich habe bei Ubuntu das Standard-Zeug genommen (codeblocks, avr-libc 
usw.) und keine Extra-Repositories eingetragen. Die Kiste läuft also 
quasi out-of-the-box.

Autor: E. Hermanns (emax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, danke. Das werde ich vielleicht auch mal so einstellen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.