mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik KFZ-Ladegerät mit Ladeautomtik aufrüsten


Autor: Martin S. (martin_s16)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein einfaches 12V Eufab-KFZ-Ladegerät des Typs CBC6. Der 
maximale Ladestrom soll 6A betragen. Soweit so gut.
Ausgerüstet ist es mit zwei LEDs, wobei eine für "betriebsbereit" steht 
und die andere für "Akku voll". Allerdings hat diese Anzeige nie 
funktioniert. Selbst wenn der Akku nachweislich voll war (Säureheber), 
leuchtete diese LED nie. Außerdem fing der Akku an zu gasen.
Nun habe ich mir gedacht, dass ich dieses einfache Ladegerät gerne zu 
einem vollautomatischen umrüsten möchte. Dazu habe ich mir bei Conrad 
den Bausatz einer Ladeautomatik geholt 
http://www.conrad.de/ce/de/product/197912/LADEAUTO... 
und bereits an einem regelbaren Labornetzteil abgestimmt.
Da dieser Bausatz eine gesiebte Gleichspannung benötigt, habe ich mal 
das Ladegerät geöffnet und mir die verbaute Schaltung angesehen. Ich hab 
die Schaltung mal per Hand nachgezeichnet und hier als PNG angehängt 
(bitte nicht zu streng sein falls der Schaltplan nicht genau stimmen 
sollte, ich hab einfach versucht anhand der Verbindungen auf der Platine 
den Schaltplan zu zeichnen. So viel Erfahrung mit Elektronik habe ich 
noch nicht, ich aber gerade dabei das zu ändern).
Mangels Multimeter (ich hab es gerade nicht zur Hand) konnte ich den 
Wert des darin verbauten Potis P1 nicht bestimmen, genausowenig um 
welche Dioden es sich handelt.
Was ich aber komisch finde ist, dass der einzige verbaute Elko darin nur 
33uF hat. Das finde ich schon sehr wenig.
Meine Frage ist nun, kann ich nach der Gleichrichtung des Wechselstroms 
durch die Dioden D1, D2, D8 und D9 einen größeren Elko verbauen und im 
Anschluss daran den Bausatz anschließen? Der Rest der originalen 
Schaltung des Ladegeräts wäre dann stillgelegt.
Wenn ich als Faustformel etwa 1000uF pro A ansetze müsste das aber ein 
riesiger Elko sein. Hat das negative Auswirkungen auf den Trafo, bzw. 
sinkt da nicht sie Spannung ab?
Muss ich vor dem Bausatz noch einen Spannungsbegrenzer einbauen? Wenn 
ja, welchen und wo?
Wie würdet ihr die Schaltung verändern, bzw. wo würdet ihr den Bausatz 
einfügen?
Da die Qualität des Scans der Handzeichnung nicht sehr gut ist, habe ich 
das ganze nochmal als .jpg ins Netz gestellt.
Wenn man es vergrößert, dann sieht man auch die Bezeichnung der 
Bauteile. Link dazu hier:
http://img9.imageshack.us/img9/9126/schaltungladegert.jpg

Viele Grüße,
Martin

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Martin,

erstmal danke für Deine gute Zeichnung, ist wesentlich besser als Vieles 
was hier sonst kommt.

Dein Ansatz ist prinzipiell richtig, folgende Tips zur Verbesserung:

a.) Über eine Diode 1N5403 o.ä. und einen Elko 1000uf/35V , 
angeschlossen an + und - des Brückengleichrichters, eine brummarme 
Gleichspannung nur für den Conrad-Bausatz erzeugen.
b.) lediglich den Relaiskontakt des Baustzes in die eigentliche 
Plus-Ladeleitung legen.
c.) bei dieser simplen Ladeautomatik stören oft die Übergangswiderstände 
der Polzangen.
Ich habe die zwei einadrigen Kabel zu dene Zangen durch zwei 2-adrige 
ersetzt, die Ende auf je eien Polzangenhälfte aufgelegt. Somit den 
Ladestrom durch die eine, den Meßabgriff durch die andere 
Polzangenhälfte erledigt (im Prinzip 4-Leiter oder Kelvinmessung, google 
zeigt dazu was)

Damit läuft diese Ladeautomatik seit Jahren zu meiner Zufriedenheit.

Autor: Martin S. (martin_s16)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andrew,

vielen Dank für Deine schnelle Antwort. Freut mich, wenn meine Zeichnung 
verständlich war.
Ich habe noch mal, dank Deiner Anregungen, eine Variante der 
Eingangsschaltung für den Conrad-Bausatz gezeichnet. Verstehe ich das so 
richtig?
Also nach der Gleichrichterschaltung des Ladegeräts parallel einen Elko 
mit 1000uF und dann noch eine Diode bevor der Anschluss an den Bausatz 
erfolgt.
Die 2-adrigen Anschlüsse an die Polklemmen (Kelvinmessung), meinst Du 
das so, wie ich es in der Schaltung des Bausatzes eingezeichnet habe?
Eine Frage habe ich noch zur der von Dir empfohlenen Diode. Du sagtest 
eine 1N5403. Laut Datenblatt verträgt die aber nur einen 
durchschnittlichen Maximalstrom von 3A. Periodische Spitzenströme bis zu 
30A. Reicht das denn? Wäre, da das Ladegerät angeblich bis zu 6A 
Ladestrom abgeben kann, nicht eine Diode der P600-Reihe besser geeignet? 
Laut Datenblatt darf hier der durchschnittliche Maximalstrom 6A 
betragen.
Sehe ich das richtig?
Danke nochmal und viele Grüße,
Martin

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin S. schrieb:
> Hallo Andrew,
>
> vielen Dank für Deine schnelle Antwort. Freut mich, wenn meine Zeichnung
> verständlich war.
> Ich habe noch mal, dank Deiner Anregungen, eine Variante der
> Eingangsschaltung für den Conrad-Bausatz gezeichnet. Verstehe ich das so
> richtig?
> Also nach der Gleichrichterschaltung des Ladegeräts parallel einen Elko
> mit 1000uF und dann noch eine Diode bevor der Anschluss an den Bausatz
> erfolgt.

Nein, a bisserl anders: Die Diode so vor den Elko (also weiter links in 
Deienr Zeichnung setzen), das Du den Elko damit vom Brückengleichrichter 
"abtrennst".

die Spannung am Elko dann direkt für den Conrad-Bausatz.

Den eigentlichen Ladestrom aber direkt vom Brückengleichrichter 
(Relaiskontakt also links  von Elko und Diode anschließen)


Ziel ist es, das NUR der Baussatz die per Elko gesiebte Spannung erhält.


> Die 2-adrigen Anschlüsse an die Polklemmen (Kelvinmessung), meinst Du
> das so, wie ich es in der Schaltung des Bausatzes eingezeichnet habe?

Ja, ich denke das passt so.

> Eine Frage habe ich noch zur der von Dir empfohlenen Diode. Du sagtest
> eine 1N5403. Laut Datenblatt verträgt die aber nur einen
> durchschnittlichen Maximalstrom von 3A. Periodische Spitzenströme bis zu
> 30A. Reicht das denn? Wäre, da das Ladegerät angeblich bis zu 6A
> Ladestrom abgeben kann, nicht eine Diode der P600-Reihe besser geeignet?
> Laut Datenblatt darf hier der durchschnittliche Maximalstrom 6A
> betragen.
> Sehe ich das richtig?

Nein, da der 6A Ladegerätemaiximalstrom ja nach obiger Änderugn nicht 
über die Diode fließt: Deshalb genügt die 1N5403 vollauf.
Vermutlich hätte sogar eine 1N4004 gereicht .-)

Autor: Martin S. (martin_s16)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Andrew Taylor schrieb:

> Nein, a bisserl anders: Die Diode so vor den Elko (also weiter links in
> Deienr Zeichnung setzen), das Du den Elko damit vom Brückengleichrichter
> "abtrennst".
>
> die Spannung am Elko dann direkt für den Conrad-Bausatz.

Ok, danke. Soweit habe ich es verstanden. Dann hat sich natürlich auch 
meine Frage bzgl. der Diode geklärt.

Vielleicht stehe ich momentan auf dem Schlauch, aber irgendwie verstehe 
ich nicht, wo ich die gesiebte Spannung nur auf den Bausatz legen soll.
Der Bausatz selbst holt sich ja quasi den Plus-Strom vom Akku? 
Jedenfalls wenn ich die Schaltung richtig interpretiere. Ich sehe 
nämlich beim Schaltplan rechts vom Relais oben keinen Kreuzungspunkt. 
Kann das sein? Außerdem, so scheint es, ist das auch so beim Blick auf 
den Bestückungsplan. Wo soll denn dann die gesiebte Spannung dem Bausatz 
zur Verfügung gestellt werden? Also wo ist der + -Anschluss?
Wenn das Relais schließt, dann wird doch der Durchgang geschaltet von 
Plus Ladegerät nach Plus Akku. Gleichzeitig zieht sich die Schaltung 
dann ihr "Verbrauchsplus" vom Akku. Ist der Ladeschluss erreicht, öffnet 
das Relais, es fließt kein Ladestrom und die Schaltung verbraucht etwas 
vom Akku, bis die untere Schaltgrenze erreicht ist und das Relais wieder 
schließt. Habe ich doch so richtig verstanden?
Außerdem, wenn ich direkt nach dem Brückengleichrichter, also noch vor 
Diode und Elko den Ladestrom abgreife, dann ist der ja ungesiebt. 
Schadet das denn nicht dem Akku? Und wenn sich die Schaltung ihr Plus 
vom Akku holt, dann ist diese Spannung doch zumindest während des 
Ladevorgangs auch ungesiebt?

Irgendwie bin ich jetzt etwas verwirrt. Deshalb bitte ich um Nachsicht, 
falls meine Fragen zu trivial sind.
Danke auf alle Fälle für Deine Geduld :-)

Viele Grüße,
Martin

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin S. schrieb:
> Andrew Taylor schrieb:
>
>> Nein, a bisserl anders: Die Diode so vor den Elko (also weiter links in
>> Deienr Zeichnung setzen), das Du den Elko damit vom Brückengleichrichter
>> "abtrennst".
>>
>> die Spannung am Elko dann direkt für den Conrad-Bausatz.
>
> Ok, danke. Soweit habe ich es verstanden. Dann hat sich natürlich auch
> meine Frage bzgl. der Diode geklärt.
>
> Vielleicht stehe ich momentan auf dem Schlauch, aber irgendwie verstehe
> ich nicht, wo ich die gesiebte Spannung nur auf den Bausatz legen soll.
> Der Bausatz selbst holt sich ja quasi den Plus-Strom vom Akku?

Das ändern wir ja noch .-)

> Jedenfalls wenn ich die Schaltung richtig interpretiere. Ich sehe
> nämlich beim Schaltplan rechts vom Relais oben keinen Kreuzungspunkt.
> Kann das sein?

Da ist kein Kreuzungspunkt, denn sonst wäre der Relaiskontakt ja 
sinnfrei (denn er wäre überbrückt).

> Außerdem, so scheint es, ist das auch so beim Blick auf
> den Bestückungsplan. Wo soll denn dann die gesiebte Spannung dem Bausatz
> zur Verfügung gestellt werden? Also wo ist der + -Anschluss?

Du trennst im Plan zw. R und Pin11 des IC. D.h. ab IC Pin11 und alles 
was rechts davon ist: Das hängt an der gesiebten Spannung.

> Wenn das Relais schließt, dann wird doch der Durchgang geschaltet von
> Plus Ladegerät nach Plus Akku. Gleichzeitig zieht sich die Schaltung
> dann ihr "Verbrauchsplus" vom Akku. Ist der Ladeschluss erreicht, öffnet
> das Relais, es fließt kein Ladestrom und die Schaltung verbraucht etwas
> vom Akku, bis die untere Schaltgrenze erreicht ist und das Relais wieder
> schließt. Habe ich doch so richtig verstanden?

War richtig verstanden von dir, und wird mit der obigen Änderung ad acta 
gelgt.

> Außerdem, wenn ich direkt nach dem Brückengleichrichter, also noch vor
> Diode und Elko den Ladestrom abgreife, dann ist der ja ungesiebt.
> Schadet das denn nicht dem Akku?

Mit der Frage kanst du im Forum 346 Folgeposts mit konträren Menungen 
erzeugen.-))
 Tatsache ist, da  Hunderttausende Ladegeräte mit ungesiebter Spannung 
arbeiten. Und die Akkus halten dennoch lange genug (etliche Jahre).
Kurz: Da mußt Du Dich nicht drum sorgen.

>
> Irgendwie bin ich jetzt etwas verwirrt. Deshalb bitte ich um Nachsicht,
> falls meine Fragen zu trivial sind.
> Danke auf alle Fälle für Deine Geduld :-)

Versuche es mal wie beschrieben aufzubauen, es sollte dann auf Anhieb 
funktionieren.


>
> Viele Grüße,
> Martin

Autor: Martin S. (martin_s16)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andrew und vielen, vielen Dank für Deine Hilfe!

Ich glaube, jetzt habe ich es verstanden! Wenn ich die Verbindung 
zwischen R2 und Pin 11 des ICs trenne, dann läuft die Schaltung selbst 
mit gesiebter Spannung vom Trafo. Eine Verbindung zum Akku-Plus besteht 
aber nach wie vor (über R2 und Pin 8), so dass ständig die aktuelle 
Spannung des Akkus überwacht werden kann und ggf. das Relais wieder 
anzieht.
Außerdem sinkt der Verbrauch aus dem Akku, da ja nur noch die Spannung 
überwacht wird, aber nicht Strom zur Aufrechterhaltung der Schaltung 
selbst aus dem Akku entnommen wird.
Habe ich das so richtig verstanden? Ich habe die Schaltung mal, so wie 
ich denke, dass es richtig sein könnte, abgeändert. Passt das so?
Aber was passiert mit dem IC während des Ladevorgangs? Über Pin 11 wird 
der IC und der Rest der Schaltung mit gesiebter Spannung versorgt. Aber 
über R2 und Pin 8 kommt doch ungesiebte Spannung in den IC. Schadet das 
nicht?
Mit dem Akku und der ungesiebten Spannung gebe ich Dir recht. Alte 
Geräte noch mit Selen-Gleichrichter haben auch keinen 
Glättungskondensator. Von daher sollte es für den Akkun kein Problem 
sein.

Jetzt habe ich aber noch eine Frage. Es gibt von diesem Bausatz zwei 
Versionen. Welche ich davon habe, kann ich nicht sagen, denn der liegt 
bei mir zu Hause. Bei der zweiten Variante ist die Schaltung etwas 
anders und es sind auch andere ICs verbaut. IC1 ist ein TL 072, IC2 ein 
TL 431CP und IC3 ein CD 4011. Ich hab mal von Conrad einen Scan des 
Schaltplans gemacht und die Linien nachgezeichnet, da die Qualität sehr 
schlecht war. Muss ich, falls ich diese Variante habe, dort nicht die 
Verbindung an zwei Stellen ändern? Also die Verbindung von Akku-Plus zu 
RL1, D1, LED1, C6, C4 und C3 und Pin 8 (IC1)? Diese dann mit der 
gesiebten Spannung versorgen und das Akku-Plus nur noch über R1 und R3 
in die Schaltung einfügen?
Könnte das stimmen, so dass die Spannung des Akkus über Pin 6 und Pin 3 
des IC1 überwacht wird?

Ich danke Dir schon vielmals für Deine Geduld. Aber ich versuche mich 
schnell in die Thematik einzuarbeiten, damit ich hoffentlich nicht allzu 
lange diese "Anfängerfragen" stellen muss.

Viele Grüße,
Martin

Autor: Martin S. (martin_s16)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andrew,

jetzt hatte ich am Wochenende Zeit mir mal meine Version des Bausatzes 
anzuschauen und es ist die Version 2 (08/02 steht auf der Bauanleitung).
Den Schaltplan habe ich jetzt mal eingescannt und etwas verändert, so 
wie ich denke, dass er richtig sein könnte.
Ich versuchs mal zu beschreiben:
Die Verbindung zwischen R1 und R3 habe ich gekappt. Genauso die 
Verbindung RL1 zum Akku-Plus.
Dann habe ich neue Verbindungen eingezeichnet. R1 ist jetzt direkt mit 
Akku-Plus verbunden. Die Akkuspannung versorgt also jetzt über die 
beiden Spannungsteiler R1 und R2 Pin 3 und Pin 6 des Dual-Op-Amp TL072. 
Laut Datenblatt sind das "inverting 2" und "non-inverting 1" input des 
TL072. Der Elko C2 bleibt so wie er ist um Störspitzen des Ladegeräts 
abzumildern.
Über R3, das direkt mit der gesiebten Spannung aus dem Ladegerät 
versorgt wird, werden die obere und untere Schaltschwelle über P1 und P2 
eingestellt. Diese Referenzspannungen sind sind über P1 und P2 mit Pin 2 
und Pin 5 des TL072 verbunden ("inverting input 1" und "non-inverting 
input 2").
Die Spannungsversorgung des TL072 über Pin 8 erfolgt direkt vom 
Ladegerät über die Siebung. Genauso der Rest des Bausatzes.
Wie ich im vorigen Post schon gemutmaßt habe, könnte es damit sein, dass 
in der "Überwachungsphase", also wenn das Relais die Ladeverbindung 
getrennt hat und die Spannung überwacht wird, der Bausatz weniger Strom 
aus dem Akku zieht?
Schau Dir doch mal die Zeichnung an, ob es so passen könnte.

Viele Grüße,
Martin

Autor: Kalle S. (kallebmw)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi zusammen,
vor Jahren habe ich die gleiche Schaltung des Bausatzes mal nachgebaut. 
Anbei die Dateien....

Kalle

Autor: Martin S. (martin_s16)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Kalle,

Dein Vorschlag ist ja interessant! Du hat also den Originalentwurf 
dahingehend abgeändert, dass bei Dir die Auswertschaltung und die 
Stromversorgung des Op-Amp TL072 nach wie vor vom Akku-Plus versorgt 
wird, aber die Magnetspule des Relais vom Ladegerät-Plus versorgt wird. 
Bei Erreichen der unteren Schaltschwelle wird dann Masse über T1 
aufgeschaltet. Habe ich das richtig verstanden?
Was ist denn Deiner Meinung nach der Vorteil es so zu schalten? Zum 
einen gegenüber dem Originalentwurf, denn der Strombedarf der Schaltung 
aus dem Akku-Plus bleibt ja gleich und zum anderen gegenüber meinem 
Entwurf (falls meiner so überhaupt funktioniert).

Viele Grüße,
Martin

Autor: Martin S. (martin_s16)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

übrigens, ich bin mir mittlerweile nicht mehr so sicher ob mein 
Vorschlag zur Abänderung der Schaltung so toll ist! Nicht dass ich über 
R1 und den Eingangstransistoren des Op-Amps dann die Schaltung mit Strom 
versorge und die Schaltung Schaden nehmen könnte.
Dann wäre eigentlich auch der zusätzliche Siebelko nicht mehr notwendig, 
denn, so wie ich die Schaltung verstehe, ist für eine gesiebte Spannung 
des Bausatzes der Elko C5 (220uF) zuständig. Man könnte ihn vielleicht 
durch einen etwas größeren ersetzen. Aber muss man das denn? Wenn ich 
den Bausatz, so wie er ist einsetze, dann reicht doch eigentlich auch 
ein direkter Anschluss an die Gleichrichterdioden des Ladegeräts?
Außerdem ist die Leerlaufspannung, wenn das Relais offen ist, doch 
vermutlich höher als 15V, so dass das den ICs nicht besonders gut tun 
würde. Wenn überhaupt, dann müsste ich noch eine Spannungsbegrenzung 
einbauen oder?


@ Kalle:
Welchen Vorteil hat denn Deine Schaltungsvariante gegenüber der von 
Conrad? Außerdem, ist bei Dir nicht auch die Leerlaufspannung ohne Akku 
eigentlich zu hoch für T1, auch wenn sie über R10 gedämpft wird? Oder 
tut ihm das nichts, solange nicht das Schaltungsplus des Transistors vom 
TL072 und dem CD 4011 freigegeben ist?

Irgendwie bin ich jetzt mehr verwirrt als vorher....

Viele Grüße,
Martin

Autor: Kalle S. (kallebmw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Martin,

- aus meiner Sicht ist es egal woher der Plus-Zweig zur Relaisversorung 
kommt: entweder vom Plus Gleichrichter oder von den +12V Batterie

- die Leerlaufspannung am T1 ist bestimmt nicht so hoch wie die max. 
zulässige Spannung des T1.

Hinweis:
Ich habe die Schaltung in ein billiges handelsübliches 4A Ladegerät 
eingebaut. Funktioniert Ok. Hatte nur einmal das Problem, dass ich den 
Akku aus Dummheit verpolt angeschlossen hatte > IC defekt. Getauscht und 
alles wieder OK.

Dann hatte ich durch Zufall ein Industrieladegerät der Feuerwehr zu 
reparieren. Diese Phasenanschnittssteuerung hatte ich mir "raus 
gezeichnet" und nachgebaut. Funktioniert super.

Falls Bedarf besteht, könnte ich dies hier einstellen oder soll ich 
einen neuen Beitrag dazu eröffnen?

Kalle

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kalle S. schrieb:
> Falls Bedarf besteht, könnte ich dies hier einstellen oder soll ich
>
> einen neuen Beitrag dazu eröffnen?

Ein neuer  Thread wäre sinnvoller, zumal man dann das Thema gezielt in 
die Kopfzeile schreiben kann - und findet es ggfs. leichter per 
Suchfunktion.

Dein Plan wäre also sehr willkommen.

Autor: Kalle S. (kallebmw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.