mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Einbinden Spice file in LTSpice SWCad


Autor: Jaepen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich möchte mir gerne eine H-Brücke mit LTSpice oder SWCad mit einem 
IRF530N simulieren.

Nun habe ich folgendes Spice File gefunden:

http://www.irf.com/product-info/models/SPICE/irf530n.spi

Kann mir jemand sagen wie ich dieses in LTSpice oder SW CAD einbinde 
kann.
Ich hab natürlich schon gesucht und verschiedene Wege gefunden aber 
irgendwie funktioniert das nicht richtig.

Vielen Dank!

Gruß Jaepen

: Verschoben durch Admin
Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anleitung
---------

Symbol nmos auf dem Schaltplan platzieren.

Cursor über dieses Bauteil schieben.
Ctrl rechte Maustaste klicken.
-> Ein Dialogfenster geht auf. Prefix:MN nach Prefix:X ändern
OK drücken

Cursor über den Text "nmos" am platzierten Bauteil schieben.
Rechte Maustaste klicken. "nmos" durch IRF530N ersetzen.

Schaltplan speichern.

In das gleiche Verzeichnis die Datei irf530n.spi kopieren.

Im Schaltplan die folgende SPICE-Direktive einfühen um die Datei 
einzubinden.

.inc irf530n.spi

Schaltplan speichern.

Fertig!

Autor: Jaepen (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Auch wenn es etwas gedauert hat habe ich das nun endlich mal versucht.
Ich bekomme aber immer die Fehlermeldung:

Fatal Error: Could not open include file "irf530n.spi"


Was mache ich da falsch?

MFG

Jaepen

Autor: Jaepen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bins nochmal und nehme alles zurück.

Den Fehler hab ich gefunden. (Man sollte sich die Dateiendungen immer 
einblenden)

Hab jetzt aber ein anderes Problem:


Unknown subcircuit called in:
xm1 p001 n002 irf530n


???

MFG


Jaepen

Autor: Jaepen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also ich habe noch immer das gleiche Problem beim Einbinder der *.spi 
dateien.
Kennt keiner da ne lösung?

Gruß Jens

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Häng deine Dateien hier an. Dann hast du 5 Minuten später die Lösung.

Autor: Ottmar K. (wil1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

schau mal hier:
[Beitrag "Schaltung als Bauteil speichern"]
so gehts....

Gruss Ottmar

Autor: Ottmar K. (wil1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Jaepen

...war wieder mal eine kleine Übung, den IRF530n in LTSpice zu 
integrieren
Die Dateien habe ich Dir samt test.asc angehängt.

Melde Dich, falls was nicht wie gewünscht funktioniert

Gruss
Ottmar

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal die Methode mit dem normalen nmos Symbol. Damit spart man sich 
ein extra Symbol zu machen. Man muss dabei nur den Prefix im Symbol auf 
X setzen. Siehe mein vorheriger Beitrag.

Die Filenamen für Modelle können beliebig sein. Die müssen nicht mit 
.sub enden.

Autor: Ottmar K. (wil1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Helmut
..klar, es gibt ja nicht nur (m)EINE Methode zum Einbinden von Modellen 
:-)
Ottmar

P.S. Eine Frage an den Experten:
Gibt es eigentlich so was wie die yahoo.group für LTspice auch in 
deutscher Sprache?

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Ottmar,
es gibt keine spezfische Gruppe für LTspice in deutsch. Ich selber bin 
als Moderator der weltweiten Yahoo group schon völlig ausgelastet. 
Deshalb will ich auch in keiner weiteren LTspice group groß tätig sein. 
Das können von mir aus andere machen.
Gruß
Helmut

Autor: Olaf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Gibt es eigentlich so was wie die yahoo.group für LTspice auch in
> deutscher Sprache?

Die Sprache ist doch eigentlich egal, wichtig ist nur das man nicht 
Mitglied bei der doofen Yahoofirma werden muss.

Olaf

Autor: Phillip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jaepen schrieb:
> Ich bins nochmal und nehme alles zurück.
>
> Den Fehler hab ich gefunden. (Man sollte sich die Dateiendungen immer
> einblenden)
>
> Hab jetzt aber ein anderes Problem:
>
> Unknown subcircuit called in:
> xm1 p001 n002 irf530n
>
> ???
>
> MFG
>
> Jaepen

Schau im Ordner nach wo die Files .asc und .spi gespeichert sind.
Beider Dateinamen muessen gleich sein!

Also:

irf530n.spi
irf530n.asc

Autor: Gerd (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

kann mir jemand helfen, dieses Modell zum Laufen zu bekommen?

Ich schaffe es einfach nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.