mikrocontroller.net

Forum: www.mikrocontroller.net Forum "vergisst" gelesene Beiträge.


Autor: nicht "Gast" (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi..

mir gefällt ja die möglichkeit, bei diesem schönen forum unkompliziert, 
ohne anmeldung lesen und schreiben zu dürfen (danke dafür!!), und 
deswegen schaue ich hier gerne 2-3x am tag rein, um einfach in 
bestimmten threads zu lesen, was ich interessant finde..

wenn ich nen link anklicke und durchlese, ist er dann ja als "besucht" 
markiert, rechts in der übersicht ist dann bei "letzer beitrag" das 
datum schwarz, wenn nix neues da ist.. wenn ich den thread nochmal 
anklicke, werde ich dann an die stelle geführt, wo ich den letzten 
beitrag gelesen habe.. ob ich nen thread gelesen habe, sehe ich auch 
daran ,dass im ff der link ne andere farbe hat (is ja nix 
ungewöhnliches)

mir passiet aber in regelmäßigen abständen, dass das forum die 
"besuchten" links  nicht mehr speichert, und alle besuchten threads 
resettet..ich darf dann threads mit 100 beiträgen von ganz oben 
betrachten, und die stelle suchen, wo ich aufgehört habe zu lesen..

ich habe zuerst gedacht, es läge an den einstellungen vom FF, aber da 
euer forum die einzige seite zu sein scheint, die irgend was vergisst, 
habe ich meine zweifel.. ist beim forum irgendwas so eingestellt, dass 
es sporadisch resettet wird?


thx..

Autor: Sam .. (sam1994)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das dürfte aber an der Chronik von Firefox liegen, die speichert wo du 
warst.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du immer brav Deine Cookies wegwirfst, dann passiert das.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist bekannt. Ich habe gerade eine die Änderung live 
geschaltet mit der ich es schon seit einer Weile beheben wollte: die 
gelesenen Beiträge werden nun bei unangemeldeten Benutzern clientseitig 
gespeichert, nicht auf dem Server. Ich hoffe dass das Problem damit 
erledigt sein sollte; bitte melden falls nicht.

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
War wohl irgendwie kontraproduktiv. Bei mir erscheinen jetzt 
grundsätzlich alle Beiträge als gelesen, auch ganz neue.

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit Opera geht's immer noch.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Icke ®. schrieb:
> War wohl irgendwie kontraproduktiv. Bei mir erscheinen jetzt
> grundsätzlich alle Beiträge als gelesen, auch ganz neue.

Bei mir auch. Schade.

...

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit aktivem Javascript gehts. Vorher auch ohne -> Rückschritt :-(

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Das Problem ist bekannt. Ich habe gerade eine die Änderung live
> geschaltet mit der ich es schon seit einer Weile beheben wollte: die
> gelesenen Beiträge werden nun bei unangemeldeten Benutzern clientseitig
> gespeichert, nicht auf dem Server. Ich hoffe dass das Problem damit
> erledigt sein sollte; bitte melden falls nicht.

Rückmeldung: Problem ist nicht erledigt.

Weder im Gast- noch im angemeldeten Modus.

Autor: Schwarzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle Beiträge in den Diskussionen schwarz markiert.

FF 3.6.15
Noscript aktiv (Javascript nicht erlaubt)
Cookies erlaubt

Autor: MWS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir geht das.
Opera 10
Java Script ein
Cookies ein

Ist doch kein Problem als seitenspezifische Einstellung Javascript für 
mikrocontroller.net zu erlauben.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne JavaScript geht es im Moment nicht. Für angemeldete Benuter lässt 
sich das evtl. ändern, für unangemeldete aber nicht, denn die 
clientseitige Datenspeicherung basiert auf JavaScript.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Opera 11, Cookies ein, JS ein: geht nicht. Lande in teilweise gelesenen 
Seiten immer oben.

Autor: MWS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A. K. schrieb:
> Lande in teilweise gelesenen
> Seiten immer oben.

Stimmt, das geht bei mir auch nicht, wobei mir das nicht wichtig ist. 
Mein voriges Post bezog sich auf die farbliche Markierung gelesener 
Beiträge.

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann ich bestätigen.
Tritt aber nicht bei alles Threads auf.

Ich hab diesen Beitrag 2 mal aufgerufen. Das erste mal bin ich oben 
gelandet, beim zweiten Aufruf(!) dann am ungelesenen Post.
Beitrag "Suche Partner für Innovatives Projekt!"

Bei diesem Beitrag hats auf Anhieb funktioniert.
Beitrag "OPV mit Offsetkorrektur gesucht - LM741 noch zeitgemäß?"


Nachtrag: bei Threads, bei denen ich fälschlicherweise am Seitenanfang 
lade, funktionieren Mausgesten oder Tastaturkombinationen erst, wenn ich 
noch einmal mitten in das Browserfenster klicke.
Da verliert wohl etwas den Fokus.

Autor: Schwarzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ist doch kein Problem als seitenspezifische Einstellung Javascript für
> mikrocontroller.net zu erlauben.

Habe ich bisher nicht untersucht bzw. brauchte es nicht zu untersuchen., 
weil es bisher problemlos ohne JS ging.

Man müsste sich ansehen, ob ausgeschlossen ist, dass JS von Dritten 
unter der Flagge von mikrocontroller.net segelt. Das könnte JS in Ads, 
JS in Forum-Uploads und JS in Wiki-Artikeln betreffen.

Autor: Peter Diener (pdiener) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich finde die clientseitige Speicherung nicht so praktisch, ich arbeite 
an mehreren verschiedenen Rechnern. Die wissen dann nichts von einander, 
an einem Rechner gelesene Beiträge sind an den anderen als ungelesene 
Beiträge markiert.

FF 3.6.15 mit No-Script sorgt selbst im angemeldeten Zustand ohnehin 
dafür, dass alle Beiträge als gelesen angezeigt werden.

Mein Fazit: Vorher wars besser.

Grüße,

Peter

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter Diener schrieb:
> Ich finde die clientseitige Speicherung nicht so praktisch, ich arbeite
> an mehreren verschiedenen Rechnern.

Die gilt nur für unangemeldete Benutzer, da war es vorher auch schon so 
dass der Zustand nur für einen Browser gespeichert wurde. Der 
Unterschied ist, dass die Speicherung jetzt clientseitig erfolgt, nicht 
über einen Cookie identifiziert auf dem Server.

> FF 3.6.15 mit No-Script sorgt selbst im angemeldeten Zustand ohnehin
> dafür, dass alle Beiträge als gelesen angezeigt werden.

Da hilft es im Moment nur JS zu erlauben.

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir funktioniert die Erkennung der gelesenen Beiträge jetzt gar 
nicht mehr. Javascript ist aktiviert und ich bin angemeldet.
Ich habe nur zwei der Beiträge im Bild gelesen.

Die Erkennung wo im Diskussionsfaden der neue Beitrag ist funktioniert 
aber mit #new.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter Diener schrieb:
> Mein Fazit: Vorher wars besser.

Schließe ich mich an.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:

> Da hilft es im Moment nur JS zu erlauben.

Welche Hosts müsste man denn erlauben?  Davon abgesehen, dass ich
angemeldet bin (und es trotzdem nicht geht), mikrocontroller.net
ist erlaubt, nur google-analytics.com und googleadservices.com sind
es nicht.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So wie es jetzt ist, macht es keinen Spaß mehr, mit Barrierefreiheit hat 
das nichts zu tun.

...

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jaaaja, meine güte leute... wüwüwüwüüüwüüwüwüü.

es ist neu und ihr habt die große ehre, mitglieder "der breiten masse" 
zu sein, an der jetzt das erste mal getestet wird.
die neuerung funktioniert noch nicht so wie gedacht - aber wisst ihr 
was? andreas weiß das auch! doch wirklich!

schrott wie "früher wars besser" und der mist über meinem post* werden 
sicherlich helfen, die fehler zu beheben.....



*
Hannes, entschuldige, aber dein Post hat den Charakter eines Kinds in 
der Trotzphase.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Lux schrieb:
> So wie es jetzt ist, macht es keinen Spaß mehr, mit Barrierefreiheit hat
> das nichts zu tun.

Bitte installiere dir doch mal zumindest den IE6 (sic). Support für den 
IE5 ist echt nicht mehr lustig.

Autor: Informierter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Lux (hannes) schrieb:

> So wie es jetzt ist, macht es keinen Spaß mehr, mit Barrierefreiheit hat
> das nichts zu tun.

Finde ich auch. Ist mal ein anschauliches Beispiel wie man ein Forum 
verschlimmbessern kann.

Übersicht seit dem gleich Null und nee, cookies sind nicht abgeschaltet.

Autor: Informierter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halt, alles zurück mit dem IE scheint es zu gehen. OK, muss erst noch 
mal schauen ..

Autor: Informierter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem Firefox geht es komischerweise nicht.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Hannes Lux schrieb:
>> So wie es jetzt ist, macht es keinen Spaß mehr, mit Barrierefreiheit hat
>> das nichts zu tun.
>
> Bitte installiere dir doch mal zumindest den IE6 (sic). Support für den
> IE5 ist echt nicht mehr lustig.

Es geht doch gar nicht um IE, mit Firefox 2.0 gehts doch auch nicht.
Ein neuerer FF läuft nicht unter W98SE.
Ein neurers OS läuft nicht auf dem Internet-Lappi (Toshiba SP 4270).
Neue bzw. modernere Hardware werde ich mir wegen diesem Forum nicht 
zulegen.

...

Autor: Schwarzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ein neuerer FF läuft nicht unter W98SE.

Das kann man aber ändern. Mit KernelEx 
(http://kernelex.sourceforge.net/) läuft auch mit kleinen 
Einschränkungen (http://kernelex.sourceforge.net/wiki/Mozilla_Firefox) 
auch ein 3.*er FF unter W98SE

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H. schrieb:
> jaaaja, meine güte leute... wüwüwüwüüüwüüwüwüü.
>
> es ist neu und ihr habt die große ehre, mitglieder "der breiten masse"
> zu sein, an der jetzt das erste mal getestet wird.
> die neuerung funktioniert noch nicht so wie gedacht - aber wisst ihr
> was? andreas weiß das auch! doch wirklich!
>
> schrott wie "früher wars besser" und der mist über meinem post* werden
> sicherlich helfen, die fehler zu beheben.....
>
>
>
> *
> Hannes, entschuldige, aber dein Post hat den Charakter eines Kinds in
> der Trotzphase.

Achnee, Du musst es ja wissen, repariere Du erstmal Deine Shift-Taste, 
ehe Du mich schräg anquatscht (siehe Forenregeln)...

Ich habe lediglich geäußert, dass es so, wie es jetzt ist, keinen Spaß 
mehr macht, da es einfach nicht funktioniert.

Ich habe damit nicht gesagt, dass früher alles besser war.

Und ich habe auch nicht gesagt, dass man es auch übertreiben kann, den 
Browser zu vergewaltigen. Weniger Formatierungsvorschrift ist manchmal 
mehr, dann greifen evtl. auch die eigenen Einstellungen betreffs 
Schriftgröße, Farbe, usw, also das, was man unter Barrierefreiheit 
zusammenfassen kann. Es gibt nämlich auch Leute, die bereits aus der 
Pubertät raus sind und mit dieser oder jener Einschränkung (Behinderung) 
leben müssen. Tip: Werd bloß nicht alt, sonst könntest Du die Welt 
vielleicht mal mit anderen Augen sehen.

...

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Lux schrieb:

> Es geht doch gar nicht um IE, mit Firefox 2.0 gehts doch auch nicht.
> Ein neuerer FF läuft nicht unter W98SE.

Es geht auch mit 3.x-er Firefox nicht.

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Lux schrieb:
> Ich habe lediglich geäußert, dass es so, wie es jetzt ist, keinen Spaß
> mehr macht, da es einfach nicht funktioniert.
Und du meinst, das zu Kund tun müssen, weil es sonst keiner merkt?

> zusammenfassen kann. Es gibt nämlich auch Leute, die bereits aus der
> Pubertät raus sind und mit dieser oder jener Einschränkung (Behinderung)
So viel nehmen wir uns beim Alter nicht.

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Hannes Lux schrieb:
>
>> Es geht doch gar nicht um IE, mit Firefox 2.0 gehts doch auch nicht.
>> Ein neuerer FF läuft nicht unter W98SE.
>
> Es geht auch mit 3.x-er Firefox nicht.

Auch der Firefox 4.0 hält alle Beiträge bereits für gelesen.

Komischerweise geht es mit dem IE 8.0. Dort ist alles wie gehabt. 
Ungelesene Beiträge erscheinen in rot.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Hannes Lux schrieb:
>
>> Es geht doch gar nicht um IE, mit Firefox 2.0 gehts doch auch nicht.
>> Ein neuerer FF läuft nicht unter W98SE.
>
> Es geht auch mit 3.x-er Firefox nicht.

Al in meinem 3.5er geht es... hab wohl eine Microcontroller 
Spezialversion ;)

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> Jörg Wunsch schrieb:
>> Hannes Lux schrieb:
>>
>>> Es geht doch gar nicht um IE, mit Firefox 2.0 gehts doch auch nicht.
>>> Ein neuerer FF läuft nicht unter W98SE.
>>
>> Es geht auch mit 3.x-er Firefox nicht.
>
> Al in meinem 3.5er geht es... hab wohl eine Microcontroller
> Spezialversion ;)

Linux?

Unter W7 geht es nicht.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man muss ja wirklich nicht immer das Neueste haben, aber wer noch mit 
WIN98(!?!) rumeiert, hat nichts, aber auch gar nichts anderes verdient. 
Aber danke für den Feierabend-Lacher, ich lach ja immer noch. Dann auch 
noch rummeckern...Das find ich bisschen schade. Manche Leute sind 
einfach zu geil ;-)

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Platinenschwenker .. schrieb:
>> Al in meinem 3.5er geht es... hab wohl eine Microcontroller
>> Spezialversion ;)
>
> Linux?
Debian Squeeze mit Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.1.16) 
Gecko/20110302 Iceweasel/3.5.16 (like Firefox/3.5.16)

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei gehts mal und mal nicht - ich benutze Opera unter Ubuntu 10.04

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> Platinenschwenker .. schrieb:
>>> Al in meinem 3.5er geht es... hab wohl eine Microcontroller
>>> Spezialversion ;)
>>
>> Linux?
> Debian Squeeze mit Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.1.16)
> Gecko/20110302 Iceweasel/3.5.16 (like Firefox/3.5.16)

Ein schlichtes "ja" hätte mir auch gereicht ;-).

Ansonsten tja, merkwürdig. Unter Linux geht es demnach wohl, unter 
Windows 7 + FF nicht, wohl aber unter Windows 7 + IE 8.0.

Autor: Frank P. (mauz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Platinenschwenker .. schrieb:
> Ein schlichtes "ja" hätte mir auch gereicht ;-).
Naja das wäre dann aber schon sehr viel weniger Information. Und:

> Unter Linux geht es demnach wohl, …
stimmt so simpel eben nicht. Bei mir geht die Landung auf dem ersten 
ungelesenen, aber die Farbgebung in der Threadliste geht nicht.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.15) Gecko/20110307 
Mandriva Linux/1.9.2.15-0.1mdv2010.2 (2010.2) Firefox/3.6.15

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frank P. schrieb:

>> Unter Linux geht es demnach wohl, …
> stimmt so simpel eben nicht. Bei mir geht die Landung auf dem ersten
> ungelesenen, aber die Farbgebung in der Threadliste geht nicht.

So ist es bei mir ebenso, Firefox 3.0 und 3.5, Linux und FreeBSD,
egal ob angemeldet oder nicht, Javascript freigeschaltet oder nicht.

Ach nein, angemeldet und Javascript verboten, dann geht nichtmal mehr
der Sprung zum ersten ungelesenen Artikel.

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Frank P. schrieb:
>
>>> Unter Linux geht es demnach wohl, …
>> stimmt so simpel eben nicht. Bei mir geht die Landung auf dem ersten
>> ungelesenen, aber die Farbgebung in der Threadliste geht nicht.
>
> So ist es bei mir ebenso, Firefox 3.0 und 3.5, Linux und FreeBSD,
> egal ob angemeldet oder nicht, Javascript freigeschaltet oder nicht.
>
> Ach nein, angemeldet und Javascript verboten, dann geht nichtmal mehr
> der Sprung zum ersten ungelesenen Artikel.

Oh man Jörg, du hast mich da gerade auf was wichtiges hingewiesen. 
Javascript!. Es ist schon so in Fleisch und Blut übergegangen hier im 
Forum kein Javascript zu benötigen, dass ich völlig übersehen habe das 
mal im NoScript freizuschalten und siehe da, es geht.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bevor das zu unübersichtlich wird, bitte ganz kurz nur folgende 
Informationen:
- Browserversion
- Eingeloggt: ja/nein
- JavaScript für mikrocontroller.net erlaubt: ja/nein
- Springen zum neuen Beitrag funktioniert: ja/nein
- Markierung neuer Beiträge in Threadliste funktioniert: ja/nein

Wie schon gesagt, ich werde es noch so einrichten dass JavaScript für 
angemeldete Benutzer NICHT mehr nötig ist. Für Gäste allerdings schon.

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Browserversion: Firefox 4.0
- Eingeloggt: ja
- JavaScript für mikrocontroller.net erlaubt: ja (in NoScript 
freigeschaltet)
- Springen zum neuen Beitrag funktioniert: ja
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Browserversion: Opera/9.80 (X11; Linux x86_64; U; de) Presto/2.7.62
  Version/11.01 unter Ubuntu 10.04
- Eingeloggt: ja
- JavaScript für mikrocontroller.net erlaubt: ja
- Springen zum neuen Beitrag funktioniert: mal gehts, mal gehts nicht.
  Habe bisher keine Systematik erkennen können.
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Was komisch ist: Wenn auf den ersten Beitrag positioniert wurde, und ich 
manuell nach unten geblättert habe, muß ich den Back-button im Browser 
zweimal drücken, um wieder in die Thread-Liste zu kommen.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Was komisch ist: Wenn auf den ersten Beitrag positioniert wurde, und ich
> manuell nach unten geblättert habe, muß ich den Back-button im Browser
> zweimal drücken, um wieder in die Thread-Liste zu kommen.
Liegt vermutlich daran, das zunächst die Seite geladen wird (Back 1), 
dann kommt das JS und "lädt" die Seite nochmal (diesmal mit der Referenz 
auf den letzten Beitrag) --> (Back 2).
Verhindert könnte man das, indem in der Threadübersicht ber JS schon der 
korrekte Link eingetragen wird, und nicht erst wenn man einen Beitrag 
anwählt, mag aber wiederum andere Nachteile haben...

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Bevor das zu unübersichtlich wird, bitte ganz kurz nur folgende
> Informationen:
> - Browserversion
> - Eingeloggt: ja/nein
> - JavaScript für mikrocontroller.net erlaubt: ja/nein
> - Springen zum neuen Beitrag funktioniert: ja/nein
> - Markierung neuer Beiträge in Threadliste funktioniert: ja/nein

Szenario 1:

. Firefox 3.0
. ja
. ja
. ja
. nein

Szenario 2:

. Firefox 3.0
. nein
. ja
. weiß nicht
. nein

Szenario 3:

. Firefox 3.5
. ja
. nein
. nein
. nein

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Browserversion: Firefox 4.0 (dito Windows 7)
- Eingeloggt: probeweise nein
- JavaScript für mikrocontroller.net erlaubt: ja (in NoScript
freigeschaltet)
- Springen zum neuen Beitrag funktioniert: ja
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Firefox Windows XP -  genaue Version kann der Admin diesem Beitrag 
entnehmen: Beitrag "Re: (V)erkaufe Depletion Mode MOSFETs Supertex DN2450N8"
- Eingeloggt: ja
- JavaScript für mikrocontroller.net erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Firefox 3.6.15 Windows 7
- Eingeloggt: ja
- JavaScript für mikrocontroller.net erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja, aber nur das erste mal. 
Wenn ich den Diskussionfaden ein weiteres Mal öffne springt er nach ganz 
oben.
- Markierung neuer Beiträge in Threadliste funktioniert: nein, siehe 
Bild oben.

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alexander Schmidt schrieb:

> - Springen zum neuen Beitrag funktioniert: ja, aber nur das erste mal.
> Wenn ich den Diskussionfaden ein weiteres Mal öffne springt er nach ganz
> oben.

Aber das ist doch ein normales Verhalten. Er springt nach einem neuen 
Posting bei Aufruf zu diesem Posting. Dann gilt der Thread erstmal als 
gelesen und springt folglich bei abermaligem Aufruf zum ersten 
Beitrag. Das halte ich für nicht tragisch. War das nicht schon immer so? 
Ich meine ja ..

PS: daran merkt man übrigens auch selber, dass man den Beitrag schon mal 
gelesen hat (indem er eben nicht zum letzten, aktuellen Beitrag 
springt)

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sämtliche Probleme mit Firefox (3.0+) sollten jetzt behoben sein. Falls 
immer noch etwas schief geht, bitte melden.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Sämtliche Probleme mit Firefox (3.0+) sollten jetzt behoben sein. Falls
> immer noch etwas schief geht, bitte melden.

Angemeldet + !JavaScript funktioniert nach wie vor noch nicht,
zumindest nicht mit dem FF 3.0 hier (3.5 kann ich erst heute abend
probieren).  Mit JavaScript funktioniert's jedoch wieder.

Autor: Skua (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe auch das Doppelt zurück Problem.(sehr nervig)
Version 11.01

Build 1190

Plattform Win32

Betriebssystem Windows XP

Javascript ein

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei meinem Opera setzt er (angemeldet, JS ein) bei 
Beitrag "Sicherheit von AKWs bei Erdbeben" 
nach wie vor nicht auf den ersten ungelesenen Beitrag.

Bei anderen Threads (durchweg kürzeren) funktioniert es zuweilen, aber 
auch nicht immer.

Ich habe die Seitenaufteilung nicht eingeschaltet.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Bei meinem Opera setzt er (angemeldet, JS ein) bei
> Beitrag "Sicherheit von AKWs bei Erdbeben"
> nach wie vor nicht auf den ersten ungelesenen Beitrag.

Bei mir auch, allerdings hatte ich das bislang drauf geschoben, dass
ich die Seiteneinteilung eingeschaltet habe, die Seite 10 jedoch noch
nicht im Index auftaucht.

Dieser Thread scheint aus irgendeinem Grund der einzige zu sein, dessen
Thread-URL nicht die Nummer des Threads, sondern einen Namen besitzt.
Vermutlich hängt der Effekt irgendwie damit zusammen.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In diesem Thread hier hat die Positionierung eben gerade auch nicht 
funktioniert.

Nachtrag: und ich kam nach dem Schreiben mit dem ersten Browser-Back an 
den Threadanfang und erst mit dem zweiten zurück in die Threadliste.

Autor: oszi40 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, bisher ist alles durch Verschlimmbesserung nur langsamer 
geworden.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der Spalte "Antworten" in der Threadliste wird seit neustem das 
Eingangsposting mitgezählt.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Uhu Uhuhu schrieb:
>> Bei meinem Opera setzt er (angemeldet, JS ein) bei
>> Beitrag "Sicherheit von AKWs bei Erdbeben"
>> nach wie vor nicht auf den ersten ungelesenen Beitrag.
>
> Bei mir auch, allerdings hatte ich das bislang drauf geschoben, dass
> ich die Seiteneinteilung eingeschaltet habe, die Seite 10 jedoch noch
> nicht im Index auftaucht.

Mit dem Auftauchen der Seite 10 im Index funktioniert für mich dort
jetzt alles.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir funktioniert die Positionierung jetzt auch wieder.

Allerdings wird noch immer das Eingangsposting bei den Antworten 
mitgezählt.

Autor: Schwarzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> In der Spalte "Antworten" in der Threadliste wird seit neustem das
> Eingangsposting mitgezählt.

Bei mir seltsamerweise nicht.

FF 3.6.16
Noscript aktiv (Javascript nicht erlaubt)
Cookies erlaubt

Autor: Platinenschwenker .. (platinenschwenker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schwarzer schrieb:

> Bei mir seltsamerweise nicht.
> Noscript aktiv (Javascript nicht erlaubt)

Ohne Javascript geht es nicht.

"mikrocontroller.net erlauben" einschalten.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im AKW-Thread funktionierte gerade die Positionierung wieder nicht mehr. 
(Opera, angemeldet + JS eingeschaltet)

Hier ging es auch nicht: 
Beitrag "Tarnkappen Technologie"

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Opera und Firefox sollten jetzt keine Probleme mehr auftreten.

Uhu Uhuhu schrieb:
> Allerdings wird noch immer das Eingangsposting bei den Antworten
> mitgezählt.

Ist korrigiert.

oszi40 schrieb:
> Sorry, bisher ist alles durch Verschlimmbesserung nur langsamer
> geworden.

Was soll das und der Screenshot aussagen? Was genau ist langsamer 
geworden?

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Sämtliche Probleme mit Firefox (3.0+) sollten jetzt behoben sein. Falls
> immer noch etwas schief geht, bitte melden.

Mit dieser Kombination läuft es immer noch nicht:
- Firefox Windows XP -  genaue Version kann der Admin diesem Beitrag
entnehmen: Beitrag "Re: (V)erkaufe Depletion Mode MOSFETs Supertex 
DN2450N8"
- Eingeloggt: ja
- JavaScript für mikrocontroller.net erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Mit IE9 geht es dagegen.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alexander Schmidt schrieb:
> - Springen zum neuen Beitrag funktioniert: ja
> - Markierung neuer Beiträge in Threadliste funktioniert: ja

Und was funktioniert NICHT? :)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:

> Was genau ist langsamer
> geworden?

Ich habe zumindest den Eindruck, dass das Laden langer Threads
(wie dem zu Fukushima) trotz eingeschalteter Seitenaufteilung
länger dauert als früher.

Andreas Schwarz schrieb:
> Und was funktioniert NICHT? :)

Angemeldeter Nutzer ohne JavaScript.  Ich vermute, das hast du
bislang einfach noch nicht wieder implementiert.

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Und was funktioniert NICHT? :)
Sorry.

- Firefox 3.6.15 Windows 7
- Eingeloggt: ja
- JavaScript global erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja,
- Markierung neuer Beiträge in Threadliste funktioniert: nein, Ergebnis 
immer noch wie im Bild oben. 
http://www.mikrocontroller.net/attachment/104842/M...

Edit: Mit Firefox 3.6.16 Windows 7 geht es auch nicht.

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jetzt hats auch bei mir zugeschlagen (den ganzen Tag gings): alle 
Beiträge gelten als gelesen.

- Browserversion: FF 3.6.16
- Eingeloggt: ja
- JavaScript für mikrocontroller.net erlaubt: ja
- Springen zum neuen Beitrag funktioniert: nein
- Markierung neuer Beiträge in Threadliste funktioniert: nein

heute hatte ich einmal gesehen, dass in "Threads mit meinen Beiträgen" 
erst alles scwarz war und dann immer mehr rot wurde.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vlad Tepesch schrieb:
> heute hatte ich einmal gesehen, dass in "Threads mit meinen Beiträgen"
> erst alles scwarz war und dann immer mehr rot wurde.
Das ist auch so, die Markierung kommt erst durch das JS.

Eventuell könnte ja mal jemand der "geht nicht"-Leute sich FireBug 
installieren und dann in der Fehlerkonsole schauen ob es Probleme gibt?
Das "blöde" an JS ist nämlich, das die gesamte Ausführung beim ersten 
Fehler abbricht wenn man keine speziellen Vorkehrungen trifft, eventuell 
kommt es zu einem merkwürdigem Fehler der mit dem Usernamen 
zusammenhängt und er kommt gar nicht mehr zur "Markierungsfunktion".

Autor: Frank P. (mauz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fall 1:
- Firefox 3.6.15 Mandriva2010.2
- Eingeloggt: ja
- JavaScript global erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja,
- Markierung neuer Beiträge in Threadliste funktioniert: nein

Konsole Firebug:
globalStorage is null
http://www.mikrocontroller.net/javascripts/combined-top.js?1300971973
Line 16

Fall 2:
- Firefox 4 RC12 OpenSuse11.4
- Eingeloggt: ja
- JavaScript global erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja,
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Ich hoffe Ihr könnt damit was anfangen.
frank

Autor: Frank P. (mauz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt gehts auch mit Firefox 3.6.15 Mandriva2010.2, Fehler in der 
Firebugkonsole ist auch weg.
Danke
frank

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frank P. schrieb:
> globalStorage is null
Das sollte zumindest nicht auftreten, eventuell noch ein Bug in der 
aktuellen jQuery Version, ob Andreas das eine angepasste Version nutzt 
kann ich jetzt aufgrund der Kompression leider schwerlich feststellen ;P

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es funktioniert wieder, Danke Andreas.
Gestern waren in der Firefox Fehlerkonsole noch einige Fehler drinnen, 
heute ist nichts mehr.

- Firefox 3.6.16 Windows 7
- Eingeloggt: ja
- JavaScript global erlaubt: ja
- Springen zum neuen Beitrag funktioniert: ja
- Markierung neuer Beiträge in Threadliste funktioniert: ja

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frank P. schrieb:
> globalStorage is null

Danke für den Hinweis, das Problem sollte jetzt endgültig behoben sein.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> eventuell noch ein Bug in der aktuellen jQuery Version

Nein, das war ein Fehler in meinem eigenen Code.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter "Einstellungen" -> "Eigene Beiträge" ist immer noch alles
schwarz.

Err, nein, es dauert einfach ... zuerst muss die Seite geladen sein,
und erst am Ende pinselt der Javascript-Code offenbar die noch nicht
gelesenen Threads rot ein.  Naja, damit kann man wohl leben. ;-)

: Wiederhergestellt durch Moderator
Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja wenn du auch soooo viele Beiträge geschrieben hat, kein Wunder ;)
Vielleicht wäre es da auch mal Zeit für eine Seitenaufteilung.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.