Forum: Mikrocontroller und Digitale Elektronik Atmega 1284P


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Stefan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich möchte einen Atmega1284P debuggen,benutze Avr Studio 6.1 sowie einen 
jtag Mk II alles auf den neuesten Softwarestand.Wenn ich mein Program 
ins Flash brenne so läuft es,beim debuggen überspringt er aber 
Breakpoints bzw. zeigt Portinhalte falsch an.Hat jemand von euch eine 
Idee was das sein könnte.Hab schon mit dem JTAG Clock rumgespielt,löst 
aber nicht das Problem.

von D. V. (mazze69)


Bewertung
0 lesenswert
nicht lesenswert
Nur mal eine Frage:
Wie groß ist das Programm? Ist es > 64kB?

von holger (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Hat jemand von euch eine Idee was das sein könnte.

Compiler Otpimierung abschalten.

von holger (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Grr

>Otpimierung

Schönes neues Wort;)

Soll heissen: Optimierung

von Stefan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi,
danke für eure Antworten.
Die Compileroptimierung ist aus,das Programm sehr kklein (max. 1K)

von Stefan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Je mehr ich lese um so mehr Fragezeichen...
Wie ist das mit dem jtag MKII?
Wenn ich bei den TOOL Einstellungen "Erase Entire Chip " wähle,löscht er 
dann das Flash Memory des Prozessors?
Wenn ich das nämlich wähle,scheint es zu laufen

von D. V. (mazze69)


Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:
> Wenn ich bei den TOOL Einstellungen "Erase Entire Chip " wähle,löscht er
> dann das Flash Memory des Prozessors?
Nicht nur den, sondern auch das EEPROM. eben "entire"

> Wenn ich das nämlich wähle,scheint es zu laufen
Merkwürden..

von D. V. (mazze69)


Bewertung
0 lesenswert
nicht lesenswert
Zeig mal deinen Aufbau via Foto mitsamt Schaltplan.

von Stefan (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
relevanter schaltplanteil hängt dran.
Der jtagmkii hängt direkt am 10pol Stecker P3

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.