Forum: Analoge Elektronik und Schaltungstechnik Boost Wandler Dau-sicher machen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Led-Quäler (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,
das Teil funktionierte bis eben tadellos, dabei brach ein LED-Anschluss 
und nun isses tot. Die Diode war hin, ausgewechselt und alles wieder 
o.k.
Um das für die Zukunft auszuschliessen, denke ich an eine Z-Diode 20V, K 
an LED+ und A an Pin3 von IC2.
Prinzipiell muss das funktionieren. Nur weiß ich nicht, ob da nicht 
schon der erste Hieb des Wandlers soviel Energie rüberreicht, den OPV zu 
schrotten.

Meinungen dazu?

Der Led-Quäler

von Led-Quäler (Gast)


Angehängte Dateien:

Lesenswert?

Nur um spätpubertierende Junguser zu demotivieren:
Das Dingens ist physikalisch da und funktioniert!

von Helge A. (besupreme)


Lesenswert?

Z-Diode und Widerstand wär sicherer. Oder du mißbrauchst deinen 
Einschalt-Mosfet mit einer z.B. 12V Z-Diode. Is ja nur für bei kaputt.

von Gerd E. (robberknight)


Lesenswert?

Led-Quäler schrieb:
> Nur weiß ich nicht, ob da nicht
> schon der erste Hieb des Wandlers soviel Energie rüberreicht, den OPV zu
> schrotten.

Der erste Hieb nicht, aber die Folgenden: die Z-Diode reagiert erst ab 
20V. Bei 27V (7V Limit am FB-Pin des LM3488 + 20V Abfall über der 
Z-Diode) hast Du ein Problem. Wenn ein Hieb reicht um von 21,5V (20V 
Z-Diode + FB-Sollwert) auf über 27V zu kommen ist das Teil kaputt.

Du hast am FB-Pin den Ausgang von Deinem Opamp dran. Der wird das auch 
nicht mögen. Außerdem regelt der Opamp sofort dagegen und damit dreht 
der LM3488 sofort wieder auf, läuft wieder in die Begrenzung und so 
weiter. Wenn das ganze für diesen Fall eh schon nah am Limit ist, geht 
das nicht lange gut.

Wenn Du dann nen Wackelkontakt hast und die LED wieder an die dann auf 
über 20V geladenen Kondensatoren kommt, kann auch die schnell hinüber 
sein.

Ich würde also sobald die Z-Diode leitet eine Selbsthaltung aktivieren 
(z.B. über 2 Transistoren), die dann dauerhaft etwas über 1,25V auf das 
Feedback legt. Und dann vermutlich R11 etwas erhöhen damit das keinen 
Konflikt mit dem Opamp gibt. Dann einen größeren Widerstand zwischen 
Led+ und Led- damit die Kondensatoren langsam entladen werden wenn keine 
LED dran ist.

Dann musst Du nach dem Fehlerfall spannungsfrei schalten und dann ist 
alles wieder gut.

von Marius S. (lupin) Benutzerseite


Lesenswert?

Wie kommst du denn darauf deine Fotos als GIF zu komprimieren?

Kannst ja mal richtige Fotos machen und das in den Kunstwerke-Thread 
stellen.
Sieht hübsch aus mit der HF-Spule...
Ist die Schaltung denn von dir?

Ich kenne den LM3488 nicht, aber kann man die Strombegrenzung nicht über 
den "I_SEN"-Eingang realisieren?



Gerd E. schrieb:
> Bei 27V (7V Limit am FB-Pin des LM3488 + 20V Abfall über der
> Z-Diode) hast Du ein Problem.

Ich glaube da hast du was missverstanden.
Er will nicht an den FB-Pin des LM3488 sondern an den nicht 
invertierenden Eingang des OPV. Ich sehe da kein Problem. Zur Sicherheit 
vielleicht noch eine Diode vom nicht invertierenden Eingang zur 
Versorgungsspannung.

Du kannst ja vor dem nicht invertierenden Eingang noch einen 
zusätzlichen Widerstand rein schalten. Dann bist du auf der sicheren 
Seite.

Du kannst das ding ja mal offen lassen und schauen wie schnell die 
Ausgangsspannung steigt (wäre einfach mal interessant zu wissen :)).

: Bearbeitet durch User
von Gerd E. (robberknight)


Lesenswert?

Marius S. schrieb:
> Ich glaube da hast du was missverstanden.
> Er will nicht an den FB-Pin des LM3488 sondern an den nicht
> invertierenden Eingang des OPV.

Hast Recht, hab ich falsch verstanden. Ändert aber am Problem nicht 
viel: beim LMC7101 sind maximal Versorgungsspannung + 0.3V am Input 
erlaubt. U_in liegt lt. Plan zwischen 5 und 9V. Im dümmsten Fall geht 
das Problem jetzt also schon bei 5.3V (also 25,3V am Ausgang) los...

: Bearbeitet durch User
von Frank M. (frank_m35)


Lesenswert?

Der LM3488 hat doch eine Strombegrenzung, auf was hast du sie denn 
eingestellt?

Auch bin ich ein bisschen der Meinung, dass du die Bauteile mächtig 
überdimensioniert hast. Der kann bei 1MHz arbeiten, da sieht mir die 
Spule ein klein wenig überdimensioniert aus. Ich habe nichts 
durchgerechnet, kann aber schwer glauben, dass sie nötig ist. Ebenso die 
Diode D1 mit 12A ist fern von gut und böse.
Ein Blick auf die Schaltung vom Evaluation Board:
http://www.ti.com/lit/ug/snva042a/snva042a.pdf
welche mehr Ausgangsleistung bei kleinerer Eingangsspannung liefert, 
zeigt, in welcher Größenordnung die Bauteile eigentlich sein müssten.

Auch ist mir der Sinn der Ausgangs-Keramikkondensatoren schleierhaft, 
zumal du komischerweise Y5V gewählt hast und somit mit 25V mächtig 
unterdimensioniert hast.
http://www.edn.com/design/analog/4402049/2/Temperature-and-voltage-variation-of-ceramic-capacitors--or-why-your-4-7--F-capacitor-becomes-a-0-33--F-capacitor

Vielleicht übersehe ich auch nur irgendwas, auf jeden Fall will ich 
nicht meckern, sondern dich nur darauf hinweisen, dass du dir vielleicht 
das Leben zu schwer gemacht hast und durch die fette Spule etc. der 
Wandler träger arbeitet als er könnte.

von Gerd E. (robberknight)


Lesenswert?

Wenn ich grad so drüber nachdenke hier noch nen besserer 
Lösungsvorschlag:

Nimm statt der Z-Diode nen TL431. Mit nem Spannungsteiler von Led+ nach 
Led- und Ref-Eingang vom TL431 stellst Du die Schwellspannung ein. 
Gleichzeitig entläd der Spannungsteiler langsam die Kondensatoren.

An der Kathode vom TL431 nen Widerstand nach Vcc und zur Basis von nem 
PNP. Mit dem PNP gehst du auf dein Eingang von Deinem Opamp um damit den 
Schaltregler abzuschalten.

Gleichzeitig legst Du vom Ausgang des PNP nen R zum Ref-Eingang des 
TL431 um ne knackige Hysterese festzulegen, aus dem Bauch raus würde ich 
mal mit 10K anfangen zu probieren.

Wenn Die Spannungsteiler die Kondensatoren so weit entladen haben daß 
die Spannung unter die Hystereseschwelle sinkt, wird automatisch der 
Schaltregler wieder angeworfen. So bekommst Du Selbsthaltung mit 
automatischer Wiedereinschaltung.

Sorry für die Schaltungsprosa, bin gerade zu faul das aufzumalen. Die 
Beschaltung des TL431 mit PNP und Hysterese kannst Du Dir hier 
anschauen:
Beitrag "Re: Verpolungs- und Überspannungsschutz mit P-MOSFET"

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.