Forum: Analoge Elektronik und Schaltungstechnik 0-10V Analog für FU mit 5V


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo in die Runde,
ich möchte für einen FU ein Analoges 0-10V Signal erzeugen, µC ist ein 
Atmega 2560. Hab hier einiges gelesen aber meistens wird es da mit einer 
Hilfsspannung ~12V, OP und RC-Glied gelöst. Gibt es da eine elegante 
Möglichkeit es über PWM und der vorhandenen 5V Versorgung zu 
realisieren?

Ladungspumpe oder der gleichen? Es geht wirklich "nur" darum es mit der 
5V Versorgung zu lösen, wenn es nicht geht OK. ;)

grüße mr.T

: Verschoben durch Admin
von Georg G. (df2au)


Bewertung
0 lesenswert
nicht lesenswert
Die einfachste Lösung: Kauf dir einen kleinen 5V->12V Wandler (Reichelt, 
MEA1D0512SC).

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
mmm ok also doch den Weg über 12V, Platztechnisch funktioniert das dann 
leider nicht :/. Dann wird die Gruppe ausgelagert :D

grüße

von ReinerH (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi,

such mal nach Ladungspumpe.
VG -R-

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Es gibt ja einige ICs dazu. mein Problem ist da gerade wie ich das Über 
PWM vom µC einstelle. Manche Varianten hab einen "FB Pin" wo man über 
den Spannungsteiler die Spannung einstellen kann...

Ich hab einige Vaianten gefunden aber meistens dann mit fester 
Spannung...

Ich könnte es ntürlich auch einfach so aufbauen...

http://www.sprut.de/electronic/switch/schalt.html

Das sieht mir nur zu Einfach aus ;)

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
mmm was ist mit der etwa dreckigen Methode mir aus den 5V, 10V zu machen 
MAX1683 oder so. Und dann mit einer DA Wandlung über PWM...

http://www.mikrocontroller.net/articles/Pulsweitenmodulation#DA-Wandlung_mit_PWM

Und Tiefpass 2. Ordnung...

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
mr.T schrieb:
> Ich könnte es ntürlich auch einfach so aufbauen...
>
> http://www.sprut.de/electronic/switch/schalt.html
>
> Das sieht mir nur zu Einfach aus ;)

Wenn du eine kräftige Endstufe an den MC Ausgang baust und damit die 
Ladungspumpe antreibst, kriegst du mit einer einstufigen Pumpe so etwa 
8V. Du wirst also eine 2-stufige brauchen. Ob das dann mit den Elkos und 
den Dioden noch so klein ist, ist die andere Frage.
Übrigens liefert mein FU von Mitsubishi die 10V als Referenz mit einigem 
mA Belastbarkeit. Wenn dein FU im Eingang von 0-10V auf 0-5V umstellbar 
wäre, wäre das auch noch eine Option. Das geht z.B. bei meinem 
Mitsubishi auch.

: Bearbeitet durch User
von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
umstellen kann ich leider nicht. Über die 10V des FUs zu gehen war auch 
eine Variante die ich im Kopf hatte. Das könnte man ja so aufbauen...?

http://www.mikrocontroller.net/articles/Datei:Pwm_filter_2.png

mit einem Rail to Rail op an den 10V, Nichtinvertierender Verstärker mit 
V=2.

Von den Bauteilen ja in etwa so wie die Lösung mit dem MAX1683, nur das 
die Teile einfacher zu bekommen sind :D...

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
mr.T schrieb:
> mit einem Rail to Rail op an den 10V, Nichtinvertierender Verstärker mit
> V=2.

Jo. Der LM358 ist allerdings kein Rail-to-Rail, aber den kann man ja 
gegen was anderes tauschen. Mit Sicherheit sind die 10V so konzipiert, 
das sie den OpAmp speisen können, braucht ja fast nur den nötigen 
Ausgangsstrom zu liefern. Wieviel genau der Ausgang liefern kann, sollte 
im Manual des FU stehen.

von mr.T (Gast)


Angehängte Dateien:
  • preview image for FU.PNG
    FU.PNG
    7,88 KB, 702 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
könnte das so wie im Anhang aussehen? Die OP Versorgung über die 10V des 
FUs.

von Otto Normal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo

Gibt der FU die 10 V nicht heraus (ev für ein externes Poti)?

Gruss Bernd

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ja ich möchte die 10V ja nutzen ;)... Quasi ein Digitales Poti über 
PWM...

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
mr.T schrieb:
> könnte das so wie im Anhang aussehen?

Da fehlt noch mindestens ein Widerstand vom PNP-Kollektor nach GND_FU 
(um 0V erzeugen zu können) und ein Widerstand zwischen 
Optokoppler-Kollektor und PNP-Basis (Basisstrombegrenzung).

Auf den PNP-Transistor kannst Du ggf. auch ganz verzichten; je nachdem 
wie weit die +10V erreicht werden sollen R3 verkleinern und/oder R1 und 
R2 vergrößern.

Gruß Dietrich

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Du kommst natürlich mit der Schaltung nicht ganz auf 10V, denn am PNP 
bleiben 0,6-0,7V hängen.
Der Bereich geht also etwa bis 9,4V. Mit dem LM358 kämst du aber 
wenigstens auf fast 0V am Ausgang runter.

: Bearbeitet durch User
von mr.T (Gast)


Angehängte Dateien:
  • preview image for FU.PNG
    FU.PNG
    6,97 KB, 372 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Meinst du in etwa so?

Grüße mr.T

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
Matthias Sch. schrieb:
> Der Bereich geht also etwa bis 9,4V.

Naja, bei dem so kleinen Kollektorstrom geht es schon noch etwas 
weiter...

von mr.T (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin ich hab mal etwas rum gespielt... so schlecht sieht das ja 
eigentlich nicht aus oder?

Grüße mr.T

von Banane (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und wenn du den FU auf die doppelte Frequenz stellst? Dann dreht der 
Motor bei 5V mit 100%.

von mr.T (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
mmm die Mittelstellung passte mit 1K nicht, mit 200 sieht es schon 
besser aus.

Ja wenn der FU das kann, ja.

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
mmm OK die 10 V Referenzen sind bei Hitachi mit +10V und 10mA angegeben

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
mr.T schrieb:
> mmm OK die 10 V Referenzen sind bei Hitachi mit +10V und 10mA angegeben

Interessant wäre auch die Eingangsimpedanz (Eingangsstrom) des 0-10V 
Steuereinganges. Wenn die genügend hochohmig ist (Steuerstrom 
entsprechend niedrig), kannst du evtl. ganz auf den Opamp verzichten und 
nur den OK einbauen. Deine idealisierte Simulation unterschlägt 
natürlich die o.a. Restspannung der CE Strecke des Phototransistors, 
geht also nicht ganz auf 0.
Selbst wenn ein Opamp nötig würde - 10mA sind schon eine ganze Menge. 
Ein TL022 z.B. würde mit 250µA auskommen.

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Moin,
10kOhm Eingangsimpedanz

http://www.hitachi-da.com/fileadmin/download/frequenzumrichter/frequenzumrichter-L200/PHB_L200-2_D_100419.pdf

Seite 162

Wie würde das denn nur mit dem Optokoppler aussehen? dann 5V seitig 
Modulieren und mit V = 2 Verstärken ?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
mr.T schrieb:
> dann 5V seitig
> Modulieren und mit V = 2 Verstärken ?

Deine 5V lassen jetzt ja schon nur die LED im Optokoppler leuchten. Für 
positive Logik (LED an = Max. Pegel am FU) schaltest du den Kollektor 
des Optokopplers an die +10V, der Emitter ist der Ausgang zum PWM 
Filter->FU und wird noch mit 2k2 oder so gegen Masse geschaltet. Wenn 
die LED ausgeht, zieht der 2k2 das Filter nach Masse. Diese Schaltung 
erlaubt zwischen 0V bis ca. 9,4V.

Für negative Logik den Emitter des Phototransistors auf Masse, der 
Kollektor ist der Ausgang zum Filter und wird mit 2k2 gegen +10V 
gezogen. Hier ist der Bereich ca. 0,6V - 10V.

: Bearbeitet durch User
von mr.T (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen und danke... :)

meinst du so wie im Anhang?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Ja, genau so. Dein Filter ist ein wenig zu hochohmig, um den FU direkt 
daraus zu füttern, aber mit dem Opamp sollte es auf jeden Fall klappen.

von mr.T (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das Tastverhältnis passt Natürlich nicht ganz aber ok... :)

Werde das mal so aufbauen und testen. Den Filter kann man ja noch 
anpassen :)...

Herzlichen Dank für deine Mühe!

Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.