mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Labornetzteil NG1620-BL defekt


Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
das oben genannte Netzteil ist defekt bzw. arbeitet nicht mehr richtig. 
Es ist ein NG1620-BL und liefert normalerweise 16V und 2A. Es ist ein 
Quad-OP LM324-N verbaut, der einen 2N3055 regelt.

Wenn ich am 1-Gang-Poti für die Spannungseinstellung nur ca. 5° drehe, 
dann liegt die volle Spannung am Ausgang an. Zum testen habe ich ein 
10-Gang-Poti angelötet und da reichen bereits die ersten 45° für die 
volle Spannung. Dazwischen kann noch "geregelt" werden. Strombegrenzung 
funktioniert einwandfrei.

Ich habe die Spannung am Poti gemessen, der liefert die richtige 
Referenz linear von max. 500mV (Vollausschlag) zum ersten OP (Pin 3). Am 
anderem Eingang von dem OP (Pin2) liegt leider fast nichts an. Ich 
vermute, dass da der Hund begraben ist. Der LM324 wurde bereits 
getauscht und bringt keine Besserung. Ich denke nicht das der 
Leistungstransistor defekt ist. Übrigens, der fette Widerstand links 
oben wird SEHR heiß.

Hat jemand von euch einen Schaltplan zu dem Netzteil? Oder kennt jemand 
dieses Problem? Ich habe bereits sehr lange gesucht und nichts gefunden. 
Auch nach baugleichen Netzteilen gesucht, anscheinend gibt es keine....

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Waldemar schrieb:
> Hat jemand von euch einen Schaltplan zu dem Netzteil?

Der liegt doch vor dir, die Platine ist doch übersichtlich.

500mV für Vollausschlag finde ich wenig, welche Referenzspannungsquelle 
wird denn verwendet? Eine Z-Diode? Die hätte mehr.

Die Transistoren durchzumessen wird doch nicht zu viel verlangt sein. 
Einer wird per Komparator das Relais für die Trafospannung umschalten, 
da hat man am Kühlblech von 3055 aber wieder heftig gespart. Ebenso wie 
die 2200 uF eher unterdimensioniert sind.

Der andere mag eine Konstantstromquelle sein, der dritte leitet den 
gesteuert vom OpAmp Ausgang nach Masse.

Autor: Waldemar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke erstmal für die "späte" Antwort.

Du hast Recht es ist nicht zu viel verlangt, das hatte ich auch vorher 
getan, aber vergessen zu erwähnen. Ich hatte die Transistoren ausgelötet 
und mit dem (AVR-)Transistortester geprüft. Es sind zwei NPN und ein 
PNP. Die haben eine Ube-Spannung von rund 0,7V und eine nach dem 
Datenblatt passende Stromverstärkung von ca. 200. Ich werde mal 
versuchen einen Schaltplan dazu aufzumalen um den Fehler zu finden.

Gruß

Autor: Michael X. (Firma: vyuxc) (der-michl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Waldemar schrieb:
> Ich habe die Spannung am Poti gemessen, der liefert die richtige
> Referenz linear von max. 500mV (Vollausschlag) zum ersten OP (Pin 3). Am
> anderem Eingang von dem OP (Pin2) liegt leider fast nichts an. Ich
> vermute, dass da der Hund begraben ist.

Da sollte die durch einen Spannungsteiler runtergeteilte 
Ausgangsspannung liegen. Anderseits, bist du sicher daß die 500mV als 
Referenz stimmt? Kommt mir etwas gering vor.

: Bearbeitet durch User
Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte schon mal angefangen den Schaltplan zu zeichnen und jetzt mit 
den beschalteten Elementen ergänzt (Potis, 2N3055, etc). es kann sicher 
sein, dass noch Fehler vorhanden sind. Und die Bauteile sind nicht schön 
angeordnet (werde ich noch machen) also sorry dafür. Es wurde halt 
schnell Leiterbahn für Leiterbahn nachvollzogen... Die Widerstandsnamen 
(R2, R3, ...) stimmen mit der Platine überein.

Die Diode, die als Schottky eingezeichnet wurde, ist die kleine Diode 
auf dem Bild im Glasgehäuse. RX ist der weggelassene Widerstand. Der 
graue Kondensator ist der umgelötete (ein Beinchen) am OP.

>>Da sollte die durch einen Spannungsteiler runtergeteilte
>>Ausgangsspannung liegen. Anderseits, bist du sicher daß die 500mV als
>>Referenz stimmt? Kommt mir etwas gering vor.

Ich habs mit dem Oszi am 10-Gang-Poti (gleicher wert 1kR wie Original 
1-Gang) gemessen. von min bis max sinds 500mV... ich kann leider erst 
nach der Arbeit nochmals nachmessen.

Gruß

Autor: Waldemar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...der Ground vom Strombegrenzungs-Poti ist der GND-OUT, also Lötpunkt 8 
und 9

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die BAS40 macht da keinen Sinn, das soll wohl eine Z-Diode sein und an 
der müssen mehr als 0.6V anliegen, eher 5.1V oder 6.8V.

Wo hängen die I und U Messinstrumente dran ?

Autor: Waldemar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Die BAS40 macht da keinen Sinn, das soll wohl eine Z-Diode sein
> und an
> der müssen mehr als 0.6V anliegen, eher 5.1V oder 6.8V.
>


Es ist natürlich keine BAS40, ich wollte diese (Schaltzeichen) nur von 
einer normalen Diode unterscheiden. Ich meine ich habe da gestern (es 
war spät) 6,6V kann sein dass es 6,8V waren gemessen.

> Wo hängen die I und U Messinstrumente dran ?
Spannungsmesser ist direkt am Ausgang also Lötpunkte 12,13 -> 8,9
Amperemeter hat an den Ausgangsbuchen einen extra Shunt 
(Konstantandraht) und misst dort potentialfrei den Spannungsabfall über 
dem Draht. Es ist nicht der, der auf dem Bild zu sehen ist.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Irgendwie habe ich den Eindruck, als ob I-Max und U-Soll vertauscht 
sind.

Das Diagramm wäre klarer, wenn T1 nach rechts kommt, und R15 auf die 
Z-Diode das erste ist was nach der Trafospannungsumschaltung kommt, 
direkt daneben IC1D mit R11, R13, die über R12 wohl eine 
Konstantstromversorgung der Z-Diode erreichen soll, aber R15 als 
Bootstrap benötigt.

Wenn man dann noch den Wert von R10 und R9 wüsste, und R8 und R7, könnte 
man ermitteln, welchen Spannungsbereich das U-Soll Poti haben sollte.

Die Netzteilschaltung ist so blöd nicht, wenn ich die ganzen anderen 
Schaltung hier im Forum so vergleiche, allerdings hätte man den LM324 
wohl mit leicht negativer Versorgung speisen sollen, so -0.7V reichen 
schon damit er ganz auf 0 geht, und Q2 und Q5 könnten knapp 
unterdimensioniert sein.

Mit einem ordentlichen Kühlkörper könnte man auf das Relais verzichten, 
denn der 2N3055 schafft 2A bei 30V.

Autor: Paul B. (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Mit einem ordentlichen Kühlkörper könnte man auf das Relais verzichten,
> denn der 2N3055 schafft 2A bei 30V.

Dann guck Dir mal die Gesamtgröße des Gerätes an. (Nimm den Netzschalter 
als Maßstab) Da kann man keinen riesigen Kühlkörper unterbringen.
Das Gerät ist schon durchdacht.

MfG Paul

Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich werde versuchen das heute Abend mal übersichtlicher zu gestalten, 
wie gesagt das war quick&dirty und das erste mal, dass ich so eine 
"große" Schaltung von der Platine abgemalt habe (es gibt immer ein 
erstes mal).

>>Irgendwie habe ich den Eindruck, als ob I-Max und U-Soll vertauscht
sind.
Es sieht zwar so aus, aber nein sind es nicht, wie gesagt ich kann mit 
einem 10-Gang-Poti wunderbar Strom und Spannung regeln (0° = 0V; 45° = 
15V von dem ersten Gang)

Komischerweise ist gestern zwischenzeitlich die Anzeige zwischen 18V und 
5V mit 1Hz hin und hergesprungen. Mit Oszi gleichzeitig gemessen und es 
ist alles sauber. Die Anzeige hat eine potentialfreie 9V-Versorgung und 
greift die Spannung direkt am Ausgang ab. Dann gings wieder, aber evtl. 
schlechte Lötstellen am Anzeigeelement, die ich dann gleich nachgelötet 
habe. (Die Chinesen haben wohl keine Zeit um richtig zu löten)


>>Q2 und Q5 könnten knapp unterdimensioniert sein.

Die Bauteilnamen von Q2 und Q4 (Q5 gibts nicht) stimmen leider nicht 
überein, es ist kein BC557 und BC547. Es sind irgendwelche andere von 
denen ich noch nie was gehört habe.

>>Mit einem ordentlichen Kühlkörper könnte man auf das Relais verzichten,
denn der 2N3055 schafft 2A bei 30V.

...mir würden 3A-4A bei 15V vollkommen reichen. Falls das Netzteil 
wieder arbeitet, wie es sein soll, dann kann ich mir ja überlegen den 
auf 3A + aktive Kühlung umzubauen.

Vielen Dank für die vielen Antworten!

Autor: Waldemar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Schaltplan muss ich dringend überprüfen, sehe gerade, dass der 
Ausgang Vout am GND liegt...

Autor: Nemesis (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Halte dich bei deinem Schaltplan mal an die Regel: Eingänge rechts
und Ausgänge nach links zeichnen.
Augenscheinlich zusammenhängende Bauteile in Modulen zeichnen,
also Spannungsregelung für sich, Stromregelung für sich und die
Potis nicht als Trimmer(sofern es keine Trimmer sind),
sondern als Potis(mit einem Pfeil als Aktor) zeichnen.
Die Ausgangsbuchsen muss man auch nachvollziehbar erkennen können.

Autor: Cyblordsfeuchtertraum (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Nemesis schrieb:
> Halte dich bei deinem Schaltplan mal an die Regel: Eingänge rechts
> und Ausgänge nach links zeichnen.

-> Eher andersherum ! Zumindest habe ich es selten mit Eingängen auf der 
rechten Seite gesehen ;-)


Viele Grüße

Jörg

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Waldemar schrieb:
> Den Schaltplan muss ich dringend überprüfen

Du solltest halt auch die Bauteilwerte reinschreiben, und zwar richtige, 
nicht BC557

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ist irgendwie eine Verbindung zu viel Ausgang - GND(A).
So wie es aussieht sind dann aber wirklich Strom und Spannungspoti 
vertauscht im Plan. Dann würde die Schaltung so etwa hinkommen.
So hätte man man auch die Kompensation am OP für die Spannung - die 
Stromreglung könnte über die GBW des OPs ausrechend stabil sein.
Für die Stromregelung wäre 0-500 mV am Poti auch in etwa richtig. Der 
Poti für die Spannung sollte eher so etwas wie 0-5 V liefern.


Der Kondensator direkt am OP (pins 9/10) ist verdächtig und könnte ein 
Hinweiss sein, dass die Schaltung zum schwingen neigt. Soweit man es aus 
dem Plan erkennen kann, ist die Schaltung auch nicht so unproblematisch. 
HF Schwingungen des Regelers könnten ggf. auch das Fehverhalten 
erklären. Es kann druchaus sein, dass man die Schwingungen am Ausgang 
nicht mal so sehr sieht.

Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,
ich war gestern fleißig und habe den Schaltplan neu und auch gut 
strukturiert erstellt. Zusätzlich habe ich jeden Widerstand halb 
ausgelötet und ausgemessen. Alle Widerstände waren in Ordnung. Bei der 
Z-Diode handelt es sich um eine 6V2, die ist auch intakt. Ich denke 
damit kann man arbeiten.

Am IC1_D Pin14 habe ich AC-gekoppelt merkwürdigen Signalverlauf gemessen 
(siehe Bild IC1_D_Pin_14) oder wird hier nur der Transistor geregelt?

Auch Bilder von U_Soll und I_Soll von min- bis max-Ausschlag sind 
angehängt.

Ich frage mich für was der Shunt in der Masseleitung sitzt, wenn er gar 
nicht benutzt wird....

Bei den Transistoren handelt es sich um:
NPN: S9014 http://www.weitron.com.tw/PDF/S9014.pdf
PNP: S9012 http://www.weitron.com.tw/PDF/S9012.pdf

Widerstand Rx ist nicht bestückt.

Ich frage mich was hier defekt sein soll?
OP ist neu
Kleinsignal-Transistoren OK
Z-Diode OK
Alle Widerstände OK
Kapazitäten 1nF/100nF OK
C1 Elko ist laut AVR-Transistortester auch OK

2N3055 scheint OK zu sein, da ja die Spannung am Ausgang, wenn auch nur 
über kleinen Bereich des U_Soll-Potis, richtig ausgegeben und der Strom 
auch geregelt wird.

Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bilder vergessen...

Autor: Waldemar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Poti zur Strombegrenzung hat 6k3 und Spannungseinstellung 1k

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Waldemar schrieb:
> Auch Bilder von U_Soll und I_Soll von min- bis max-Ausschlag sind
> angehängt.
>
> Ich frage mich für was der Shunt in der Masseleitung sitzt, wenn er gar
> nicht benutzt wird....

Du hast bis heute nicht verstanden, dass U und I andersrum sind. 
Natürlich wird der shunt verwendet. Die Spannung am 1k I Poti hängt 
natürlich vom Strom ab.

Dein 500mV Sägezahn ist das übliche Schwingen von instabilen Netzteilen. 
Daher der Kondensator am OpAmp. Wenn das bei Spannungsregrln auftritt, 
würde ich einen kleinen Kondensator parallel zu R8 versuchen.

Autor: gk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R8 geht vermutlich an R7 und nicht ans Poti. Mess trotzdem mal den 
Endtransistor durch, der Treibertransistor könnte, je nach Fehlerfall, 
auch die Ausgangsspannung liefern. Ansonsten Spannungen messen, z.B. an 
den Op-Amp Eingängen.

Und Danke fürs Schaltbild, wenn es denn mal stimmt. Es gab die Büchsen 
mal für 18 Euronen (ohne Märchensteuer), da konnte ich nicht 
widerstehen.

gk

Autor: hinz (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Die Beschaltung an IC1D kann nicht stimmen.

Autor: Die Menschheit verblödet (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Die Beschaltung an IC1D kann nicht stimmen.

Doch, die stimmt ganz genau.
(Das behaupte ich ohne jede Begründung -genau wie Du auch ohne 
Begründung behauptest, daß das nicht so ist.)

Autor: hinz (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Die Menschheit verblödet schrieb:
> hinz schrieb:
>> Die Beschaltung an IC1D kann nicht stimmen.
>
> Doch, die stimmt ganz genau.
> (Das behaupte ich ohne jede Begründung -genau wie Du auch ohne
> Begründung behauptest, daß das nicht so ist.)

Wunderbar, und jetzt nimm brav deine Froschpillen.

Autor: Andrew T. (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde mir auch eher über die Beschaltung am IC1C - OPV Gedanken 
machen als um IC1D.

IC1C soll wohl eine gepufferte Referenz darstellen, und da würde die 
Verbindung zw. R10/R6 besser an Pin 8 als an Pin 10 des LM324  passen, 
um den niedrigen Ausgangswiderstand des OPV zu nutzen. An Pin 10 (so wie 
jetzt gezeihnet) belastet es die Z-Diode direkt, was sicher 
schaltungstechnisch nicht optimal ist.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Andrew T. schrieb:
> IC1C soll wohl eine gepufferte Referenz darstellen

Nein.

Siehe LM723 Innenschaltung.

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Andrew T. schrieb:
> Ich würde mir auch eher über die Beschaltung am IC1C - OPV
> Gedanken
> machen als um IC1D.

Der Wert von R15 ist jedenfalls auch nicht plausibel.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Der Wert von R15 ist jedenfalls auch nicht plausibel.

Doch, ist er, er dient nur dem bootstrap.
Wurde alles schon beschrieben.
Wenn hinz natürlich leserenitent ist...

Autor: hinz (Gast)
Datum:

Bewertung
-3 lesenswert
nicht lesenswert
Michael B. schrieb:
> hinz schrieb:
>> Der Wert von R15 ist jedenfalls auch nicht plausibel.
>
> Doch, ist er, er dient nur dem bootstrap.
> Wurde alles schon beschrieben.

Ist bekannt.


> Wenn hinz natürlich leserenitent ist...

Auch du darfst deine Froschpillen nehmen.

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Plan dürfte wie oben von GK schon angemerkt das untere Ende von R8 
noch falsch sein. Der sollte an R7 und den - Eingang des OPs gehören.

Die Schaltungsart fängt realtiv leicht an zu schwingen. Da reicht es 
ggf. aus wenn die Elkos etwas gealtert sind, oder auch einfach die Kabel 
anders liegen.

Ansatzpunkte gegen die Schwingunden wären etwa:
- Kondensator parallel zu R8 wie Mawin oben vorgeschlagen hat, ggf. mit 
etwa 500 Ohm ein Serie.
- Widerstand (ca. 100 Ohm) von Basis zum Emitter beim 2N3055
- Den Kondensator zwischen den Pins 12 und 13 eher wieder entfernen
- ggf. Ein Widerstand in Reihe zu C4
- 10 µF Low ESR Elko parallel zum Ausgang
- 100 µF low ESR Elko und ggf. 100 nF zum Ladeelko dazu

gff. müsste man die Schaltung auch richtig simulieren um die passenden 
Werte zu finden.

Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Servus,
ich habe auf die schnelle die Simulation erstellt. Ich habe nur ein 
fremdes Bauteil (2n3055) benutzt um eine schnellere Simulationszeit zu 
erreichen.

Irgendwie will die Simulation zwischen drin nicht weiter machen....

Kann sich das bitte einer ansehen?

Ich werde zunächst den 2n3005 richtig überprüfen und das mit dem 
Widerstand R8 werde ich heute auch nachprüfen und all die anderen 
Vorschläge auch. Danke euch!

Autor: wg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle Bauteile kosten ~10 EUR zusammen und wenn Du die einfach pauschal 
alle (!) getauscht hättest, wärst Du jetzt schon fertig...

Die Widerstände kann man schnell durchmessen, die Dioden auch, die 
kleinen
Transistoren hast Du schon als fehlerfrei gemessen und der LM324 wurde 
schon
getauscht.

Da bleibt doch fast nichts mehr übrig.

Und so komplex ist die Schaltung auch nicht, dass man jetzt noch 
Simulationen durchführen müsste...?

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für die Simulation hätte es gereicht nur die Spannungsregelung (Teil um 
IC1D) zu nehmen. Auch die Spannungsreferenz muss man nicht mit 
simulieren. Ein Modell für den 2N3055 ist normal in der Standard 
Bibliotek von LTspice. Der Shunt dürfte auch eher 0.1 Ohm statt 1 mOhm 
sein.
Der Elko am Ausgang ist im Plan oben kleiner (100 µF). Außerdem könnte 
der ESR des Elkos wichtig sein - den sollte man also einschließen.

Die Schaltung ist nicht so komplex, aber die Frequenzkompensation ist 
auch nicht so einfach. Da hilft die Simulation schon um die richtige 
Größe der Kondensatörchen zu finden. Im Prinzip sind es 5 Bauteile die 
man anpassen sollte: C4, ggf. einen zusätzlichen Widerstand in Reihe zu 
C4, den Kondensator und Widerstand parallel zu R8 und den 
Ausgangskondensator (incl. ESR).

Man kann es natürlich auch von Hand durchrechnen, aber so ganz einfach 
ist das nicht, und halt etwas fehlerträchtiger. So als 
Überschalgsrechnung von Hand könnte es hinkommen mit 100 nF mit 1 K in 
Serie parallel zu R8 und dann ggf. noch C4 auf bis zu 5 nF vergrößern.

Autor: Tcf K. (tcfkao)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Waldemar schrieb:
> Wenn ich am 1-Gang-Poti für die Spannungseinstellung nur ca. 5° drehe,
> dann liegt die volle Spannung am Ausgang an. Zum testen habe ich ein
> 10-Gang-Poti angelötet und da reichen bereits die ersten 45° für die
> volle Spannung. Dazwischen kann noch "geregelt" werden. Strombegrenzung
> funktioniert einwandfrei.
>
> Ich habe die Spannung am Poti gemessen, der liefert die richtige
> Referenz linear von max. 500mV (Vollausschlag) zum ersten OP (Pin 3). Am
> anderem Eingang von dem OP (Pin2) liegt leider fast nichts an.

Nachdem ich mir alles durchgelesen habe... Du BEDIENST das Gerät 
falsch!
Du hast das Spannungspoti auf Vollgas, und drehst die ganze Zeit an der 
STROMbegrenzung! Dazu passen die Spannungen und Pin-Nummern!
Pin 12 des OP ist die Referenzspannung, Pin 3 ist die Stromreferenz.

Dann passt die ganze Beschreibung des Verhaltens, und das Gerät ist gar 
nicht defekt! Oder ein Spassvogel hat die Potis für Strom und Spannung 
vertauscht / falsch eingebaut.

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Schon MaWin hatte darauf hingewiesen: Spannungsregelung und 
Strombegrenzung vertauscht.

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die vermeintliche Schwingung am OP Pin 14 könnte auch einfach nur 100 Hz 
Restrippel sein, die der OP ausregeln muss. Die Angabe von 718 Hz beim 
ersten Bild lässt anderes vermuten - nach dem Raster sind es aber 100 Hz 
+ etwas 50 Hz.

Autor: Tcf K. (tcfkao)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Schon MaWin hatte darauf hingewiesen: Spannungsregelung und
> Strombegrenzung vertauscht.

Ja aber eben nicht nur im Schaltplan falsch bezeichnet sondern auch in 
der Bedienung! Er dreht die ganze Zeit am Stromregler.

Autor: Nemesis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn da Lastfrei ein Restrippel zu messen ist, würde ich mal den
Siebelko checken, ob der überhaupt noch die Nennkapazität hat.

Die Schaltung im Simulator ist aber nicht mit der oberen Schaltung
identisch.

Ein paar Schaltungsspezifika kommen mir bei der asymmetrischen
Versorgung auch ein bisschen komisch vor. R4 würde z.B. nur bei
symmetrischer Versorgung in bestimmten Schaltungen Sinn machen.
Bei den anderen Ops gibts erwartungsgemäß Spannungsteiler.

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Widerstand R4 ist vermutlich ein Überbleibsel für den Fall, dass 
auch am OP für die Stromregelung noch ein Kondensator hängt. So ist er 
weitgehend ohne Funktion. Den hätte man in der Simulation (und 
Schaltung)  auch weglassen könnten. Wesentlicher wäre ggf. R5, der 
könnte ggf. stören, wenn er zu groß wird.

Autor: Waldemar (Gast)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Guten Morgen,
ich möchte sagen, dass all die, die mir gesagt haben U/I-Steller sei 
vertauscht, absolut recht haben! Ich möchte mich für meine Ignoranz 
entschuldigen, denn das wollte ich nicht so glauben....

Es ist so, dass ich dieses Netzteil von einem Kollegen bekommen habe 
(der es wegschmeißen wollte), der wiederum das als Nachlass von seinem 
vor kurzem verstorbenen Schwiegervater bekommen hatte. Er meinte nur es 
sei defekt, lässt sich aber einschalten.

Somit habe ich das Netzteil kurz eingeschaltet, das ganz oben 
beschriebene Problem entdeckt und es anschließend gleich zerlegt. Die 
Potis waren in dem Fall wirklich vertauscht eingebaut gewesen. Dieses 
triviale Problem stellte sich wohl als Herausforderung dar. Ich suchte 
nach einer weit komplizierteren Ursache für dieses Verhalten, statt 
anzunehmen, dass (nur) die Potentiometer vertauscht eingebaut waren! Die 
Potis wurden wohl von seinem Schwiegervater verkehrt eingebaut, denn 
mein Kollege wusste davon nichts. Peinlich....

Mit dem Netzteil gab es trotzdem ein Problem, welches ich auch mal 
angesprochen habe: Kontaktfehler/kalte Lötstelle o.ä. welches aber durch 
das mehrmalige aus- und einlöten der Bauteile und nachlöten aller 
Lötstellen beseitigt wurde.

Nun haben "wir" uns lange genug mit dem Netzteil beschäftigt und ein 
Schaltplan, (nicht fertiges) Simulationsmodell erstellt. Diese Sachen 
werden hoffentlich denen behilflich sein, die dieses Netzteil mal 
reparieren möchten.

Die Unterlagen werden auch mir helfen dieses Netzteil auf 3A zu 
erweitern, denn der Transistor wurde gestern überhaupt nicht warm 
(deltaT 5-10°C), als ich ihm 2A bei 15V dauerhaft entzogen habe.

Vielen Dank an all die, die mir hier geantwortet haben!

Autor: Waldemar (Gast)
Datum:
Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
Zur Vollständigkeit der aktualisierte Schaltplan.

Der R8 ist tatsächlich am R7 dran. Ich werde mir natürlich die 
Vorschläge des Umbaus gegen die Stabilitäts-"Probleme" mal vornehmen und 
umsetzen.

Was ich aber zum Netzteil sagen kann:
Nach dem ich ihm noch ein 10-Gang-Präzisionspoti verpasst habe, ist 
wirklich ein gutes billiges, ähhm preiswertes, Produkt. Die Anzeigen 
sind erstaunlich genau (bis auf zweite Nachkommastelle) und die geringe 
Restwelligkeit von max. 20mVpp bei voller Last. Außerdem geht die 
Spannungsregelung bis auf 0V!

Dieses Netzteil ist wirklich perfekt für den Bastelkeller.

Autor: Lurchi (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Der kritische Fall hinsichtlich Erwärmung ist der Kurzschluss, bzw. der 
volle Strom bei einer Spannung, dass gerade so das Relais noch nicht auf 
die kleinere Spannung runter schaltet. Der andere kritische Fall wäre 
eine hochdynamische Last, so dass dauernd das Relais umschaltet - das 
ist etwa der Härtetest mit "Kurzschluss" über eine Raspel.

Den maximalen Strom sollte man eher nicht vergrößern - die billigen 
Netzteile sind in der Regel sehr knapp ausgelegt. Auch der Trafo , 
Gleichrichter, Ladeelko und ggf. sogar das Relais müssten dann größer 
werden. Eher wäre bei so einem Netzteil zu überlegen den maximalen Strom 
noch etwas zu reduzieren.

Wo man eventuell etwas mehr erlauben könnte wäre bei der Spannung. Da 
muss man dann allerdings bei hoher Spannung, viel Strom und ggf. gerade 
niedriger Netzspannung ggf. mit Restrippel rechnen der durchschlägt.

Autor: Nemesis (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Waldemar schrieb:
> Peinlich....

Ne, gelebte Kultur hier im Forum (vermutlich in anderen auch) erst
mal das technische Problem zu beschreiben, anstatt mal erst eine
sinnvolle einleitende Vorgeschichte zu veröffentlichen.
Das macht nämlich viel aus. Auch ist es ein wenig problematisch
welche Fähigkeiten und Möglichkeiten ein Treadstarter hat.
Ein Profil darüber wäre da sicher hilfreich.

Waldemar schrieb:
> Zur Vollständigkeit der aktualisierte Schaltplan.

Das der Plan frei von Mängeln sein soll, halte ich für unwahrscheinlich
aber nicht für unmöglich. Jedenfalls sehe ich für die 
Spannungseinstellung
nur eine Komparatorschaltung (IC1_D) und keinen Spannungsverstärker
(evtl. Spannungsfolger), wie man das erwartet. Das für die 
Strombegrenzung
ein Komparator (IC1_A) benutzt wird, wäre dagegen nachvollziehbar, auch
wenn die Schaltung da auch Fragen aufwirft.

Autor: Marian  . (phiarc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nemesis schrieb:
> Jedenfalls sehe ich für die
> Spannungseinstellung
> nur eine Komparatorschaltung (IC1_D)

Ach? Nur weil es keinen Widerstand vom Ausgang zu (-) gibt, hat dieser 
Verstärker keine Gegenkopplung?

Autor: Der Andere (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Waldemar schrieb:
> Die Unterlagen werden auch mir helfen dieses Netzteil auf 3A zu
> erweitern,

Willst du dir das wirklich antun?
Dazu brauchst du einen größeren Trafo, sehr wahrscheinlich einen 
größeren Gleichrichter, bessere Kühlung des Transitors oder gar einen 2. 
Endstufentransistor, die Treibertransistoren bringen ggf. nicht genug 
Strom oder werden zu heiss, ....

Für deine Tests musst du (wie schon mal geschrieben) den Kurzschlussfall 
berücksichtigen, dann fällt im Gerät die größte Leistung ab.

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nemesis schrieb:
> Jedenfalls sehe ich für die Spannungseinstellung
> nur eine Komparatorschaltung (IC1_D) und keinen Spannungsverstärker
> (evtl. Spannungsfolger), wie man das erwartet.

Doch, genau so eine Schaltung ist das. IC1D bildet mit den Transistoren 
einen ganz normalen nichtinvertierenden Verstärker. Die Eingangsspannung 
kommt vom Poti U_soll und die Gegenkopplung machen R7/R8 (Vu ist knapp 
3).

Die Ausgangskapazität mit 100µF wäre mir in einem Labornetzteil viel zu 
groß.

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ArnoR schrieb:
> (Vu ist knapp 3)

Vertippt, meinte knapp 4

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der OP IC1D bildet die klassische Integratorschaltung für die Regelung. 
Der Teils ist also einfach nach Lehrbuch, wenn auch Anfängerniveau.

Die Ausgangsstufe mit den Transistoren ist dagegen schon etwas 
problematisch, weil die Verstärkung / Bandbreite deutlich vom Strom 
abhängt. Der klassiche und bessere Weg wäre hier einfach eine 
Darlingtonschaltung - für eine so kleine Spannung ist das eigentlich 
kein Problem, zumal die OPs wohl sowieso eine separate Versrogung haben.

Autor: Andrew T. (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lurchi schrieb:
> Der OP IC1D bildet die klassische Integratorschaltung für die
> Regelung.
> Der Teils ist also einfach nach Lehrbuch, wenn auch Anfängerniveau.
>
> Die Ausgangsstufe mit den Transistoren ist dagegen schon etwas
> problematisch, weil die Verstärkung / Bandbreite deutlich vom Strom
> abhängt. Der klassiche und bessere Weg wäre hier einfach eine
> Darlingtonschaltung - für eine so kleine Spannung ist das eigentlich
> kein Problem, zumal die OPs wohl sowieso eine separate Versrogung haben.

Die Ausgangsstufe IST bereits eine Darlingtonschaltung.

Es gibt da die "simple" Version" (alos z.B. 2 x npn) und die 
"modifizierte" (gemsicht pnp/npn).
Beides hat Vor- und Nachteile.

Hier wurde bewußt auf geringe Sättigungsspannung geplant, daher: 
gemischt.

Autor: Marian  . (phiarc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andrew T. schrieb:
> Beides hat Vor- und Nachteile.

Ja, Sziklai macht gern Ärger, Darlington ist langsam.

: Bearbeitet durch User
Autor: Paul B. (paul_baumann)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Marian B. schrieb:
> Ja, Sziklai macht gern Ärger,
Nicht mehr. Er sit 1998 in Kalifornien gestorben.
>Darlington ist langsam.
Der ist nicht nur langsam, der bewegt sich gar nicht mehr, denn er starb 
1997
------------------------------------------------------------------------ 
-

>Labornetzteil NG1620-BL defekt

-> Was war letzen Endes? ->Waldemar defekt, Netzteil in Ordnung.

MfG Paul

Autor: Nemesis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ArnoR schrieb:
> Die Eingangsspannung
> kommt vom Poti U_soll und die Gegenkopplung machen R7/R8 (Vu ist knapp
> 3).

...und wurde hinter dem Treibertransistor abgegriffen. Wenn man die
Sziklai-Stufe da mit einbezieht, erkennt man die Gegenkopplung.
Die Zeichnung ist da Anfangs etwas verwirrend. Jetzt hab ich das
auch gerafft.

Autor: gk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nemesis schrieb:
> ...und wurde hinter dem Treibertransistor abgegriffen.


Keine Ahnung was Du damit meinst. Wenn man die Ausgangsspannung konstant 
halten will, dann muss man auch die Ausgangsspannung abgreifen. Und das 
betrifft auch den Minuspol der Ausgangsspannung. Man beachte hierzu das 
nette Detail mit den zwei unterschiedlichen Massesymbolen.

gk

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Endstufe ist weder eine klassische Darlington noch eine 
Sziklai-Stufe, jedenfalls nicht für die Spannung. Der Emitter des ersten 
Transistors geht an die Ausgangsseite des Shunts und nicht an den 
Ausgang.

Dadurch hat die Stufe ein hohe, vom Strom abhängige 
Spannungsverstärkung. Die kann man ggf. sogar als Spannungsgsteuerte 
Stromquelle ansehen. Entsprechend würde ich bei der Schaltung auch keine 
schnelle Lastausregelung und ggf. die Neigung zum Schwingen erwarten.

Für hohe Ausgangsspannungen ( > 30 V) mag diese Art Endstufe ihre 
berechtigung haben, für kleine Spannungen (wo der OP noch den 
Spannungshub schafft) wird es mit der einfachen Darlingtonschaltung 
einfacher und läßt sich leichter stabilisieren. Da kommt man dann auch 
mit einem kleineren Kondensator am Ausgang aus.

Autor: Marian  . (phiarc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lurchi schrieb:
> Die Endstufe ist weder eine klassische Darlington noch eine
> Sziklai-Stufe, jedenfalls nicht für die Spannung. Der Emitter des ersten
> Transistors geht an die Ausgangsseite des Shunts und nicht an den
> Ausgang.

Stimmt, es ist ein Sziklai-Paar, dass hier als Emitterstufe fungiert. 
Ist mir vorher nicht aufgefallen, normalerweise haben Labornetzgeräte ja 
eine Kollektorendstufe.

Autor: Tcf K. (tcfkao)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lurchi schrieb:
> Die Endstufe ist weder eine klassische Darlington noch eine
> Sziklai-Stufe, jedenfalls nicht für die Spannung.

Die Endstufe T1/Q2 ist eine Sziklai-Schaltung, allerdings in 
Emitterschaltung und nicht als Emitterfolger -- weil eben ein 
Leistungs-NPN billiger ist als ein Leistungs-PNP.
Zusammen mit der Emitterschaltung des Q4 ergibt das tatsächlich eine 
hohe Verstärkung, um diese etwas zu reduzieren die Gegenkopplung mit R3 
-- der wäre bei einem Emitterfolger in der Endstufe unsinnig.

Wohl auch um die Schaltung bei kleinen Ausgangsspannungen stabil zu 
bekommen die relativ hohe Grundlast mit R19 (470R).

Die Strombegrenzung ist tatsächlich nur eine Begrenzung und keine echte 
Regelung sondern eher Komparator, deswegen auch der Ripple in den 
Oszillogrammen weiter oben.

Egal, war eh alles ein Sturm im Wasserglas...

Autor: Mani W. (e-doc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn es jetzt wieder funktioniert, sollte man vor dem
Auslöten diverser Bauteile mit einer Lupe die Lötstellen kontrollieren,
die können auch genug Fehler beinhalten, aber das weis man ja eh...

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lurchi schrieb:
> Die kann man ggf. sogar als Spannungsgsteuerte
> Stromquelle ansehen.

Richtig.

Die allerdings regelt viel schneller auf (steigende Spannung) als zu, 
wie man am Sägezahn der Oszilloskopbilder sieht.

Könnte man die Schaltung so umstricken, daß sie auch schnell wieder 
zuregelt, könnte man den Ausgangselko verkleinern.

Ein einfacher Widerstand von der Basis des 2N3055 nach Masse tut es 
nicht, weil dann UBE des 2N3055 überschritten wird, wenn die 
Ausgangsspannung nicht so schnell sinkt wie gewünscht.

Autor: Lurchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Osziloskop bilder oben haben einfach nur 100 Hz Rippel gezeigt. Das 
muss nicht viel mit der Endstufe zu tun haben. Die Sägezahnform kriegt 
man halt auch beim Ladeelko.

Die Endstsufe ist auch tatsächlich unsymmetrisch und hat Schwierigkeiten 
schnell auszuschalten. Beim 2N3055 dauert es halt einfach ein paar µs, 
wenn man nur den Baisstrom wegnimmt. Die übliche Lösung das etwas zu 
verbessern ist ein Widerstand parallel zur Basis - Emitterstrecke des 
2N3055. Q2 muss dann ggf. 10-100 mA oder so mehr an Strom liefern. Ggf. 
Wäre auch noch ein Widerstand am Emitter von Q2 angebracht, damit die 
Endstufe etwas linearer wird. Da sollte man aber ggf. die Simulation zu 
Rate ziehen, denn mit mehr Strom wird sie auch schneller.
Wenn der Rest der Schaltung gut abgestimmt ist könnte man dann sicher 
einiges kleiner mit der Kapazität werden. Da sollte dann aber sowohl RC 
parallel zu R8 und wohl auch ein Widerstand in Reihe zu C4 passend 
gewählt sein.

Beim Kondensator am Ausgang kommt es nicht nur auf die Kapazität, 
sondern auch auf den ESR Wert an. Oft ist es auch besser, wenn man da 
nicht nur einen Kondensator hat, sondern 2: einen kleinen Folien oder 
Keramischen Kondensator (wenig ESR/ESL) um wirklich schnelle Störungen 
und extere HF abzufangen und dann einen Kondensator / Elko mit etwas ESR 
so im Bereich 0.1-1 Ohm. Die RC Kombination ist das was Schwingneigung 
wirklich zuverlässig dämpfen kann. Den reinen Kondensator könnte eine 
Induktive Last aufheben und zum schwach gedämpften Schwingkreis machen.
Aber auch die Stromregelung braucht ggf. eine gewisse Kapazität (mit 
ESR) am Ausgang.

Neben dem Kondensator am Ausgang hat aber auch die Schaltung, wenn sie 
in die Strombegrenzung geht in der Regel auch noch einmal kapazitives 
Ausgangsverhalten. Da kommt also noch scheinbare Kapazität vom Regler 
dazu - auch das können einige 10 µF sein, wenn der Regler oder die 
Endstufe so wie hier langsam ist. Wirklich störend ist die Kapazität am 
Ausgang vor allem für eine schnelle Strombegrenzung. Gerade einfache, 
langsame Netzteile mit dem Leistungstransistor im Kollektorschaltung 
können einen kleinen (oder gar keinen) Kondensator am Ausgangs haben, 
aber trotzdem effektiv viel Kapazität, weil die Stromregelung langsam 
ist.

Autor: W.S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
An diesem Thread ist zwar ein Bart dran, aber aus aktuellem Anlaß hab 
ich ihn ausgegraben und dabei festgestellt, daß das tatsächliche 
Innenleben vermutlich von Charge zu Charge heftig variiert. Wer zwei 
solche Teile besitzt, kann sich wohl drauf verlassen, daß selbige 
mindestens drei völlig verschiedene Innenleben haben... X-)

Anbei ist der Schaltplan meines Netzteils - ist vielleicht hilfreich 
für Leute, die diese Variante reparieren wollen. Sinnigerweise wurde nur 
die Hälfte des Vierfach-OpV's benutzt, dafür dann aber ein zusätzlicher 
LM741 verbraten.

W.S.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.