Forum: Analoge Elektronik und Schaltungstechnik Ferrariszähler auslesen mit Reflexlichtschranke und LM393


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von LOL (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,

obwohl ich hier schon eine Weile mitlese ist dies mein erster Fragepost 
in diesem Forum und außerdem mein erstes Projekt, insofern bitte ich um 
Nachsicht für meine Naivität. Meine Elektronikerfahrung ist bis dato 0, 
mal abgesehen vom Spielen mit Routern und Nachbauen einfachster 
Schaltungen.

Das Projekt an sich ist nichts neues und stark von Google inspiriert:
http://www.hobbyheizer.de/index.php/haussteuerung/stromzaehler
http://www.fingers-welt.de/gallerie/eigen/elektro/energie/energie.htm

Aufgabenstellung:
=================
Es gilt einen Sensor zu bauen, der die Zählscheibe (rote Markierung, der 
Rest des Rades ist schwarz-silber gezackt) eines Ferrariszählers (80 
u/kWh; schlimmstenfalls 3x20A) optisch erfasst und das Ergebnis als 
Schaltsignal verfügbar macht.

Das Schaltsignal soll später in ein vorhandenes 1-Wire Netz übergeben 
werden, wo es über entsprechende Zählerbausteine geloggt und ausgewertet 
wird.

Die Spannungsversorgung des Sensors muss via 5V (real am Bus: >4,5V) 
erfolgen, eine extra Versorgungsleitung wird im gesamten Bus (Cat.5 - 
AWG24) mitgeführt. Da der gesamte 1-Wire-Bus bislang ohne besondere 
Spannungsversorgung auskommt (via USB-Port versorgt), soll die Lösung 
<<20mA Stromaufnahme haben, idealerweise weniger.

Implementationsstand:
=====================
Der Schaltplan im Anhang des Posts wurde von mir auf einem Steckbrett 
zusammengeschustert und funktioniert offenbar. Der echte Aufbau auf 
Lochraster fehlt noch.

Die Variante mit dem LM393 wurde gewählt, weil a) vorhanden und b) ist 
ohne Verstärkung und Schalthysterese nichts zu machen:
Das Zählrad reflektiert extrem unterschiedlich das Licht des OPB743 und 
die "Schluckung" der roten Markierung ist nur geringfügig stärker als 
der sie direkt umgebende Bereich (irgend ein Lack?? oder es "eiert"?). 
Es gibt aber auch Bereiche auf dem Zählrad, die viel besser 
reflektieren.

Von den teilweise "krummen" Widerstandswerten (R2..R5 etc.) bitte nicht 
irritieren lassen, die sind Überzählig und boten sich für das Steckbrett 
an.

Der Vorwiderstand R1 der LED wurde experimentell ermittelt, Werte bis 
180 Ohm wurden getestet (Leistungsbudget..). Das Ergebnis war, das zwar 
mehr Licht verfügbar ist
und sich das mit verschiedenen Reflektoren auch deutlich bemerkbar 
macht, allerdings ist beim echten Zählrad der Übergang rot<-> nicht rot 
mehr oder weniger konstant
schlecht geblieben. Vermutlich da die Scheibe sehr dünn ist und das 
meiste Licht an Ihr vorbei geht?

Das Oszilloskop zeigt allerdings, das die Schaltschwelle nur wenige mV 
über dem Umgebungspegel liegt, was mir Sorge bereitet - ein Zappeln der 
Schaltung wäre für das Zählergebnis fatal.
Überhaupt ist der Spannungsverlauf alles andere als optimal?

Bevor ich also ein Stück Lochraster verbaue und es dann nicht 
funktioniert:

Fragen und Probleme:
====================
0.)
Irgendwelche krassen Fehler in diesem Erstlingswerk?

1.) Was kann ich tun, um bei ca. 15m einfacher Zuleitungslänge Störungen 
zu minimieren?

2.)
Was kann ich tun, um die Schaltung besser vor Fehlern zu schützen? 
(Verpolung, Spannungsspitzen). Dioden an Q1 (C->|-E; C->|-+5V)?

3.)
Falls jemand eine Idee hat, wie ich aus dem Sensorsignal das Optimum 
rausholen kann, bitte her damit. Verschiedene andere Sensoren/IR-LED 
waren noch schlechter.
Insbesondere würde ich die Schwankungen gern Glätten, die durch das 
Zählrad ausgelöst werden: Das Oszilloskop-Bild zeigt ca. 1/2 Umdrehung 
mit allen "Highlights".


Danke schon mal für eure Hilfe!

von LOL (Gast)


Angehängte Dateien:

Lesenswert?

Nachtrag: Datenblatt OPB743.

Das Teil hat nur 4 Pins, der im Schaltplan vorhandene Fototransistor war 
einfach nur in Kicad vorhanden....

von Falk B. (falk)


Lesenswert?

@ LOL (Gast)

>Die Variante mit dem LM393 wurde gewählt, weil a) vorhanden und b) ist
>ohne Verstärkung und Schalthysterese nichts zu machen:

Schon mal richtig.

>Das Zählrad reflektiert extrem unterschiedlich das Licht des OPB743 und
>die "Schluckung" der roten Markierung ist nur geringfügig stärker als
>der sie direkt umgebende Bereich (irgend ein Lack?? oder es "eiert"?).
>Es gibt aber auch Bereiche auf dem Zählrad, die viel besser
>reflektieren.

Schlecht. Da muss man was machen. Du brauchst ordentlich Kontrast 
zwischen Zahrand un kein Zahnrad. U.a. kann man mit einer passenden 
Lochblende Streu- und Umgebungslicht dämpfen.

>schlecht geblieben. Vermutlich da die Scheibe sehr dünn ist und das
>meiste Licht an Ihr vorbei geht?

Kann sein. Poste mal ein Bild.

>Das Oszilloskop zeigt allerdings, das die Schaltschwelle nur wenige mV
>über dem Umgebungspegel liegt, was mir Sorge bereitet

Mir auch ;-) Das ist nicht stabil und zuverlässig.

>Überhaupt ist der Spannungsverlauf alles andere als optimal?

In der Tat, du hast mehr oder minder nur Rauschen, wenn gleich die 
Differenz zwischen  LOW und HIGH schonn recht groß ist, fast 4V. Aber 
die wilden Schwingungen sind uncool. Entweder Umgebungslicht oder eine 
verseuchte Spannungsversorgung.

>Irgendwelche krassen Fehler in diesem Erstlingswerk?

Das Symbol für Q1 ist falsch, dort muss ein NPN hin.

>1.) Was kann ich tun, um bei ca. 15m einfacher Zuleitungslänge Störungen
>zu minimieren?

LC-Filter an die Spannungsversorgung.

>Was kann ich tun, um die Schaltung besser vor Fehlern zu schützen?
>(Verpolung,

Verpoldiode, Schottky

> Spannungsspitzen).

So viele gibt es da nicht.

>Falls jemand eine Idee hat, wie ich aus dem Sensorsignal das Optimum
>rausholen kann, bitte her damit.

Dazu brauchen wir ein Bild des Zählers.

> Verschiedene andere Sensoren/IR-LED
>waren noch schlechter.

>Insbesondere würde ich die Schwankungen gern Glätten, die durch das
>Zählrad ausgelöst werden:

Dann hast du ja gar keine Signal mehr ;-)

> Das Oszilloskop-Bild zeigt ca. 1/2 Umdrehung
>mit allen "Highlights".

Viel Streulich und Rauschen. Das wird nix, auch wenn eine großer 
Signalhub vorhanden ist.

Erstmal solltest du Umgebungslicht dämpfen, also eine große, lichtdichte 
Kappe über den ganze Aufbau. Dann muss man sehen, dass man den Kontrast 
verbessert. Ich sag mal du brauchst mindestens 100mV Spannungsdifferenz 
vom Optokoppler (Zahn - kein Zahn), damit das halbwegs sicher ist. Und 
die dürfen auch nicht weglaufen, denn du kannst ja nicht dauernd 
nachregeln. Du hast zwar mehr, aber auch verdammt viel starkes Gezappel 
Den meisten Gewinn wird man wohl durch die passende Mechanik und Blenden 
erreichen.

R6 ist zu hochohmig im Verhältnis zu R7, da muss man eher tauschen ;-)
Oder man nimmt gleich einen MOSFET als BS170, dann entfällt R7.

R3 und R4 sind ungüngstig. Ersetze sie durch EINEN Widerstand (100k oder 
so), so wie beim klassischen Schmitt-Trigger. Die Schaltschwelle 
wird dann normal mit dem Poti RV1 eingestellt. Mit R5=909K und dem neuen 
R3=100k hat man ca. +/-250mV Hysterese, das passt.

: Bearbeitet durch User
von Falk B. (falk)


Lesenswert?

Versorge deine Schaltung mal probeweise aus 3x AA Batterien.

von Werner H. (werner45)


Lesenswert?

Nimm statt einer IR-Led eine grüne oder weiße und eine separate 
Fotodiode/-Transistor oder eine zersägte Schranke.
Das verbessert den Kontrast der roten Marke.
Probiere Farbfolien vor dem Empfänger.
Linsen zur Abbildung helfen auch noch das Streulicht zu vermindern.

Gruß   -   Werner

von LOL (Gast)


Angehängte Dateien:

Lesenswert?

Hallo Falk,

Falk B. schrieb:
>>schlecht geblieben. Vermutlich da die Scheibe sehr dünn ist und das
>>meiste Licht an Ihr vorbei geht?
>
> Kann sein. Poste mal ein Bild.

Siehe Anhang. Der Zähler ist mein Experimentierzähler, der "echte" hat 
die schwarze Riffelung nicht. Von daher hoffe ich auf einen Worst-Case 
im Testaufbau.

>>Das Oszilloskop zeigt allerdings, das die Schaltschwelle nur wenige mV
>>über dem Umgebungspegel liegt, was mir Sorge bereitet
>
> Mir auch ;-) Das ist nicht stabil und zuverlässig.

Es gibt glaube ich einen Peak von ca. 150mV, und diverse Tests mit und 
ohne Licht waren auch immer nachvollziehbar.
Das Rauschen liegt vermutlich am Aufbau und am Oszi, davon abgesehen 
sind das halt 2s pro Div, das Rad dreht sehr langsam.

Der Verlauf ist aber nachvollziehbar immer so, d.h. ca. 50% des Umlaufes 
reflektiert es so gut, das es die Spannung ziemlich stark runterzieht, 
allerdings 25% des Umlaufes dafür fast gar nicht.
Prinzipiell wäre mir das ja egal, weil ob ich nun 2cm oder 1/4 des 
Umlaufes zähle ist nicht relevant. Allerdings macht auch der gut 
reflektierende Teil so Sprünge, und die lösen dann mehrfache Impulse 
aus.

Der 150-200mV Peak im Oszi-Bild ist die rote Markierung und deren Dauer, 
da wird schön exakt geschalten. Die schluckt nochmal mehr Licht als der 
Rest der Scheibe.

Mit dem Trimmer ist das auch ziemlich gutmütig einzustellen, ca. 1/2 
Umdrehung derzeit.

>>Irgendwelche krassen Fehler in diesem Erstlingswerk?
>
> Das Symbol für Q1 ist falsch, dort muss ein NPN hin.

Ahja. Ich habe da derzeit PNP drin, weil ich ja gegen GND schalte. Mit 
einer Test LED (nicht im Bild) von +5V -> Q1 Pin C geht es auch und ich 
sehe wann geschalten wird ;)

>>1.) Was kann ich tun, um bei ca. 15m einfacher Zuleitungslänge Störungen
>>zu minimieren?
>
> LC-Filter an die Spannungsversorgung.

Macht das auch Sinn bei dem "Schaltkontakt"? Der ist ja normal auch +5V. 
Besonders schnell und steil muss vermutlich nicht geschalten werden.
(Der DS2423 am anderen Ende hat zwar ne Hysterese, aber glaube ich keine 
große.)

>>Was kann ich tun, um die Schaltung besser vor Fehlern zu schützen?
>>(Verpolung,
>
> Verpoldiode, Schottky
>
Okay, also ein paar BAT46 dazu.

>> Das Oszilloskop-Bild zeigt ca. 1/2 Umdrehung
>>mit allen "Highlights".
>
> Zu wenig, das ist nur Streulich und Rauschen.

Ich hatte im Raum nur ne Neonröhre mit 22W an. Wenn ich die direkt auf 
den Zähler richte, sieht das genau so aus. Taschenlampe ändert auch 
nichts, der 150mV Peak bleibt, nur der allgemeine Pegel verschiebt sich 
(ggf. Trimmer nachstellen).

> Erstmal solltest du Umgebungslicht dämpfen, also eine große, lichtdichte
> Kappe über den ganze Aufbau. Dann muss man sehen, dass man den Kontrast
> verbessert. Ich sag mal du brauchst mindestens 50-100mV
> Spannungsdifferenz vom Optokoppler (Zahn - kein Zahn), damit das

rot<->nicht rot. Und die hab ich, das Oszibild hat auf Ch.2 2V/div. Egal 
was ich gemacht habe: Das absolute Maximum war immer an der roten 
Markierung, nur halt nur ca. 5-10% mehr als das restliche Signal - und 
letzteres schwankt extrem.

> R6 ist zu hochohmig im Verhältnis zu R7, da muss man eher tauschen ;-)
> Oder man nimmt gleich einen MOSFET als BS170, dann entfällt R7.

Okay, das ist dann was zur Nachbesserung des Schalters.

> R3 und R4 sind ungüngstig. Ersetze sie durch EINEN Widerstand (10k oder
> so), so wie beim klassischen Schmitt-Trigger. Die Schaltschwelle
> wird dann normal mit dem Poti RV1 eingestellt. Mit R5=909K und dem neuen
> R3=10k hat man ca. +/-25mV Hysterese, das passt.

Okay, werd ich mal testen. R4 ist drin, weil der im Datenblatt von TI:
http://www.ti.com/lit/gpn/lm193-n
Seite 14, Fig. 23 drin ist. In den anderen Schaltungen und bei den 
Rechnern im Internet hab ich den nirgendwo gefunden. Funktionierte aber 
glaube ich besser mit, bei diversen Iterationen vor diesem Post war er 
nicht drin.

Mit R3 kleiner werde ich mal testen, 10k hatte ich aber IIRC auch schon 
mal verbaut. Das war glaube ich nicht besser, eher schlechter. Könnte 
das am Poti liegen? Das ist ein 10 Umdrehungen trimmer, leider habe ich 
davon keine >20k. Werde ich morgen nochmal testen.

von LOL (Gast)


Lesenswert?

Falk B. schrieb:
> Versorge deine Schaltung mal probeweise aus 3x AA Batterien.

Werd ich machen. Derzeitige Spannungsversorgung ist der 5V 
Festpannungsausgang von einem Peaktech 6035D

https://www.reichelt.de/Labornetzgeraete/PEAKTECH-6035D/3/index.html?ACTION=3&GROUPID=4952&ARTICLE=42362&OFFSET=500&WKID=0&;

(Keine Ahnung, ob das noch das selbe Modell ist, meins ist >10 Jahre 
alt.)

Das sollte eigentlich Linear sein, aber bei dem Kabelchaos auf dem Tisch 
würde mich nichts wundern. Trägt aber zum Worst-Case Szenario bei ;)

von Falk B. (falk)


Lesenswert?

@ LOL (Gast)

>Umlaufes zähle ist nicht relevant. Allerdings macht auch der gut
>reflektierende Teil so Sprünge, und die lösen dann mehrfache Impulse
>aus.

Eben das darf nicht sein.

>Der 150-200mV Peak im Oszi-Bild ist die rote Markierung und deren Dauer,
>da wird schön exakt geschalten. Die schluckt nochmal mehr Licht als der
>Rest der Scheibe.

Ja, aber die Störungen, Peaks sind Mist.

>Ahja. Ich habe da derzeit PNP drin, weil ich ja gegen GND schalte.

Mit einem PNP? Sehr unüblich.

> Mit
>einer Test LED (nicht im Bild) von +5V -> Q1 Pin C geht es auch und ich
>sehe wann geschalten wird ;)

Du betreibst den Transistor falsch. Das geht zwar, ist aber nicht sehr 
schön und auch nicht leistungsfähig.

>> LC-Filter an die Spannungsversorgung.

>Macht das auch Sinn bei dem "Schaltkontakt"?

Deine Lichtschranke und der Komparator sind kein Schaltkontakt, sondern 
Analogtechnik. Und wie man sieht, eher störungsempfindlich.

>Der ist ja normal auch +5V.
>Besonders schnell und steil muss vermutlich nicht geschalten werden.

Darum geht es nicht. Die Störungen von aussen sollen keine Fehlpulse 
erzeugen!

>Ich hatte im Raum nur ne Neonröhre mit 22W an. Wenn ich die direkt auf
>den Zähler richte, sieht das genau so aus. Taschenlampe ändert auch
>nichts, der 150mV Peak bleibt, nur der allgemeine Pegel verschiebt sich
>(ggf. Trimmer nachstellen).

Hmmm.

>rot<->nicht rot. Und die hab ich, das Oszibild hat auf Ch.2 2V/div. Egal
>was ich gemacht habe: Das absolute Maximum war immer an der roten
>Markierung, nur halt nur ca. 5-10% mehr als das restliche Signal - und
>letzteres schwankt extrem.

Das ist schlecht.

Wie der Werner schon schrieb. Nimm eine grüne LED. Denn die rote 
Markierung reflektiert kein grünes Licht, ist also bei grüner 
Beleuchtung schwarz (probiers aus im Dunkeln). Der helle Teil ist 
"weiß", er reflektiert alle Farben gleich gut. Damit bekommt man 
deutlich mehr Kontrast. Trotzdem muss man die Empfängerdiode gut 
ausrichten und mit Blenden versehen, damit sie nur die schmale Scheibe 
"sieht" und keinerlei Streulicht. Möglicheweise bekommt man das auch mit 
dem Reflexkoppler hin, muss man halt viel probieren. Z.B. mit schwarzem 
Klebeband eine einfache Streifenblende herstellen, welche nur noch die 
Scheibe sichtbar läßt. Vielleicht 1mm Spaltbreite.

von LOL (Gast)


Lesenswert?

Falk B. schrieb:
>>Ahja. Ich habe da derzeit PNP drin, weil ich ja gegen GND schalte.
>
> Mit einem PNP? Sehr unüblich.

Grad noch mal nachgelesen, genau falsch rum. Clever ;)
>>> LC-Filter an die Spannungsversorgung.
>
>>Macht das auch Sinn bei dem "Schaltkontakt"?
>
> Deine Lichtschranke und der Komparator sind kein Schaltkontakt, sondern
> Analogtechnik. Und wie man sieht, eher störungsempfindlich.

Ich meinte hier den Transistorausgang, wenn ich den dann mal richtig rum 
habe.

>>rot<->nicht rot. Und die hab ich, das Oszibild hat auf Ch.2 2V/div. Egal
>>was ich gemacht habe: Das absolute Maximum war immer an der roten
>>Markierung, nur halt nur ca. 5-10% mehr als das restliche Signal - und
>>letzteres schwankt extrem.
>
> Das ist schlecht.
>
> Wie der Werner schon schrieb. Nimm eine grüne LED. Denn die rote

Werde ich auch mal probieren. Brauche ich denn dann nicht auch einen 
anderen Fototransistor? Laut Datenblatt sind die ja stark von der 
Wellenlänge abhängig.

Das was mir am OPB743 halt gut gefallen hat ist das beide Teile der 
Optik halbwegs auf einander ausgerichtet sind. Gut, Reflektiert am 
besten bei 4mm (die Messung ist laut Datenblatt mit Papier gemacht), von 
der reinen Mechanik sollte das mit einem echten Reflektor weiter gehen. 
Ich hatte das auch vorher mit einem Metallspiegel probiert - bis 10mm 
war alles im grünen Bereich. Nur war der Spiegel halt nicht die 
Zählscheibe...

Immerhin kann man das Gehäuse aufhebeln und die Diode bzw. den 
Transistor austauschen.

von Frank G. (frank_g53)


Lesenswert?

LOL schrieb:
> Brauche ich denn dann nicht auch einen
> anderen Fototransistor?
Dein verwendeter Sensor sieht groß aus,
ich verwende für diesen Zweck diesen 
hier:https://www.reichelt.de/Optokoppler/ELI-TR8307/3/index.html?ACTION=3&GROUPID=3046&ARTICLE=114341&OFFSET=16&;

Den setze ich auch für den Wasser- und Gaszähler ein.

von Werner H. (werner45)


Lesenswert?

...Vielleicht hilft auch ein "rot-selektiver" Empfänger in Form einer 
roten Led als Fotodiode. Habe mal gelesen, daß die Leds für ihre 
Emissionsfarbe auch als Empfänger am empfindlichsten sind, aber das nie 
ausprobiert.
Beleuchtung dann mit weißer Led.
Falschlicht-Abblendung ist aber hier zwingend nötig, um das 
Signal-Rausch-Verhältnis schon zu Beginn zu verbessern.

Jetzt erinnere ich mich, mal einen Aufsatz des Zählerherstellers 
Landis&Gyr gelesen zu haben, wobei die mit der Auswertung genau dieses 
Meßverfahrens auch etliche Klimmzüge machen mußten, bis das fehlerfrei 
funktionierte. Das war vor der Led-Zeit und die arbeiteten mit einer 
Abbildungsoptik für die Glühbirne und die Fotodiode.

Gruß   -   Werner

PS: Im Nahen IR, wo die Reflexlichtschranken arbeiten, wird nur der 
äußere Schutzlack gesehen, egal ob es darunter blank oder gefärbt ist. 
Das erklärt auch den relativ schlechten Kontrast.

von Jörg E. (jackfritt)


Lesenswert?

Frank G. schrieb:
> LOL schrieb:
>> Brauche ich denn dann nicht auch einen
>> anderen Fototransistor?
> Dein verwendeter Sensor sieht groß aus,
> ich verwende für diesen Zweck diesen
> 
hier:https://www.reichelt.de/Optokoppler/ELI-TR8307/3/index.html?ACTION=3&GROUPID=3046&ARTICLE=114341&OFFSET=16&;
>
> Den setze ich auch für den Wasser- und Gaszähler ein.

Kannst du was zu deinem Aufbau und der Schaltung sagen zeigen? Ich habs 
mal mitm Wasserzähler probiert aber der wollte nich ?

von Frank G. (frank_g53)


Angehängte Dateien:

Lesenswert?

Jörg E. schrieb:
> Kannst du was zu deinem Aufbau und der Schaltung sagen zeigen?

Nicht professionell, aber es funktioniert:
* Einen Impedanzwandler
* nachgeschalteten Schmitt-Trigger
* eine LED als Justierhilfe.
Dann habe ich solange auf dem Steckbrett herumexperimentiert, bis es 
passte.
Als erste Gehversuche nahm ich einen Sensor, den ich mal irgendwo 
ausgeschlachtet hatte (Siehe Gaszählerfoto).
Daraufhin bestellte ich ein paar bei Reichelt.

Auf dem Stromzählerfoto sieht man schön den IR-Punkt.

: Bearbeitet durch User
von LOL (Gast)


Lesenswert?

Hallo Werner,

Werner H. schrieb:
> ...Vielleicht hilft auch ein "rot-selektiver" Empfänger in Form
> einer
> roten Led als Fotodiode. Habe mal gelesen, daß die Leds für ihre
> Emissionsfarbe auch als Empfänger am empfindlichsten sind, aber das nie
> ausprobiert.

Ich habe das mal in google geworfen, und wie es scheint sind LEDs in 
einem leicht anderen Bereich lichtempfindlich, als sie selbst 
abstrahlen:

https://led-brdf.wikispaces.com/Led+Sensing+and+Spectral+Sensitivity

Und der Bereich ist wohl auch sehr klein.
(PDF am Ende der Seite)

Glaubt man dieses, wäre eine grüne Beleuchtung mit gelber oder oranger 
LED als Empfänger vermutlich optimal.

Insofern habe ich mal all meine LED durchprobiert - am besten war eine 
Orange LED. Leider ist eine LED oder Fotodiode mit Zusatzaufwand 
verbunden, was die Schaltung angeht - da sind Größenordnungen zum 
Fototransistor dazwischen.

Allerdings habe ich auch nur 15+ Jahre alte no-name LED da.

Nennen wir es Plan B.

Ich habe auch IR-Empfänger / Fototransistoren die ich aus diversen 
Geräten habe getestet, die reagieren höchstens auf rotes Licht und das 
auch nur um Größenordnungen schlechter als auf IR.

Somit habe ich derzeit nichts zur Hand, was ich mal eben spontan umbauen 
könnte - kommt auf die Shoppingliste.

> PS: Im Nahen IR, wo die Reflexlichtschranken arbeiten, wird nur der
> äußere Schutzlack gesehen, egal ob es darunter blank oder gefärbt ist.
> Das erklärt auch den relativ schlechten Kontrast.

Die anderen Projekte, die ich fand argumentieren damit, das der rote 
Lack auch IR absorbiert - zumindest besser als der Rest der Scheibe.
Die Masse verwendet aber einen µC und Wesentlich mehr Leistung für die 
Beleuchtung als die paar mA, die ich derzeit nutze.


Außerdem habe ich heute auch mal mit verschiedenem Streulicht 
experimentiert:

Die jetzige Schaltung ist unempfindlich gegen Energiesparlampen, 
Neonröhren und LED-Licht. Aber wehe, wenn eine Halogenlampe (uralte 
Taschenlampe) kommt: Die scheint einen immensen Infrarotanteil zu haben 
(wen wundert's) und übertönen die LED selbst bei indirektem Licht 
sofort.

Sonne dürfte genau so tödlich sein, allerdings ist das im Moment eher 
schwer zu testen.

Jedenfalls muss da also definitiv ne Kappe drüber, sollte das jemals 
fertig werden.

von Falk B. (falk)


Lesenswert?

@ Frank G. (frank_g53)

>Nicht professionell, aber es funktioniert:

Mit viel Glück!

>* Einen Impedanzwandler

Im Schaltplan steht Transimpedanzverstärker, aber das stimmt nicht.

>* nachgeschalteten Schmitt-Trigger

Das ist der sinnvolle Teil deiner Schaltung ;-)

>* eine LED als Justierhilfe.

Dito.

Deine Schaltung ist schlecht. U1.1 ist bei dir als Komparator ohne 
Hysterese beschaltet. Ganz große Pfui! Denn damit zappelt der Ausgang 
nahe der Schaltschwelle schon rum, und zwar von 0V bis VCC. Das ist KEIN 
Linearverstärker, es fehlt die Rückkopplung! Der nachgeschaltete 
Schmitt-Trigger ist damit praktisch wirkungslos, es gibt ja nicht mal 
eine RC-Filter gegen höherfrequente Fehlpulse!

Das Ganze kann man deutlich einfache und BESSER aufbauen, wenn man 
gleich die 1. Stufe als invertierenden Schmitt-Trigger beschaltet. 
Der ist hochohmig genug am Eingang, LM393 & Co.

Der Phototransistor ist verpolt im Schaltplan.

von Falk B. (falk)


Lesenswert?

@ LOL (Gast)

>> ...Vielleicht hilft auch ein "rot-selektiver" Empfänger in Form
>> einer
>> roten Led als Fotodiode.

Nein.

> Habe mal gelesen, daß die Leds für ihre
>> Emissionsfarbe auch als Empfänger am empfindlichsten sind, aber das nie
>> ausprobiert.

LEDs sind miese Photodioden, die Empfindlichkeit ist deutlich geringer.

>Glaubt man dieses, wäre eine grüne Beleuchtung mit gelber oder oranger
>LED als Empfänger vermutlich optimal.

Vergiss das.

>Insofern habe ich mal all meine LED durchprobiert - am besten war eine
>Orange LED. Leider ist eine LED oder Fotodiode mit Zusatzaufwand
>verbunden, was die Schaltung angeht - da sind Größenordnungen zum
>Fototransistor dazwischen.

Eben!

>Ich habe auch IR-Empfänger / Fototransistoren die ich aus diversen
>Geräten habe getestet, die reagieren höchstens auf rotes Licht und das
>auch nur um Größenordnungen schlechter als auf IR.

Logisch, die haben meist einen Tageslichtsperrfilter drin.

>Die anderen Projekte, die ich fand argumentieren damit, das der rote
>Lack auch IR absorbiert - zumindest besser als der Rest der Scheibe.

Ist auch so. Die Frage ist halt, ob der Kontrast reicht.

>Die Masse verwendet aber einen µC und Wesentlich mehr Leistung für die
>Beleuchtung als die paar mA, die ich derzeit nutze.

Das braucht man alles nicht. Der uC reißt es nicht raus, mehr 
Lichtleistung auch nicht.

>Die jetzige Schaltung ist unempfindlich gegen Energiesparlampen,
>Neonröhren und LED-Licht. Aber wehe, wenn eine Halogenlampe (uralte
>Taschenlampe) kommt: Die scheint einen immensen Infrarotanteil zu haben
>(wen wundert's) und übertönen die LED selbst bei indirektem Licht
>sofort.

Also eine Kappe über alles!

von LOL (Gast)


Angehängte Dateien:

Lesenswert?

Außerdem neu:

1.)
Ich habe Messungen im Batteriebetrieb (4x1,2V NiMh) gemacht. Das 
Ergebnis sieht nicht anders aus als gestern auch.

Mir viel auch auf, das die Spitzen in der "gut" reflektierenden Zone 
offenbar daher kommen, das die schwarze Riffelung teilweise nicht 
vollständig ist und vermutlich dort das Alu der Scheibe durchscheint. 
Wenn der Zähler wirklich still steht (Stecker raus - das Teil läuft auch 
ohne Verbraucher langsam weiter...), sind die Messungen am Oszi nur 
waagerechte Linien.

2.)
Umbau der Schaltung auf 10k Widerstand, Stromversorgung wieder über das 
Labornetzteil.

Ergebnis im Bild Oszi-10k_vertikal.gif - keine Änderung.
Hier habe ich auch mal die rote Markierung hervorgehoben, man sieht den 
Spitzenwert recht gut.

3.)
Test anderer Ausrichtung der LEDs.
Ich hatte die bislang parallel zur Scheibe/Horizontal, da ich hoffte, so 
einen breiteren Streifen bestrahlen zu können und evt. die "Riffelung" 
mit Reflektieren würde. Außerdem war das so wesentlich einfacher 
auszurichten ;-).

Eine vertikale Ausrichtung brachte keine Wesentliche Änderung des 
Signalpegels, allerdings ist die Montage deutlich schwieriger, weil der 
Reflektierende Punkt "kleiner" ist: In der Höhe hat man quasi nur den 
Scheibendurchmesser Spiel, in der Breite ist die Position dagegen fast 
egal, pi*Daumen reicht.

Bei horizontaler Ausrichtung ist das Ganze erheblich "schwammiger": Man 
kann die Scheibe zwar quasi nicht verfehlen, hat dafür aber Probleme, 
den Punkt maximaler Reflexion zu finden. Alles reflektiert irgendwie, 
nur halt nicht gut.

Für die endgültige Mechanik werde ich deshalb eher die vertikale 
Variante wählen: Lieber empfindlich zu justieren als nicht das Maximum 
finden.


Im Moment glaube ich, wie bereits vorgeschlagen mit einer komplett 
schwarzen Kappe das Ablesen realisieren zu können. Allerdings sind dann 
Fremdablesungen des Zählers nicht mehr ohne Eingriff möglich. Das geht 
vermutlich ins Auge, falls doch mal jemand vom Netzbetreiber 
reinschaut...


Ich werde mir morgen mal den endgültigen Zähler vornehmen, vielleicht 
funktioniert das Ganze ohne geriffeltes Rad (und daher kommende 
Schwankungen) besser. Da ich nur den einen Zähler habe (alle anderen 
haben Reflektoren oder Reedkontakte) ist es vermutlich besser, die 
Kirche im Dorf zu lassen...

GGf. probiere ich noch mal die Schaltung von frank_g53 aus, mal sehen.

Über Erfolg oder Misserfolg berichte ich dann entsprechend ;)

Danke an alle Beteiligten für die hilfreichen Kommentare.

von Carl D. (jcw2)


Lesenswert?

Ist der Transistor tatsächlich ein PNP und wenn ja, woher bekommt der 
seinen Basisstrom? Das ist wohl eher ein NPN (BC547) verbaut wurden. Die 
Anschlüsse würden dann auch passen.
 Der LM393 Hat eigentlich schon einen OpenCollector-Ausgang, das ist der 
Grud warum R6 gebraucht wird. Es wird also kein extra Transistor 
gebraucht.

von Falk B. (falk)


Lesenswert?

@ LOL (Gast)

>Ich habe Messungen im Batteriebetrieb (4x1,2V NiMh) gemacht. Das
>Ergebnis sieht nicht anders aus als gestern auch.

Auch das ist eine wichtige Erkenntnis.

>Wenn der Zähler wirklich still steht (Stecker raus - das Teil läuft auch
>ohne Verbraucher langsam weiter...), sind die Messungen am Oszi nur
>waagerechte Linien.

OK.


>Ergebnis im Bild Oszi-10k_vertikal.gif - keine Änderung.
>Hier habe ich auch mal die rote Markierung hervorgehoben, man sieht den
>Spitzenwert recht gut.

Naja, die Wackler davor und danach sind aber auch nicht ohne.

>den Punkt maximaler Reflexion zu finden. Alles reflektiert irgendwie,
>nur halt nicht gut.

Schlecht.

>Für die endgültige Mechanik werde ich deshalb eher die vertikale
>Variante wählen: Lieber empfindlich zu justieren als nicht das Maximum
>finden.

Eben!

>Im Moment glaube ich, wie bereits vorgeschlagen mit einer komplett
>schwarzen Kappe das Ablesen realisieren zu können.

Versuch doch mal schrittweise eine Blende zu bauen. Vielleicht reicht ja 
eine Teilblende.

>Schwankungen) besser. Da ich nur den einen Zähler habe (alle anderen
>haben Reflektoren oder Reedkontakte) ist es vermutlich besser, die
>Kirche im Dorf zu lassen...

Eben!

von Frank G. (frank_g53)


Lesenswert?

LOL schrieb:
> GGf. probiere ich noch mal die Schaltung von frank_g53 aus, mal sehen.

Lieber nicht:

Falk B. schrieb:
> Deine Schaltung ist schlecht. U1.1 ist bei dir als Komparator ohne
> Hysterese beschaltet. Ganz große Pfui! Denn damit zappelt der Ausgang
> nahe der Schaltschwelle schon rum, und zwar von 0V bis VCC. Das ist KEIN
> Linearverstärker, es fehlt die Rückkopplung! Der nachgeschaltete
> Schmitt-Trigger ist damit praktisch wirkungslos, es gibt ja nicht mal
> eine RC-Filter gegen höherfrequente Fehlpulse!

Muss mir bei Gelegenheit das "Design" nochmal ansehen/messen. Ist schon 
länger her. Zählerstände passen aber bis jetzt.
Es sind 2 Neonröhren über den Schaltungen installiert.Wenn das Licht 
ein- und ausgeschaltet wird, hat das keinen störenden Einfluss. Daher 
habe ich die Kondensatoren einfach weggelassen.....
Ist eben alles ein Provisorium, was wahrscheinlich nicht mehr geändert 
wird.....

LOL schrieb:
> Das geht
> vermutlich ins Auge, falls doch mal jemand vom Netzbetreiber
> reinschaut...

Bei mir hatten sie den Verdacht ich würde den Zähler manipulieren.....

von LOL (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,

ein finales Update hierzu:

LOL schrieb:
> Ich werde mir morgen mal den endgültigen Zähler vornehmen, vielleicht
> funktioniert das Ganze ohne geriffeltes Rad (und daher kommende
> Schwankungen) besser. Da ich nur den einen Zähler habe (alle anderen
> haben Reflektoren oder Reedkontakte) ist es vermutlich besser, die
> Kirche im Dorf zu lassen...

Das habe ich heute mal mit der Schaltung probiert, Messaufbau wie 
zuletzt mit 10k/909k Hysterese und vertikaler Sensoranordnung, 
Stromversorgung 4xAA und ich hab mir diesmal nicht die Mühe gemacht, den 
Schwellwert nachzuregeln.
Am Zählerplatz ist mit Oszi und Steckbrett nicht so dolles arbeiten ;)

Ich hatte den Zähler vorab nicht exakt studiert, weil ich ja einen 
anderen zum testen hatte von dem ich ausging, das er "worst case" sei.

Nun ja, war er.

Siehe Anhang.

Das Oszi-Bild wurde gemacht, während ich mit besagter 
Halogen-Taschenlampe gestört habe ;-) Durch die physische Nähe der 
Scheibe trifft man schlichtweg nicht mehr -> keine nennenswerte 
Auswirkungen.

Das der Unterschied derartig krass sein könnte, hatte ich nicht 
erwartet.
Ich musste nicht mal den Vorwiderstand für den Fototransistor 
anpassen...

Der Hauptunterschied ist vermutlich, das beim EVU-Zähler das Zählrad 
deutlich näher dran ist, was es direkt in den Fokus des OPB743 bewegt. 
Dadurch ist die Reflexion nahezu ideal.

Außerdem ist das Zählrad glatt, hat keine Lackschicht und die rotbraune 
Markierung ist dick + matt.

Insofern: Viel unnötiger Aufwand/Sorge.

Falls also jemand 4mm->1cm via IR Reflektiv messen will: Der OPB743 von 
Pollin ist sehr nett für 0,30€. Sogar mit wenig Strom für die LED ;)

Ich mach jetzt noch die Mechanik hübsch, danach dürfte die Sache 
erledigt sein.


Carl Drexler schrieb in Beitrag #4406492
> Das ist wohl eher ein NPN (BC547) verbaut wurden. Die
Anschlüsse würden dann auch passen.
Das mit dem PNP vs. NPN hatten Falk Brunner schon klargestellt, steht 
auf der ToDo-Liste. Das alles ist bis dato nur drin, damit die Messwerte 
vergleichbar waren. Einen Transistor werde ich trotzdem vorsehen, auch 
wenn es mit dem LM393 geht: Erstens mehr Strom möglich, zweitens lieber 
der Transistor stirbt als der LM. </Paranoia>

Frank G. schrieb in Beitrag #4406536
> Bei mir hatten sie den Verdacht ich würde den Zähler manipulieren.....

Da hab ich auch drüber nachgedacht.
Prinzipiell ist es aber trivial nachzuweisen, das a) mein Verbrauch 
gleich bleibt b) ich das Ding hier dokumentiert habe c) es nicht 
magnetisch ist ;) Insofern seh ich da nicht das Problem, Smart Home ist 
jetzt bekannter als früher. Mal abgesehen davon, das wenn das nächste 
mal jemand vom Netzbetreiber kommt, es vermutlich derjenige ist, der 
einen neuen Zähler setzen will. Und das wird vermutlich kein Ferraris 
sein ;)


Danke nochmal für eure Hilfe und Anregungen.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.