mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik RELAIS Ansteuerung ULN2003V12


Autor: Marcus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mir eine Schaltung mit einem ULN2003V12 aufgebaut, da ich eine 
Steuerspannung von 3.5V und eine Arbeitsspannung von 12V habe.

Der µC steuer mit 3.6V den Eingang des ULN und die Ausgänge des ULN 
steuern dann mit 12V die Relais. (gemeinsames GND)

Ich habe mittlerweile 3 Eingänge des ULN gebrückt, da der ULN bei 3.6V 
nur 100mA verträgt, die Relais aber mit 140mA angeben sind.

Trotzdem raucht der ULN nach ca. 10 Sekunden Tätigkeit ab.

In meinem Testaufbau sind der ULN und 2 Relais (die bistabile Relais 
ansteuern).
Irgendetwas mache ich falsch, aber keine Ahnung was.

Gibt es vielleicht eine bessere Lösung als meinen Ansatz?
Ich muss hinzufügen: Ich bin blutiger Anfänger, und für jede Hilfe 
dankbar.

Gruß
Marcus

: Verschoben durch Admin
Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hast Du die Freilaufdioden (Pin 9) nicht wirklich an +12V 
angeschlossen ...
Auserdem fehlt da zumindest ein C über die Betriebsspannung in der Nähe 
des ULN (ist zwar eigentlich nicht wirklich nötig bei solch einem IC, 
aber der fängt dann wenigstens die Freilaufspannungsspitze ab).

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Freilaufspannungsspitze

Was soll das sein?

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Trotzdem raucht der ULN nach ca. 10 Sekunden Tätigkeit ab.

Miss doch mal die Eingangs- und Ausgangsspannung.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jens - Danke
Pin9 liegt an +12V an.
Hoffe dass ich C für Kondensator richtig verstehe.
Wie sollte der Kondensator dimensioniert sein?
Einen Kondensator hatte ich nicht eingeplant, da die Musterschaltungen 
von TI auch keinen haben.

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Marcus schrieb:
>> Trotzdem raucht der ULN nach ca. 10 Sekunden Tätigkeit ab.

Was heisst "Tätigkeit"? Die Relais sind 10 Sekunden angezogen (es fließt 
also dauerhaft Strom), oder schaltest du in diesen 10 Sekunden oft ein 
und aus.

Marcus schrieb:
> Wie sollte der Kondensator dimensioniert sein?
> Einen Kondensator hatte ich nicht eingeplant, da die Musterschaltungen
> von TI auch keinen haben.

Die Kondensatoren helfen induktive Effekte von Zuleitungen zu mindern.
Bei dir sieht es so aus, also ob bei GND und +12V Kabel im Spiel sind.

Nimm am besten eine Kombination aus mehreren, parallelen Kondensatoren, 
z.B. 10nF, 100nF und 1uF (jeweils Keramik, >= 25V).
Plazierung nahe dem ULN.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Hinz - Danke
Leider sind bei meinen Versuchen alle 4 ULNs, die ich hatte, 
durchgebrannt.
AM ULN liegen 12.24Van
Pin1,2,3 11,5V
Pin4,5,6 12.24V
Pin14,15,16 12.07V
Pin11,12,13 12.24V
Die Relais ziehen noch an, wenn die Spannung anliegt.
...
Während des Durchmessens habe ich eine Lötbrücke entdeckt.
Werde erst mal einen neuen ULN bestellen und schauen.
...
Danke an alle bisherigen Antworter.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Joe - Danke.

Mit Tätigkeit meine ich dass die Relais vielleicht alle Sekunde ein Mal 
geschaltet haben - nicht Dauer EIN.

Es ist eine gedruckte Schlatung auf einer Platine.
Die Kondensatoren parallel zum ULN - richtig?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Pin1,2,3 11,5V
>Pin4,5,6 12.24V

Wie das? Ich denke, Du steuerst diese Eingänge mit 3,6V an ...

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> Nimm am besten eine Kombination aus mehreren, parallelen Kondensatoren,
> z.B. 10nF, 100nF und 1uF (jeweils Keramik, >= 25V).
> Plazierung nahe dem ULN.

Meinst du der ULN2803 arbeitet im GHz Bereich?

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Ich habe mittlerweile 3 Eingänge des ULN gebrückt, da der ULN bei 3.6V
> nur 100mA verträgt, die Relais aber mit 140mA angeben sind.

Welche Variante von dem Relais hast Du denn? Ich finde ein Datenblatt zu 
RSM850 in dem die 12 Volt Variante mit 1028 Ohm angegeben ist. Das wären 
gerade mal 12 mA, was ein Ausgang des ULN locker schafft.
Welchen Spulenwiderstand haben Deine Relais? Weleche genaue Bezeichnung 
haben die Relais?

Was soll die Schaltung machen? Die Relaiskontakte vom rechten Relais 
sind nur zum Teil beschaltet. Das reche Relais kann nur anziehen wenn 
das linke Relais angezogen ist, nur dann bekommt es VCC.
Das Linke Relais hat auch keine weitere Funktion, es legt mit dem linken 
Kontakt GND auf NO des linken Kontakts des rechten Relais.

Din Pins 5 und 6 sind lt. Datenblatt unbeschaltet, bei Dir nicht.

Das Schaltbild ist stark verbesserungswürdig.

Für die 2 Relais würden auch 2 Standardtransistoren reichen.

: Bearbeitet durch User
Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@all - bitte nicht vergessen: ich bin blutiger Anfänger was 
elektronische Schaltungen anbelangt

@Jens
Ich habe jeweils gegen GND gemessen.

@Jörg - Danke
Aufgabe der 2 Relais sollte sein, 3 bistabile Relais zu schalten, bei 
denen ein Coil Set und ReSet übernimmt, d.h. je nach Flussrichtung die 
Kontakte schalten.
Ziel ist es Verbraucher ein und aus zu schalten.
Geht das einfacher? Sehe ich den Wald vor lauter Bäumen nicht?

Sorry, die Bezeichnung der Relais ist falsch. Die Relais die ich hier 
habe sind diese: V23079-A1003-B301
Die bistabilen Relais sind folgende: V23079-B1203-B301

Das ist mein erstes Schaltbild und deshalb wundert es mich nicht, dass 
es besser werden kann - und ich hoffentlich auch.

Wie kann ich denn die beiden Relais gegen Standardtransistoren tauschen? 
Kannst Du mir eine Beispielschaltung schicken?

Autor: Marcus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Jörg
Du hast völlig Recht. Ich hatte die Relais in der Schaltung ausgetauscht 
und dabei sind die Kontakte in der Schaltung 1 Pin nach unten gerutscht. 
Habe ich noch gar nicht bemerkt. DANKE.
Anbei die Schaltung mit PAINT korrigiert (auf die Schnelle - morgen 
mache ich es dann richtig).

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marcus,

dann poste morgen doch mal das komplette Schaltbild.
Bis dahin möchte ich Dich auf einen Beitrag aus dem Forum verweisen:

https://www.mikrocontroller.net/articles/Basiswide...

Hast Du die Bauteile schon, vor allem die bistabilen Relais?
Was soll die Schaltung machen?
Warum bistabile Relais? Aus Gründen des Stromsparens?
Welche Last soll am Ende geschaltet werden?

Ich würde den ULN durch 2 Transistoren ersetzen und damit die 2 
"normalen" Relais ansteuern.
Wenn Du die bistabilen noch nicht hast, es aber bistabile sein sollen, 
würde ich welche nehmen die 2 Spulen haben. Eine für Set, die andere für 
Reset. Dann könntest Du die Relais mit je 2 Transistoren ansteuern. Dann 
würden die Relais Deiner "Vorstufe" entfallen und Du bräuchtest die 
Spannung zum ansteuern nicht umpolen.

: Bearbeitet durch User
Autor: Jens G. (jensig)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
@ Marcus (Gast)

>@Jens
>Ich habe jeweils gegen GND gemessen.

Ja eben - wie kommen da an den Eingängen die rund 12V zustande, wenn Du 
doch nur 3,6V da als Signalspannung hast.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, hab gerade gelesen das Du die Relais schon hast😀

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Ja eben - wie kommen da an den Eingängen die rund 12V zustande, wenn Du
> doch nur 3,6V da als Signalspannung hast.

Das würde dann auch den uC in die ewigen Jagdgründe schicken.

Autor: Leo C. (rapid)
Datum:
Angehängte Dateien:
  • preview image for 1.png
    1.png
    41,8 KB, 245 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Ich habe mittlerweile 3 Eingänge des ULN gebrückt, da der ULN bei 3.6V
> nur 100mA verträgt, die Relais aber mit 140mA angeben sind.

Marcus schrieb:
> Sorry, die Bezeichnung der Relais ist falsch. Die Relais die ich hier
> habe sind diese: V23079-A1003-B301

Da hast Du Dich verguckt. Die Relaisspulen sind mit 140mW (nicht mA) 
angegeben. Bei 12V macht das ca. 12mA. Der Widerstand beträgt 1029 Ohm. 
Kommt dann aufs selbe raus (Überraschung).

Autor: Marcus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen Jörg und @all,
Danke schon mal für Eure gestrigen Beiträge.

@Jörg
Habe eine einfache Zeichnung angehängt. Meintest Du das in der Art?
Ich brauche insgesamt 3 Relais, bzw. 6 Kontakte. Kann ich die Relais 
einfach parallel schalten? Oder muss ich das Bildchen 3 mal nehmen?

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OH SORRY vergiss die Zeichnung - total falsch.

Autor: Marcus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, jetzt ein neuer Versuch.

Autor: Dietrich L. (dietrichl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Pin1,2,3 11,5V
> Pin4,5,6 12.24V
> Pin14,15,16 12.07V
> Pin11,12,13 12.24V

Pin 1-6 sind Eingänge, Pin 11-16 Ausgänge.
Da der ULN invertiert müssen bei "high" an den Eingängen die Ausgänge 
"low" werden.
Wenn dann trotzdem noch 12V an den Ausgängen anliegen fließt viel 
Strom. Und die Verlustleistung P=I*U ist umso "gewaltiger". Da muss der 
ULN abrauchen.

> Während des Durchmessens habe ich eine Lötbrücke entdeckt.

Hat diese Lötbrücke 12V an die ULN-Ausgänge gelegt? Dann ist die Sache 
klar.

Es ist übrigens gut zur Kontrolle den Strom der 12V-Quelle zu messen. 
Dann hast Du einen einfachen Überblick, ob da was nicht stimmt.

Gruß Dietrich

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Dietrich - Danke.
Nein, die Lötbrücke hatte damit nichts zu tun. Aber ich muss die 
Schaltung neu machen. Mittlerweile habe ich da so viel dran rumgelötet 
(Leiterbahnen durchtrennt und Luftverkabelt), dass ich nicht mehr 
durchblicke.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Leo - stimmt Danke für den Hinweis - ja, es bleibt leider bei der 
Überraschung

Autor: FlexTheFox (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ferndiagnose durch die Glaskugel, ohne den Thread im Detail gelesen zu 
haben:
Wenn ich das richtig verstanden habe, verteilst du den Relais-Strom auf 
mehrere Eingänge, sodass er pro Eingang unterhalb dem Maximum bleibt. 
Idee: gut. Problem: einer der Bipolartransistoren im ULN wird 
toleranzbedingt ein Bisschen besser leiten. Er übernimmt mehr vom 
Relaisstrom und entwickelt mehr Verlustleistung. Durch die höhere 
Temperatur im einzelnen Transistor beginnt er noch besser zu leiten, 
usw. Schlussendlich übernimmt er den ganzen Relaisstrom, fackelt ab, und 
das ganze geht mit den verbleibenden Paralleltransistoren weiter.

Beitrag "2 Transistoren parallel?"

Ist das erste, was mir beim lesen des Threads durch den Kopf ging. Kann 
aber auch sein, dass ich was übersehen habe.

Gruess

Felix

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@FlexTheFox - Danke
Guter Einwand, allerdings hatten wir zuvor schon festgestellt, dass die 
Spule nur ca. 12mA/140mW bei 12V zieht und das der ULN aushalten müsste.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> So, jetzt ein neuer Versuch.

Hallo Marcus,

was ist das jetzt für ein Relais mit 2 Spulen?
Wenn es bistabil ist - ok, wenn nicht bringt dir diese Ansteuerung 
nichts.

Ohne jetzt nachzurechnen kommen mir die 10 K Vorwiderstände zu hoch vor.
Ansonsten wäre es aber korrekt, auch an die Schutzdiode hast du gedacht.

Hier noch mal einige Fragen die ich oben schon gestellt habe:

> Was soll die Schaltung machen?
> Warum bistabile Relais? Aus Gründen des Stromsparens?
> Welche Last soll am Ende geschaltet werden?

Siehe Dir mal die Software KiCAD, Target oder Eagle an. Damit kannst Du 
schönere und vor allem übersichtlichere Schaltpläne zeichnen😀

Gruss
Jörg

: Bearbeitet durch User
Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Jörg
Ja, es handelt sich um bistabile Relais, mit zwei Spulen. Jede Spule 
kann set und reset übernehmen.
10k sind zuviel? Welche Auswirkung hat das? Mit welcher Formel berechne 
ich den benötigten Wiederstand?

- Ich möchte mehrere Verbraucher physikalisch vom Netz trennen können.
- Bistabil, damit sowohl der eine als auch der andere Zustand, 
unabhängig von der Stromversorgung, immer so ist, wie zuletzt 
geschaltet.
- Last: max. 12V 3A

Wenn nach der Schaltung kein Fehler auszumachen ist, weshalb der ULN 
abraucht, dann habe ich wohl in der tatsächlichen Verdrahtung einen 
Fehler - richtig?

Danke und Gruß
Marcus

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Wenn nach der Schaltung kein Fehler auszumachen ist, weshalb der ULN
> abraucht, dann habe ich wohl in der tatsächlichen Verdrahtung einen
> Fehler - richtig?

Yes!

Hast Du den Aufbau noch? Dann poste mal einige gute Bilder. Vielleicht 
können wir etwas erkennen.

Rest kommt später, meine Frau ruft....😀

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jörg
Ja, dann eile mal ;-)
Das ist mir auch eingefallen, aber leider erst, als es zu spät war. Das 
was jetzt noch übrig ist reicht nicht mehr für eine Analyse.
Ich überlege jetzt ob ich es noch ein Mal mit einem ULN versuche oder 
Deinem Vorschlag mit den Transistoren nachgehe.
Teile bestellen muss ich so oder so, da ich keinen funktionierenden ULN 
oder Transistoren/Dioden/Widerstände habe.

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vermutlich hast du den ULN verkehrt herum angeschlossen.
Ansonsten sind die ja fast unverwüstlich.
Mit System hättest du den Fehler finden können.
- Ohne ULN und Relais Spannung anlegen und prüfen
- ULN einbauen, dabei Strom prüfen
- Relais nacheinander anschließen, dabei Strom prüfen

Strombegrenzung des NT auf 100mA(?) einstellen. Da geht nichts in 10s 
kaputt.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich den ULN falsch herum angeschlossen hätte, dann hätten die 
Relais doch nicht erst mal korrekt funktioniert bevor der ULN gestorben 
ist, oder?

Autor: Da Schef (daham)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gelötet mit geerdetem Lötkolben und Spannungsversorgung von 
Labornetzteil?
messe bitte spannung zwischen Lötkolbenspitze und deiner 
Stromversorgung.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Ja, dann eile mal ;-)

So, reingefallen! Meine Frau hat gesagt wir gehen ein Messgerät kaufen.
Im Schuhladen gibt es aber keine Messgeräte😩

Die bistabilen Relais haben einen Spulenwiderstand von 1029 R. Damit 
benötigen sie bei 12 Volt ca. xx mA.
Die Spannung vom uC beträgr 3,3 Volt, abzüglich der 
Basis-Emmiter-Spannung von 0,7 Volt fallen an dem 10 K Widerstand 2,6 
Volt ab. Dadurch fließt ein Strom von xx mA durch den Widerstand in die 
Basis des Transistors.

Lies dir doch mal den Artikel über Transistoren durch den ich weiter 
oben verlinkt habe. Ich weis, das ist gemein😎 Möchtest Du etwas lernen 
oder nur die Schaltung zum laufen bringen?

Trotzdem die Anmerkung. Es kann mit den 10 K funktionieren, muss es aber 
nicht. Ich sehe den Widerstand deutlich kleiner. Transistoren 
unterliegen Exemplarstreuungen. Es kann daher sein das 2 Transistoren 
aus deiner Bastelkiste unterschiedlich reagieren.

Zur Frage ULN oder Transistoren? Den ULN kannst Du sockeln und im 
Fehlerfall leichter tauschen. Allerdings geht bei den kleinen Strömen 
nichts kaputt. Der Aufwand mit Transistoren ist etwas höher.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@DaSchef - Danke
Das werde ich mal machen - guter Tipp auch für später.

@Jörg
Ich will was lernen, aber auch die Schaltung ans laufen bringen ;-)
Ich kenne keine SO16 Sockel. Wo gibt es denn sowas?

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ahh ... jetzt habe ich die Sockel gefunden "SOP16 to DIP16 adapter" - 
wusste ich gar nicht dass es soetwas gibt.

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> So, jetzt ein neuer Versuch.

Versuch doch mal, die Schaltpläne in Zukunft als PNG-Datei zu erzeugen 
und hochzuladen. Das kommt der Lesbarkeit umfangreicherer Schaltpläne 
und der Schärfe zu gute. (s. Hinweis zu Dateianhängen und den Artikel 
über Bildformate)

Die JPEG-Kompression ist für Photos optimiert und muss vor scharfen 
Linien ziemlich kapitulieren bzw. erzeugt im Verhältnis zum 
Informationsgehalt riesige Dateien.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Wolfgang - Danke
Jepp, mache ich zukünftig.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marcus,

der Basisstrom, der aktuell bei einem Vorwiderstand von 10K fließt
liegt bei ca. 0,26mA. Das wird vermutlich auch funktionieren.

Trotzdem habe ich mal eine Berechnung beigefügt:

Deine Last, die Relais haben einen Spulenwiderstand von ca. 1K, liegt 
bei ca. 11,7 mA, bei einer Versorgungsspannung von 12 Volt.
Lt. Datenblatt des BC847 liegt Vcesat bei 90 mV was bei einem Ic von 10 
mA einem Basisstrom von 0,5 mA ergibt.

Der erforderliche Vorwiderstand berechnet sich daher:

R=U/I = 2,6 V / 0,55 mA = 4727R
Der nächste verfügbare Wert ist 4700R bzw. 4K7.

2,6V ist die Spannung die vom uC kommt minus Ube (3,3V - 0,7V = 2,6V).
0,55 mA habe ich angesetzt weil etwas mehr als 10 mA (Wert aus 
Datenblatt) fließen.



Wolfgang schrieb:
> Versuch doch mal, die Schaltpläne in Zukunft als PNG-Datei zu erzeugen
> und hochzuladen.

Marcus schrieb:
> @Wolfgang - Danke
> Jepp, mache ich zukünftig.

Nochmal der Tipp mit Eagle, Target, KiCAD... zu arbeiten. Dein 
"Schaltbild" ist unübersichtlich. Und das obwohl es nur wenige Bauteile 
enthält. Ein Relais wird in einem Schaltbild auch anders dargestellt. 
Wenn Deine Schaltungen mal komplexer werden ist gute Lesbarkeit und gute 
Übersicht wichtig.

: Bearbeitet durch User
Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg,

vielen Dank für Deine Berechnung.
Ich habe gestern schon 4k7 Widerstände bestellt - freu - da habe ich ja 
richtig gerechnet - oder zumindest so falsch, dass es wieder richtig 
ist.

Aber wenn ich nach den berechneten Werten gehe, dann hätte der ULN nicht 
sterben dürfen, wenn ich nicht einen Schaltungsfehler gemacht hätte. Zu 
blöd nur, dass ich es nicht mehr kontrollieren kann.

Ich habe eagle genutzt, aber die Bibliothek offensichtlich für die 
Relais falsch angelegt. Muss ich bei einem anderen Relais mal 
"abschreiben".

Habe mich entschieden es noch ein mal mit dem ULN zu versuchen. Sollte 
das nicht klappen, habe ich sicherheitshalber Transistoren, Dioden und 
Widerstände gleich mitbestellt.
Werde berichten.

Gruß
Marcus

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Aber wenn ich nach den berechneten Werten gehe, dann hätte der ULN nicht
> sterben dürfen, wenn ich nicht einen Schaltungsfehler gemacht hätte.

Hallo Marcus,

es wird ein Schaltungsfehler gewesen sein. Ich vermute Du hast einen 
oder mehrere Ausgänge des ULN direkt auf 12 Volt gelegt. Wenn dann der 
entsprechende Eingang auf H geht entsteht am Ausgang ein Kurzschluss. 
Bei weiteren Versuchen solltest Du am Netzgerät eine Strombegrenzung 
einstellen. 100 mA sollten reichen.

Gruß
Jörg

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Habe mich entschieden es noch ein mal mit dem ULN zu versuchen. Sollte
> das nicht klappen, habe ich sicherheitshalber Transistoren, Dioden und
> Widerstände gleich mitbestellt.

Deinen ULN hast du ja für die 3,3V richtig ausgewählt.
Aber ehe du mit Transis rummachst, kannst du gleich den ULN2003A im 
DIP-16 nehmen. Ist besser handhabbar und noch unkaputtbarer.
Sollte bei deinen geringen Strömen prinzipiell auch bei 3,3V gehen.

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg,

ich dachte der ULN2003V12 wäre der einzige der am Eingang 3.3V und am 
Ausgang 12V unterstützt. Wer lesen kann ist klar im Vorteil.
Der v12 kann am IN1 1.8-5V und am OUT ..20V.
Der A, 3.3-5V und am OUT ..48V.
Klaro ist mir der ULN2003A lieber, da er 300mA anstelle der 100mA 
verträgt (was allerdings meinen Fehler nicht behebt ;-) ) und besser 
verfügbar ist.

Ich glaube, dass ich meinen Fehler jetzt kenne. Ich hatte zuerst 
angenommen, dass der ULN gegen COM, also V+ schaltet. Er schalter aber 
gegen GND. Daraufhin habe ich die Schaltung geändert. Schätze, dass ich 
da irgendeine eine Brücke vergessen habe einzureißen.

Ist das richtig, dass im ULN pro Channel 2 Transistoren hintereinander 
geschaltet sind - einer der schaltet und einer der verstärkt?

Gruß
Marcus

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Deinen ULN hast du ja für die 3,3V richtig ausgewählt.

Wieso steht dann in den Datenblättern immer "ULN2003A 5V TTL, CMOS"?

> Aber ehe du mit Transis rummachst

Quark, für zwei Relais nehme ich zwei BC238 oder neuer und gut ist.

> kannst du gleich den ULN2003A im
> DIP-16 nehmen. Ist besser handhabbar und noch unkaputtbarer.

Unkaputtbar, das glaubst' ja wohl selbst nicht. Ich habe schon genug 
Baugruppen gesehen, wo ein ULN2xxx aufgedampft ist. Ein Problem von 
denen ist, dass viele Leute gerne die zulässige Summe der Last 
überfahren. Der Stein kann xxx mA pro Ausgang, aber nicht für alle 
gleichzeitig!

Autor: db (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich hatte zuerst angenommen, dass der ULN gegen COM,

Lieber im Forum lesen, als ein Datenblatt lesen? Ist das die Zukunft?

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Ist das richtig, dass im ULN pro Channel 2 Transistoren hintereinander
> geschaltet sind - einer der schaltet und einer der verstärkt?

ne, die verstärken beide. Sogenannter Darlington-Transistor. Vorteil 
ist, dass man mit sehr kleinen Steuerströmen arbeiten und keine eigene 
Stromversorgung braucht. Das ist aber auch gleichzeitig der grosse 
Nachteil der Dinger: der Basisstrom des Endtransistors wird vom 
Kollektorpotential bezogen, d.h. dort bleibt immer eine relativ hohe 
Restspannung incl. rel. hoher Verlustleistung. Beides nicht schön, aber 
in vielen Anwendungen tolerabel.
Lösen kann man das Problem mit Mosfets in der Endstufe (TBD62083 z.B.)

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Ist das richtig, dass im ULN pro Channel 2 Transistoren hintereinander
> geschaltet sind - einer der schaltet und einer der verstärkt?

Das steht im Datenblatt! Und man muss nicht mal lesen, Bilder ansehen 
reicht.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
H.Joachim S. schrieb:
> Darlington-Transistor.

Nicht beim ULN2003V12.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> ich dachte der ULN2003V12 wäre der einzige der am Eingang 3.3V und am
> Ausgang 12V unterstützt. Wer lesen kann ist klar im Vorteil.
> Der v12 kann am IN1 1.8-5V und am OUT ..20V.
> Der A, 3.3-5V und am OUT ..48V.
> Klaro ist mir der ULN2003A lieber, da er 300mA anstelle der 100mA
> verträgt (was allerdings meinen Fehler nicht behebt ;-) ) und besser
> verfügbar ist.

Hallo Marcus,

Du musst bei allen Bauteilen auf die genaue Bezeichnung achten. Nimm als 
Beispiel den BC846. Siehe dir vom dem mal das Datenblatt an und achte 
dabei auf die Bezeichnung BC846A, BC846B, BC846C und die damit 
verbundenen Parameter. Gleiches gilt für den ULN2003xxx und und und...


Marcus schrieb:
> Ich glaube, dass ich meinen Fehler jetzt kenne. Ich hatte zuerst
> angenommen, dass der ULN gegen COM, also V+ schaltet. Er schalter aber
> gegen GND.

Der Anschluß "COM" (Pin 9) hat nur die Funktion die internen 
Schutzdioden zu "aktivieren". Die übernehmen die Funktion wie in deiner 
Transistorschaltung die Dioden 1N4148. Wenn Du z.B. LEDs oder 
Siebensegmentanzeigen ansteuerst kann dieser PIN unbeschaltet bleiben. 
Ebenso wenn Du externe Schutzdioden verwendest.

Worauf Du beim ULN2003 auch achten musst ist die max. Strombelastung der 
Ausgänge einzeln und in Summe. Das ist in Deinem Fall nicht relevant, 
vielleicht planst Du aber mal andere Projekte mit höheren Lastströmen.


Manfred schrieb:
> Quark, für zwei Relais nehme ich zwei BC238 oder neuer und gut ist.

Marcus steuert 2 bistabile Relais mit je 2 Spulen an = 4 Transistoren.
Der ULN2003 hat zwar 7 Ausgänge, also 3 zuviel, er ist aber so preiswert 
das ich auf ihn zurückgreifen würde. Dann aber in DIL-Bauweise um ihn 
auch sockeln zu können.

: Bearbeitet durch User
Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> H.Joachim S. schrieb:
>> Darlington-Transistor.
>
> Nicht beim ULN2003V12.

Richtig, der hat FET.

Jörg R. schrieb:
> Dann aber in DIL-Bauweise um ihn
> auch sockeln zu können.

Den ULN2003V12 für 3,3V gibt es nicht in DIL.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Jörg R. schrieb:
>> Dann aber in DIL-Bauweise um ihn
>> auch sockeln zu können.
>
> Den ULN2003V12 für 3,3V gibt es nicht in DIL.

Richtig, ULN2003V12 habe ich aber auch nicht geschrieben😀

Marcus schrieb:
> Klaro ist mir der ULN2003A lieber

...hierauf habe ich Bezug genommen, leider habe ich das "A" bei ULN2003 
vergessen.

: Bearbeitet durch User
Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Klaro ist mir der ULN2003A lieber, da er 300mA anstelle der 100mA
> verträgt (was allerdings meinen Fehler nicht behebt ;-) ) und besser
> verfügbar ist.

Dann lies das Datenblatt!
Deiner und auch der ULN2003A machen 100mA pro Kanal.
Und max. beide 500mA.
Also kein Thema für dich.
Aber sicher muß dafür der SMD-Typ aufgelötet sein, um die Wärme 
wegzukriegen.

Autor: Marcus (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Danke an alle die konstruktive Beiträge leisten.

Hallo Jörg,
ja, ich muss genauer lesen, allerdings fällt es mir als Neuling noch 
recht schwer den Überblick zu behalten. Aber es wird.
Habe mich dazu entschieden eine geätzte Platine zu nehmen, dann ist die 
Verdrahtung wenigstens wie im Plan und besser nachvollziehbar. Die 
sollen Anfang kommender Woche da sein. Bin gespannt.
Gruß
Marcus

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> ja, ich muss genauer lesen, allerdings fällt es mir als Neuling noch
> recht schwer den Überblick zu behalten. Aber es wird.

Hallo Marcus,

es hat Spass gemacht Dir zu antworten😀 Du bist auf die Kommentare 
eingegangen und man merkt das Du interessiert bist und dir Mühe gibst. 
Lasse Dich nicht von Kommentaren verunsichern die dich z.B. nur auf 
Datenblätter verweisen. Jemand der dir helfen will gibt dann auch 
konkrete Tipps.

Jeder hat mal klein angefangen und auslernen wird man nie.

> Habe mich dazu entschieden eine geätzte Platine zu nehmen, dann ist die
> Verdrahtung wenigstens wie im Plan und besser nachvollziehbar. Die
> sollen Anfang kommender Woche da sein. Bin gespannt.
> Gruß Marcus

Denke aber daran das Fehler im Plan auch auf der Platine wiederzufinden 
sind. Du kannst das komplette Schaltbild ja noch mal posten.

Die nicht benutzten Eingänge des ULN2003A kannst Du offen lassen oder 
auf GND legen.

Gruß Jörg

Autor: Marcus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg,
gestern sind die Platinen gekommen und ich habe wieder einen ULN 
eingelötet, ein paar LEDs und Vorwiderstände für das Auge und siehe da, 
es funktioniert. Es war also kein Fehler in der Schaltung, auch nicht 
der böse Lötkolben, nein, ich hatte, wie schon vermutet, wohl einen 
Fehler bei der Verdrahtung gemacht.
Wie auch immer. Das Ergebnis zählt: Yippee es funktioniert.
Ich danke Dir für Deine Geduld.
Gruß
Marcus

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus schrieb:
> Wie auch immer. Das Ergebnis zählt: Yippee es funktioniert.

Hallo Marcus,

dann hat sich der Aufwand ja gelohnt😀

Schön das Du Feedback gibst.

Am besten nimmst Du zukünftig für Versuchsaufbauten ein Netzgerät mit 
einstellbarer Strombegrenzung.

Gruß
Jörg

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.