mikrocontroller.net

Forum: Platinen Altium Designer erzeugte Bauteil zu einen Footprint zuweisen


Autor: Yasemin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, guten Abend euch allen,

ich bin nämlich sehr neu bei Altium Designer. Brauche wirklich dringend 
Hilfe! :((

In der Bibliotek von Altium Designer habe ich leider keinen 
Fotowiderstand gefunden. Habe deswegen selber gezeichnet und möchte nun 
das gezeichnete Symbol zu einer Footprint die schon bereits als 
Widerstand gibt, zuweisen. Geht das überhaupt?
Hab eigentlich einen Footprint auch gemacht und versucht das zu 
zuweisen. Es hat einigermaßen geklappt, leider nach dem ich Schematic 
auf PCB hochgeladen habe, gab bei der Fotowiderstand keine Luftlinien 
zwischen andere Komponenten.

Kann mir jemand vielleicht weiter helfen, wie ich das machen soll.

Vielen Dank im Voraus.
(Wegen grammatischen und Groß/Kleinschreibung entschuldige mich :I)

Gruß
Yasemin

Autor: Cyborg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So kann man nicht nachvollziehen, was du vergessen hast.
Hier ein paar Hilfen:
https://www.youtube.com/results?search_query=altiu...

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vermutlich passen die Pinnummern nicht zusammen.
Wenn du das Update zum PCB machst bekommst du Fehlermeldungen.
Vielleicht sind die Wires im Schaltplan nicht an dem Pin angeschlossen.

Mach mal ein Screenshot von dem Schaltplan Symbol im Schaltplan.

Jens

Autor: Yasemin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, habe gerade die Videos geschaut. Eigentlich hatte ich auch so wie 
denen gemacht :/

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber?
klappt es nun oder nicht?

Autor: Yasemin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jens,

ich kann gerade kein Screenshot machen, da ich auf meinem eigenen 
Rechner kein Altium Designer habe :/
Kann aber gerne morgen früh einfügen.

Meine Vermutung ist auch, dass es mit dem Drahten nicht was passt. Es 
scheint dass sie verbunden sind aber wahrscheinlich nicht..

Autor: Yasemin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann erst morgen nochmal ausprobieren :/

Autor: Merve (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen Jens,

so sieht der Schaltplan aus. Es gibt wirklich kein Kontakt zwischen 
Pins. Wenn ich bisschen bewege kommt so gelbe Strich, zeigt wohl dass es 
kein Verbindung gibt. Wie kriege ich es richtig hin?

Es nervt wirklich :(

Autor: Nils Z. (nils_z)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast die Pins mit dem falschen Ende nach außen platziert, siehe 
Tutorial:

> Remember that only one end of a pin is electrical (referred to as the hot end )
> and you must place the pin with this end out from the component body. The
> non-electrical end of the pin has the pin name next to it.

Deswegen ist auch der Name des Pins in der Leiterbahn. Heißen die Pins 
im Footprint auch 14 und 15?

http://techdocs.altium.com/display/ADOH/Creating+L...

Autor: Merve (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Muss ich nur die Richtung ändern oder?
Habs gemacht funktioniert immer noch nicht.


Footprint sieht so aus bei mir. Die Pins haben im Footprint keine Namen, 
oder sollte es haben?

Autor: Nils Z. (nils_z)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau doch mal in das Tutorial, das ich verlinkt habe ;-)

Problem 1:
Du musst die Pins im Schematic Symbol drehen, deswegen führt der Link 
auch zum Absatz "Adding Pins to the Schematic Component".

Problem 2:
Die Pins im Schematic müssen genauso heißen wie die Pads im Footprint. 
Die Pads im Footprint haben bei dir die Namen 1 und 2, sieht man doch im 
Screenshot. Die Pins im Schematic haben aber die Namen 14 und 15, da 
funktioniert die Zuordnung nicht.

Das sind zwei unabhängige Probleme. Drehe die Pins im Schematic Symbol 
und ändere ihre Namen von 14/15 auf 1/2. Am Footprint musst du nichts 
machen.

Autor: Taz G. (taz1971)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nils hat es schon ganz richtig erklärt.
Nur damit es keine Verwirrungen kommt. Nils meint mit Pin-Namen den 
'Designator'. Vom Symbol der Pin mit dem 'Designator 1' ist mit dem 
Footprint Pad 'Designator 1' verbunden. Der Display Name vom Symbol 
spielt dabei keine Rolle.

Autor: Cyborg (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Bilde ich mir das ein oder ist der TO nicht mal in der Lage
hier unter seinem ursprünglichem Nicknamen zu posten?
Wenn es zwei getrennte Personen sind, sollte der Zweite
entweder sich auch so zu erkennen geben oder einen eigenen
Thread aufmachen, auch wenns das gleiche Thema ist.
Ansonsten verwirrt das.
Zum Problem:
Man sollte erst mal das Tutorial von Altium lesen.
Wer dazu zu faul ist, soll sich ein anders Hobby suchen und nicht
versuchen hier Resourcen zu binden und die Programmbedienung 
auszulagern. Hier wird nur Hilfe zur Selbsthilfe gegeben.
Wer dem englischen nicht mächtig ist, muss es eben lernen, ansonsten
wird er das Programm NIE bedienen können, da es in Englisch geführt
wird.
Alternativ wären Eagle, Target oder Kicad geeigneter, denn dazu
gibts deutsche Anleitungen.
Dann mal so das eigene Vorgehen Schritt für Schritt beschreiben.
Bilder als Screenshots ergänzend einstellen wäre hilfreich.
Damit wären auch Screenshots von Arbeiten in der Library hilfreich.
Man kann neue Symbols nicht einfach ins Schema zeichnen, sondern muss
dazu die Library öffnen, dann Symbol und Footprint bearbeiten und
dann die Library wieder schließen.
Leider stellen sich manche im Umgang mit Computern im Allgemeinen
und Software im Besonderen, noch etwas unbeholfen an. Natürlich
hat jeder mal so angefangen, aber das haben alle und das mal ohne
Forum, durch lesen und üben, üben, üben.

Autor: Taz G. (taz1971)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Cyborg
Ich finde deinen Beitrag total daneben.
Ein Forum ist für mich ein Platz um eine möglichst konkrete Frage zu 
stellen und eine möglichst konkrete Antwort zu bekommen.
Antworten wie mach erst das Tutorial, google doch mal, ruf den Support 
an, deinstalliere Windows, benutz doch ein anderes Programm empfinde ich 
nicht als hilfreich und ist für mich nur TROLL.
Wenn ich nach Hilfe Google finde ich auch immer so unqualifizierte 
Antworten wie Deine. Denk mal an die Leute, die das gleiche Problem wie 
der TO haben und deine Antwort mit Google finden -> "Faul, Englisch 
nicht mächtig,anderes Hobby, unbeholfen ...." das sind nicht die 
Antworten, die sie suchen.

Bitte ein wenig mehr konstruktiv

Autor: Christian B. (luckyfu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich muss Cyborg aber etwas recht geben. Altium ist ein Programm, welches 
sich an professionelle Entwickler richtet. Hier fehlen aber schon die 
absoluten Grundlagen, welche man in wirklich jedem Tutorial findet, als 
Video und als Text. Sicherlich ist das forum dazu da, fragen bei 
Problemen zu lösen, aber eine Einarbeitung in ein Professionelles 
Programm ohne Grundkenntnisse, das kann das Forum sicher nicht leisten. 
Hier muss der TO schon selbst mal etwas Engagement zeigen.
Ansonsten hat man hier wieder den klassischen Fall: TO mit 
nichtssagender Fehlerbeschreibung. Nach einigem Rätselraten, was denn 
gemeint sein könnte kommen Bilder, die das Problem auf den ersten Blick 
erkennen lassen. Die hätten schon in den ersten Post gehört und der 
Thread hätte nur 2 Postings: Problem gelöst. Stattdessen sind wir bei 
Posting Nummer 14, weil es dem TO ja noch nichtmal gelungen ist, das 
Bild vom Schematic part und footprint zusammen hochzuladen, sondern auch 
erst auf Anforderung Teil 2 nachgeliefert wurde.

Aus welchem Grund sollte man hier also nicht etwas angefressen 
reagieren, vor allem, weil es andauernd vorkommt. Es gibt Probleme, da 
ist am Anfang noch nicht klar, wo die Ursache steckt und das Beschreiben 
ist entsprechend schwierig. Hier jedoch ist das ziemlich eindeutig und 
wurde in Antwortpost #1 bereits mit der Forderung nach den 
entsprechenden Bildern gelöst.

Nichtsdestotrotz gehört es nunmal dazu, beim Einarbeiten in ein Programm 
sich darüber schlau zu machen. Dazu kann die Frage in einem Forum 
gehören. In dem Fall wäre es aber zweifellos schlauer gewesen, sich mal 
eine bestehende Library anzusehen und die Unterschiede zum eigenen 
Machwerk zu suchen. Oder man macht einfach ein entsprechendes Tut mit 
und arbeitet dies durch. Nicht auszudenken, was passiert, wenn dann noch 
eine Datenbank als Bauteillib herangezogen werden soll. Oder ein 
weiterer spannender Part: Datenausgabe. Das wird sicher noch spannend. 
Daß der TO hier mit 2 Namen agiert ist auch so ein Zeichen, wie sehr er 
die Hilfe des Forums repektiert.

Autor: Taz G. (taz1971)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Christian,
ich geb Dir vollkommen Recht. Die Qualität der Antwort hängt auch stark 
von der Qualität der Frage ab. Ich stimme Dir auch in allen Punkten voll 
zu. Den Hinweis auf ein Tutorial als Antwort finde ich auch sehr gut, am 
besten mit einem Link in die TechDocs oder nach YouTube. Aber Cyborg 
Antwort war nur ein persönlicher Angriff auf den TO und hatte nichts mit 
der Problemlösung zutun. Das man irgendwann angefressen reagiert kann 
ich verstehen, sollte man aber trotzdem unterlassen und lieber nichts 
schreiben.
Wenn ich nach Problemlösungen suche finde ich mehr unsinnige Antworten 
als hilfreiche, wäre schön wenn es umgekehrt wäre. Gerade bei Windows 
Fragen scheint die standard Antwort zu sein "installier Linux dann haste 
das Problem nicht".

: Bearbeitet durch User
Autor: Cyborg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Taz G. schrieb:
> Aber Cyborg
> Antwort war nur ein persönlicher Angriff auf den TO und hatte nichts mit
> der Problemlösung zutun.

Wenn du den Thread von Anfang an gelesen hättest, wäre dir aufgefallen,
das ich dem TO empfohlen habe, sich erst mal bei Youtube ein paar
Anleitungen anzuschauen, bevor er hier weiter nutzlos versucht eine
Lösung zu finden, deren Problem nicht mal im Ansatz verständlich
vorgetragen wurde. Da kann man nämlich dann rätseln wie blöde und
kommt der Lösung auch nie nahe. Das Problem des TO ist nämlich nicht
nur die Bauteiledition in Altium, sondern auch der Umgang mit dem
Computer und dem Forum (Doppelter Thread, mehrere Nicks, unsinnige
Antworten). Wenn einige TOs lernresistent sind, dann wird es dem TO
nicht helfen und das wäre hier ja nicht das erste  und wird  auch nicht
das letzte mal sein. Das Forum ist voll mit Threads, die einfach nur
Tod sind.

> Das man irgendwann angefressen reagiert kann
> ich verstehen, sollte man aber trotzdem unterlassen und lieber nichts
> schreiben.

Das bezog sich ja auf dich. Du musst meine Posts weder lesen,
noch beachten, geschweige denn kommentieren, denn du bist ja
nicht der TO und an den war meine Antwort gerichtet.
Wenn du es trotzdem tust, musst du mit einer Antwort oder Reaktion
rechnen, die du gar nicht willst oder dir gefällt.
Auch angemeldet bist du im Forum nur ein Gast (wie jeder hier)
und kein Platzhirsch mit Sonderrechten. Die haben nur die Mods.
Auf deine Kritik lege ich gar keinen Wert. Ich beantworte
Fragen so, dass eine Fragender auch motiviert ist, darauf zu reagieren
oder zu antworten. Weich gespülte Antworten kann man sich meist sparen
weil die in der Regel ignoriert werden. Doppelte Namensnutzung ist nicht
nur verwirrend, sie ist auch hier nicht zulässig.
Siehe mal dir die Nutzungsbedingungen an.

Außerdem gibts da ja noch die Netiquette. Lies die mal, da wirst du
vom Codex viele Ähnlichkeiten finden.

http://www.mikrocontroller.net/articles/Netiquette...

Autor: Taz G. (taz1971)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Cyborg schrieb:
> Wenn du es trotzdem tust, musst du mit einer Antwort oder Reaktion
> rechnen, die du gar nicht willst oder dir gefällt.
Ich habe mit einer Reaktion gerechnet und die wollte ich auch und deine 
Antwort darauf gefällt mir, besonders der Hinweis auf die Netiquette.
Ich habe die Punkte, die mir in deiner Antwort nicht gefallen schon 
erwähnt, möchte Dich bloß bitten mit Anfängern oder Leuten die nicht so 
versiert im Umgang mit dem PC (Google,Altium,Forum usw.) sind etwas 
verständnisvoller zubehandeln.


> Auch angemeldet bist du im Forum nur ein Gast (wie jeder hier)
> und kein Platzhirsch mit Sonderrechten.
Das meine ich, jetzt greifts Du mich persönlich an. Völlig unnötig. Habe 
selber nie was anders behauptet. Jeder kann sich registrieren dadurch 
bekommt man keine Sonderrechte.

Also danke für deine Antwort und ich hoffe Du hast verstanden was ich 
sagen wollte. Und das Du das eben nicht als einen persönlichen Angriff 
auf deine Person siehst sondern als ein allgemeines Problem der Foren.

PS: Ich denke, ich habe meinen Standpunkt klar gemacht und da wir 
Offtopic sind möchte ich hier nur noch zur Ausgangsfrage Bezug nehmen.

@Yasemin
Frage ausreichend beantwortet, läuft alles ? Wäre nett Response zu 
geben.

: Bearbeitet durch User
Autor: Cyborg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Taz G. schrieb:
> verständnisvoller zubehandeln.

Noch Weichgespülter? Dann habe ich die Befürchtung, dass man
ja gar nicht mehr ernst genommen wird. Keine erstrebenswerte
Perspektive. Solange sich TOs nicht mal ein klein wenig vorstellen
(ist hier total aus der Mode) wird man immer das Problem haben
sich auf das Bildungsniveau des Fragestellers einstellen zu können.
Gerade die, die hier helfen (wollen) schlagen sich ja so manche
Stunde um die Ohren und das sollte dann nicht nutzlos gewesen sein.
Sicher sollte man auch auf den Tonfall achten, denn die gehören
zu den Umgangsformen. Aber Fragen sollten auch beantwortet werden
und der Weg des Threads sollte vom TO sinngemäß geführt und nicht
mit kühnen Theorien verzerrt werden. Da gibts so einige, die sich
nicht daran halten. Nichts gegen Querkritik, solange es um einen
geposteten Sachverhalt geht und der durch einen besseren Post
ersetzt wird. Niemand kann alles wissen, aber jeder kann was dazu
lernen.

Autor: yasemin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Taz,

danke dass du mich verstanden hast. Wollte nur ein Konkrete Antwort 
haben.  Ich hatte gegooglt, tutorials geguckt etc. und hatte leider 
nicht hilfreiches gefunden. Es ist nicht so das ich direkt hier gelanden 
bin. Warum ich nicht gefunden habe, kann auch an meinem Sprachprobleme 
liegen, weiß ich nicht. Übrigens, ich bin ein internationaler Studentin 
und mache das nicht als Hobby. Ob es für professionelle Entwickler 
gerichtet ist oder nicht, macht es kein Unterschied, ich möchte es halt 
lernen, wobei ich das auch auf der Arbeit brauche. Na ja, ich dachte 
hier können mir Leute weiterhelfen. Danke auch an die Leute die mir 
weitergeholfen haben, war sehr hilfreich. Aber das Verhalten von Cyborg 
also wie er geantwortet hat, war schon sehr unangenehm (unsinnige 
Antworten etc.). Ob ich nochmal hier was fragen werde, traue ich mir 
leider nicht mehr zu..


Und noch was, ich habe zwar zwei Vornamen von daher ist die Verwirrung 
entstanden, nicht das ich was anderes erreichen wollte.

Autor: Roger (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Dann versuchs mal mit einen Altium Lehrgang/Schulung:

Termine hier.  Preise einige hundert Euro.

http://www.altium.com/de/events

Roger

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.