mikrocontroller.net

Forum: Platinen T-962: Kalibrierung


Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus,

ich versuche es jetzt mal bei euch. Ich habe einen T-962 Reflow Ofen und 
diesen mittlerweile auch recht erfolgreich umgebaut, siehe:
https://www.direcs.de/2016/07/t-962-kein-schlechte...

Nun mit neuer Firmware sieht es so aus:
https://github.com/UnifiedEngineering/T-962-improv...

Über F3 "Manual Mode" -> Hier habe ich ja für Links und Rechts jeweils 
einen Gain und einen Offset.

Erster Test mit Multimeter/Tempsensor dran:
Soll 1: 150° eingestellt.
Dann hatte ich "Actual" 152,1°, L 154,2°, R 149,9° laut Ofen. Mein 
Temperatursensor hat (wenn auch erst 1 Minute später) ziemlich genau 
150° angezeigt und diese auch gehalten.

Soll 2: 250° eingestellt.
Dann hatte ich "Actual" 253,7°, L 256,1°, R251,4° laut Ofen. Mein 
Temperatursensor hat (wenn auch wieder erst 1 Minute später) ziemlich 
genau 275° angezeigt und diese auch gehalten.

Was lerne ich daraus, bzw. was muss ich einstellen? Offset brauche ich 
ja eigtl nicht, aber den Gain muss ich bei beiden auf 125/100=0.8 
stellen.

Oder wie kann ich den noch besser kalibrieren? Hierzu finde ich leider 
kein sauberes Howto!

Danke, VG

: Verschoben durch Moderator
Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin ich der einzige t962 Nutzer?! Liebe community, macht mich nicht 
schwach ;)

Autor: Florian Xy (florian_mc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Statt in der Luft zu messen, solltest du auf der Oberseite des PCBs 
messen, denn diese Temperatur ist für den Lötprozess entscheidend, weil 
es ein IR Ofen ist.

Grüße,
Florian

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das habe ich nicht erwähnt - der Sensor lag auf einem "Test-PCB" der 
Größe 10x10cm auf! Also war exakt die Oberflächentemperatur des PCBs.

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
//neuer Versuch

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...

Autor: Florian Xy (florian_mc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Selbstversuch macht klug.

Für ein gutes Lötergebnis liegt es auch nicht immer am Ofen. Die 
Lötpaste ist entscheidend. Auch wenn es die gleiche Legierung ist, 
reagieren diese je nach Hersteller unterschiedlich, das Flussmittel 
spielt auch eine ganz große Rolle. Dann darf die Lotpaste nicht falsch 
gelagert und auch nicht überlagert sein.

Im Betrieb haben wir über einen Zeitraum von 4 Monaten zig Versuche 
durchgeführt. Inzwischen haben wir eine Paste ausgewählt, die der 
Hersteller Felder aus Deutschland direkt frisch für uns auf Bestellung 
herstellt. Die eingestellte Temperaturkurve weicht deutlich vom 
Datenblatt des Herstellers ab.
Hilft einfach nur probieren und schauen, was die Lotpaste während der 
Temperaturkurve macht und später natürlich das Lötergebnis der gesamten 
Baugruppe bzw. Testplatine.

Diese Tipps kann ich dir mitgeben.

Grüße,
Florian

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Florian,

danke dir. Somit ist die "Abweichung" fürs erste irrelevant meinst du?

Hintergrund war halt, dass ich so meine Bauteile eigentlich bei 25° zu 
viel verheize...

danke für den Tipp mit der Paste!

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reflower schrieb:
> Hintergrund war halt, dass ich so meine Bauteile eigentlich bei 25° zu
> viel verheize...

Wieso "eigentlich"?

Für den Bauteilstress ist das wahre Temperaturprofil am Bauteil 
entscheidend. Bei 275°C verfärbt sich das Board doch schon fast. Guck 
dir mal die Grenzkurven in den Bauteildatenblättern an.

275°C ist selbst für bleifrei normalerweise viel zu viel. Die 
Aktivierungstemperatur für die Paste darf auch nicht zu hoch sein, damit 
nicht schon die Hälfte verdampft ist, bevor es in die Reflow-Phase geht.

Autor: Dieter F. (jim_quakenbush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reflower schrieb:
> ich versuche es jetzt mal bei euch. Ich habe einen T-962 Reflow Ofen und
> diesen mittlerweile auch recht erfolgreich umgebaut, siehe:
> 
https://www.direcs.de/2016/07/t-962-kein-schlechte...

Prima - gibt ein Fleisskärtchen :-)

Das mit dem Kapton-Klebebeand habe ich auch gemacht. Ist sinnvoll und 
stinkt weniger. Da ich nur selten Platinen Reflow-Löte brauche ich den 
Rest eigentlich nicht. Das mitgelieferte Standard-Profil reicht für 
meine Zwecke vollkommen aus.

Ich "Reflowe" aber auch keine grösseren Platinen - vermutlich geht das 
bei diesem Ofen auch nicht undbedingt optimal.

Meine Ergebnisse sind aus meiner Sicht vollkommen O.K. - ohne weitere 
Optimierungen.

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Wolfgang: Vll falsch ausgedrückt:
Am Ofen stelle ich ein: Fahre von 150...250. Real auf dem PCB Fahre ich 
150...275. Somit war jetzt meine Frage: Eigtl müsste ich die Gain bei 
beiden Seiten(? Frage 1) auf 100/125=0,8 stellen (Frage 2). Dann müsste 
ich zumindest REAL 1:1 die Temperatur die ich einstelle auf dem PCB 
haben. Was ich da einstelle ist ja nochmal eine andere Sache ;)

@Dieter: Danke fürs Kärtchen ;) Hast du mal die Realtemperaturen 
gemessen?!

Autor: Dieter F. (jim_quakenbush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reflower schrieb:
> @Dieter: Danke fürs Kärtchen ;) Hast du mal die Realtemperaturen
> gemessen?!

Gerne :-)

Nö, habe ich nicht. Aber mir ist noch kein Platinchen verkokelt sonst 
hätte ich mir dazu Gedanken gemacht.
Das liegt ggf. auch daran, dass ich den Ofen immer kalt starte und 
bisher nur max. 6 * 6 cm Platinchen im Ofen hatte.

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reflower schrieb:
> Am Ofen stelle ich ein: Fahre von 150...250. Real auf dem PCB Fahre ich
> 150...275. Somit war jetzt meine Frage: Eigtl müsste ich die Gain bei
> beiden Seiten(? Frage 1) auf 100/125=0,8 stellen (Frage 2).

Nein, schon verstanden. Die Verstärkung ist nicht passend zum Sensor 
eingestellt und und du stresst deine Bauteile erheblich, wenn du die 
Temperatur im jetzigen Zustand (blind) steuerst. Es macht keinen Spaß, 
dauernd mit irgendwelchen gefakten Temperaturwerten und Korrekturen 
rumzueiern. Deswegen hat man im Messwesen Einheiten eingeführt.

Ob nach der Änderung der Verstärkung der Offset geändert werden muss, 
wirst du sehen. Ich halte es für unwahrscheinlich, dass die 
Temperaturkurve ausgerechnet um den 150°C-Punkt dreht.

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar Wolfgang, sprich - probieren geht über studieren. Danke!

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Reflower,

ein wenig Aufwand solltest Du vielleicht für reprodzierbare Ergebnisse 
doch betreiben. Falls noch nicht geschehen in jedem Fall 1,5 Taler für 
die Kaltstellenkompensation opfern. Und wie an anderer Stelle 
beschrieben alle metallischen Teile, die berührbar sind, niederohmig mit 
dem Schutzleiter verbinden. Dieses CE_Zeichen an meinem Modell - tzzz.

Eigentliche Frage, wie Offset und Verstärkung einzustellen sind:


Um es einfacher zu haben, die Verstärkung am Gerät auf b = 1,00 und den 
Offset auf a = 0,0°C einstellen. Weiterhin vor jedem Lötvorgang das 
Gerät einen kompletten Zyklus durchlaufen lassen.

Bestimmung der Geradengleichung aus zwei Messungen, z.B. bei Soll_1 = 
100° C und Soll_2 = 230° C ergeben Ist_1 und Ist_2. Der 
Differenzenquotient ergibt den neuen Wert b' mit

b' = (Ist_2 - Ist_1) / (Soll_2 - Soll_1)

Den Offset a' errechnest Du z.B. mit Ist_1 - b' * Soll_1.

Nun die Werte im Ofen übernehmen und das Temperaturprofil durch 
Aufzeichnen des Verlaufs testen, ggf. nachkorrigieren.

Gruß Holger

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Holger,

"Dazu wird die Spannung einer Referenztemperatur gemessen und diese 
störende Spannung vom Messergebnis abgezogen. Diesen Prozess wird 
Kaltstellenkompensation genannt." -> und wo gibts das für 1 Taler?

Letztlich sollte es ja ein Hobbyofen sein. Mein Messgerät sagt hierbei:
"-20...1000 °C, ± 3 %" -> bei 275° könnte ich also gute +-8° daneben 
lieben -> Sprich, das ist e alles nur hingemogelt ;)

Zu deiner Gleichung:
In meinem Fall wäre b' = (275°-150°)/(250°-150°) = 1,25; a' = 150° - 
1,25 * 150° = -37,5°; Bist du dir da sicher? letztlich würde ich eher 
erwarten, es müsste eine geringere Verstärkung (wie meine errechneten 
0,8) sein, damit ich die Temperaturgerade "flacher" lege. In diesem Fall 
wäre die Gerade also um die Steigung 0,8 flacher durch den Punkt 150°.

Autor: Cyblord ---- (cyblord)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reflower schrieb:
> Bin ich der einzige t962 Nutzer?! Liebe community, macht mich nicht
> schwach ;)

Ich nutze diesen Ofen ebenfalls und habe damals auch einen Thread dazu 
eröffnet. Allerdings nutze ich ihn mit Originalsoft- und hardware. Hatte 
bisher noch keinen Anlass da was dran zu basteln.

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Reflower,

bin mir nicht ganz sicher ;-)

Bei Firma Reichelt 
(https://www.reichelt.de/ICs-CA-HV-/DS-18B20/3/inde...) 
sind es 1,43 Taler zzgl. MwSt.

Leider habe ich Soll und Ist vertauscht. Es ergibt sich in Deinem Fall 
b' = 0,8 und a' = +30° K. Dumm nur, dass der Offset ohne 
Softwareänderung sich maximal bis +/- 25 K korrigieren lässt. Nach 
Einbau eines DS18B20 sollte aber alles in Ordnung gehen und auch b' nahe 
bei 1 liegen.

@cyblord: Das Gerät ohne jegliche Hardwareänderung, somit ohne 
brauchbaren Schutzleiteranschluss des metallischen Gehäuses zu 
betreiben, ist in meinen Augen grob fahrlässig. Einfach einmal den 
Widerstand zwischen Griff der Lade und PE messen ...

Autor: Florian Xy (florian_mc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mal von meinem Puhui T-937M Temperaturen mitgeloggt.

Siehe Betrag:
Beitrag "Re: Erfahrung mit dem T937/T937M IR+Hot Air Lötofen?"

Grüße,
Florian

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Holger,

den DS18B20 habe ich schon längst verbaut. Was sollte dadurch 
passieren?! ;)

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Holger...?

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holger schrieb:
> Nach Einbau eines DS18B20 sollte aber alles in Ordnung gehen und
> auch b' nahe bei 1 liegen.

Hast du schon mal auf die erste Seite vom Datenblatt des DS18B20 und auf 
die Schmelztemperatur von Lötpaste geguckt?

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Reflower
Urlaub 8-)

Mit einem Thermoelement lässt sich prinzipbedingt nur eine 
Temperaturdifferenz ermitteln. Um auf die absolute Temperatur schließen 
zu können, muss an der Übergabestelle, welche i.d.R. durch die 
Anschlussklemmen  abgebildet wird, deren Temperatur bestimmt werden.

Verzichtet man darauf, kann diese z.B. mit einer typischen 
Raumtemperatur von 20°C angenommen werden, was vielleicht in einigen 
Fällen hinreichend ist. Nicht so im diesem Ofen, erhöht sich die 
Temperatur doch nicht nur im "Backraum", sondern deutlich auch im 
umgebenden Teil. Trotz permanent laufendem Lüfter lassen sich im Bereich 
der Steuerelektronik schlanke 40°C ermitteln. In diesem Beispiel ergibt 
sich eine Differenz von
40°C - 20°C = 20 K, welche ohne Messung der Vergleichstemperatur nicht 
erfasst und damit die gewünschte Ofentemperatur exakt um diesen Betrag 
daneben läge.
Das gemeine an dem Umstand ist weiterhin, dass zu Beginn eines ersten 
Zyklus vielleicht noch mit der Annahme gearbeitet werden kann, diese 
Innentemperatur sich aber im Verlauf des Prozesses verändert. Ein 
zweiter zeitnah gestarteter Zyklus wird dann eine andere Temperaturkurve 
abfahren. Letztlich erhält man keine reproduzierbaren Ergebnisse, was 
aber sicher Voraussetzung für ein ordentliches Lötergebnis ist.

Ich schließe nicht aus, das es auch ohne Vergleichsstellenmessung zu 
einem brauchbaren Lötergebnis kommen kann, ordne dies aber in die 
Kategorie Glücksfall, genügte doch schon alleine durch einen plötzlichen 
und vollkommen unerwarteten Sommereinbruch hervorgerufene 
Raumtemperaturerhöhung auf 30°C, das schmale Prozessfenster bei 
bleifreiem Lot zu verletzen.

@Wolfgang
Ich habe das Datenblatt des DS18B20 gelesen und kenne die 
Liquidustemperaturen von diversen Loten.

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holger schrieb:
> Ich habe das Datenblatt des DS18B20 gelesen und kenne die
> Liquidustemperaturen von diversen Loten.

Und wo siehst du dann gemeinsamen Nenner?

Auf irgendwelche Extrapolationsexperimente, weit weg vom Arbeitspunkt, 
würde ich mich nur bedingt verlassen wollen.

Autor: kiakin@freenet.de (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wolfgang,
einen gemeinsamen Nenner sehe auch ich nicht, fehlen mir die zu 
addierenden Brüche ;-)

Im T-962 sind zwei Thermoelemente verbaut, die die relative Temperatur 
im Ofenraum bestimmen, mit dem DS18B20 wird die Absoluttemperatur an der 
Vergleichsstelle gemessen. So wird erst sehr exakt die absolute 
Temperatur im Ofen berechenbar.
Also nix Extrapolation, sondern elementare Basics der Messtechnik.

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, jetzt hat es etwas gedauert.

Also, meine letzten Werte waren:
SOLL 150 -> IST 150
SOLL 250 -> IST 275

Sodala, dann mal auf +25k Offset beide Seiten und 0.8 Gain.

nun:
SOLL 150 -> IST 155
SOLL 250 -> IST 300 (!!!) Stinki stinki.

Sodala, wo was wer ist falsch?! ich weiß langsam keinen Rat mehr...

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was mir aufgefallen ist. Die Temperaturen stellen sich immer erst stark 
verzögert ein. Auch beim Lötprofil fährt er die Kurve zwar nach, aber 
"hinkt" immer 30-40° hinterher...

Autor: Reflower (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also nochmal zweimal bei g=0, offset=0 geschaut. Langsam glaub ich gar 
nix mehr....

SOLL 150 -> IST 150
SOLL 250 -> IST 275

SOLL 100 -> IST 88
SOLL 200 -> IST 188

Es ist echt schwer zu sagen, weil die Temperatur erst stagniert und dann 
- obwohl der ofen immer sagt gleiche temp - auf 10 minuten nochmal um 
10° ansteigt...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.