mikrocontroller.net

Forum: Markt [V] Rauchmelder FireAngel ST-620-DET


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Olly T. (twinpeaks)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Ich habe hier zwei Rauchmelder FireAngel ST-620-DET übrig.

Sie wurden 08/2014 gekauft, liegen nun also schon 2 1/2 Jahre herum. Die 
Verpackung ist ungeöffnet, die 10-Jahres-Batterie ist somit noch 
deaktiviert (aktiviert sich erst, wenn der Melder auf der Montageplatte 
angebracht wird).

Die Besonderheit des FireAngel ST-620-DET ist, dass er einen Rauch- mit 
einem Hitzemelder kombiniert, er erkennt also Feuer auch, wenn es nicht 
raucht.

Preis je Melder 10,-

Für je 2,- kann ich auch noch ein Magnetolink Befestigungsset dazulegen.

Versand als DHL Päckchen 4,-

Autor: Jürgen G. (Firma: Elektronikentwickler Aachen) (fjgensicke)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Die ST-620 sind alle Schrott, weil deren Batterie fehlerhaft gefertigt 
wurde. (China lässt grüssen).
Ich hatte ein ganzes Mietshaus damit ausgestattet und nach 1 - 1,5 
Jahren fingen die an zupiepen.
Nach Recherchen kam dann raus, dass die einen Serienfehler bei der 
Batterie haben.

Mein Tipp: erst gegen den neuen ST-622 austauschen und dann verkaufen.

Nach Umtausch hätte ich interesse!

Autor: Udo S. (urschmitt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen G. schrieb:
> Mein Tipp: erst gegen den neuen ST-622 austauschen und dann verkaufen.

Weisst du wo man im Internet gekaufte umtauschen kann?
Ich habe 2 Chargen insgesamt ca. 20 Stck. Inzwischen sind 5 Stck. davon 
defekt. Allerdings alle schon (z.T. knapp) über dem 
Gewährleistungzeitraum von 2 Jahren.
Den Hersteller in UK habe ich angeschrieben und keine Antwort erhalten.

Also mein Rat:
FINGER WEG VON DEM MIST!

: Bearbeitet durch User
Autor: Olly T. (twinpeaks)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen G. schrieb:
> Die ST-620 sind alle Schrott, weil deren Batterie fehlerhaft gefertigt
> wurde. (China lässt grüssen).

Ui, das wusste ich nicht, das hört sich ja nicht gut an, gibt's dazu 
nähere Infos, Rückrufaktion o.ä.?
Ich habe hier 8 Stk. seit 2 1/2 Jahren in Betrieb, bisher ohne Ausfall.

Autor: Jürgen G. (Firma: Elektronikentwickler Aachen) (fjgensicke)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ja gibt es in BRD:

EPS Service- Center
Lütke Feld 11
48329 Havixbeck

Oder:
Habe auch einen Kontakt aus England, die den Austausch forcieren.
Schicke mir eine E-Mail, dann leite ich Dir den Kontakt weiter.

Autor: Olly T. (twinpeaks)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ich habe gestern mit dem FireAngel Support Kontakt aufgenommen.
Laut deren Aussage gibt es keine bestimmte Chargen, die Probleme machen, 
es sind immer nur individuelle Rauchmelder, die eine schlechte Batterie 
abbekommen haben. Daher tauschen sie keine Melder auf Verdacht oder 
anhand der Chargennummer aus.
Defekte Melder werden aber ausgetauscht, dafür soll man sich an 
Technik@sprue.com wenden.
Die Garantie zählt nur für den ursprünglichen Käufer, bei Weitergabe der 
Melder muss ein evtl. Austausch über diesen stattfinden.

Ich glaube, es ist besser, wenn ich sie einfach behalte. :-)
Sollte sie doch noch jemand haben wollen: 20,- incl. Versand für beide.

Zur Info: man kommt von außen durch die Schlitze im Gehäuse an die 
Batterie ran. Nach 2,5 Jahren Betrieb hat die CR 17335 bei dem Exemplar, 
das ich gemessen habe, noch 3,05V.

Diese Rauchmelder haben übrigens eine Service-Schnittstelle unter dem 
Aufkleber auf der Rückseite. Das Programm kann man sich herunterladen 
und es verlangt nach einem TTL232R-3V3 Interface (mit FTDI-Chip). Mal 
sehen, ob ich das ans Laufen bekomme, meine Neugier ist geweckt.

Autor: Mayk L. (fx2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olly T. schrieb:

> Diese Rauchmelder haben übrigens eine Service-Schnittstelle unter dem
> Aufkleber auf der Rückseite. Das Programm kann man sich herunterladen
> und es verlangt nach einem TTL232R-3V3 Interface (mit FTDI-Chip). Mal
> sehen, ob ich das ans Laufen bekomme, meine Neugier ist geweckt.

Hast du was rausbekommen ?
Ich habe hier mal einen aufgemacht und die Batterie gewechselt. Er piept 
weiter. Ich vermute, dass es nicht an der Batterie liegt sondern an der 
Software.

Autor: Olly T. (twinpeaks)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mayk L. schrieb:
> Hast du was rausbekommen ?

Nein, noch nicht, 1000 andere Dinge zu tun...
Ich muss mir erst einen Adapter bauen, um die Pads im Rauchmelder 
vernünftig kontaktieren zu können, passende Pogopins hab ich immerhin 
schon...

Autor: Mayk L. (fx2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe schon gesehen, dass es beim Hersteller Software gibt - die an 
der Schnittstelle eine Diagnose durchführen kann.
Ich weiss halt nur nicht wie man es anschliesst.

hxxx://fireangel.eu/st-620/

Autor: Olly T. (twinpeaks)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mayk L. schrieb:
> Ich weiss halt nur nicht wie man es anschliesst.

Es gibt z.B. auf eBay Bilder von den dazugehörigen Diagnosekabeln. Auf 
denen sieht man 3 Pins und kann auch auf die Position schließen.
Meine Versuche mit einer Hand dort drei Messpitzen draufzuhalten und mit 
der anderen Hand die Software zu starten waren nicht von Erfolg gekrönt, 
deswegen wollte ich mir als nächstes so einen Stecker nachbauen, damit 
man in Ruhe testen kann.

Die drei Pins könnten GND, RX und TX sein. Oder evtl. auch nur RX und 
der Rauchmelder wird über eine Handshakeleitung in einen Servicemode 
versetzt.

Edit: die Software verlangt nach einem "TTL232R-3V3" Kabel. Also ein 
FTDI-Kabel mit 3,3V Pegeln und der Zeichenkette "TTL232R-3V3" als 
Product Decription. Diese kann man mit FT-Prog entspr. ändern, falls 
nötig.

: Bearbeitet durch User
Autor: Adam P. (adampr1)
Datum:
Angehängte Dateien:

Bewertung
5 lesenswert
nicht lesenswert
Hallo,

ich habe mein FireAngel ST-620 angeschlossen und ausgelesen. Mein piepte 
alle 40sekunden - schwache Batterie (laut Beschreibung auf dem 
Aufkleber) aber die Batterie Spannung liegt bei 3.02V. Nach auslese 
piept nicht mehr jede 40sek. (muss langer testen). Weil ich kein Stecker 
habe, habe ich ein paar Kabel direkt angelötet. Zu auslesen muss man ein 
Papierstück zwischen Kontakt einlegen (sieche Foto). Wenn alles 
angeschlossen ist dann muss man Anwendung starten und TEST-Taste kurz 
drücken dann kommen werte im Anwendungsfenster

PS nur verstehe ich nicht - meine Rauchmelder sind vor ca. 2Jahre 
eingebaut aber auf dem auslese Foto siecht mann  "Hours since 
manufacture 53438" dass ist fast 2227 Tage - ca. 6 Jahre ???

PS. Das schwarze Kabel vom Piezzo habe ich nur zu Testzeit abgelötet - 
es ist zu laut


Entschuldige bitte die schlechte Grammatik; Deutsch ist nicht meine 
Muttersprache.

BR.
Adam

Autor: Feldkurat K. (feldkurat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Adam P. schrieb:
> PS nur verstehe ich nicht - meine Rauchmelder sind vor ca. 2Jahre
> eingebaut aber auf dem auslese Foto siecht mann  "Hours since
> manufacture 53438" dass ist fast 2227 Tage - ca. 6 Jahre ???

"Hours since manufacture 53438" bedeutet die Zeit seit der Herstellung.
Das bedeutet, daß die Rauchmelder schon 4 Jahre alt waren, als Du sie 
installiert hast.

Autor: soul e. (souleye)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Die Skalierung kannst Du ja leicht prüfen wenn Du morgen nochmal 
ausliest. Dann müsten 24h mehr drauf sein.

Autor: Robin H. (heronic)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat schon jemand geschafft den ST-630-DET auszulesen? - Der hat ja ein 
paar Pins mehr. Wobei die Frage ist, ob da nicht auch nur 3 in 
Verwendeung sind.

Autor: Andreas N. (andreas_n884)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir jetzt die Software und den Adapter gekauft. Man kann damit 
aber nicht viel machen. Das Programm sagt immer,  das die Batterie einen 
zu hohen Innenwiderstand hat. Egal ob es eine neue oder die alte ist. 
Den Fehler kann man auch nicht löschen. Kann man das Teil nicht komplett 
zurück setzen, so das alle Daten weg sind ?

: Bearbeitet durch User
Beitrag #6015833 wurde vom Autor gelöscht.
Autor: Friedemann S. (pyrochroa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olly T. schrieb:
> Mayk L. schrieb:
>> Ich weiss halt nur nicht wie man es anschliesst.
>
> Es gibt z.B. auf eBay Bilder von den dazugehörigen Diagnosekabeln. Auf
> denen sieht man 3 Pins und kann auch auf die Position schließen.
> Meine Versuche mit einer Hand dort drei Messpitzen draufzuhalten und mit
> der anderen Hand die Software zu starten waren nicht von Erfolg gekrönt,
> deswegen wollte ich mir als nächstes so einen Stecker nachbauen, damit
> man in Ruhe testen kann.
>
> Die drei Pins könnten GND, RX und TX sein. Oder evtl. auch nur RX und
> der Rauchmelder wird über eine Handshakeleitung in einen Servicemode
> versetzt.
>
> Edit: die Software verlangt nach einem "TTL232R-3V3" Kabel. Also ein
> FTDI-Kabel mit 3,3V Pegeln und der Zeichenkette "TTL232R-3V3" als
> Product Decription. Diese kann man mit FT-Prog entspr. ändern, falls
> nötig.

Olly T. schrieb:
> Mayk L. schrieb:
>> Ich weiss halt nur nicht wie man es anschliesst.
>
> Es gibt z.B. auf eBay Bilder von den dazugehörigen Diagnosekabeln. Auf
> denen sieht man 3 Pins und kann auch auf die Position schließen.
> Meine Versuche mit einer Hand dort drei Messpitzen draufzuhalten und mit
> der anderen Hand die Software zu starten waren nicht von Erfolg gekrönt,
> deswegen wollte ich mir als nächstes so einen Stecker nachbauen, damit
> man in Ruhe testen kann.
>
> Die drei Pins könnten GND, RX und TX sein. Oder evtl. auch nur RX und
> der Rauchmelder wird über eine Handshakeleitung in einen Servicemode
> versetzt.
>
> Edit: die Software verlangt nach einem "TTL232R-3V3" Kabel. Also ein
> FTDI-Kabel mit 3,3V Pegeln und der Zeichenkette "TTL232R-3V3" als
> Product Decription. Diese kann man mit FT-Prog entspr. ändern, falls
> nötig.

Hallo Olly T.
gibt es was neues an der FireAngel Front? Mich quälen z.Z. auch 16 
vernetzte Rauchmelder ST-630-DET des Nachts und habe nun endlich den 
Übeltäter gefunden. Da die RM aber alle aus derselben Charge sind 
(15296-1537AN), gehe ich davon aus, dass es nicht mehr lange dauert, bis 
das Galama von vorne losgeht.

Das Diagnosekabel ist derzeit bei den meisten Lieferanten ausverkauft 
(wen wunderts...) und bei denen, wo es noch zu bekommen ist, kostet es 
150 - 200€. Ich werde mir also auch eines mit einem DSD TECH USB zu TTL 
Seriell Adapter selber bauen, aber eigentlich wäre es ja viel 
interessanter, den SPI-Bus zu belauschen um herauszufinden, ob zufällig 
die SN des auslösenden Melders mitgesendet wird. Dann müsste man nicht 
immer alle Melder durchprobieren.

Hat in der Richtung schon mal jemand was probiert? Ich bin leider nicht 
der Mikrocontroller Spezialist und tue mich schon schwer, überhaput 
einen passenden Adapter zu finden, der SPI auf 868MGz sniffen könnte.

Gruß
FS

Autor: K. S. (the_yrr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Friedemann S. schrieb:
> Ich bin leider nicht
> der Mikrocontroller Spezialist und tue mich schon schwer, überhaput
> einen passenden Adapter zu finden, der SPI auf 868MGz sniffen könnte.

Die Funk Verbindung wird auf 868MHz laufen, die SPI Verbindung selber 
kaum. SPI kann einige 10 MHz schnell sein. Hier erwarte ich aber eher 
einen "langsamen" Bus, da die Datenmenge vernachlässigbar gering ist und 
der µC zum Stromsparen auch eher langsam sein wird.

Der 620 hat einen PIC mit maximal 8Mhz, zuzm 630 habe ich nichts 
gefunden. Kannst du Bilder vom Innenleben machen auf denen man die 
Beschriftung der ICs lesen kann?

Als Adapter empfehle ich einen Salea Logic Clone, ist spottbillig und 
funktioniert mit Pulseview/Sigrok (Open Source). Falls da drin ein sehr 
viel schnellerer µC werkelt muss ebentuell ein schnellerer Logic 
Analyzer her, aber der wird dann sehr viel teurer.

Autor: Friedemann S. (pyrochroa)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal ein Photo des Sendemoduls. Um den Chip der Sensorplatine 
fotographieren zu können, müsste ich die Messkammer ablöten. Der ist 
aber vermutlich nicht relevant, oder? Das mach ich aber auch noch, wenn 
es der Sache dienlich ist.

Gruß
FS

Autor: Friedemann S. (pyrochroa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Friedemann S. schrieb:
> Hier mal ein Photo des Sendemoduls. Um den Chip der Sensorplatine
> fotographieren zu können, müsste ich die Messkammer ablöten. Der ist
> aber vermutlich nicht relevant, oder? Das mach ich aber auch noch, wenn
> es der Sache dienlich ist.
>
> Gruß
> FS

Max. 32 MHz lt.Datenblatt. Auf dem Quarz steht 30.0. Ich vermute, das 
sind 30 MHz. Das könnte passen.

Autor: Jörg E. (jackfritt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schmeiss die Funkmodule raus. Die sind der Übeltäter für alle Ausfälle.
Mit diesem Schrott laufen die Rauchmelder ca. 2-12 Monate dann sind sie 
leer. Und meistens so leer das sie keinen Mucks mehr von sich geben. Die 
interne Batterie funktioniert dann meist noch. Also ablöten und 10 
Minuten warten bis alle Elkos auf der Platine entleert sind und dann 
wieder anlöten. Danach funktionieren die ohne Funkmodul einwandfrei. Ich 
habe hier insgesamt 50 Stück mit Funkmodulen die alle Schrott sind. Ich 
glaube das die Funkmodule einen Fehler haben. Auch aus unterschiedlichen 
Chargen.
Ich habe es aufgegeben mit dem Deutschen Support. Reine Hinhaltetaktik. 
Habe sogar das Kabel gekauft um Festzustellen das man damit überhaupt 
nix anfangen kann ausser Werte auszulesen die keinen Sinn ergeben und 
dann vom Support zu hören das man wöchentliche Checklisten führen müsse 
um Garantieersatz zu bekommen. Ein paar wurden mir getauscht den Rest 
hatte Ich gar nicht mehr verbaut nur einzelne Chargen getestet. Alle mit 
den gleichen Symptomen.

Mal ordentlich Kohle für Schrott in den Sand gesetzt.
Ich kaufe bei denen nix mehr....

Autor: Friedemann S. (pyrochroa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe jetzt etwa die Hälfte runtergemacht gehabt und die 
Litiumzelle des Funkmoduls nachgemessen. Da kommt man ja super schnell 
dran. Sie hatten alle > 3,0V. Auch bei dem RM, der die 1 bis 2 
nächtlichen Piepser verursacht hat. Den RM habe ich auch geöffnet und 
die Spannung auch nachgemessen. Auch hier > 3.0V. Also irwie an den 
Batterien scheint es bei mir nicht zu liegen.
Ich habe mir damals dummerweise auch das Relaismodul für über 100€ 
gekauft. Die Konstellation hat zusammen mit unserem Kachelofen schon 
einige Male gute Dienste geleistet. Also irgendiwe wäre es mir schon was 
Wert, wenn das Problem gelöst werden könnten. Aber klar: Lieber ein Ende 
mit Schrecken als ein Schrecken ohne Ende.

Was wäre denn eine nachgewiesene zuverlässige Alternative mit zentraler 
Alarmierung?

: Bearbeitet durch User
Autor: Olly T. (twinpeaks)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Friedemann S. schrieb:
> Hallo Olly T.
> gibt es was neues an der FireAngel Front?

Nicht wirklich. Bei mir ist 2017 einer meiner 8 Melder (ST-620-DE) 
ausgefallen und wurde ausgetauscht. Der Rest hält sich allerdings 
tapfer.
Mein Vater hat die gleichen aber ihm sind schon deutlich mehr 
ausgefallen (ca. die Hälfte).

Ich hatte mir mal einen Adapter 3D-gedruckt und mit drei Pogo-Pins nach 
dem o.g. eBay-Bild versehen. Damit konnte ich schließlich auch den 
Melder auslesen (siehe Anleitung von Adam). Die Batterie des 
ausgefallenen Rauchmelders (der nun 2 Jahre ausgeschaltet in der 
Schublade lag) zeigt 3,06V an, aber auch "Low Battery".
Auf der Rückseite steht "Austausch gegen Ende 2024", er müsste also 
eigentlich noch 5 Jahre durchhalten.


> Mich quälen z.Z. auch 16
> vernetzte Rauchmelder ST-630-DET des Nachts

Meine 620 sind nicht vernetzt, dazu kann ich also nix sagen.


> Ich werde mir also auch eines mit einem DSD TECH USB zu TTL
> Seriell Adapter selber bauen

Du brauchst wahrscheinlich einen Adapter mit FTDI Chip der sich als 
"TTL232R-3V3" meldet (kann man ggfs. mit der FTDI Software FT_Prog 
ändern).

: Bearbeitet durch User
Autor: Friedemann S. (pyrochroa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wer nicht vernetzt, kann ja diese rabiate Methode der 
Lebensdauerverlängerung anwenden:

https://www.instructables.com/id/FireAngel-BatteryLife-Repair/

Das mit den Batteriespannungen ist doch komisch. Dann zeigt das Programm 
doch einfach Unsinn an, wenn bei dir die Batteriespannungen eigentlich 
auch OK waren. Hat da der Support mal was dazu gesagt?

Ja, der bestellt TTL Adapter hat den richtigen Chip drauf:

https://www.amazon.de/gp/product/B07BBPX8B8/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1

Danke auch für den STL File. Ich schau mal ob ich das gedruckt bekomme.

Autor: Jörg E. (jackfritt)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Wenn Ihr die Batterie messt dann bitte mit Belastung. Siehe da, sie ist 
dann doch leer.

Autor: Friedemann S. (pyrochroa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat schon jemand zufällig die RX/TX Pins beim ST-630 gefunden oder kann 
mir sagen, wie man das anstellt?

@Jörg:
Du hast völlig Recht, aber das ist nicht so einfach: Mit wieviel Ohm 
soll die (ausgebaute) Batterie belastet werden, ohne dass sie beim 
Messen zu viel Ladung verliert und dann mit Sicherheit im Eimer ist?

Autor: Olly T. (twinpeaks)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe gerade die Batterie meines ausgefallenen Melders vermessen.
Die Zelle hat angeblich 1500 mAh, bei 10 Jahren geplanter Laufzeit 
dürfen im Schnitt also nicht mehr als 17 µA fließen.
Die Batterie hat momentan eine Leerlaufspannung von 3,08 V (gemessen mit 
Multimeter). Belastet mit 100 Ohm bricht die Spannung auf 2,95 V ein, 
dabei fließen ca. 30 mA, also knapp das 2000-fache des mittleren zu 
erwartenden Stroms. Ri wäre damit (3,08V - 2,95V) / 30mA = 4,3 Ohm. So 
richtig schlecht sieht das alles doch gar nicht aus, oder?

Autor: Friedemann S. (pyrochroa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessant wäre vorallem zu wissen, wie der Melder das selber misst. Im 
aktivierten Zustand liegt die Spannung bei 3.05V. Mit abgeklemmtem 
Beeper (nervig) und gedrücktem Taster springt die Spannung an der 
Batterie zwischen 2,64V und 2,90V ein paar mal hin und her, vermutlich 
im Takt der LEDs. Das ist eindeutig zu wenig. Macht er RM nun selber 
Tests, in dem er den Taster "betätigt" und der Beeper dabei deaktiviert 
wird? Der Beeper wird ja ausgelöst, um den niedrigen Batteriestand 
anzuzeigen und nicht um die Batterie zu testen.

Autor: Max G. (l0wside) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Friedemann S. schrieb:
> Was wäre denn eine nachgewiesene zuverlässige Alternative mit zentraler
> Alarmierung?

Gira Dual Q mit Funkmodul. Ich habe den Vorgänger (wenn auch 
drahtvernetzt, weil im Neubau möglich). In 7 Jahren kein einziger 
Fehlalarm.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.