Forum: Mechanik, Gehäuse, Werkzeug JBC Advanced 2950 Display Probleme


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Thomas S. (tstag)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich hab mir letztens endlich mal was gegönnt und eine JBC Lötstation 
gekauft. Soweit bin ich zufrieden, leider spinnt das Display.. Zeichen, 
die senkrechte Linien beinhalten werden nicht richtig dargestellt. 
Könnte das ein Problem vom Display sein oder gibt es einen Controller 
der einen Hau haben könnte?
Weis jemand evtl. ob es hier Ersatzteile gibt?

Danke schonmal!

Thomas

von Christopher B. (chrimbo) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> letztens

Thomas S. schrieb:
> Problem vom Display

Reklamation?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> Soweit bin ich zufrieden, leider spinnt das Display.

Dann tausche sie um.

von Gerd E. (robberknight)


Bewertung
0 lesenswert
nicht lesenswert
Könnte ein Kontaktproblem sein.

Ich kenn dieses genaue Modell jetzt nicht, aber in anderen Modellen wird 
ein Flatflex-Kabel zwischen Controller und Display verwendet. Wenn da 
die Kontaktstellen oxidiert sind kann es zu solchen Effekten kommen.

Also mal aufmachen und reinschauen. Vielleicht reicht es schon aus das 
Kabel zum Display einmal rauszuziehen und wieder reinzustecken.

von Thomas S. (tstag)


Bewertung
0 lesenswert
nicht lesenswert
Als hät ich das Geld eine neue zu kaufen ;) Es ist eine gebrauchte 
Lötstation und bei dem Preis kann man das in Kauf nehmen, würd es aber 
trotzdem gerne reparieren.

von Thomas S. (tstag)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gerd E. schrieb:
> Könnte ein Kontaktproblem sein.
>
> Ich kenn dieses genaue Modell jetzt nicht, aber in anderen Modellen wird
> ein Flatflex-Kabel zwischen Controller und Display verwendet. Wenn da
> die Kontaktstellen oxidiert sind kann es zu solchen Effekten kommen.
>
> Also mal aufmachen und reinschauen. Vielleicht reicht es schon aus das
> Kabel zum Display einmal rauszuziehen und wieder reinzustecken.

Ich habs mal aufgemacht, das Display ist bedrahtet und direkt auf die 
PCB gelötet. Hab mal ein paar Bilder gemacht, hat jemand schonmal so ein 
Display gesehn?

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Das ist ein Display mit "COG"-Controller, d.h. unter der weißen 
Vergussmasse sitzt ein Chip, der das Display ansteuert.

Reparieren kann man an dem Display nichts, denn das Problem befindet 
sich zwischen dem Chip unter der Vergussmasse und dem Displayglas.

Es könnte eines der üblichen HD44780-basierenden Displays sein, 
insofern könnte man (wenn man die Anschlussbelegung 'rausfindet) das 
Display auch durch ein anderes ersetzen.

Aber ...

Hast Du die Lötstation gebraucht, d.h. ohne Garantie/Gewährleistung 
gekauft, oder warum hast Du sie aufgeschraubt?

von Thomas S. (tstag)


Bewertung
0 lesenswert
nicht lesenswert
Jap, ist ne gebrauchte, dann kann man auch mal reinschaun. Ne kalte 
Lötstelle ist´s nicht, hab gleich mal alle Pins nachgelötet. Wenn es ein 
HD44780 basiertes Display ist, könnte man ein zweites "parallel" anlöten 
um es auszuprobieren oder kann dabei was draufgehn?

von Gerd E. (robberknight)


Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> Wenn es ein
> HD44780 basiertes Display ist, könnte man ein zweites "parallel" anlöten
> um es auszuprobieren oder kann dabei was draufgehn?

Nein, das sollte man nicht so einfach. Denn der µC kann da auch vom 
Display lesen und dann Treiben die beiden ICs einen Pin u.U. auf 
unterschiedliche Pegel was dann zum Kurzschluss führt. Mit einem 
Widerstand dazwischen ginge es vermutlich.

Ich würde aber eher mit dem Oszi oder Logic Analyzer zuschauen und dann 
versuchen die Signale zuzuordnen. Auch auf die Signalpegel achten, es 
gibt die Displays in 5V und 3.3V (und sicher auch noch in irgendwelchen 
exotischen Spannungen).

Danach dann nur ein anderes Display auflöten.

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Auf der Lötseite scheinen nur sieben der Pins angeschlossen zu sein, die 
ersten vier von links gesehen führen direkt an den (vermutlichen) µC, 
die letzten drei auf der rechten Seite sind wahrscheinlich für die 
Versorgungsspannung zuständig (zwei dicke Leiterbahnen) und 
möglicherweise für den Kontrast des Displays (da ist ja ein Trimmer in 
der Nähe).

Kann natürlich auch 'ne Fehlinterpretation sein, so perfekt ist das Bild 
nun auch nicht.

von SCNR (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Auf der Lötseite scheinen nur sieben der Pins angeschlossen zu sein, ...

Ja und?
Sind eventuell vorhandene Anschlüsse auf der Bestückungsseite 
schlechter?

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Du hast Deine Frage eine Stunde und drei Minuten zu spät gestellt.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Scheint ein SPI Display zu sein, wenn da keine weiteren Pins belegt 
sind. Evtl. hat das Display eine Option auf Parallelbetrieb, das würde 
die vielen Pins erklären.
Falls auf der Rückseite des LCD was steht, könnte das evtl hilfreich 
sein. Auch die Bezeichnung des MC könnte helfen.

: Bearbeitet durch User
von Christoph B. (birki2k)


Bewertung
0 lesenswert
nicht lesenswert
Bei dem Display könnte das Displaytech 162COG-BA-BC passen, zumindest 
funktioniert das an anderen Stationen.

http://de.rs-online.com/web/p/lcd-displays-monochrom/5326559

: Bearbeitet durch NewsPoster
von Thomas S. (tstag)


Bewertung
0 lesenswert
nicht lesenswert
Christoph B. schrieb:
> Bei dem Display könnte das Displaytech 162COG-BA-BC passen, zumindest
> funktioniert das an anderen Stationen.
>
> http://de.rs-online.com/web/p/lcd-displays-monochrom/5326559

Das schaut ja sehr gut aus! Danke! Werd gleich mal eins bestellen :)

von Thomas S. (tstag)


Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> Christoph B. schrieb:
>> Bei dem Display könnte das Displaytech 162COG-BA-BC passen, zumindest
>> funktioniert das an anderen Stationen.
>>
>> http://de.rs-online.com/web/p/lcd-displays-monochrom/5326559
>
> Das schaut ja sehr gut aus! Danke! Werd gleich mal eins bestellen :)

Das Display ist letzte Woche angekommen, heute hab ich es verbaut - es 
funktioniert! Die Vergussmasse ist nicht mehr weiß sondern schwarz, aber 
scheint nur optik zu sein.

Vielen Dank an alle und insbesondere an Christoph!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.