Forum: Analoge Elektronik und Schaltungstechnik 10mV Signal auf Rechteck 5V verstärken


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich brauche mal einen Schaltungs- oder Realisierungsvorschlag auf die 
schnelle.

Gegeben: ein Sinussignal ca. 10mVpp, 440Hz, aus ca. 10 Ohm Quelle,
         ein Billig-3digit LED Frequenzzähler, der einen 12V DC
         Versorgungseingang hat und einen Input, der wohl 5V TTL 
braucht.

Ich hatte jetzt eine 1stufige Transistorschaltung aufgebaut aus einem 
BC517.
Hab jetzt nicht genau nachgemessen, aber ich glaube die Verstärkung war 
etwa 50. Die verstärkte Spannung reichte nicht aus, um den 
Frequenzzähler zum Zählen zu bringen. Wie gesagt, ist so'n Billigding 
aus Hongkong 2Stck. für 5€, undokumentiert, aber erfüllt seinen Zweck, 
wenn richtig angesteuert.

Ich suche nun nach einem möglichst schnellen, bauteilearmen Aufbau, 
vielleicht Komparator, will nicht noch einen 7805 investieren, ein 7812 
ist schon auf der Vero-Platine, könnte den Output auch mit einer 
Zenerdiode klippen.

Frage ist, ob ich noch eine Transistorstufe dahinterschalte oder alles 
wieder runterreiße und ein IC einsetze, ich bewege mich aber mehr im 
fliegenden Aufbau auf der Präzision von Lochrasterplatinen und habe 
keine Zeit mehr, noch groß eine Platine zu entwickeln, wo ein IC 
draufkommt.

Vorschläge?


Grüße
Christoph

: Verschoben durch Moderator
von Falk B. (falk)


Bewertung
3 lesenswert
nicht lesenswert
Man nehme einen Komparator. LM393 ist dein Freund. Pull-Up am Ausgang 
nicht vergessen. Wobei 10mV schon verdammt wenig ist. Besser man nimmt 
einen LM358, das ist ein Doppel-OPV. Deine einen nimmt man als 
AC-Verstärker mit Faktor 10, den 2. ALs Komparator. Bei 440 Hz ist das 
problemlos.

: Bearbeitet durch User
von ChristophK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Danke. Ich hatte zunächst an einen Schmitttrigger aus 2 Transistoren 
gedacht,
aber letztlich habe ich mich jetzt doch für die Lösung mit dem LM358 
entschieden.

Grüße
Christoph

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Ist das für den Kammerton a?

von Jacko (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@ Christian S. (roehrenvorheizer)

> Ist das für den Kammerton a?

Bestimmt nicht! Den würde man auf 4 Stellen auflösen!

Wenn es bei berühmten Orchestern mittlerweile üblich wurde,
auf recht genau 442, 443, oder 444 Hz zu stimmen, dann dürfte
die dreistellige Auflösung (+/- 1 Hz) indiskutabel sein!

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Ich brauche mal einen Schaltungs- oder Realisierungsvorschlag auf die
> schnelle.

Vergiss deinen Analogverstärker, nimm einen Komparator (ausreichend 
schneller push pull Typ für 5V, so was wie TLV, als Schmitt-Trigger mit 
2mV Hysterese geschaltet, vergleicht mit gleitendem Mittelwert, die 1nF 
müssen auf reales Signal angepasst werden. Falls der Eingang 
kondensatirgekoppelt sein soll noch ein bias-Netzwerk aus 10k nach +5V 
und 10k nach 0V.
1
                    +5V
2
                     |
3
                 +---(-1M-+
4
                 |   |    |
5
         +--3k3--+--|+\   |
6
Signal --+          |  >--+-- digital
7
         +--10k--+--|-/
8
                 |   |
9
                1nF  |
10
                 |   |
11
                 0V  0V

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wieso würde man den auf 4 Stellen auflösen? 0,1% Genauigkeit reicht. Es 
ist tatsächlich dafür gedacht, anzuzeigen, ob ein Instrument in 440 Hz 
oder in Hz Schritten bis runter zu 434 bzw. rauf zu ca. 447 Hz gestimmt 
ist.

Das ist in dem Anwendungsfalle ausreichend.

Ich habe das Diskretgefrickel aufgegeben und mich hingesetzt und einen 
kleinen Print gemacht.

Bin zwar mit dem Output noch nicht ganz zufrieden. Vielleicht habt Ihr 
ein paar Schaltungsverbesserungvorschläge.

Hier sind ein paar Bilder:



Grüße
Christoph

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Vielleicht habt Ihr
> ein paar Schaltungsverbesserungvorschläge.

Öh, einen Beitrag über deinem? Aus MaWins Schaltung kommt ein beinharter 
Rechteck, der sich dank gleitender Mittelwertbildung auch nahezu bei 50% 
Tastverhältnis bewegt. Sollte auch mit einem LT1017 klappen (wenn man 
den Pullup am Ausgang nicht vergisst).

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke Martin,

sah Deine Schaltung zu spät. Da saß ich schon im "circuit cellar" :)
Ja, Hysterese einbauen, hatte ich auch ursprünglich gedacht, aber ich 
wollte erst mal sehen, die ich mit der Verstärkung hinkomme und wie das 
Ausgangssignal aussieht. 5mVpp reicht, um den Zähler das abgebildete 
Signal noch zählen zu lassen. Bei der tatsächlich dann im Betrieb 
auftretenden Eingangsspannung von ca. 15mVpp (konstanter Sinus) sieht 
das Signal noch schrafkantiger aus. Drehe ich die Eingangsspannung 
weiter runter, wird das Ausgangssignal leicht unsymmetrisch und geht 
nicht mahe ganz runter.

Die anderen Randbedingungen waren, daß ich für diesen chinesischen 
Zähler +12V brauche. Der hat onboard noch einen 7805 und das 
Eingangssignal wollte ich dann auch nicht größer als 5V machen.

Grüße
Christoph

von Possetitjel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:

> Wieso würde man den auf 4 Stellen auflösen?

1Hz bei 440Hz ist eine relative Abweichung von 0.22%.

Jeder Halbton ist 5.9% höher als der vorige; üblich
ist eine Unterteilung der Halbtöne in 100 Cent, das
sind also 0.06%.

Dein Gerät kann also nur 4-Cent-Stufen auflösen.

> 0,1% Genauigkeit reicht.

Sicher wird das in der Praxis genügen. Anders wäre
es noch hübscher.

von Paul B. (paul_baumann)


Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Sicher wird das in der Praxis genügen. Anders wäre
> es noch hübscher.

Zitat Albert Einstein:
Mache es so einfach wie möglich -aber nicht einfacher!

Zitat Ende

MfG Paul

von Possetitjel (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Paul B. schrieb:

> Possetitjel schrieb:
>> Sicher wird das in der Praxis genügen. Anders wäre
>> es noch hübscher.
>
> Zitat Albert Einstein:
> Mache es so einfach wie möglich -aber nicht einfacher!

Etwas näher am Thema:

Es gibt nur eine Sache, die noch unsauberer klingt als
eine Blockflöte, und das sind zwei Blockflöten.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> ChristophK schrieb:
>
>> Wieso würde man den auf 4 Stellen auflösen?
>
> 1Hz bei 440Hz ist eine relative Abweichung von 0.22%.

Ja, Du hast recht. Worst case ist ja 0,9999999... Hz Fehler. Nicht 
0,5Hz, wie ich fälschlicherweise angenommen hatte.

>
> Jeder Halbton ist 5.9% höher als der vorige; üblich
> ist eine Unterteilung der Halbtöne in 100 Cent, das
> sind also 0.06%.
>
> Dein Gerät kann also nur 4-Cent-Stufen auflösen.
>
>> 0,1% Genauigkeit reicht.
>
> Sicher wird das in der Praxis genügen. Anders wäre
> es noch hübscher.

Wie gesagt, es soll kein Stimmgerät sein. Die Stimmung des Gerätes 
selbst ist viel genauer (Quarzgenau und µC gestützt). Das Gerät, das die 
Frequenz des Instruments liefert, läßt um 440Hz herum in 1 Hz Stufn 
variieren. Die LED-Anzeige dient nur zur "Verifizierung" und weil ich - 
und jetzt kommt der zweite Punkt - noch ein weiteres Gimmick hinzufügen 
will: durch einen Schalter oder Taster, kann ich ein Mikrofon an den 
Eingang schalten und man kann jetzt z.B. einen Bläser bitten, doch mal 
ein A zu spielen und man sieht sofort, wo er "liegt". Oder das Piano 
befragen.

Gut, das kann das menschliche Gehör auch, aber es hat keine 
Digitalanzeige :)

Deshalb jetzt noch meine Frage: Ich glaube, ein Elektret-Mikrofon (diese 
kleinen Pillen) liefert schon ein ziemlich großes Signal (>>10mVpp), 
oder?

Ja, das Gerät ist in eine Hammondorgel eingebaut :), die ja bekanntlich 
auf 50Hz Netzfrequenz läuft (in USA 60Hz). Das ist normalerweise kein 
Problem, wenn die Orgel allein spielt. Im Ensemble mit Orchester, 
insbesondere Piano, wird von der Hammondorgel häufig verlangt, daß sie 
"nachgibt" und sich anpaßt, was zwar von Hause aus nicht geht, statt den 
Klavierstimmer zu holen. Da gibt es dann Frequenzwandler, die man auch 
hierzulande einsetzt um das Problem zu umgehen.

Grüße
Christoph

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> ChristophK schrieb:
>> Vielleicht habt Ihr
>> ein paar Schaltungsverbesserungvorschläge.
>
> Öh, einen Beitrag über deinem? Aus MaWins Schaltung kommt ein beinharter

Wie meinen?

> Rechteck, der sich dank gleitender Mittelwertbildung auch nahezu bei 50%
> Tastverhältnis bewegt. Sollte auch mit einem LT1017 klappen (wenn man
> den Pullup am Ausgang nicht vergisst).


Bin nach dem Tip, einen LM358 zu nehmen in den Keller abgetaucht.

Und, wie gesagt, ich muß auch auf 5V runter.

Grüße
Christoph

von Possetitjel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:

> Im Ensemble mit Orchester, insbesondere Piano, wird von
> der Hammondorgel häufig verlangt, daß sie "nachgibt" und
> sich anpaßt, was zwar von Hause aus nicht geht, statt den
> Klavierstimmer zu holen. Da gibt es dann Frequenzwandler,
> die man auch hierzulande einsetzt um das Problem zu umgehen.

"Moment, das Cis ist zu hoch. Ich bin mal kurz am Umrichter."
Super! :)

von Paul B. (paul_baumann)


Bewertung
3 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Es gibt nur eine Sache, die noch unsauberer klingt als
> eine Blockflöte, und das sind zwei Blockflöten.

Diese Instrumente machen mich mürbe.

Darum: Blockflöten in Blockheizkraftwerke!

MfG Paul

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
@ Paul Baumann (paul_baumann)


>Mache es so einfach wie möglich -aber nicht einfacher!

>MfG Paul

Huch, der Paul ist wieder da? Lange Urlaub gehabt? ;-)

von Falk B. (falk)


Bewertung
3 lesenswert
nicht lesenswert
@ Paul Baumann (paul_baumann)

>Darum: Blockflöten in Blockheizkraftwerke!

Das nenn ich mal ein passenden Spruch zu anstehenden Bundestagswahl . . 
.
Die BHKWs werden sich vor neuem Personal kaum retten können!!!

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich will die Schaltung von Mawin auch mal aufbauen. Vielleicht sind die 
Anzeigefehler, die ich (anderer Thread in µC) bei dem Chinateil 
beobachte, auch auf das Pulseshaping zurückzuführen.

LT1017 ? Habe ich im Moment nicht in meinen Schubladen. LM358, LM311 
hätte ich. Und 12V stehen zur Verfügung, muß aber auf 5V runter. Kann 
natürlich noch einen 7805 hinterherschalten. Gut, und den Bias noch 
rein, da ich mit einem C einkoppel.

Grüße
Christoph

von HildeK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Falk B. schrieb:
> Huch, der Paul ist wieder da?

Ja, das habe ich in den letzten Tagen auch bemerkt.
Schön, dass du wieder da bist, Paul - oder auch nicht, wenn jetzt dein 
langer Urlaub zu Ende ist :-).

von der schreckliche Sven (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> LM311
> hätte ich.

Ist doch prima. Der macht nicht nur ein super Rechteck, sondern auch 
gleich den Pegelwandler.

von Paul B. (paul_baumann)


Bewertung
2 lesenswert
nicht lesenswert
O.T.
HildeK schrieb:
> Schön, dass du wieder da bist, Paul - oder auch nicht, wenn jetzt dein
> langer Urlaub zu Ende ist :-).

Ich freue mich, daß Du Dich freust, daß ich wieder da bin.
:)

Nein, im Urlaub war ich nicht,
das konnt' ich mir nicht leisten.
Der Rechner brauchte zuviel Strom,
da geht's mir, wie den Meisten.

Mir fehlte auch die Reise-Lust
auf Südpol, China, Malediven
auch nicht auf Italien
mit dem Turm, dem Schiefen...

MfG Paul

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Paul B. schrieb:
> Nein, im Urlaub war ....

Ja, du bist es wirklich!

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
der schreckliche Sven schrieb:
> ChristophK schrieb:
> LM311
> hätte ich.
>
> Ist doch prima. Der macht nicht nur ein super Rechteck, sondern auch
> gleich den Pegelwandler.

Habe die Schaltung aufgebaut. Allerdings mit 9V Betriebsspannung. Leider 
bringen 10mVpp den Komparator nicht zum komparieren.

(1uF an pin 3 ist bei mir 2uF)

Grüße
Christoph

von ArnoR (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Leider
> bringen 10mVpp den Komparator nicht zum komparieren.

Der hat im günstigsten Fall 100nA Biasstrom, somit (wegen der 100k) eine 
zusätzliche Offsetspannung von 10mV, die vom Signal überwunden werden 
muss.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Habe die Schaltung aufgebaut. Allerdings mit 9V Betriebsspannung. Leider
> bringen 10mVpp den Komparator nicht zum komparieren.

Was sieht man dann auf dem Foto vom Oszi?

9V Versorgung sind jedenfalls kein Problem.

Reduzier mal die 100k-Widerstände auf 10k.
Wenn es noch immer nicht geht, mach zwischen die beiden 100k 
(10k)-Widerstände ein Poti und gleiche den Offset ab. Potiwert 10k bzw. 
1k.

Alternativ: Schalte den Verstärker davor vom Ursprungspost. Wobei dort 
der R101 wieviel Ohm hat? Ich lese da 1Ω? Nimm mindestens 10kΩ, oder 
lasse ihn ganz weg. Auch R102 darf größer werden.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
der schreckliche Sven schrieb:
> ChristophK schrieb:
> LM311
> hätte ich.
>
> Ist doch prima. Der macht nicht nur ein super Rechteck, sondern auch
> gleich den Pegelwandler.

HildeK schrieb:
> ChristophK schrieb:
> Habe die Schaltung aufgebaut. Allerdings mit 9V Betriebsspannung. Leider
> bringen 10mVpp den Komparator nicht zum komparieren.
>
> Was sieht man dann auf dem Foto vom Oszi?
>
>
Auf dem oberen Kanal 5mV/DIV .
Ca. 17,5 mVpp. Ab da greift der Komparator.

unten 5V/DIV

Beitrag #5135859 wurde vom Autor gelöscht.
von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Auf dem oberen Kanal 5mV/DIV .
> Ca. 17,5 mVpp. Ab da greift der Komparator.

Danke. Da sieht man, dass die Symmetrie fehlt. Nur bei den negativen 
Spitzen des Eingangssignals schaltet er. Wie oben schon gesagt, Offset 
vom Biasstrom.

Mach mal die 100k am +E Eingang kleiner auf 10k oder 22k (ggf. die 
Kondensatoren entsprechend vergrößern), vielleicht reicht das schon. 
Dann ist die durch den Offsetstrom hervorgerufene Spannung auch 
entsprechend kleiner. Sonst, wie gesagt, ein Poti in den Teiler 
100k/100k und mit dem Abgriff über den R auf den +E des Komparators.
Musst du so hochohmig sein am Eingang? Die Quellimpedanz sei doch nur 
10Ω ...

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Muß mich korrigieren: man sieht ca. 13,5mVpp
auf dem oberen Kanal.

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin noch nicht soweit, daß ich ein einigermaßen symmetrisches Signal 
bei ca. 10mVpp Eingangsspannung bekomme.

Habe die Schalung modifiziert und ein Poti eingebaut. Wenn ich am Poti 
drehe, passiert kurzzeitig etwas, nämlich daß das Tastverhältnis 
symmetrischer wird, aber der 2µF Kondensator folgt der Spannung und das 
Signal pendelt sich auch wieder in den vorherigen Fall ein.

Es ist nicht so, daß ich mit dem Poti um das Tastverhältnis 0,5 herum 
einstellen könnte. Ich kann auch keine Änderung des Tastverhältnisses 
permanent einstellen, wie oben beschrieben.

Auch habe ich Schwingungen, wie man auf dem Oszillogramm sehen kann - 
ich hoffe ich kann das durch Kompensationsbeschaltung bereinigen.



Grüße
Christoph

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Muß noch nachtragen: das Oszillogramm zeigt den Zustand bei R1=10K 
(statt 100K Eingangslastwiderstand)
--
Christoph

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> aber der 2µF Kondensator folgt der Spannung und das
> Signal pendelt sich auch wieder in den vorherigen Fall ein.

Oh - das hatte ich bei der Betrachtung übersehen. Klar, die Asymmetrie 
ist durch die Biasströme und den Eingangsoffset hervorgerufen worden. 
Der Teiler selber ist gar nicht so wichtig, solange er sich im Common 
Mode Bereich bewegt.

Spendiere mal zwischen dem Potiabgriff und dem 2µ-Kondensator auch noch 
einen Widerstand mit dem gleichen Wert wie R1. Idee: die Biasströme sind 
in beiden Eingängen etwa gleich groß und der Spannungsabfall an R1 
sollte auch am -E erfolgen. Wirkt das?

Ich sehe gerade in http://www.ti.com/lit/ds/symlink/lm311.pdf, dass der 
LM311 ja ein Offsetbalancing möglich macht. Schau dir mal die Bilder 17 
und 25 im Link an (nur die Beschaltung von Balance und Bal/Strb).

von Axel S. (a-za-z0-9)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Habe die Schalung modifiziert und ein Poti eingebaut. Wenn ich am Poti
> drehe, passiert kurzzeitig etwas, nämlich daß das Tastverhältnis
> symmetrischer wird, aber der 2µF Kondensator folgt der Spannung und das
> Signal pendelt sich auch wieder in den vorherigen Fall ein.

Die Schaltung ist ja auch Unsinn: du hast da wieder einen 100K Widerling 
vor dem einem Komparator-Eingang. Der Eingangsstrom des Komparators 
bewirkt in Verbindung damit eine Verschiebung (Offset) der 
Schaltschwelle.

Du mußt wenn schon, dann beide Eingänge des Komparators über je 100K an 
die Referenzspannung führen. Dann fehlt dir aber immer noch eine 
Hysterese. Und den Eigen-Offset des Komparators kriegst du so auch nicht 
weg.

Leg doch einfach den (NF) Eingang des Komparators auf Ub/2 und gib dem 
anderen Eingang eine per Trimmer leicht um Ub/2 verschiebbare 
Referenzspannung. Dann kannst du alle Fehler wegtrimmen.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke. Aber ich brauche unbedingt single supply.
Die Balance-Beschaltung befreit mich aber nicht von der Notwendigkeit 
des Vcc/2-Spannungsteilers?

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@HildeK:
Bezog mich auf Abb. 25 mit meiner Bem. zu single supply, aber Du sagtest 
ja "nur die Beschaltung von Bal und Bal/Stb". OK.

@AxelSchwenke:

Dank. Auch wenn's doof klingt, aber was meinst Du mit "NF". 
Niederfrequenz? Negativ ...? Ich plädiere für Op-Amp bezogene 
Eingangsbezeichnungen. :)

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Danke. Aber ich brauche unbedingt single supply.
Ich sehe gerade nicht, wo man dir Dual-Supply vorgeschlagen hat.

> Die Balance-Beschaltung befreit mich aber nicht von der Notwendigkeit
> des Vcc/2-Spannungsteilers?
Nein, das bleibt. Es kommt nur die Beschaltung aus Bild 17 dazu.

Das von mir früher vorgeschlagene Poti an dem Teiler kannst du wieder 
entfernen - war ein gedanklicher Kurzschluss :-) und würde nur sinnvoll 
sein mit der von Axel Schwenke vorgeschlagenen Modifikation.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
HildeK schrieb:
> ChristophK schrieb:
>> Danke. Aber ich brauche unbedingt single supply.
> Ich sehe gerade nicht, wo man dir Dual-Supply vorgeschlagen hat.
>

Fig. 25 hat Dual-Supply. Ich hatte mich im Nachgang korrigiert,und Dir 
zugute gehalten :), daß Du nur die Bal Beschaltung meintest.

Grüße
Christoph

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Habe die Schalung modifiziert und ein Poti eingebaut. Wenn ich am Poti
> drehe, passiert kurzzeitig etwas, nämlich daß das Tastverhältnis
> symmetrischer wird, aber der 2µF Kondensator folgt der Spannung und das
> Signal pendelt sich auch wieder in den vorherigen Fall ein.

Du hast die Schaltung offenbar immer noch nicht nicht mal in Grundzügen 
verstanden.

Die Unsymmetrie wird durch den Offsetfehler des schlechten OpAmp 
verursacht, man kann eben für ein 10mV Signal keinen um 7mV falschen 
OpAmp verwenden.

Aber es wurde nicht ohne Grund ein TLV Komparator empfohlen, nicht der 
unsinnige von Falk stammende LM358.

Wenn man unbedingt jeden Tag nachjustieren will und ein Poti verwenden 
will: Klar, als Offsetpoti am OpAmp mit Offseteingängen, z.B. LM311.

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dann sähe die Schaltung jetzt so aus:


Wäre das OK?

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sollte ich noch Hysterese vorsehen? 47K pos. feedback

von Axel S. (a-za-z0-9)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Dann sähe die Schaltung jetzt so aus:
> Wäre das OK?

Sollte besser funktionieren. Wenn du den Offset-Abgleich mit R5/R6 
vorsiehst, bist du auch nicht sklavisch an 100K für R7 gebunden.

ChristophK schrieb:
> Sollte ich noch Hysterese vorsehen? 47K pos. feedback

47K wäre viel zu niederohmig. Der Ausgang des Komparators schwingt ja 
um 5V. Der Spannungsteiler aus Feedback-Widerstand und dem Widerstand am 
Komparatoreingang bestimmt die Größe der Hysterese. Wenn du 5mV willst, 
brauchst du 1000:1. Bei 100K am Komparatoreingang also 100M. Du siehst 
also: die Impedanzverhältnisse deiner Schaltung sind alles andere als 
optimal.

Da dir die Polarität egal ist, kannst du die Komparatoreingänge 
tauschen. Dann kannst du R7 niederohmiger machen und entsprechend einen 
praxistauglicheren Wert für den Feedback-Widerstand vorsehen. Ich würde 
nicht über 10M gehen. Wenn du R7 verkleinerst, mußt du aber auch R2/R3 
verkleinern. Sonst wackelt deine Referenzspannung.

: Bearbeitet durch User
von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@AxelSchwenke:
Danke. Ich bin ohnehin nicht an 100K gebunden. Die kamen mal irgendwie 
aus einem Vorschlag hier. Die Original-Transistorschaltung schließt das 
Signal am Eingang mit 1 Ohm ab. Die Quelle ist ohnehin sehr niederohmig. 
Aber in meiner Anwendung darf ich die Quelle nicht mit weniger als ca. 
100 Ohm belasten, weil die Amplitude noch für andere Zwecke gebraucht 
wird. Aber ich könnte bei  R1,R2,R3,R7 um 1-2 Größenordnungen 
runtergehen.

--
Christoph

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Schön, daß Du meinen Vorschlag aufgenommen hast.
Hatte nicht wirklich damit gerechnet, und so hab ich den Thread aus den 
Augen verloren. Mit dem kleinen Schaltplan hatte ich`s mir wohl ein 
bißchen zu einfach gemacht. Darum Danke an alle für die 
Verbesserungsvorschläge. Jetzt weiß ich selber auch mehr.


ChristophK schrieb:
> Dann sähe die Schaltung jetzt so aus:
> Wäre das OK?

Ja klar.
Der 2µF gehört aber direkt an Pin 3.
Beim ersten Versuch (mit C an Pin 3)zeigte das Oszi ja ein sauberes 
Rechteck. Nur mit einem blöden Tastverhältnis.

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> ChristophK schrieb:
>> Dann sähe die Schaltung jetzt so aus:
>> Wäre das OK?
>
> Ja klar.
> Der 2µF gehört aber direkt an Pin 3.
> Beim ersten Versuch (mit C an Pin 3)zeigte das Oszi ja ein sauberes
> Rechteck. Nur mit einem blöden Tastverhältnis.

Ich hatte jetzt angenommen, das ungleiche Tastverhältnis käme daher, daß 
der Biasstrom (100nA) im 100K einen Offset generiert, der in der 
Größenordnung des Nutzsignals ist. Dachte, ich kompensiere das durch 
einen zweiten 100K im +-Eingang.

Habe die Schaltung auch ohmisch noch mal modififiziert.

Grüße
Christoph

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Ich hatte jetzt angenommen, das ungleiche Tastverhältnis käme daher, daß
> der Biasstrom (100nA) im 100K einen Offset generiert, der in der
> Größenordnung des Nutzsignals ist. Dachte, ich kompensiere das durch
> einen zweiten 100K im +-Eingang.

Ja, das war schon richtig. Hat das keine Verbesserung gebracht? Wobei 
eben die Widerstände für den Teiler  und für R1/R7 mit 100k schon recht 
groß sind. Die Biasströme in die Eingänge müssen ja nicht identisch groß 
sein und damit bleibt immer noch die Differenz der Spannungsabfälle als 
Fehler übrig.

Im neuen Bild hast du aber die Zeitkonstante zum Filtern des -E für die 
gleitende Schwelle dramatisch reduziert und natürlich die Belastung des 
Eingangssignals mit 100Ω stark erhöht und dann wäre auch C1 zu klein. 
Vorher 100kΩ, jetzt 100Ω. Ich würde eher so 1k für R1 und R7 
vorschlagen.
Außerdem: R8 ist zwar sinnvoll, aber viel zu niederohmig. So gibt das 
eine Hysterese von mehr als 100mV, es schaltet dann wieder nichts. 
Behalte den R8 im Hinterkopf, denke mal an Werte zwischen 1MΩ und 10MΩ 
und lasse ihn zum Testen, in wie weit das Offsetproblem kompensierbar 
ist, zunächst mal weg oder setze ihn auf 10MΩ.
Mache ihn dann so klein wie nötig bzw. so groß wie möglich für ein 
sauberes Ausgangssignal: Zu klein: nichts geht, zu groß: Schwingen oder 
mehrfache Flanken.

Ich habe dir mal einen Vorschlag angehängt (Referenzen aus meinem Plan):
- simuliert habe ich mit dem LM393, einen 311 hab ich nicht als Modell. 
Der   393 hat aber einen deutlich kleineren Eingangsbiasstrom. Und: es 
gibt noch viel bessere!
- R1 und R2 sind unsymmetrisch gewählt (Teiler 9V auf ca. 2.5V), weil 
die Mitkopplung mit R6 auch mit 5V Pegel läuft und somit die Hysterese 
symmetrisch wirkt.
- 1mV sind in der Simulation kein Problem, aber da hab ich auch ein 
perfektes Eingangssignal ohne Rauschen etc. Für 10mV sollte es aber auch 
mit nicht so ganz perfekten Signalen gehen. Der Störanteil deiner Quelle 
muss so oder so deutlich kleiner sein als das Nutzsignal!

Und wenn das Ganze noch immer zu kritisch ist, dann spendiere einen 
einfachen Transistorverstärker davor oder nimm einen besseren Komparator 
mit weniger Offset und Bias.

Bei deinen Tests solltest du auch mal mit dem Eingangssignalpegel von 
'oben' kommen (z.B. 100mV) und schauen, ab welchem Pegel es anfängt, 
kritisch zu werden.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
HildeK schrieb:
> ChristophK schrieb:
>> Ich hatte jetzt angenommen, das ungleiche Tastverhältnis käme daher, daß
>> der Biasstrom (100nA) im 100K einen Offset generiert, der in der
>> Größenordnung des Nutzsignals ist. Dachte, ich kompensiere das durch
>> einen zweiten 100K im +-Eingang.
>
> Ja, das war schon richtig. Hat das keine Verbesserung gebracht? Wobei

Soweit bin ich nicht mehr gekommen. Zu dem Zeitpunkt hatte ich meinen 
Print derart "versaut" mit Huckepackwiderständen, Trimmer in der Luft, 
abgeknipsten leads usw. Habe einen neuen gemacht.

> eben die Widerstände für den Teiler  und für R1/R7 mit 100k schon recht
> groß sind. Die Biasströme in die Eingänge müssen ja nicht identisch groß

Meinst Du nicht auf dem selben Silizium sind die in etwa (aus 
Symmetriegründen) gleich?

> sein und damit bleibt immer noch die Differenz der Spannungsabfälle als
> Fehler übrig.
>

Ja, da hatte ich auf Kompensation oder geringe Differenz gesetzt, den 
Rest hätte der Balance-Trimmer gemacht.

> Im neuen Bild hast du aber die Zeitkonstante zum Filtern des -E für die
> gleitende Schwelle dramatisch reduziert und natürlich die Belastung des

> Eingangssignals mit 100Ω stark erhöht und dann wäre auch C1 zu klein.

100 Ohm Last ist OK. Ich erwähnte ja, daß die SIgnalquelle sehr 
hiederohmig ist. Wenige Ohm.

> Vorher 100kΩ, jetzt 100Ω. Ich würde eher so 1k für R1 und R7
> vorschlagen.

Wenn ich richtig gerechnet habe, wäre bei 100 Ohm und C1=1µF, die 
Grenzfrequenz des Hochpasses ca. 1,5 KHz, wäre natürlich etwas zu hoch 
bei 440Hz. Also 4,7µF wären dann angebracht. Oder, wie Du vorschlägst, 
1K.
Aber wegen der Hysterese noch mal: Ich hatte  gerechnet 5mV zu 5V ~1000.
Also 100/100000 (deshalb die 100K).



> Außerdem: R8 ist zwar sinnvoll, aber viel zu niederohmig. So gibt das
> eine Hysterese von mehr als 100mV, es schaltet dann wieder nichts.
> Behalte den R8 im Hinterkopf, denke mal an Werte zwischen 1MΩ und 10MΩ
> und lasse ihn zum Testen, in wie weit das Offsetproblem kompensierbar
> ist, zunächst mal weg oder setze ihn auf 10MΩ.
> Mache ihn dann so klein wie nötig bzw. so groß wie möglich für ein
> sauberes Ausgangssignal: Zu klein: nichts geht, zu groß: Schwingen oder
> mehrfache Flanken.
>
> Ich habe dir mal einen Vorschlag angehängt (Referenzen aus meinem Plan):
> - simuliert habe ich mit dem LM393, einen 311 hab ich nicht als Modell.
> Der   393 hat aber einen deutlich kleineren Eingangsbiasstrom. Und: es
> gibt noch viel bessere!
> - R1 und R2 sind unsymmetrisch gewählt (Teiler 9V auf ca. 2.5V), weil
> die Mitkopplung mit R6 auch mit 5V Pegel läuft und somit die Hysterese
> symmetrisch wirkt.
> - 1mV sind in der Simulation kein Problem, aber da hab ich auch ein
> perfektes Eingangssignal ohne Rauschen etc. Für 10mV sollte es aber auch
> mit nicht so ganz perfekten Signalen gehen. Der Störanteil deiner Quelle
> muss so oder so deutlich kleiner sein als das Nutzsignal!
>
> Und wenn das Ganze noch immer zu kritisch ist, dann spendiere einen
> einfachen Transistorverstärker davor oder nimm einen besseren Komparator
> mit weniger Offset und Bias.
>
> Bei deinen Tests solltest du auch mal mit dem Eingangssignalpegel von
> 'oben' kommen (z.B. 100mV) und schauen, ab welchem Pegel es anfängt,
> kritisch zu werden.

Danke erst mal. Werde Deine Vorschläge mal umsetzen.

Christoph

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
>> eben die Widerstände für den Teiler  und für R1/R7 mit 100k schon recht
>> groß sind. Die Biasströme in die Eingänge müssen ja nicht identisch groß
>
> Meinst Du nicht auf dem selben Silizium sind die in etwa (aus
> Symmetriegründen) gleich?
Nicht unbedingt. Allerdings sollten die Unterschiede natürlich eine 
Zehnerpotenz kleiner sein als der Absolutwert.

>> sein und damit bleibt immer noch die Differenz der Spannungsabfälle als
>> Fehler übrig.
>>
>
> Ja, da hatte ich auf Kompensation oder geringe Differenz gesetzt, den
> Rest hätte der Balance-Trimmer gemacht.
Ja, ich ja auch mit meinem Vorschlag.

ChristophK schrieb:
> Wenn ich richtig gerechnet habe, wäre bei 100 Ohm und C1=1µF, die
> Grenzfrequenz des Hochpasses ca. 1,5 KHz, wäre natürlich etwas zu hoch
> bei 440Hz. Also 4,7µF wären dann angebracht. Oder, wie Du vorschlägst,
> 1K.
Korrekt.

> Aber wegen der Hysterese noch mal: Ich hatte  gerechnet 5mV zu 5V ~1000.
> Also 100/100000 (deshalb die 100K).
Ja, aber nicht die 100Ω wirken, sondern die Quellimpedanz. Muss dann 
auch gehen. Du beeinflusst ja den +E und daran hängt die Quelle.
Auch ich hab da was vergessen in meinem Bild: in Serie zur Quelle muss 
noch ein Widerstand mit 100Ω, denn auf die wirkt der 
Hysteresewiderstand! Dann hast du dir Rechnung 100R zu 100k oder 470k 
oder 1Meg.

Ich sagte ja: Hysterese so klein wie nötig (Rauschen) und so groß wie 
möglich (noch funktional) - da dazwischen!

Außerdem: bei einem 10mV Signal sind 5mV Hysterese schon sehr viel, du 
hast ja das auf beide Seiten. Zudem kommt noch, dass die durch den 2.2µ 
geglättete Spannung, die als Schwelle wirkt, auch nicht stabil ist und 
durch das Eingangssignal um ein paar mV verändert wird. Daher muss auch 
dort der Wert noch (deutlich) erhöht werden.

ChristophK schrieb:
> Danke erst mal. Werde Deine Vorschläge mal umsetzen.

Ja, teste mal. Und mach noch 100Ω in Serie zur Quelle. Und erhöhe meinen 
C1 ruhig auf 47µF.
Den Hysteresewiderstand wirst du dann auf <1Meg machen können, aber das 
würde ich den Gegebenheiten anpassen und am Labortisch optimieren.

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Schließe das Eingangssignal an -E des Komparators an, dann hat 
die Quellimpedanz keinen Einfluss mehr auf die Hysterese. Dann entfällt 
auch der o.g. 100R in Serie zur Quelle.
Das Ausgangssignal ist damit zwar invertiert, im vorliegenden Fall 
spielt das aber keine Rolle.

Siehe Anhang, so gefällt es mir momentan am Besten :-).

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Was bedeutet Rser=1 in Deiner Simulation?

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ach so, noch was - ist zwar für den eingeschwungenen Zustand egal -, 
aber real ist die Quelle

SINE(-5m 5m 440)

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Was bedeutet Rser=1 in Deiner Simulation?

Innenwiderstand der Quelle, das kann man dem Spannungssymbol als 
Parameter mitgeben. Ja, du hattest 10Ω geschrieben, in der letzten 
Schaltung spielt das aber fast keine Rolle mehr.

ChristophK schrieb:
> Ach so, noch was - ist zwar für den eingeschwungenen Zustand egal -,
> aber real ist die Quelle
>
> SINE(-5m 5m 440)
Das bedeutet ±5mV Amplitude mit +5mV DC-Offset, der erste Wert gibt den 
DC-Offset an und der ist wegen dem Eingangs-C egal.
Ok, du hast von 10mVpp geredet (pp hatte ich übersehen), -> dann wäre 
SINE(0 5m 440) richtig gewesen. Ich habe mit der doppelten Amplitude 
simuliert.
Für 10mVpp muss R6 (im letzten Bild) auf jeden Fall auf 1-2Meg erhöht 
werden. Die Hysterese sollte dann nicht mehr als 5mVpp haben, die 
beteiligten Widerstände sind R6 und R4 und das ist genau das Verhältnis 
5V/5mV bei 1Meg für R6.
In der Simulation geht die Schaltung runter bis etwa 6mVpp.
Eine kleine Transistorstufe davor wäre zumindest bei der Verwendung des 
LM311 sehr empfehlenswert um einfach mit mehr Pegel dessen 
Unzulänglichkeiten zu umgehen. Die muss ja nicht mehr als v=10 oder 20 
machen.

Es sind halt relativ kleine Signale und da wird die Simulation oftmals 
zu Ergebnissen führen, die auf Grund von Bauteiltoleranzen nachher doch 
nicht ganz passen. Außerdem: bei tausendfach größerem Ausgangssignal als 
Eingangssignal muss man beim Aufbau schon sehr darauf achten, wie das 
Layout und die Masseführung ist und ob ev. übersprechenden Signale auf 
den Eingang wirken können.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke. Ich habe zwar schon mal mit LTSpice/PSpice gearbeitet, aber mir 
waren die Parameter jetzt entfallen, insofern war das lediglich ein 
Beitrag zum CO2-Ausstoß, den ich da produziert habe :)

Ja, in der Tat wäre ein Vorverstärker nützlich, am besten ein 
Bandpaß-Filter um 440Hz +/- 15Hz.

Eignet sich so ein LM393 auch als OP-amp? Oder könnte ich den LM358 
nehmen und ihn als schlechteren Komparator einsetzen, wenn er 100mv als 
Eingangssignal bekäme (Verstärkung 20 der Vorstufe)?

Grüße
Christoph

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Eignet sich so ein LM393 auch als OP-amp? Oder könnte ich den LM358
> nehmen und ihn als schlechteren Komparator einsetzen, wenn er 100mv als
> Eingangssignal bekäme (Verstärkung 20 der Vorstufe)?

Der 393 ist nicht als OPA verwendbar.
Umgekehrt schon, eine 358 kann verstärken (bei 440Hz auch mehr als 20) 
und ist mehr oder weniger gut als Komparator verwendbar. Für den Zweck 
würde es aber gehen. Auch einen einfachen Bandpass kannst du in den 
Verstärker mit integrieren.
Einzig: dessen Ausgangssignal kann nicht mit einem Pullup auf die 5V 
angepasst werden, bei 9V Versorgung wird er bei HIGH rund 7V abliefern. 
Das ließe sich aber mit einem einfachen Spannungsteiler korrigieren.

Probier doch einfach mal den Vorverstärker im Anhang. Leichtes 
Bandpassverhalten, Verstärkung ca. 100.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke noch mal für die umfangreiche Hilfe und Begleitung meines 
"Projekts".

Der Vorverstärker war dann letztlich der Bringer. Raus aus dem 
5mV-Signal in einen Bereich von ca. 0,5V. Habe dann doch meine 
ursprüngliche Schaltung mit dem Eingangsspannungsteiler von HildeK 
27K/10K verwendet, weil der Print schon fertig war. Habe den 
Vorverstärker dann noch auf ein Stück Platinenüberstand mit Bohrlöchern 
"gestrickt".

Jetzt kommt aber das große Dilemma: der - sei er noch so - billige 
1Hz./.75MHz Zähler zählt meinen 440Hz Rechteck nicht.

Ich habe einen sauberen Rechteck  am Pull-Up Ausgang des LM311 (0-5V),
gebe den auf den BNC-Eingang des Zählers über einen Cinch/BNC-Adapter 
(kann ich ja schlecht mit 50Ohm abschließen) und der Zähler zeigt wild 
springende Werte von 1,3 bis 1,7 KHz an.

Vielleicht mißt er in der Flanke des Rechecks noch etwas. Habe keine 
Hysterese eingebaut.

Grüße
Christoph

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Situation gerettet. Habe den Ausgang mit einem RC-Filter beschwert. 1K 
zu 150nF.

von ChristophK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Und noch die Anzeige. Zuvor maß auch mein Keithley 2000 völligen 
,,Mist". Jetzt zeigt es auch brav denselben Wert wie der Counter.

Alles in Butter.

Grüße
Christoph

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das sind übrigens im oberen Kanal 5mV/div
Also ca 5mVpp(!). Und unten 5V/div, die Ausgangsspannung der 
Komparatorstufe nach dem RC-Filter, was dann auch gleich der 
Eingangsspannung des Frequenzzählers ist.

--
Christoph

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Das sind übrigens im oberen Kanal 5mV/div

Man sieht auch, daß das Signal schon auf der Bildschirmbreite um ca. 
halbe Amplitude Versatz hat, da liegt also ein Sinus auf einem Sinus von 
ca. 1/10 der Frequenz.

Je nach dem, wie man die Schaltschwelle legt, und wie langsam die 
Adaption der Schaltschelle erfolgt, kommen also natürlich Zufallszahlen 
bei raus.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Am Eingang liegt eine Überlagerung mit 50Hz vor. Lag irgendwie am 
fliegenden Aufbau. Hatte den Eingang auch schon mal störungsfreier.
Nun hat der Vorverstärker etwas Bandpassverhalten. Zufallszahlen kommen 
mitnichten heraus.

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> ChristophK schrieb:
>> Das sind übrigens im oberen Kanal 5mV/div
>
> Man sieht auch, daß das Signal schon auf der Bildschirmbreite um ca.
> halbe Amplitude Versatz hat, da liegt also ein Sinus auf einem Sinus von
> ca. 1/10 der Frequenz.
> ...


Außerdem ist das Bild verwackelt (siehe Schrift 465) und mindestens 2 
Strahldurchläufe abgelichtet.

Christoph

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> Je nach dem, wie man die Schaltschwelle legt, und wie langsam die
> Adaption der Schaltschelle erfolgt, kommen also natürlich Zufallszahlen
> bei raus.

@laberkopp:
Ich wollte Dich immer noch mal fragen, was Du mit "wie langsam die 
Adaption der Schaltschwelle erfolgt" meintest. (abgesehen vom Tippfehler 
:)

--
Christoph

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.