Forum: Mikrocontroller und Digitale Elektronik Spannungsversorgung für µC im KFZ-Bordnetz


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Felix A. (felixbrb)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Moin,

ich möchte in meinem alten Trabant eine Mikrocontrollerschaltung 
betreiben. Dazu brauche ich eine saubere Spannungsversorgung von 3,3V. 
Das habe ich versucht aufzubauen und bin da leider auf Probleme 
gestoßen. Ja, ich weiß, dazu gibt es viele Beiträge hier, an denen ich 
mich auch orientiert habe. Ich bin außerdem kein Elektroniker und habe 
nur laienhaftes Elektronikwissen. Ich würde mich daher über Hilfe sehr 
freuen - insbesondere, wenn diese für mich verständlich ausgedrückt 
wird. Mein Projekt dient der reinen Befriedigung meiner Neugier - fragt 
also nicht nach Sinn und Unsinn der ganzen Sache. Ich will einfach was 
dabei lernen.

Ich habe meine 3,3V Spannungsversorgung nach unten aufgezeichneter 
Schaltung aufgebaut. Das ganze ist an die Vorschläge auf dieser Seite 
angelehnt: http://www.ostermann-net.de/electronic/dse-faq.htm#F.23

Ich habe allerdings den Spannungsregler durch einen Traco TSR 1-2433 
ersetzt. Das schien mir damals eine gute Wahl, weil man sie im Grunde 
ohne weitere Beschaltung nutzen kann. Als Stromdrossel habe ich dieses 
Bauteil verwendet: 
https://www.reichelt.de/Funkentstoerdrosseln-Ringkern/TLC-1-0A-47-/3/index.html?ACTION=3&LA=2&ARTICLE=105588&GROUPID=3182&artnr=TLC+1%2C0A-47%C2%B5&SEARCH=%252A

Soweit so gut. Prinzipiell funktioniert der Aufbau und der Controller 
läuft damit. Leider tut er dies nicht besonders zuverlässig - 
insbesondere die USB-Verbindung vom Controller zum Laptop bricht oft ab, 
was bei einer Versorgung des Controllers über ein Netzteil nie passiert. 
Ich habe mich daher auf die Suche nach der Ursache gemacht und bin auch 
fündig geworden. Ich kann im gesamten Bordnetz im Takt der Zündung 
heftige Spannungsspitzen messen. Es handelt sich also wahrscheinlich um 
die Rückinduktion aus den Zündspulen. Am Zündspulenanschluss direkt kann 
ich bis +/-50V Spitzen messen, die dann ausklingen. Die Schwingungen 
haben eine Frequenz von ca. 25MHz, allerdings könnte es auch sein, dass 
mein Oszi (Picoscope) das einfach nicht weiter auflösen kann. Diese 
Störungen werden natürlich durch die genannte Schaltung zur 
Spannungsversorgung gedämpft, so dass auf der 3.3V Seite nurnoch Spitzen 
von +/-10V messbar sind. Brauchbar ist das so allerdings nicht.

Der Trabant hat eine originale Transistorzündanlage. Diese wird durch 
einen Hall-Sensor an der Kurbelwelle gesteuert und läd die zwei 
Zündspulen (eine für jeden Zylinder) über entsprechende 
Leistungstransistoren in Darlington-Schaltung abwechselnd. Das 
funktioniert erstaunlich gut und zuverlässig. Ich hatte in 120.000km 
noch kein einziges Problem damit. Aber das nur am Rande.

Ich habe nun verschiedene Maßnahmen ausprobiert. Ich habe die 
Keramikkondensatoren durch Low-ESR-SMD Kondensatoren unterstützt, in der 
Hoffnung, dass diese besser auf diese hohen Frequenzen reagieren können. 
Das hat leider nix gebracht. Als nächstes habe ich einen 
Durchführungskondenstor auf 12V Zuleitung eingesetzt und das Ganze wurde 
damit deutlich besser. Nun habe ich auf der 3,3V Seite nurnoch Spitzen 
zwischen 2V und 4,5V messen können. Damit läuft der Controller und die 
USB-Verbindung schon fast problemlos. Allerdings eben noch nicht ganz. 
Hin und wieder setzt das Ganze immer noch aus. Und so richtig gut schein 
diese Lösung auch noch nicht zu sein.

Ich könnte mir nun vorstellen, dass diese Induktivität die ich da 
verwende nicht so toll ist und diese durch eine andere ersetzen. Denn 
eigentlich sollten hinter der Induktivität doch keine so hohen 
Frequenzen mehr messbar sein - sind sie aber. Gibt es dazu irgendwelche 
Vorschläge oder Anmerkungen? Weiterhin habe ich mich nun zu Varistoren 
belesen, da diese im Nanosekundenbereich auf Spannungspitzen reagieren 
können. Ich könnte mir vorstellen einen 16V Varistor parallel zu meiner 
Supressordiode zu platzieren. Dabei kam mir aber auch der Gedanke, dass 
ich je einen Varistor ja dann auch gleich über den Zündspulen platzieren 
könnte. Das würde die Störung gleich an der Quelle eleminieren. Das habe 
ich hier so gesehen: 
http://www.sr71.dyndns.info/_HochspannungsGenerator.php Macht das Sinn?

Für verständliche Anregungen und Vorschläge bin ich sehr dankbar.

Viele Grüße, Felix

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
47uH sind schon etwas wenig verwende mal so eine stromkompensierende 
Drossel.
https://www.reichelt.de/Stromkompensierte-Drosseln/CAF-1-0-27/3/index.html?ACTION=3&LA=446&ARTICLE=32279&GROUPID=3183&artnr=CAF+1%2C0-27

Und spendiere nochmal nen Kerko direkt an der Drossel.

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Es gibt keine stromkompendensierenden Drosseln :-)

Das Grundproblem heisst Trabant. Und damit verbunden sparsames 
Masselayout, nicht vorgesehen für Elektronik. Aber immerhin wohl schon 
12V-Anlage.
Prinzipell ist deine Schaltung in Ordnung, hilft aber nicht, wenn die 
Masse wild hin und her hüpft. Sternerdung (Batterie-Minus) hilft. Soweit 
ich mich erinnere, war auch schon der Minuspol der Lima ein Problemchen.
Von den Zündspulen solltest du die Finger lassen, die hohen 
Primärspannungen (das sind auch locker 200V+) sind erforderlich um 
ausreichend Zündenergie zu haben. Evtl. helfen Widerstandszündkabel und 
verstärkte Masseleitung von den Zündendstufen.

Versorgst du den Laptop über einen Wandler aus dem Kfz-Netz oder im 
Akkubetrieb? Und was genau willst du mit deiner Schaltung eigentlich 
machen? Je nach Anwendung kann ein komplett isoliertes Design eine 
erhebliche Erleichterung sein.

von Mani W. (e-doc)


Bewertung
-12 lesenswert
nicht lesenswert
Felix A. schrieb:
> ich möchte in meinem alten Trabant eine Mikrocontrollerschaltung
> betreiben.

Das ist eine echte Innovation!

Felix A. schrieb:
> Ich bin außerdem kein Elektroniker und habe
> nur laienhaftes Elektronikwissen.

Aber Mikrocontroller einsetzen...


Felix A. schrieb:
> Mein Projekt dient der reinen Befriedigung meiner Neugier - fragt
> also nicht nach Sinn und Unsinn der ganzen Sache.

Sicher nicht...;-))

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Die geringsten Störungen wirst du sicher haben, wenn du direkt an der 
Batterie anzapfst und möglichst wenig der Fahrzeugelektrik mitbenutzt. 
Wenn du dann die Zuleitungen zum MC entfernt von den Zündkabeln 
verlegst, sollte die restliche Siebung eigentlich ausreichen.
Denke dran, das Kabel mit fliegender Sicherung direkt an der Batterie 
abzusichern.

Du könntest auch den Weg gehen, die Zündung bzw. deren Speisung zu 
glätten, aber das läuft ja innerhalb des Wagens schon ganz gut.
In meinem Japaner ist direkt an der Endstufe der Transistorzündung, die 
sich in der Zündspule befindet, ein Entstörkondensator der Sorte 
2µF/450V, der die doppelte Funktion des Entstörers und des 
Pufferkondensators für die Endstufe erfüllt.

: Bearbeitet durch User
von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Felix A. schrieb:
> Ich könnte mir nun vorstellen, dass diese Induktivität die ich da
> verwende nicht so toll ist und diese durch eine andere ersetzen.

Richtig.

Die Spule soll zusammen mit dem Kondensator als LC Filter solche Impulse 
wegfiltern, die der Spannungsregler wegen Langsamkeit nicht ausregelt.

Offenbar überträgt der Traco Impulse besonders gut. Welche Spule am 
geeignetsten ist, musst du ausprobieren, mit erscheint deine von der 
Bauform her recht gross, was zu grosser Koppelkapazität führt. Eine 
"UKW-Drossel" ist meist gut geeignet.

Auch der Aufbau hat bei so hohen energiereichen Nadelimpulsen einen 
Einfluss, daher war wohl dein Durchführungskondensator gut.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
0 lesenswert
nicht lesenswert
Ich hab viele viele Jahre eine einfache Standard-Beschaltung eines 7805 
mit Verpolschutzdiode (und einem etwas größeren Elko dahinter um 
Spannungsschwankungen abzufangen, glaube da sind 1000µF drin) in einem 
VW T3 betrieben - die Betriebsstunden für den AVR-Controller und 7805 
dürften sich langsam Rekordwerten nähern. Am Eingang gibts noch eine 
kleine Sicherung falls doch was schiefgehen sollte (Schaltung läuft am 
Dauerplus), die ist auch noch die allererste.

Das läuft seit dem Einbau ohne Probleme, der Controller ist auch nicht 
einmal hängengeblieben oder so.

von Felix A. (felixbrb)


Bewertung
0 lesenswert
nicht lesenswert
Thomas O. schrieb:
> 47uH sind schon etwas wenig verwende mal so eine stromkompensierende
> Drossel.
> 
https://www.reichelt.de/Stromkompensierte-Drosseln/CAF-1-0-27/3/index.html?ACTION=3&LA=446&ARTICLE=32279&GROUPID=3183&artnr=CAF+1%2C0-27
>
> Und spendiere nochmal nen Kerko direkt an der Drossel.

Vielen Dank für deine Antwort. Ich werde das so mal umsetzen und 
berichten. :)

H.Joachim S. schrieb:
> Es gibt keine stromkompendensierenden Drosseln :-)
>
> Das Grundproblem heisst Trabant. Und damit verbunden sparsames
> Masselayout, nicht vorgesehen für Elektronik. Aber immerhin wohl schon
> 12V-Anlage.
> Prinzipell ist deine Schaltung in Ordnung, hilft aber nicht, wenn die
> Masse wild hin und her hüpft. Sternerdung (Batterie-Minus) hilft. Soweit
> ich mich erinnere, war auch schon der Minuspol der Lima ein Problemchen.
> Von den Zündspulen solltest du die Finger lassen, die hohen
> Primärspannungen (das sind auch locker 200V+) sind erforderlich um
> ausreichend Zündenergie zu haben. Evtl. helfen Widerstandszündkabel und
> verstärkte Masseleitung von den Zündendstufen.
>
> Versorgst du den Laptop über einen Wandler aus dem Kfz-Netz oder im
> Akkubetrieb? Und was genau willst du mit deiner Schaltung eigentlich
> machen? Je nach Anwendung kann ein komplett isoliertes Design eine
> erhebliche Erleichterung sein.

Auch dir vielen Dank für deine Antwort. Kannst du mir erklären, 
inwieweit das Masselayout (Karosserie ist Masseführend wie bei fast 
jedem Auto) problematisch ist und warum daher die Masse hin und her 
hüpft? Die Masse der Lima ist über das Limagehäuse mit dem Limahalter 
und darüber mit dem Motor verbunden, welcher letztendlich ein fettes 
Alukabel zum Minuspol der Batterie hat. Das ist sicher nicht optimal 
(aber durchaus üblich) und dadurch könnte ich mir schon vorstellen, dass 
das Massepotential nicht überall identisch ist. Aber warum hüpft es 
dann?

Machen Widerstandszündkabel noch Sinn, wenn ich Zündkerzenstecker mit 
entsprechendem Widerstand verwende - so wie es der Hersteller 
vorschreibt? Masseleitung zur Zündendstufe ist keine schlechte Idee. Die 
bekommt ihre Masse bisher über den Zündspulenhalter und der bekommt sie 
vom Radkasten an dem er festgeschraubt ist. Das ist ja schnell getestet. 
:)

Matthias S. schrieb:
> Die geringsten Störungen wirst du sicher haben, wenn du direkt an der
> Batterie anzapfst und möglichst wenig der Fahrzeugelektrik mitbenutzt.
> Wenn du dann die Zuleitungen zum MC entfernt von den Zündkabeln
> verlegst, sollte die restliche Siebung eigentlich ausreichen.
> Denke dran, das Kabel mit fliegender Sicherung direkt an der Batterie
> abzusichern.
>
> Du könntest auch den Weg gehen, die Zündung bzw. deren Speisung zu
> glätten, aber das läuft ja innerhalb des Wagens schon ganz gut.
> In meinem Japaner ist direkt an der Endstufe der Transistorzündung, die
> sich in der Zündspule befindet, ein Entstörkondensator der Sorte
> 2µF/450V, der die doppelte Funktion des Entstörers und des
> Pufferkondensators für die Endstufe erfüllt.

Danke für die Vorschläge, aber ich habe direkt an der Batterie fast noch 
die gleichen Spitzen messen können. Ich denke die Batterie ist viel zu 
träge um diese schnellen Peaks zu puffern. Den Gedanken hatte ich 
nämlich auch schon - hat aber leider nix gebracht. Auch einen 
Entstörkondensator (neu von Bosch) habe ich direkt an den Zündspulen 
montiert wie es überall empfohlen wird. Leider wieder kein messbarer 
Unterschied. :(

MaWin schrieb:
> Felix A. schrieb:
>> Ich könnte mir nun vorstellen, dass diese Induktivität die ich da
>> verwende nicht so toll ist und diese durch eine andere ersetzen.
>
> Richtig.
>
> Die Spule soll zusammen mit dem Kondensator als LC Filter solche Impulse
> wegfiltern, die der Spannungsregler wegen Langsamkeit nicht ausregelt.
>
> Offenbar überträgt der Traco Impulse besonders gut. Welche Spule am
> geeignetsten ist, musst du ausprobieren, mit erscheint deine von der
> Bauform her recht gross, was zu grosser Koppelkapazität führt. Eine
> "UKW-Drossel" ist meist gut geeignet.
>
> Auch der Aufbau hat bei so hohen energiereichen Nadelimpulsen einen
> Einfluss, daher war wohl dein Durchführungskondensator gut.

Alles klar, dann hatte ich ja schon den richtigen Gedanken. Meinst du, 
es macht Sinn den Traco durch einen anderen Regler zu ersetzen? Einen 
Linearregler wollte ich nicht nehmen, denn ich rechne mit bis zu einem 
Amper Stromverbrauch bei meiner Gesamtschaltung. Das wird mir zu heiß 
mit einem Linearregler. Aber vielleicht macht ja ein anderer 
Schaltregler mehr Sinn. Ich habe auch schon überlegt einen 5V 
Schaltregler zu nutzen und dahinter einen 3,3V Linearregler einzusetzen. 
Aber das wäre vermutlich auch mit Kanonen auf Spatzen ... und ob es mein 
Problem löst?

Ben B. schrieb:
> Ich hab viele viele Jahre eine einfache Standard-Beschaltung eines 7805
> mit Verpolschutzdiode (und einem etwas größeren Elko dahinter um
> Spannungsschwankungen abzufangen, glaube da sind 1000µF drin) in einem
> VW T3 betrieben - die Betriebsstunden für den AVR-Controller und 7805
> dürften sich langsam Rekordwerten nähern. Am Eingang gibts noch eine
> kleine Sicherung falls doch was schiefgehen sollte (Schaltung läuft am
> Dauerplus), die ist auch noch die allererste.
>
> Das läuft seit dem Einbau ohne Probleme, der Controller ist auch nicht
> einmal hängengeblieben oder so.

Würde ich gern so machen, aber wie gesagt, wird mir ein Linearregler bei 
1A Stromverbrauch schlicht zu heiß. Daher brauche ich eine Lösung mit 
Schaltregler.

Achja, nochmal die Frage nach den Varistoren: Macht es Sinn die 
Suppressordiode durch einen schnellen Varistor zu unterstützen?

Gruß, Felix

: Bearbeitet durch User
von Jakob (Gast)


Bewertung
0 lesenswert
nicht lesenswert
USB ist für 5 V spezifiziert.

Vielleicht ist deine Spannungsversorgung unschuldig?

von Felix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jakob schrieb:
> USB ist für 5 V spezifiziert.
>
> Vielleicht ist deine Spannungsversorgung unschuldig?

Nein, der Controller läuft als USB-Slave und hat daher den 
USB-B-Anschluss - liefert selbst also keine Versorgungsspannung. Das 
Laptop (USB-Master) liefert zwar prinzipiell die 5V, diese sind aber in 
meinem Fall nicht verbunden, da der Controller ja vom Bordnetz aus 
versorgt werden soll. Trotzdem Danke für deinen Tipp.

Gruß, Felix

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Felix A. schrieb:
> Achja, nochmal die Frage nach den Varistoren: Macht es Sinn die
> Suppressordiode durch einen schnellen Varistor zu unterstützen?

Nein. Varistoren sind Klasse, gelegentliche Störenergien zu absorbieren. 
Für Dauerbetrieb sind sie i.a. nicht zu gebrauchen. Die verändern sich 
mit der Zeit und enden mit einem satten Kurzschluss.

von Felix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ah, ok danke für die Erklärung. Ich hatte den Wikipediaartikel aber so 
verstanden, dass das nur für die alten Varistoren aus Siliziumkarbid 
gilt. Ich dachte die modernen altern nicht mehr. Lieg ich da falsch?

Gruß, Felix

von Felix A. (felixbrb)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Moin,

ich kann Erfolg vermelden! :) Ich wollte am Wochenende fleißig sein und 
hatte mich auf viele Versuche zur Störungsbekämpfung eingestellt. Umso 
erstaunter war ich, als gleich die erste Maßnahme voll ins Schwarze traf 
und die Störung komplett beseitigte.

Ich habe mal 2 Bilder angefügt. Das erste Bild zeigt die Störung, wegen 
der ich hier überhaupt schreibe. Wobei die blaue Kurve direkt zwischen 
dem Durchführungskondensator und dem Eingang meiner oben gezeigten 
Schaltung (also im Grunde vor der Spule) abgenommen wurde und die rote 
Kurve direkt hinter der Spule gemessen ist. Man sieht schön, dass die 
Störung nahezu ungedämpft durch die Spule geht. Die Störung im zweiten 
Bild habe ich ebenfalls immer messen können. Sie wird allerdings 
problemlos von der Spule geschluckt. Was das genau ist, weiß ich nicht, 
vielleicht der Lichtmaschinenregler? Wer kann dazu etwas sagen?

Jemand schrieb hier ich solle doch mal Widerstandszündkabel versuchen. 
Dabei habe ich mich erinnert, dass die originalen 30 Jahre alten 5k Ohm 
Kerzenstecker immer sehr unzuverlässig waren und ich hin und wieder 
deswegen liegen blieb. Irgendwann hatte ich dann Kerzenstecker aus neuer 
Produktion beschafft, welche allerdings nur 1k-Ohm hatten. Damit lief 
der Trabi nun mehrere Jahre deutlich zuverlässiger. Jedenfalls habe ich 
testweise die 1k Ohm Kerzenstecker gegen originalen Kerzenstecker mit 
den vorgeschriebenen 5k Ohm ausgetauscht und siehe da, ich kann die 
Störung aus dem ersten Bild nicht mehr messen. Die aus zweite Störung 
ist noch da, aber die wird ja von meiner Spule geschluckt. Mein Problem 
ist damit gelöst. die Schaltung läuft nun stabil.

Nun würde ich das aber gern noch verstehen was da passiert ist. Ich habe 
bisher folgende Theorie: Der Widerstand zwischen den Kerzenelektroden 
ist im Zündmoment zunächst deutlich größer als 5k Ohm. Der Widerstand 
der Kerzenstecker spielt somit zunächst bei der Frage ob sich ein 
Zündfunke an den Elektroden aufbaut oder nicht kaum eine Rolle. 
Unmittelbar danach baut sich ein Ionenkanal zwischen den Elektroden auf 
und verringert den Widerstand erheblich. Nun ist es durchaus 
entscheidend, wie der Widerstand auf der restlichen Zündleitung ist. Je 
größer er ist, desto langsamer und niederfrequenter entläd sich die 
Zündspule. Das erhöht einerseits die Brenndauer und verringert 
andererseits die Störabstrahlung.

Weiß jemand ob ich mit meiner Theorie richtig liege?

Kann mir jemand sagen, was die zweite Störung sein könnte?

Hat jemand vielleicht noch einen Tipp für weiterführende Literatur?

Vielen Dank schon mal im Voraus. Gruß, Felix

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Felix A. schrieb:
> Je
> größer er ist, desto langsamer und niederfrequenter entläd sich die
> Zündspule.

Der Tiefpass spielt da auch eine Rolle, aber wichtiger ist, das ein 
wenig belasteter Hochspannungstrafo (und eine Zündspule ist das ja) 
einfach weniger Strom auf der Primärseite zieht, als ein höher 
belasteter.

: Bearbeitet durch User
von Thomas O. (kosmos)


Bewertung
1 lesenswert
nicht lesenswert
es ist schon gut immer an der Störquelle zu entstören, ich hätte aber an 
meine Schaltung den Anspruch das Sie mit soetwas zurechtkommt, konnte ja 
auch mal sein das ein Auto neben deinem steht vom dem die Störungen 
ausgehen.

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Sei einfach froh, dass es nun funktioniert und belass es dabei. Das Ding 
ist eine Billigst-Konstruktion, dem Notstand geschuldet.

>welcher letztendlich ein fettes Alukabel zum Minuspol der Batterie hat

>Masseleitung zur Zündendstufe ist keine schlechte Idee. Die
>bekommt ihre Masse bisher über den Zündspulenhalter und der bekommt sie
>vom Radkasten an dem er festgeschraubt ist.

Noch Fragen? Das ist bei weitem noch nicht alles an elektrischen 
Erbärmlichkeiten.
Aus einem Schweinsohr macht man auch heute keine schicke oder wenigstens 
brauchbare Handtasche. Weil es nicht geht.

von Bülent C. (mirki)


Bewertung
0 lesenswert
nicht lesenswert
Automotive LDO's kosten kein Vermögen...

von Felix (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Danke für eure Antworten. Aber so richtig befriedigend finde ich das 
nicht. Ich würde das schon gern besser verstehen.

H.Joachim S. schrieb:
> Aus einem Schweinsohr macht man auch heute keine schicke oder wenigstens
> brauchbare Handtasche. Weil es nicht geht.

Diesen Vergleich halte ich für ungerechtfertigt. Das Fahrzeug ist 
deutlich besser als die Allgemeinheit annimmt. Ich bin mit diesem Auto 
schon 120000km gefahren, es ist jetzt 30 Jahre alt (welches moderne Auto 
wird das wohl noch schaffen?) und war mit mir schon in halb Europa 
(Norwegen bis Italien, Frankreich bis Österreich). Ich fahre damit auch 
jeden Tag zur Arbeit. An dem Fahrzeug gibt es sicher Kompromisslösungen 
die den Umständen in seiner Entwicklungszeit geschuldet waren. Dennoch 
war das Fahrzeug damals durchaus auf dem Stand der Zeit. Wenn man sich 
drauf einlässt, kann man es durchaus auch heute noch als vollwertigen 
Gebrauchsgegenstand nutzen. Ob man den heutigen Stand der Technik in 
Fahrzeugen jedoch wirklich benötigt um von A nach B zu kommen, wage ich 
stark zu bezweifeln. Simpel und robust hat auch seinen Reiz und manchmal 
Vorteile.

Thomas O. schrieb:
> es ist schon gut immer an der Störquelle zu entstören, ich hätte
> aber an
> meine Schaltung den Anspruch das Sie mit soetwas zurechtkommt, ...

Habe ich ebenfalls. :) Keine Sorge. Daher frage ich hier ja auch weiter 
und akzeptiere es nicht einfach so.

Bülent C. schrieb:
> Automotive LDO's kosten kein Vermögen...

Wie ich Eingangs erwähnte bin ich kein Elektroniker. Kannst du das etwas 
weiter ausführen?

Ich wäre immer noch froh, wenn mir jemand mehr zu den gezeigten 
Störungen sagen könnte.

Gruß, Felix

von Der Andere (Gast)


Bewertung
-3 lesenswert
nicht lesenswert
Bülent C. schrieb:
> LDO's

Seit wann braucht man einen "Low Dropout" Regler (=LDO) um von 12 V auf 
3,3V zu regeln?

von Bülent C. (mirki)


Bewertung
0 lesenswert
nicht lesenswert
schaust du hier
Beitrag "Re: 12V KFZ Versorgungs-Schaltung aus de.dse-faq"

Nebenbei: In diesem Thread findest Du die Antworten auf Deine Fragen

: Bearbeitet durch User
von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
@Felix: Ich wollte dich keinesfalls kritisieren. Sehr löblich ein paar 
Infos wie die Bilder nachzureichen. Leider sieht man da nicht wirklich 
ein Problem auf der Versorgungsspannung, jeder Spannungsregler sollte 
damit zurechtkommen. Ich habe nicht ganz verstanden wo die die Spannung 
abgegriffen hast. Mach das mal an mehreren Punkten, gerade am zw. VCC 
und GND-Pin, zw. dem Reset-Pin und GND-Pin oder an den Eingängen des µCs 
und GND.

Mich würde mal deine Beschaltung des µC's interessieren, kannst du da 
auch noch ein Bild posten?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Felix schrieb:
> Simpel und robust hat auch seinen Reiz und manchmal
> Vorteile.

Das ist schon richtig, fahre ja selber keinen Neuwagen. Aber der kleine 
Bursche ist eben nicht dafür gedacht, mit Computern und hochmoderner 
Elektronik zusammenzuarbeiten. Das höchste der Gefühle war ein 
Autoradio, das man recht einfach entstören kann, aber für mehr war die 
Bordelektrik nie ausgelegt.
Deswegen kann man eben aus einem Schweinsohr keine Handtasche machen, 
bzw. aus einem 601 kein Datenzentrum.Und wenn du dir das H-Kennzeichen 
erhalten willst, bastelst du am besten auch nicht so viel dran rum.

Du hast ja jetzt 'ne Lösung.

: Bearbeitet durch User
von H.Joachim S. (crazyhorse)


Bewertung
-1 lesenswert
nicht lesenswert
So wars von mir gemeint. Die Technik an sich funktioniert 
erwiesenermassen, das bestreitet ja niemand.
Elektromagnetische Verträglichkeit war damals mehr oder weniger ein 
Fremdwort. Es reichte, wenn der Radio/Fernsehempfang beim Vorbeifahren 
nicht deutlich gestört wurde. Dein "Transistorzündung" war glaube ich 
nur eine nackte Unterbrecherzündung, wobei der Unterbrecher nicht die 
Zündspule direkt schaltete (das war am Anfang so) sondern einen 
Transistor und der wiederum die Zündspule. Das ganze, um den 
Unterbrecherabbrand in den Griff zu kriegen. Also auch da einfachste 
Technik, auch durch grössten Dreck im Bordnetz nicht aus der Ruhe zu 
bringen.
Und dann die unsägliche Gleichstromlichtmaschine mit elektromagnetischem 
Regler. Ja, funktioniert, Lebensdauer zwar begrenzt, aber immerhin. 
Kommutatorfeuer und Regler erzeugen energiereiche Störungen im Bordnetz. 
Die stören aber bei Primitivtechnik (Hitzedrahtblinkgeber z.B.) nicht, 
daher wurde auch kein Aufwand getrieben die zu minimieren.

von Felix A. (felixbrb)


Bewertung
1 lesenswert
nicht lesenswert
Thomas O. schrieb:
> @Felix: Ich wollte dich keinesfalls kritisieren. Sehr löblich ein
> paar
> Infos wie die Bilder nachzureichen. Leider sieht man da nicht wirklich
> ein Problem auf der Versorgungsspannung, jeder Spannungsregler sollte
> damit zurechtkommen. Ich habe nicht ganz verstanden wo die die Spannung
> abgegriffen hast. Mach das mal an mehreren Punkten, gerade am zw. VCC
> und GND-Pin, zw. dem Reset-Pin und GND-Pin oder an den Eingängen des µCs
> und GND.

Abgegriffen habe ich das, wo ich eben gerade rankam. Das war in meinem 
Fall einmal direkt an dem Beinchen vom Durchführungskondensator und 
einmal direkt am Beinchen der Supressordiode - eben vor und nach der 
Induktivität. Mein Plan war ja eigentlich diese auszutauschen und daher 
habe ich auch dort drumrum gemessen. Das hatte sich nach der Erkenntnis 
mit dem Kerzenstecker erstmal erledigt. Aber das will ich nun trotzdem 
noch versuchen und schauen was dann passiert.

> Mich würde mal deine Beschaltung des µC's interessieren, kannst du da
> auch noch ein Bild posten?

Mein Mikrocontroller sitzt auf dem Infineon XMC Relax Lite Kit - ein 
Promotion-Board von Infineon um den XMC4500 zu pushen. Nettes 
Bastlerboard, wenn man beruflich eh XMC-Controller programmiert.

Bülent C. schrieb:
> schaust du hier
> Beitrag "Re: 12V KFZ Versorgungs-Schaltung aus de.dse-faq"
>
> Nebenbei: In diesem Thread findest Du die Antworten auf Deine Fragen

Ich habe den Thread jetzt fast durchgelesen. Das ist ne Menge Holz, wenn 
man kein Elektroniker ist. Aber ich habe erstaunlich viel verstanden. 
Vielen Dank für diesen Beitrag. Ich werde mich dort weiter durcharbeiten 
und kann mir gut vorstellen deine Schaltung zu übernehmen. Mich würde 
aber interessieren, welche Spule du genau genommen hast. Offensichtlich 
sind 47µH nicht das einzige, was eine Spule charakterisiert. Interessant 
finde ich ja auch den erwähnten Ansatz die Spule ganz wegzulassen. 
Weiterhin werden mir wohl die 300mA nicht reichen. Ich muss noch mal 
rechnen, vielleicht komme ich mit 500mA hin, aber 1A wäre mir schon 
lieber. Dafür müsste ich noch einen passenden LDO finden. Dann kommt man 
aber auch darauf, dass ein Linearregler schon ordentlich Wärme 
produziert, wenn er von 14,3V Bordnetzspannung auf 3,3V 
Controllerspannung runterregeln soll. Deswegen hatte ich mich für einen 
Schaltregler entschieden - mit all seinen anderen Nachteilen. Wenn ich 
dafür eine Lösung hätte könnte ich mir das sehr gut vorstellen. Ich muss 
den ganzen Thread bei Gelegenheit noch mal ganz in Ruhe lesen. Danke! :)

Matthias S. schrieb:
> Felix schrieb:
>> Simpel und robust hat auch seinen Reiz und manchmal
>> Vorteile.
>
> Das ist schon richtig, fahre ja selber keinen Neuwagen. Aber der kleine
> Bursche ist eben nicht dafür gedacht, mit Computern und hochmoderner
> Elektronik zusammenzuarbeiten. Das höchste der Gefühle war ein
> Autoradio, das man recht einfach entstören kann, aber für mehr war die
> Bordelektrik nie ausgelegt.
> Deswegen kann man eben aus einem Schweinsohr keine Handtasche machen,
> bzw. aus einem 601 kein Datenzentrum.Und wenn du dir das H-Kennzeichen
> erhalten willst, bastelst du am besten auch nicht so viel dran rum.
>
> Du hast ja jetzt 'ne Lösung.

Das stimmt schon, das Auto stammt aus einer Zeit, wo das alles noch 
keine Rolle spielte. Nur so am Rande: H-Kennzeichen is bei mir nicht. 
Mit dem H-Kennzeichen könnte ich das Fahrzeug nicht mehr frei als 
Alltagswagen nutzen und sparen tut man auch nix. Die 600ccm sind in 
regulären Steuern und Versicherung billiger als jede H-Zulassung. Das 
wäre höchstens was, wenn man in die Umweltzonen will - will ich aber 
nicht. :)

H.Joachim S. schrieb:
> So wars von mir gemeint. Die Technik an sich funktioniert
> erwiesenermassen, das bestreitet ja niemand.
> Elektromagnetische Verträglichkeit war damals mehr oder weniger ein
> Fremdwort. Es reichte, wenn der Radio/Fernsehempfang beim Vorbeifahren
> nicht deutlich gestört wurde. Dein "Transistorzündung" war glaube ich
> nur eine nackte Unterbrecherzündung, wobei der Unterbrecher nicht die
> Zündspule direkt schaltete (das war am Anfang so) sondern einen
> Transistor und der wiederum die Zündspule. Das ganze, um den
> Unterbrecherabbrand in den Griff zu kriegen. Also auch da einfachste
> Technik, auch durch grössten Dreck im Bordnetz nicht aus der Ruhe zu
> bringen.
> Und dann die unsägliche Gleichstromlichtmaschine mit elektromagnetischem
> Regler. Ja, funktioniert, Lebensdauer zwar begrenzt, aber immerhin.
> Kommutatorfeuer und Regler erzeugen energiereiche Störungen im Bordnetz.
> Die stören aber bei Primitivtechnik (Hitzedrahtblinkgeber z.B.) nicht,
> daher wurde auch kein Aufwand getrieben die zu minimieren.

Ich nehme niemanden seine Meinung zu diesem Auto krumm, aber ich 
korrigiere auch gern, wenn die Leute sich falsch an die Technik dieses 
Autos erinnern. Da kenne ich mich halt etwas aus und dein Beitrag ist 
mal wieder so ein Fall. Ließ mal hier wie fortschrittlich die Zündung 
dann doch schon war. Ganz ohne Unterbrecher und mit Hall-Sensor ab 1985 
in Serie: http://trabant-dessau.de/Bilder-technik/beschr_ebza.jpg

Auch die "unsägliche Gleichstromlichtmaschine" musste in den letzten 
Baujahren gegen eine moderne Drehstromlichtmaschine mit eletronischem 
Laderegler weichen: 
https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&ved=0ahUKEwj9hdC2nvjWAhXHMBoKHYhvC-IQFggzMAE&url=http%3A%2F%2Fwww.trabant-original.de%2Ftoupl%2Fuploads%2Fdds_1984_01_drehstromlima-p601.pdf&usg=AOvVaw0pfCiIKK4uueIDGjjd9hBb

Ich will nicht neunmalklug erscheinen und dich belehren. Aber es ärgert 
mich schon ein wenig, dass so viel Quatsch über dieses Auto verbreitet 
wird. Es war natürlich trotzdem ein Kind seiner Zeit, das wolltest du 
sicher damit sagen und das ist auch unbestritten so. :)

Gruß, Felix

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Ach, schon ok.
Ich hatte auch mal so einen Eimer, ich krieg heute noch (negative) 
Gänsehaut wenn ich mal einen höre oder rieche.

Ich meinte, ich müsse einen digitalen Drehzahlmesser bauen (Zahlen waren 
cool, wenn auch dafür unbrauchbar, wusste ich aber noch nicht). Ok, das 
theoretische Grundgerüst was da an Störungen abgeht war mir noch fremd. 
Im Bastelkeller (NE555, D192, D147 und VQB71) funktionierte alles 
bestens, im Auto ums Verrecken nicht. Hauptstörer war die Lichtmaschine, 
aber so richtig habe ich es nie hingekriegt.

Aber das sie noch ne Drehstromlichtmaschine spendiert haben, wusste ich 
tatsächlich nicht.

von THOR (Gast)


Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.