Forum: Analoge Elektronik und Schaltungstechnik Hartley Oszillator schwingt nicht wie simuliert


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von David S. (david_s916)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen.

Ich versuchen einen Hartley Oszillator mit etwa 12 MHz aufzubauen. Dabei 
habe ich mich hieran orientiert:
http://www.electronics-tutorials.ws/oscillator/hartley.html

Da ich wenig Ahnung davon habe wie die Bauteile zu dimensionieren sind, 
habe ich das ganze System simuliert und dort zum Schwingen gebracht 
(siehe Anhang – die angezeigte Spannung ist die über R_load). Leider Tut 
der physikalische Aufbau keinen Mucks.
Ich wäre dankbar wenn mir da jemand weiterhelfen könnte.

Viele Grüsse,
David

von xyz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
1. .asc-Datei mitliefern
2. gutes aussagekräftiges scharfes Foto vom Aufbau

von Marc E. (mahwe)


Bewertung
1 lesenswert
nicht lesenswert
was für Spulen verwendest du??

: Bearbeitet durch User
von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
David S. schrieb:

> Leider Tut
> der physikalische Aufbau keinen Mucks.
> Ich wäre dankbar wenn mir da jemand weiterhelfen könnte.

Tja, dann hast Du ja schon etwas gelernt: Den Unterschied
zwischen Theorie und Praxis. M.E. sind Simulationsproramme
nur für Menschen mit guten Elektronikkenntnissen geeignet.
Sie müssen vor allen den Unterschied zwischen idealen und
realen Bauelementen kennen.

von David S. (david_s916)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt - ich lerne einiges bei diesem Projekt. Leider weiss ich nicht, 
welche parasitären Effekte mir hier in die Quere kommen.

Die Spulen sind zwei baugleiche PCB Spulen - die Anwendung soll ein 
induktiver Sensor sein (basierend auf Frequenzmessung).

Im Anhang, wie angefragt, ein Bild der Schaltung und das .asc file mit 
einem verwendeten .lib file.

von xyz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Ich wollte die Frage "Steckbrett" nicht explizit stellen, weil ich 
dachte, es sei inzwischen Allgemeinwissen, dass diese für HF völlig 
ungeeignet sind.
Bau das ganze kompakt auf eine kupferkaschierte Platine auf. Ja, dazu 
braucht man einen Lötkolben.

von Günter Lenz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Es gibt in deiner Schaltung keine Rückkopplung vom
Ausgang zum Schwingkreis, deshalb kann sie auch nicht
schwingen.

Lies mal auch dies, da gibt es ähnliche Probleme.

Beitrag "Pierce Oszillator mit LCR-Schwingkreis"

von ds (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
12Mhz und Steckbrett =>keine gute Idee

von Peter R. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
V1 ist auf jeden Fall falsch an den Schwingkreis angeschlossen. V1 muss 
an die "Anzapfung"

PCB-Spulen auf dem Steckbrett???

Im allgemeinen haben PCB-Spulen derart geringe Induktivität, dass die 
Induktivität der Leitungen auf einem Steckbrett erhebliche Unterschiede 
zur gezeichneten Schaltung ergeben.

Auch für die Kontaktstreifen kann man mehr als 10pF Kapazität zum 
jeweiligen Nachbar annehmen.

Erst einmal Maßnahmen ausführen, die die Schwingfreudigkeit des Aufbaus 
erhöhen: Arbeitspunkt des Transistors verändern, Last weglassen, C2 auf 
nF vergrößern, 100p sind zu klein, R7, mit 2 Ohm ist für die 
Oszillatorspule ein Kurzschluss. V1 ist auf jeden Fall falsch 
angeschlossen. V1 gehört
an die Anzapfung des Schwingkreises. Die gehört signalmäßig an Masse. R3 
wirkt als Bedämpfung des SK. R3 sollte Null sein, dann ist der SK direkt 
am Kollektor angeschlossen. Der niederohmige Spannungsteiler (5k5) 
bedämpft den Schwingkreis viel zu stark. Mach erstmals einen mit 22k 
draus.

Dass die Schaltung in der Simulation "schwingt" ist mir sowieso ein 
Rätsel.


Vielleicht koppeln sich die beiden Induktivitäten magnetisch, sodass 
eine Gegenkopplung entsteht. Die Kopplung wird ja von der Simulation 
nicht nachgebildet.

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und wenn du den Fehler entdeckt hast, daß es keine
Rückkopplung gibt, würde ich auch noch L2 kleiner oder
L1 größer machen, so im Verhältnis 1:5, damit der Schwingkreis
die Impedanz runter transformiert, weil die Eingangsimpedanz
des Transistors ziemlich niedrig ist, damit verbessert sich
die Betriebsgüte.

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Und vergiss nicht, einen günstigen Arbeitspunkt für den Transistor 
einzustellen.

mfG

von David S. (david_s916)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antworten.

Ich habe die fehlende Rückkopplung in der Simulation eingefügt. Damit 
bin ich zumindest so weit gekommen, dass sich Simulation und Schaltung 
nun gleich verhalten: beide schwingen nicht.
Ich habe die Schaltung auch durch Parameteränderungen nicht zum 
Schwingen gebracht. Stattdessen bin ich zu einer anderen Schaltung 
übergegangen (Tieze-Schenk statt Internet) bei der die «Anzapfung» nicht 
auf Masse sondern auf positive Spannung gelegt wird (siehe Anhang).
Damit konnte ich Schwingungen sowohl in der Software als auch auf dem 
Steckbrett erreichen.
Damit würde ich mich vorerst zufrieden geben. Allerdings habe ich die 
Bauteile lediglich empirisch eingestellt und weiss nicht wie/ nach 
welchen Kriterien diese zu optimieren sind. Falls da noch jemand einen 
Tipp hat wäre ich dankbar.

von Peter R. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Zunächst: beim Hartley Oszillator sollte die Anzapfung  mindestens bei 
1:3 der Induktivitäten sein, schließlich ist der Ausgangswiderstand des 
Ts wesentlich größer als der Eingangswiderstand. Das 1:1 der beiden 
Induktivitäten hier ist sicher nicht sinnvoll. grob gesagt: Die 
Rückkopplung ist viel zu stark, da wird der Ts extrem in die Begrenzung 
getrieben. Deshalb auch die komischen Zacken im Spannungsverlauf anstatt 
einer Sinusform.

Wenn 1/4 der HF-spannung an der Basis und 3/4 am Kollektor anliegen ist 
das schon die Grenze. ist das Ganze kein Sinusoszillator sondern ein 
Kippschwinger. also müsste L1 mindestens dreimal so groß sein als L2.

Der R1 ist mit 1kOhm eine starke Belastung des Schwingkreises, Bei dem 
Emitterstrom von ca. 2,5mA  (ca.4,4V an R4) ist doch ein Basisstrom von 
nicht mehr als 0,1mA ausreichend. 10kOhm als R4 wären meiner Meinung 
ausreichend.

Auch C2 würde ich etwas größer machen (nF)

überschlägig habe ich 24MHz als Schwingfrequenz ausgerechnet (47pf, 
0,9µH)
Bei solch einer Frequenz hat ein Steckbrettaufbau mit dem Schaltbild, 
das die Simulation durchrechnet, nur noch wenig Gemeinsamkeit.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.