Forum: Mikrocontroller und Digitale Elektronik benötige Hilfe bei der Suche eines Linereceivers


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich möchte digitale Signale die zwischen einem Controller und 
einem Galvo-System (Spiegelreflexionssystem für Laseranwednungen) 
gesendet werden abgreifen und mitlesen. Laut dem Protokoll, gibt es für 
jede Datenleitung eine positive und eine negative (invertierte) Leitung 
mit einer 120 Ohm Impedanz. Über die Spannungspegel wird nichts erwähnt. 
Rein aus dem Bauch heraus würde ich sagen, dass ich hier mit einem 
RS422/485 Linereceiver die Signale auf TTL Level bekommen würde. Dazu 
habe ich aber vorerst Messungen mit dem Oszi gemacht. Dabei bin ich wie 
folgt vorgegangen. Ich habe die positive Leitung in ein Kanal des Oszis 
gesteckt und die negative Leitung in ein weiteres separates Oszi Kanal. 
MIt diesem Messaufbau habe ich bei beiden Kanälen Spannungen im Bereich 
0..30V gemessen. Wobei die Signale sehr verrauscht waren. Wenn ich beide 
Kanäle voneinander Subtrahiert habe, habe ich Spannungen im Bereich von 
-30..30V bekommen. Die Messergebnisse haben mich nun sehr verunsichert. 
Ich wüsste jetzt nicht welches Interface solch ein riesigen 
Spannungsbereich auf TTL Level redzuzieren könnte. Außerdem frage ich 
mich, ob mein Messaufbau so korrekt ist, oder ich vielleicht etwas 
wichtiges übersehen habe. Ich hoffe ihr könnt mich ein bisschen 
aufklären...

: Verschoben durch Admin
von Analog OPA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hört sich schwer nach einem Abschlussproblem an. Bei 422 kann man 
durchaus +/-24V messen. Wahrscheinlich hast Du noch ein paar Impedanzen 
mitgemessen.

von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> Hört sich schwer nach

... hier schon mal anderweitg durchgekaut an?

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Analog OPA schrieb:
> Hört sich schwer nach einem Abschlussproblem an. Bei 422 kann man
> durchaus +/-24V messen. Wahrscheinlich hast Du noch ein paar Impedanzen
> mitgemessen.

Das sind Signale mit einer Frequenz von 2MHz. Ist das bei solch einer 
Frequenz möglich, dass Impedanzen entstehen? Und wenn ja, wie kann ich 
sie unterdrücken, sodass ich die eigentliche Datenübertragung nicht 
störe?

Und vielen Dank für deine Antwort :)

von Purzel H. (hacky)


Bewertung
0 lesenswert
nicht lesenswert
Bei 2MHz sollte ein Abschlusswiderstand von 120 Ohm am Ende drin sein. 
Zeig doch mal ein paar Bilder. zB mit dem Oszilloskop.

von Christoph db1uq K. (christoph_kessler)


Bewertung
0 lesenswert
nicht lesenswert
Sind die Störungen wirklich breitbandiges Rauschen oder ist das einfach 
übrlagerter Netzbrumm?

von Tom K. (ez81)


Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.