mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Spannung filtern, wie macht man es richtig?


Autor: Gustl Buheitel (-gb-)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe eine Platine die mit 5V versorgt wird aus so einem "Wandwarze" 
Netzteil. Und darauf habe ich dann einen 3,3V LDO und noch einen DCDC 
Wandler (TMR 6-0521) nach +-5V für den galvanisch getrennten Bereich.

Tja und das rauscht ganz fürchterlich. Ich weiß aber auch nicht wie man 
das genau mit dem Oszi misst. Wenn ich an dem Oszi nichts angeschlossen 
habe, also den 1:1 "Tastkopf" offen liegen habe, dann habe ich auch 
massig Rauschen, sogar mehr als wenn das angeschlossen ist.

Einmal ist scope_12 das Rauschen hinter dem DCDC Wandler. Ich habe aber 
schon versucht das zu filtern. Der Ausgang vom Wandler geht in eine 22uH 
Spule, dann über dicke Elkos und dann noch durch Ferritperlen. Im 
Datenblatt des DCDC Wandlers steht was von maximal 50 mVp-p. Mein 
Rauschen ist aber sehr viel schlechter, wieso? Was macht, dass das mehr 
wird? Ich habe da bisher nur das passive Zeug bestückt und sonst noch 
nichts.

Scope_13 zeigt das 3,3V Netz. Das rauscht auch stark obwohl auch da 
dicke Kondensatoren drinnen sitzen. Ich tippe ja auch einen Messfehler, 
weiß aber auch nicht wie man das richtig misst. Das Oszi hängt ja an der 
Steckdose, aber die Platine ist über ihre Stromversorgung nicht geerdet, 
das ist sie erst, wenn ich die mit dem Tastkopf anfasse.

Autor: OS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der DC/DC Wandler braucht keine Kondensatoren direkt am Ausgang ?
Das sollte im Datenblatt oder den Applikations Hinweisen drin stehen.
Das zweite Bild vom Oszi bekommst Du vermutlich auch wenn Du die 
Masseklemme mit der Tastspitze verbindest.
Deshalb nicht die Masseklemme vom Tastkopf verwenden, sondern direkt den 
Tastkopf mit der Masse verbinden, dazu ist Normalerweise eine 
Kontaktfeder beim Tastkopf dabei.

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OS schrieb:
> Der DC/DC Wandler braucht keine Kondensatoren direkt am Ausgang ?

Aber er sollte damit klar kommen. Im Datenblatt steht dazu
Capacitive load ±5 VDC / ±12 VDC output models:
2000 μF max. / 900 μF max. (each output)
https://assets.tracopower.com/20180213154502/TMR6/...

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier gibt es Dokumente:

https://us.tracopower.com/products/browse-by-categ...

Ok, die hatte ich nicht gelesen. Also am Eingang habe ich keine Spule. 
Aber auch in den Dokumenten tmr6-emi-consideration.pdf ist am Ausgang 
kein Kondensator. Sollte ich diese also weglassen?

Ich habe da dicke Kondensatoren eingebaut, weil ich auf der Platine 
viele Relais verbaue und die brauchen Strom beim Schalten. Und ich 
dachte, dass mehr Kondensatoren das Rauschen eben nicht schlimmer 
machen.

Autor: Michael Bertrandt (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Mein Rauschen ist aber sehr viel schlechter, wieso?

Vielleicht misst dein Tastkopf durch die Leitung zur Masseklemme die 
Störstrahlung des Magnetfelds des Wandlers mit ?

Gustl B. schrieb:
> Ich habe da dicke Kondensatoren eingebaut, weil ich auf der Platine
> viele Relais verbaue und die brauchen Strom beim Schalten.

Ein Relais ist völlig unproblematisch denn es IST eine Spule: Der Strom 
steigt nach dem Einschalten langsam, das kann jeder Spannungsregkler 
problemlos ausregeln. Schlimmer ist das Ausschalten, das aber mit einer 
Freilaufdiode begrenzt sein sollte. Da reagiert der Regler nur auf den 
ausbleibenden Stromverbraucher, rauschen iust das auch nicht, sondern 
ein overshoot.

> Und ich dachte, dass mehr Kondensatoren das Rauschen eben nicht
> schlimmer machen.

Grosse Kondenstaoren nützen zumidnest nichts bei hohen Frequenzen.

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Schlimmer ist das Ausschalten, das aber mit einer
> Freilaufdiode begrenzt sein sollte.

Wieder was gelernt.

Michael B. schrieb:
> Vielleicht misst dein Tastkopf durch die Leitung zur Masseklemme die
> Störstrahlung des Magnetfelds des Wandlers mit ?

Mein "Tastkopf" ist ein Koax Kabel das ich auf die Platine gelötet habe. 
Innenleiter auf die +5V und Schirm auf Masse. Eben weil ich da schlecht 
mit dieser Korokoklemme hinkomme.

Michael B. schrieb:
> Grosse Kondenstaoren nützen zumidnest nichts bei hohen Frequenzen.

Ja, aber stören sollten sie auch nicht.

Autor: Possetitjel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:

> Ich habe da dicke Kondensatoren eingebaut, weil ich
> auf der Platine viele Relais verbaue und die brauchen
> Strom beim Schalten.

???

Und wieso stören sich die Relais an der unsauberen
Spannung?


> Und ich dachte, dass mehr Kondensatoren das Rauschen
> eben nicht schlimmer machen.

Das ist kein Rauschen. Wirklich nicht.

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Und wieso stören sich die Relais an der unsauberen
> Spannung?

Hatte ich nicht behauptet. Aber mit mehr C belasten sie den DCDC Wandler 
nicht so stark.

Possetitjel schrieb:
> Das ist kein Rauschen. Wirklich nicht.

Ja, ist es nicht, ist eigentlich ein fast sauberer Ton.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
denke du solltest hier mal Spulen im hohen mH Bereich verwenden.

10-100µH verwende ich bei kleinen µC-Schaltungen.

Versuche mal die Frequenz in LTSpice o.ä. nachzubilden und teste 
dahinter dein LC-Filter ob es schon ausreichend früh einsetzt.

Autor: Possetitjel (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Gustl B. schrieb:

> Possetitjel schrieb:
>> Und wieso stören sich die Relais an der unsauberen
>> Spannung?
>
> Hatte ich nicht behauptet.

Naja, dann verstehe ich Deine Frage nicht. Wenn es nicht
stört -- warum willst Du es dann filtern?


> Aber mit mehr C belasten sie den DCDC Wandler nicht
> so stark.

???

Wer? Die Relais? -- Die belasten im großen und ganzen immer
gleich stark.


> Possetitjel schrieb:
>> Das ist kein Rauschen. Wirklich nicht.
>
> Ja, ist es nicht, ist eigentlich ein fast sauberer Ton.

Ja :)

Ich gebe -- auch wenn der Eindruck ein anderer ist -- nicht
so besonders gern den Krümelkacker vom Dienst. Ein spektral
fast reines Störsignal erfordert nun mal andere Maßnahmen als
echtes Rauschen. Deswegen stört mich der Etikettenschwindel...

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Naja, dann verstehe ich Deine Frage nicht. Wenn es nicht
> stört -- warum willst Du es dann filtern?

Weil da nicht nur Relais drauf sitzen, sondern auch ein ADC.

Possetitjel schrieb:
> Wer? Die Relais? -- Die belasten im großen und ganzen immer
> gleich stark.

Ja, aber wenn da viel C in der Nähe ist, bricht die Spannung nicht so 
weit ein. Zum Schalten brauchen die 40mA@5V für 500us, das ist nicht 
sonderlich viel und kann aus den Cs kommen.

So, habe jetzt mal weiter bestückt (viele kleine Cs) und dieser Ton ist 
weg. Oder vielleicht kann ich den nur nichtmehr so messen. Habe jetzt 
zum richtigen Tastkopf 10:1 von Agilent gewechselt. Jetzt ist es ein 
Rauschen mit so 40 mV p-p in dem man das Schalten des DCDC Wandlers 
sehen kann.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Wenn ich an dem Oszi nichts angeschlossen
> habe, also den 1:1 "Tastkopf" offen liegen habe, dann habe ich auch
> massig Rauschen, sogar mehr als wenn das angeschlossen ist.

Antenne. Offen, also hochohmig, fängst du alles ein, was der Äther 
bietet. Geh damit mal in die Nähe einer Leuchtstoffröhre.

Autor: Jürgen Wissenwasser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Problem sind die gewählten Kondensatoren:
Du willst eine saubere Ausgangsspannung, hast aber faktisch nur Elkos 
(oder Tantal?) verbaut, die einen hohen ESR und v.a. ESL (beim Elko) 
haben. Gemäß deinem ersten Oszi-Bild taktet das Ding mit >600kHz - da 
kannst Du mit Elkos/Tantal-Kos nix ausrichten.


Deine Drossel hat 22uH und bei 14MHz Eigenresonanz - ist also mal ok.
Die Kondensatorbank muß umgebaut werden:
* (optional) 100nF direkt hinter die Drossel (HF zuerst blocken)
* Danach 10uF - Achtung: Klasse II-Dielektrika wie X7R oder X5R
    verlieren mit Bias-Spannung schnell an Kapazität,
    daher mind. 10V-Rating
* Evtl. ein zweiter MLCC mit 10uF.
* Dahinter kann man dann 2x100uF Elkos/Ta-Kos setzen. Das sollte 
reichen.


Die Ferrit-Beads sind an der Stelle unnötig - das gehört auf die Seite 
des Geräts, das Du damit versorgen willst.

Wichtig: Ausmessen unter verschiedenen Lastbedingungen!

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, Danke! Wie kann man sowas denn vorher simulieren? Ich meine ja mit 
Multisim kann ich einen Bode-Plot machen, und der zeit dann auch, dass 
es ab der Grenzfrequenz stark nach unten geht, aber so wirklich nah an 
der Realität ist das eben nicht. Da kann ich die Grenzfrequenz auch 
selber ausrechnen.
Simuliert man sowas überhaupt oder probiert man es auf einer Testplatine 
aus?

Habe jetzt die 470uF rausgenommen und noch zwei 10uF Keramik parallel 
eingebaut. Das Ergebnis ist deutlich besser.

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, irgendwie bin ich entweder sehr dumm oder habe zu wenig Erfahrung. 
Jedenfalls ist es so, dass dieser Ton vom Schaltregler auch dann vom 
Oszi gemessen wird, wenn ich den Masse Clip und die Spitze vom Tastkopf 
an genau den gleichen Kontakt auf der Platine halte. Und zwar ganz egal 
wo genau. Also ich beiße mit dem Clip in die Spitze und gehe damit dann 
an einen beliebigen Punkt und sehe das Signal etwas unter 1MHz. Woran 
liegt das?
Ich dachte zuerst das läge am Netzteil weil das nicht geerdet ist, aber 
mit einem geerdeten Labornetzteil das mit dem Oszi an der gleichen 
Steckdosenleiste hängt ist es nicht besser.
Dann dachte ich das ist eben eine Antenne der Tastkopf und habe den nur 
knapp über die Platine gehalten (wieder Clip und Spitze verbunden), aber 
da war nichts zu sehen.
So langsam bin ich ratlos weil es nichts bringt etwas zu jagen was man 
nicht versteht.

Vielen Dank!

Autor: MiWi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Hallo,
>

> Tja und das rauscht ganz fürchterlich. Ich weiß aber auch nicht wie man
> das genau mit dem Oszi misst. Wenn ich an dem Oszi nichts angeschlossen
> habe, also den 1:1 "Tastkopf" offen liegen habe, dann habe ich auch
> massig Rauschen, sogar mehr als wenn das angeschlossen ist.


Das was noch fehlt ist ein Foto vom Messaufbau. Hast Du mit der Feder 
oder mit dem Masseklips gemessen?

Und das mit dem 1:1 an 1Mohm Oszieingan vergiß gaaaaaaaaanz schnell. 
Wenn Du hf mit 1:1 messen willst dann mit 50Ohm und den dazugehörendem 
Aufbau.

So wie die Bilder aussehen sind das nur Artefakte die vom mehr als 
fehlerhaften Messaufbau stammen.

Suche einmal im www nach "wie messe ich mit einem Tastkopf" und wende 
das an, zb. Youtube-Video "Wie arbeite ich mit einem Oszilloskop? Teil 2 - Der passive Tastkopf" oder suche nach 
ABCprobes_s.pdf von Tektronix (zb. 
web.mit.edu/6.101/www/reference/ABCprobes_s.pdf), nach dem Lesen, 
Verstehen und Anwenden sollten Deine Messungen dann korrekt sein.

Viel Erfolg


MiWi

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Link zum PDF. Ja also ich gehe mit dem Keysight Tastkopf 
10:1 an einen beliebigen Kontakt und habe dabei den Clip mit der Spitze 
verbunden. So eine Feder besitze ich nicht, die wurde nicht 
mitgeliefert. Aber gut, kann ich bauen. Das Rauschen ist relativ 
niedrig, so 50mVpp aber ich habe das Schaltsignal von DCDC Regler laut 
drinnen, also alle ca. 1,5 us habe ich 200mVpp ein kurzes Klingeln.

Autor: MiWi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Danke für den Link zum PDF. Ja also ich gehe mit dem Keysight Tastkopf
> 10:1 an einen beliebigen Kontakt und habe dabei den Clip mit der Spitze
> verbunden. So eine Feder besitze ich nicht, die wurde nicht
> mitgeliefert. Aber gut, kann ich bauen. Das Rauschen ist relativ
> niedrig, so 50mVpp aber ich habe das Schaltsignal von DCDC Regler laut
> drinnen, also alle ca. 1,5 us habe ich 200mVpp ein kurzes Klingeln.

Die Feder läßt sich mit jeder Büroklammer nachwickeln, es ist wichtig 
das die Fläche, die von der Schleife  Tastkopfspitze <> Masseanschluß 
gebildet wird so klein(!!) wie möglich ist, denn das ist (nicht nur) 
eine Rahmenantenne , die genau das macht was ihr Name sagt: sie 
empfängt. Und das Oszi macht was es kann, es zeigt diese virtuellen 
Signale an und du wunderst Dich und fragst im Forum was da los ist...

Weiters wird bei solchen Messungen an Netzteilen normalerweise aus gutem 
Grund nicht mit der vollen Bandbreite sondern mit BW-Limit (20MHz) 
gearbeitet. Auch dazu gibt es viele Hinweise im Netz.

Wie gesagt, ein oder 2 brauchbare Fotos vom Messaufbau fehlen, denn ohne 
den ist alles weitere nur  stochern im (vermeintlichen) Erfahrungsnebel.


MiWi

Autor: Gustl Buheitel (-gb-)
Datum:
Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
So, hier Bildchen.

Oszi_BW heißt mit Bandbreitenbegrenzung und Oszi_full heißt ohne.

Mit dem neuen Tastkopf ist es in der Tat krass viel besser. Wieder was 
gelernt, danke! Ist das jetzt OK so wie es ist?

Vielleicht hätte ich da gar nicht basteln müssen und es hat von Anfang 
an schon gepasst ... männo. Aber schicker Trick mit der Tastspitze, 
kannte ich noch nicht.

Autor: MiWi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> So, hier Bildchen.
>
> Oszi_BW heißt mit Bandbreitenbegrenzung und Oszi_full heißt ohne.
>
> Mit dem neuen Tastkopf ist es in der Tat krass viel besser. Wieder was
> gelernt, danke! Ist das jetzt OK so wie es ist?

Ja, genau so macht man solche Messungen


> Vielleicht hätte ich da gar nicht basteln müssen und es hat von Anfang
> an schon gepasst ... männo.

Vermute ich auch.

> Aber schicker Trick mit der Tastspitze, kannte ich noch nicht.

Wann immer so komische Störungen da sind: Feder herauskramen oder selber 
drehen und nachmessen.

btw: Wenn Du für das Layout verantwortlich bist und Platz hast (falsch: 
sorge dafür das Platz dafür da ist): sehe kleine Löcher (große Vias oder 
so) für Tastkopfspitze und Feder in geeignetem Abstand an kritischen 
Signalen vor, dann ist`s in Zukunft leichter das zu messen: Feder drauf, 
in die Löcher stecken und am Oszi herumkurbeln.

PS: Layout sieht auf den ersten Blick auch brauchbar aus, ich würde, 
wenn es der Strom hergibt die beiden Leitungen auf Bild 5V.jpg, dort wo 
die Kerkos sitzen ein bischen einschnüren, damit wirklich alles an den 
Kerkos vorbei muß... ist aber quasi sudern auf hohem Niveau und nicht 
unbedingt nötig.

Das FPGA wird mit den 30mVpp keine Probleme haben und der LTC2225, der 
da auch auf der Platine sitzt hat hoffentlich eh seine eigene lokale 
Abblockung mit Ferrit/Kerko und sieht von den 30mV pp nix...

Wie auch immer: Gratulation zum Erkenntnisgewinn

noch einen schönen und nun auch entspannten Sonntag

MiWi

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MiWi schrieb:
> sehe kleine Löcher (große Vias oder
> so) für Tastkopfspitze und Feder in geeignetem Abstand an kritischen
> Signalen vor

Sehr gute Idee! Zumindest Testpads werde ich einplanen.

MiWi schrieb:
> Layout sieht auf den ersten Blick auch brauchbar aus, ich würde,
> wenn es der Strom hergibt die beiden Leitungen auf Bild 5V.jpg, dort wo
> die Kerkos sitzen ein bischen einschnüren

Vielen Dank!
Tja, da waren eigentlich keine Kerkos sondern SMD Elkos. Habe viel 
umgebaut weil ich irgendwie diese Störung wegbekommen wollte.

Jap, der LTC2325 sitzt auf der galvanisch getrennten Seite mit 5V_ISO. 
Der hat selber auch noch viele Kerkos um sich herum wie LTC das im 
Evalboard auch gemacht hat.

MiWi schrieb:
> Wie auch immer: Gratulation zum Erkenntnisgewinn
>
> noch einen schönen und nun auch entspannten Sonntag

Danke und ebenfalls einen schönen Tag!

: Bearbeitet durch User
Autor: MiWi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:

> Vielen Dank!
> Tja, da waren eigentlich keine Kerkos sondern SMD Elkos. Habe viel
> umgebaut weil ich irgendwie diese Störung wegbekommen wollte.

Noch eine Anmerkung: Heutzutage schalten fast alle Schaltregler so 
schnell das Elkos nur mehr die "Nf" Grundlast machen. 100u sind bei dem 
Design, das Du da liegen hast vollkommen genug (keine Lastsprünge, 
100-200mA Grundlast, ein paar LEDs, die gelegentlich schalten)

Alles andere mit mehr als 200kHz (Pi x Daumen) sollten Kerkos puffern, 
die können das deutlich besser. Und da achte auf die 
Spannungsabhängigkeit der Kapazität, wenn also Platz auf der Platine ist 
2 oder 3 10u/50V Kerkos einsetzen, selbst wenn es nur 3V3 sind, die 
gestützt werden müssen. Unmittelbar neben den Speicherdrossel auch 10n 
oder so (0603 ist ok) platzieren, damit die kapazitiv über die 
Speicherdrossel herübergekoppelten Störungen abgeleitet werden.

Wenn Du das beherzigst dann sind solche Schaltregler fast vollkommen 
unsichtbar auf den nachfolgenden Versorgungsspannungen.

Und unbedingt die Kerkodatenblätter von solchen 10u/50V Teilen anschauen 
und acht geben, das die Spannungsdreatingkurven angegeben sind... es 
wird besser aber es ist noch lange nicht üblich, das die Daten vorhanden 
sind.
Sonst verbaust Du einen 10u/6V/0603 Kerko, der dann bei 3V3 nur noch 1-2 
uF hat... auch blöd

siehe als Einstieg zu der Probelmatik 
http://pdfserv.maximintegrated.com/en/an/TUT5527.pdf


MiWi

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank erstmal.

MiWi schrieb:
> Alles andere mit mehr als 200kHz (Pi x Daumen) sollten Kerkos puffern,
> die können das deutlich besser.

Ja, wegen geringerer ESR. Aber wie ist das, wann verwendet man kleine Cs 
und wann Große? Ich meine wenn das beides Kerkos sind mit gleicher ESR, 
dann ist doch mehr C kein Nachteil oder doch? Gut es kostet mehr Platz, 
aber sonst?
Ich habe hier 100n und 10u die ich gerne beide verwende z. B. an den 
Versorgungseingängen der OPVs. Ich mache das weil ich es so gelesen 
habe. Aber wieso 100n? Klar ein 10.1u hätte eine höhere ESR wie ein 10u 
und ein 100n parallel. Aber wieso nicht zwei 5.6u parallel? Ist in etwa 
das gleiche C und sind auch zwei Kerkos also gleiches ESR wenn bei 
gleicher Bauform.
Ich frage, weil sonst könnte ich ja einfach immer große Kerkos 
verwenden. Z. B. 47u in 0805. Oder mir nur einen Typen kaufen wie 10u 
und dann den notfalls mehrmals parallel verbauen.


MiWi schrieb:
> Und da achte auf die
> Spannungsabhängigkeit der Kapazität,

Das ist mir klar, aber Danke für das PDF. Habe auf der Platine auch 
einen 16Bit DAC drauf und dahinter einen OPV von -15V bis +15V (als 
Signalgenerator um meinen ADC mit den Relais zu testen) und da habe ich 
50V Kerkos verbaut. Sonst verwende ich immer mindestens 16V Kerkos.

MiWi schrieb:
> Wenn Du das beherzigst dann sind solche Schaltregler fast vollkommen
> unsichtbar auf den nachfolgenden Versorgungsspannungen.

Das hätte ich nicht gedacht. Aber gut zu wissen. Ich mache mich so 
langsam an den Entwurf der finalen Platine. Die bekommt 12 ADC Eingänge, 
also 3x den LTC2325. Da werde ich also drei getrennte galvanisch 
getrennte Bereiche bauen mit je einem DCDC Regler. Die 6 Watt des TMR6 
brauche ich zwar nie, aber wenn man sich das Datenblatt anguckt 
http://www.mouser.com/ds/2/687/tmr6-519432.pdf dann hat der eine recht 
hohe Schaltfrequenz und wenig Ripple. Ich habe mir auch mal einen von 
Murata angeguckt, den NMH0505SC 
http://www.farnell.com/datasheets/2357330.pdf und der schaltet sehr viel 
langsamer und hat mehr Ripple. Ich werde also trotzdem den 6 Watt 
nehmen, die Schaltfrequenz von so um die 750kHz ist einfach besser 
filterbar.

Autor: Burkhard K. (buks)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Ich habe hier 100n und 10u die ich gerne beide verwende z. B. an den
> Versorgungseingängen der OPVs. Ich mache das weil ich es so gelesen
> habe.

Hi Gustl, Dich könnte evtl. Kapitel 17.5.2 aus "OpAmps for Everyone" 
(web.mit.edu/6.101/www/reference/op_amps_everyone.pdf, 3. Auflage 2002) 
interessieren.

Wichtiger Faktor bei der Auswahl von Entkopplungskondensatoren ist 
dessen jeweilige Resonanzfrequenz. Wie die Abb. 17.6 zeigt, ist die 
Impedanz eines Tantals mit Fr = 1MHz bei 100 kHz noch recht hoch, die 
eines Kerkos mit 10 nF nicht viel kleiner. Bei 600 kHz würde der Tantal 
mit ca. 1 Ohm greifen, der Kerko hat immer noch eine deutliche höhere 
Impedanz.

Gustl B. schrieb:
> So eine Feder besitze ich nicht, die wurde nicht mitgeliefert.
Sind bei Keysight-Tastköpfen eigentlich Standard - evtl. nur übersehen? 
Liegen typischerweise in dem Tütchen mit dem kleinen 
Plastikzubehörgeraffel.

Autor: Brezensalzer (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Bei einer Versorgung könnte man ein LC-Filter nehmen. Hier haben wir es 
zu tun mit ungefähr 500kHz. Ein Filter mit 5kHz Grenzfrequenz liegt um 2 
Dekaden darunter. Ein LC-Filter liefert dann satt Dämpfung.

Dazu legt man zunächst das C fest (nehmen wir mal 10µF Kerko, der kann 
auch noch 500kHz was anfangen), das führt zu einem L von:
fg = 1/(2*PI*Wurzel(LC))-> L=1/(4*PI²*f²*C) = 101µH

D.h. Mit 100µH und 10µF (oder irgenwas in dem Bereich) wird das klappen. 
Mit 10µH vielleicht auch noch.

Vorsicht mit LC-Filtern in der Versorgung: Hier sollte man die Güte im 
Auge behalten. Q=(1/R)*Wurzel(L/C) sollte sich im Idealfall um 1 
bewegen. Oder man kuckt sich das bei allen Betriebsfällen an, ob da eh 
nix hüpft.

Wer hier nicht drauf schaut, jagt seine Schaltung beim ersten Lastsprung 
durch den Kamin. Ich würde eher weniger Dämpfung für mehr Sicherheit 
nehmen.

Im Idealfall legt man sich erst einmal fest, wie sauber es sein muss, 
und filtert nur soviel wie möglich. Weil, wenn du ein Relais steuerst, 
dann interessiert ein bisserle Rippel nicht soviel. Ich täte dann gar 
nichts filtern.

Wie immer gilt:
Bauchgefühl, Viel hilft viel und Bauernregeln sind ein Merkmal 
schlechter Elektroniker.

Autor: Hühnerfutter (Gast)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Hallo Gustl,

ich habe auch noch etwas für Dich. Für das Dokument wurde einiges 
ausprobiert, und man kann freilich auch z.B. mit um einiges höheren 
Induktivitäten arbeiten, und/oder verschiedene Methoden kombinieren 
(z.B. CLC-Filter mit Low-Noise-Spannungsregler danach - das hatten wir 
vor einigen Jahren mal versucht, imho sehr erfolgreich).

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Burkhard K. schrieb:
> Hi Gustl, Dich könnte evtl. Kapitel 17.5.2 aus "OpAmps for Everyone"
> (web.mit.edu/6.101/www/reference/op_amps_everyone.pdf, 3. Auflage 2002)
> interessieren.

Vielen Dank, werde ich mir angucken.

Burkhard K. schrieb:
> Sind bei Keysight-Tastköpfen eigentlich Standard - evtl. nur übersehen?
> Liegen typischerweise in dem Tütchen mit dem kleinen
> Plastikzubehörgeraffel.

Hm, ist schon lange her dass ich die ausgepackt habe. Mal gucken ob ich 
die noch finde.

Brezensalzer schrieb:
> D.h. Mit 100µH und 10µF (oder irgenwas in dem Bereich) wird das klappen.
> Mit 10µH vielleicht auch noch.

100uH wird aber schon groß wenn da auch noch Strom durch soll.

Brezensalzer schrieb:
> Weil, wenn du ein Relais steuerst,
> dann interessiert ein bisserle Rippel nicht soviel. Ich täte dann gar
> nichts filtern.

Also die Relais sind meistens irgendwie geschalten aber es fließt kein 
Strom durch die Spule. Die sind auf beiden Seiten latching damit ich 
eben keinen dauerhaften Stromfluss habe der stören könnte. Wenn die 
schalten darf gerne die Spannung etwas rauschen und einbrechen, zu der 
Zeit muss ich die ADC Werte sowieso wegwerfen.

Brezensalzer schrieb:
> Bauchgefühl, Viel hilft viel und Bauernregeln sind ein Merkmal
> schlechter Elektroniker.

Tja, das stimmt schon. Ist eben nicht so einfach wenn man keine Ahnung 
hat und auch wenig Erfahrung in dem Gebiet. Da muss ich wohl durch.

Autor: Gustl Buheitel (-gb-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Hühnerfutter:

Vielen Dank! Das ist tatsächlich sehr interessant.

Autor: Spannungsteiler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Hm, irgendwie bin ich entweder sehr dumm oder habe zu wenig Erfahrung.
> Jedenfalls ist es so, dass dieser Ton vom Schaltregler auch dann vom
> Oszi gemessen wird, wenn ich den Masse Clip und die Spitze vom Tastkopf
> an genau den gleichen Kontakt auf der Platine halte. Und zwar ganz egal
> wo genau.

Hi Gustl!
In der Absicht, Dir noch mehr nützliche Informationen zu deinem
Verständnis zuzusteuern, verlinke ich dieses Thema;
Beitrag "Passlab Clone Aleph M(J) Störungen am Ausgang"

Insbesondere die dort vorkommene Links sind sehr interessant!

Es handelt sich zwar bei mir um ein anderes Thema wie bei Dir, aber
die Natur des Problems sind die gemessene Hochfrequente Störsignale,
die mangels Wissen sehr nebulös erscheinen!

Ich wünsche Dir gutes Vorankommen!!

MfG!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.