Forum: Analoge Elektronik und Schaltungstechnik Generator als BLDC Motor


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Marcel K. (sunny198828)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schönen guten Tag,


Ich habe das Thema mal wieder aufgefasst.

Hier ist der alte Thread.

Beitrag "BLDC Motor mit MC33035"

Habe die sensoren jetzt wie im Bild eingezeichnet eingeklebt.
Strom auf den Rotor gegeben und per hand gedreht.
Schitt, Sensoren sind auf 60° und nicht wie gedacht auf 120°.
Denn es gibt einen zustand wo alle 3 Led's Aktiv sind. Laut Tabelle
müsste das Position 1 sein , denn bei 120° gibt es diesen zustand nicht.

Habe es trozdem mal mit einem Atmega48 und AVR447 Probiert.
Komischerweiße Läuft das aber ebend nicht auf der Position 1 wenn der
Rotor da steht Läuft der Motor/Generator garnicht an, da muss ich dann
nachhelfen.

Aber Kraft hat er Trozdem und der Motor Läuft auch ohne knurren. Schön
ruihg bis auf die schrottigen quitschenden Lager (nach 7 jahren im
keller). :-P
Wer kann mir sagen wie ich die sensoren einkleben muss das ich auf 120°
bin.

oder eben den AVR447 code auf 60° umschreiben aber von IAR habe ich 
keine Ahnung. Den MC33035 möchte ich eigentlich nicht mehr nutzen da der 
kein Sinus kann.
mfg

PS: Ich hoffe ihr versteht was ich meine

: Verschoben durch Moderator
von illegal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Marcel K. schrieb:
> Wer kann mir sagen wie ich die sensoren einkleben muss das ich auf 120°
> bin.

Eine ganze mechanische Umdrehung ist in mehrere elektrische unterteilt.
Die Polpaarzahl gibt dir den Zusammenhang. Auf einer elektrischen 
Umdrehung müssen die Hallsensoren in 120° Versatz hin.

In wievielen Positionen lässt sich der Rotor beim Bestromen von Rotor 
und sagen wir mal U-V einrasten?

Ist ein Pol des Rotors an einer Stelle breiter als die 3 Sensoren 
nebeneinander?

von Marcel K. (sunny198828)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin Rotor rastet 6 mal pro umdrehung.

Hmm das mit den Polen vom Rotor, da habe ich noch garnicht drüber 
nachgedacht! Ja könnte sein das die breiter sind.

Das heißt die Sensoren weiter auseinander und mein Problem müsste gelöst 
sein oder ?

Jetzt momentan sind die Sensoren 20° ausenander. Also mechanisch auf dem 
Stator gesehen. Kann ich die nicht einfach 120° mechanisch einsetzten ?

mfg

von Marcel K. (sunny198828)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
irgendwie kann man nachträglich keine Bilder hochladen ...

so ähnlich sieht der Rotor aus. ( nur verpeckter ... hab grad keine lust 
den Generator zu zerlegen.)Die sensoren sind am äußersten rand vom 
Stator.

shit jetzt ist das Bild dreimal da ...

: Bearbeitet durch User
von Volker B. (Firma: L-E-A) (vobs)


Bewertung
0 lesenswert
nicht lesenswert
Marcel K. schrieb:

> so ähnlich sieht der Rotor aus. ( nur verpeckter ... hab grad keine lust
> den Generator zu zerlegen.)Die sensoren sind am äußersten rand vom
> Stator.

...und dann fällt Dir nichts auf, wenn Du Dir den Klauenpolläufer 
anguckst?
Hinweis: Wie breit ist den ein Pol? Sollen die Pole nicht die selbe 
Breite haben, wenn man sie als Lagegebermagnet "missbraucht"? Wo müsste 
man dann die Sensoren montieren, damit sie Pole gleicher Breite "sehen"?

Grüßle
Volker.

von Marcel K. (sunny198828)


Bewertung
0 lesenswert
nicht lesenswert
Hi,
hmm da stehe ich jetzt wirklich auf dem schlauch ... Den Hallsensor B 
eventuell auf die gegenüberliegende seite ?

Edit: Habe mir das nochmal angeschaut und überlegt. Die Lösung ist doch 
relativ simpel. Die Senoren müssen einfach in die mitte des Stators, 
denn da sind die Klauen ja alle gleich breit.

Danke Volker ohne diesen Tipp währe ich nicht auf diese einfache Lösung 
gekommen.

mfg

: Bearbeitet durch User
von Ostpol (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volker B. schrieb:
> Sollen die Pole nicht die selbe
> Breite haben, wenn man sie als Lagegebermagnet "missbraucht"? Wo müsste
> man dann die Sensoren montieren, damit sie Pole gleicher Breite "sehen"?

Ok, das hast Du nicht verstanden. Frage anders gestellt:

Auf welcher Höhe wären die (3eckigen, gewechselt angeordneten)
Pole alle gleich breit?

von Marcel K. (sunny198828)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Na in der mitte wenn man von der seite auf den Rotor schaut.

Habe das mal eingezeichnet. Oder liege ich da voll daneben ?

Eigentlich doch nicht.

: Bearbeitet durch User
von illegal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Soweit richtig.

Ein weiteres Problem ist aber, dass der Stator auch ein Magnetfeld 
erzeugt. Das sorgt dafür, dass die Sensoren nicht nur den Rotor "sehen". 
Sind deine Sensoren nur einseitig sensitiv?

Daher wird bei PC-Lüftern z.B. das Streufeld zur Sensorik benutzt.

Ein weiterer Weg wäre ein Winkelsensor oder ein Resolver...

von Marcel K. (sunny198828)


Bewertung
0 lesenswert
nicht lesenswert
Nutze TLE4935 die sollen ja nur auf einer seite sensitiv sein.

Der Generator lief ja auch schon mit den sensoren. Ich werde die jetzt 
mal mittig hin setzten und dann nochmal Testen.

mfg

von illegal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gibt es bereits Erfolge?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.