mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FF-Schaltungs Lösung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessante FF-Schaltung?!
https://www.arduinoforum.de/attachment.php?aid=3013

Hat Einer auf diese Artr schon mal eine FF-Lösung gemacht,die Älteren?
Wurde diese Art schon mal veröffentlicht?

Autor: Peter D. (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Wurde diese Art schon mal veröffentlicht?

Ja, sehr oft.
Ich hab sie zu DDR-Zeiten mit dem V40098 (HEF40098) aufgebaut für 3 
Taster.

Der TTL 7404 in der Schaltung ist allerdings ungeeignet. Man muß einen 
CMOS 74HC04 nehmen.

Autor: Feldkurat K. (feldkurat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter D. schrieb:
> Der TTL 7404 in der Schaltung ist allerdings ungeeignet. Man muß einen
> CMOS 74HC04 nehmen.

Das muß man NICHT, wie Du in der angefügten Zeichnung sehen kannst. Der 
Urheber wird sicher nicht zum Ziel gehabt haben, funktionsunfähige 
Zeichnungen unters Volk zu bringen. Darüber hinaus habe ich selbst dise 
Schaltung mehrfach mit D104, der dem 7404 entspricht funktionsfähig 
aufgebaut. Merke: Es gibt auch noch andere Leute auf der Welt, die sich 
mit Elektronik beschäftigen.

Nur mal so als Anmerkung.

Autor: Karl B. (gustav)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
wieso unbedingt SN7404-Hex-Inverter? Vier davon bleiben doch unbenutzt.
Warum nicht zwei Pufferstufen diskret aufbauen?

ciao
gustav

Autor: Peter D. (peda)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Feldkurat K. schrieb:
> Darüber hinaus habe ich selbst dise
> Schaltung mehrfach mit D104, der dem 7404 entspricht funktionsfähig
> aufgebaut.

Dann hast Du aber den Widerstand anders dimensioniert. Ein 4,7k kann 
niemals ein Standard-TTL mit 1,6mA Eingangsstrom auf low halten.
4,7k * 1,6mA = 7,5V

Autor: Karl B. (gustav)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
der HC hat drei Stufen hintereinandergeschaltet.
(Die Logik-Pegel sind stärker von Vcc abhängig. Wie immer bei CMOS.)

ciao
gustav

Autor: Michael B. (laberkopp)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Hat Einer auf diese Artr schon mal eine FF-Lösung gemacht,die Älteren?

Hoffentlich nicht, das sieht ja schon mal so richtig Scheisse aus.

Standard-TTL mit 100k, funktioniert nie und nimmer, das muss schon CMOS 
74HC04 sein.

Feldkurat K. schrieb:
> Der Urheber wird sicher nicht zum Ziel gehabt haben, funktionsunfähige
> Zeichnungen unters Volk zu bringen. Darüber hinaus habe ich selbst dise
> Schaltung mehrfach mit D104, der dem 7404 entspricht funktionsfähig
> aufgebaut. Merke: Es gibt auch noch andere Leute auf der Welt, die sich
> mit Elektronik beschäftigen.

Der Urheber bist wohl du. Sie funktioniert in der Dimensionierung nicht, 
siehe

https://streamable.com/qfj7u

> Wurde diese Art schon mal veröffentlicht?

Die Toggle-Schaltung mit Taster ist normal, funktioniert aber nur mit 
CMOS.

Die H-Brücke geht höchstens als Prinzipschaltung durch, es fehlen für 
die induktive Last Freilaufdioden, und die Elkoankopplung produziert 
negative Spannungen am Eingang die nicht abgeführt werden.

Und warum man unbedingt 4A Transistoren verwenden muss mit hFE von 20 
bei 18mA Basisstrom, ist schleierhaft, so kann die Spule seriös nur 
360mA bekommen.

Die Schaltung hat also Arduino-Level: Von Laien ohne Plan.

Autor: Al. K. (alterknacker)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Michael B. schrieb:
> Arduino-Level:

Wer sich so über Andere erhebt, kann nicht besser sein!

Autor: Thomas E. (picalic)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Michael B. schrieb:
> Standard-TTL mit 100k, funktioniert nie und nimmer, das muss schon CMOS
> 74HC04 sein.

und

Michael B. schrieb:
> Die Toggle-Schaltung mit Taster ist normal, funktioniert aber nur mit
> CMOS.

Offenbar hast Du das Funktionsprinzip nicht verstanden! Der 100k hat 
nicht die Aufgabe, den Eingangspegel am Logikgate irgendwo hin zu 
ziehen, und das Prinzip ist auch nicht an CMOS-Technik gebunden. 
Freilich ist der 4,7k Widerstand für Standard-TTL zu groß - mit einem 1k 
sollte es aber gehen.
LS-TTL und 4,7k wäre auch ok. CMOS ist wie gesagt nicht notwendig.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas E. schrieb:
> Offenbar hast Du das Funktionsprinzip nicht verstanden!

Thomas, zu spät aufgestanden ?
Das Thema ist durch !
Wie von peda vermutet, zeigt mein Aufbau, daß die Schaltung in der 
Dimensionierung NICHT funktioniert.

Thomas E. schrieb:
> Freilich ist der 4,7k Widerstand für Standard-TTL zu groß - mit einem 1k
> sollte es aber gehen.

Vielleicht. Sicher geht TTL mit 470R.

Thomas E. schrieb:
> LS-TTL und 4,7k wäre auch ok. CMOS ist wie gesagt nicht notwendig.

Möchte ich beweifen, habe aber kein LS04 da, und auch keine Lust, jetzt 
dem hundersten "da wir gescheitert sind den Schwachsinn erfolgreich 
unters Volk zu bringen ändern wir die Ausgangsbedingungen Schritt für 
Schritt etwas ab" hinterherzulaufen. Perpetuum Mobiles funktionieren 
auch, man hätte nur den Aufbau etwas anders machen müssen.

Autor: Thomas E. (picalic)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Thomas, zu spät aufgestanden ?
> Das Thema ist durch !
> Wie von peda vermutet, zeigt mein Aufbau, daß die Schaltung in der
> Dimensionierung NICHT funktioniert.

Das Thema waren aber nicht meine Schlafgewohnheiten oder ein falsch 
dimensionierter Widerstand, sondern Deine Aussage, daß es mit dem 100k 
Widerstand und TTL angeblich nie und nimmer funktionieren kann, und daß 
es CMOS-Technik sein muss, offenbar wegen dem 100k Widerstand. Den 
4,7kOhm-Widerstand hast Du nicht mal erwähnt!

Michael B. schrieb:
> Vielleicht. Sicher geht TTL mit 470R.

Also geht es jetzt doch mit TTL (und 100k!) - demnach hast Du das 
Funktionsprinzip jetzt verstanden? Na, prima, Glückwunsch!

Mag sein, daß 1k bei Standard-TTL und 4k7 bei LS für eine zuverlässige 
Funktion noch etwas zu hoch ist - das ist aber eben nur eine Frage der 
Dimensionierung und nicht eine Frage der grundsätzlichen Funktion.
Daß Perpetuum Mobiles tatsächlich funktionieren, darf aber im Gegensatz 
dazu ernsthaft bezweifelt werden, egal, was man an deren Aufbau auch 
verändert.

Autor: Thomas E. (picalic)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Möchte ich beweifen, habe aber kein LS04 da

Hab's gerade mal spontan ausprobiert:
Ein ST 74LS04 gibt bei mir noch eindeutig High-Pegel (>2,4V) aus, wenn 
der Eingang über einen 8,2 kOhm Pull-Down nach GND gezogen wird. Am 
Eingang liegt dann ungefähr 1V an. Mit 4,7kOhm hat man also gute 
Chancen, daß es funktioniert.

Ein TI SN7404N hat mit 2,2kOhm Pull-Down noch High ausgegeben. Hier 
sollte 1k also i.d.R. auch gehen.

: Bearbeitet durch User
Autor: Michael B. (laberkopp)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Thomas E. schrieb:
> Ein TI SN7404N hat mit 2,2kOhm Pull-Down noch High ausgegeben.

Reih' dich gleich ein in diesen Thread,

Beitrag "Power-Mosfet mit Logic-Level geschaltet - wie kann man die Konsequenzen messen?"

wer zu blöd ist, Datenblätter zu lesen,
sondern seine Schaltungen nach dem Verhalten EINZELNE EXEMPLARE baut,
der gehört ins (offenkundig grosse) Reich der Pfuscher.

Hättest du Grundlagen der Aussagelogik irgendwann mal verstanden, 
wüsstest du, daß zum Widerlegen EIN Beispiel reicht (meins), aber zum 
BELEGEN (deins) nicht.

Autor: Thomas E. (picalic)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Michael B. schrieb:
> Hättest du Grundlagen der Aussagelogik irgendwann mal verstanden,
> wüsstest du, daß zum Widerlegen EIN Beispiel reicht (meins), aber zum
> BELEGEN (deins) nicht.

Jedenfalls ist Dein "Standard-TTL mit 100k, funktioniert nie und 
nimmer," leicht mit einem Experiment zu widerlegen.
Was hast Du mit Deinem Experiment nun bewiesen? Daß ein Standard-TTL 
Eingang über 4,7 kOhm nicht auf Null-Pegel gezogen werden kann hätte ich 
Dir auch so sagen können - das Gestöpsel auf dem Breadboard und die 
Filmerei hättest Du Dir sparen können.
Aber statt einfach den offensichtlich falsch dimensionierten Widerstand 
gegen einen vernünftigen Wert auszutauschen und so konstruktiv zur 
Lösung beizutragen, benutzt Du das willkommene, negative Ergebnis Deines 
Experiments, um Deine (falsche) Aussage zu beweisen, daß die Schaltung 
mit TTL nicht funktioniert.

Im Übrigen habe ich nirgendwo geschrieben, daß ich mit dem kleinen Test 
irgend etwas belegen will. Wenn Du "...hat man also gute
Chancen, daß es funktioniert." als "wird es garantiert funktionieren" 
verstehst, solltest Du an Deinen Interpretationsfähigkeiten von 
geschriebenen Texten arbeiten.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.