mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mikrocontroller mit Nulldurchgangserkennung und TRIAC direkt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: PTS (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Danish (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Kann der Attiny den Einschaltautomatik von triac aufbringen?

Und warum ist da eine Batterie am Regler Ausgang?

Autor: Danish (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry Auto Korrektur.
Soll Einschaltstrom, bzw Gatestrom sein.

Autor: PTS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, müsste, 35 mA max.
Regler hängt dran, da der AVR auf einem Digispark-Klon sitzt.

Autor: PTS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zero-Crossing wird nicht registriert :-(
Aber auch kein Rauch.

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PTS schrieb:
> Zero-Crossing wird nicht registriert :-(
Woran erkennst du das? Wie sieht denn deine Detektionsstrategie genau 
aus?
Und was misst du an den Pins des uC in Bezug auf den GND des uC?

Autor: Bernhard S. (b_spitzer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mirkowellentrafo und 230V... wo soll das angeschlossen werden? Phase an 
den oberen Test-Anschluß, der Mikrowellen-Trafo an den Triac und dann??
Den Neutralleiter vom Mikrowellen-Trafo an den unteren Test-Anschluß? 
Dann liegen am Mikrocontroller 230V AC an - Wumms! Der 1MEG-Widerstand 
dürfte da kaum was helfen.

Oder hängt der Controller "in der Luft" und soll nur das Gate des Triac 
ansteuern? Male mal einen Gesamt-Schaltplan inclusive der geplanten 
Verbindungen zu 230V und dem Trafo.

: Bearbeitet durch User
Autor: Gerhard O. (gerhard_)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Falls von Interesse, hier ist ein praktisches, funktionierendes 
Beispiel einer Motor Steuerung nach NXP AN10496 Angaben aus 2008. Ich 
testete es mit einem 2KW Universal Motor.

Da keine Netztrennung vorhanden ist, alle einschlägigen Sicherheits- 
Vorkehrungen treffen und einhalten. Es besteht Lebensgefahr.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man kann auch mittels Optotriac den Haupttriac zünden und umgeht so alle 
Probleme mit Nulldurchgang und Potenzialtrennung:

http://www.onsemi.com/PowerSolutions/product.do?id=MOC3083M

Autor: PTS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Hilfsbereitschaft.

Ich habe mal Equipment rausgekramt und für sichere 30 VAC gesorgt.
Wenn das Gate nicht angeschlossen ist, funktioniert die 
Nulldurchgangserkennung vermutlich (LED am Gate-Ausgang erlischt 
planmässig kurz), d.h. dort wird der INT0 ausgelöst.
Wenn das Gate angeschlossen ist, ist der Gate-Ausgang immer High, d.h. 
er wird entweder das Gate "hochgezogen", oder die 
Nulldurchgangserkennung funktioniert nicht.

Autor: PTS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Man kann auch

Zu einfach! ;-)

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PTS schrieb:
> Könnte so gehen, oder

Fällt eher unter Prinzipschaltung, alle Sicherheitsvorkehrungen, wie 
VDR, Übertemp und Sicherungen fehlen.

Ob der Spannungsregler die Rückspeisung verträgt müsste man mit dem 
Einzelexemplar abchecken.

Autor: PTS (Gast)
Datum:
Angehängte Dateien:
  • preview image for 0.png
    0.png
    3,84 KB, 154 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Der Spannungsregler hat sich zum Glück noch nicht beschwert und wird bei 
USB-Betrieb auch "rückwärts" gespeist.

Also: die Nulldurchgangserkennung funktioniert (passabel, denke ich). 
Siehe Anhang (Bezug ist 3V+).

[bei INT0 aufpassen mit den level/edge interrupts vs. sleep mode]


Aber irgendwas passt beim Triac nicht: wenn ich den Schaltausgang mit 2 
Hz Rechteck blinken lasse, ist alles gut. Wenn ich den Ausgang über 50 
Ohm ans Gate halte, resettet der Controller.
Das passiert auch, wenn keine Wechselspannung anliegt!

Im Schaltplan stimmen die Pin-Nrn. nicht: am BTA12 ist 1 A1, 2 A2, 3 G. 
Es ist aber gemäß Symbol verbunden, d.h. A1 ist an 3V+ und G sollte 
dadurch per Mikrocontroller auf A1-3V geschaltet werden.

Wenn ich die Spannung auf 115 VAC aufdrehe und das Gate manuell mit 
Batterie-Minus verbinde, schaltet der Triac eine angeschlossene 
Glühlampe ein. Es fliessen 38 mA durchs Gate.

Hier ist der Schaltplan vom "Digispark" (D3 ist falschherum 
eingezeichnet). M.M. sollten die unbeschalteten USB-Leitungen keinen 
Einfluss haben.



Ahhrgh!
Es ist die Versorgungspannung: 3V Batterie, und mit 16 MHz getaktet, mag 
der AVR dann offenbar die 40 mA nicht.
Mit 5 V aus einem isolierten DCDC blinkt die Glühlampe einwandfrei, und 
auch der Pulsbetrieb funktioniert.

Ich melde mich evtl. nochmal mit Messungen, und ob der Triac den Trafo 
überlebt...

Autor: PTS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Triac hat einige 125 ms Pulse (+ Zeit bis zum nächsten 
Strom-Nulldurchgang) durch den MOT mit Last überlebt.
Messungen mache ich vorerst keine, genug Zeit vergeudet.

Beim Punktschweissen die Teile schön zusammenpressen, damit es 
keinen/weniger Lichtbogen bzw. Funkenflug gibt. Brandgefahr!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.