Forum: Mikrocontroller und Digitale Elektronik Voltcraft DSO-1062D hängt im Startbildschirm


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo ihr hilfreichen Helfer,
ich habe mir bei eBay für kleines Geld ein o.g. DSO gekauft.
Leider zeigt sich (lt. Anbieter nach einem Firmwareupdate)   auf dem 
Display nach dem Einschalten nur "Voltcraft DSO-1062D Digital 
Oscolloscope".
Taster leuchten zt, aber reagieren nicht.

Vielleicht haben ja ein paar User das Angebot gesehen.

Leider kann ich weder über UART noch über USB auf das Gerät zugreifen 
und bin so langsam mit meinem Latein am Ende.

Weiß hier jemand Rat?


Danke im voraus für hilfreiche Antworten.

Michael

von Harry L. (mysth)


Bewertung
-1 lesenswert
nicht lesenswert
as wird vermutlich dieses gewesen sein:
Beitrag "DSO-1062D fährt nicht mehr hoch."

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@ Harry L.: Gut möglich, aber nutzt ja nix...

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noch etwas habe ich beobachtet:
Wenn ich über UART angeschlossen bin, sind die LEDs der Taster, bis auf 
eines, aus.
Verbindung bekomme ich trotzdem nicht.

Im Gerätemanager wird, bei Anschluß über USB und Treiberinst.  "DSO 
Mesurement Divive" angezeigt. mehr nicht.

HTH

Michael

von pegel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und das Update auf Hantek Firmware über USB Stick geht auch nicht?
Die Geräte sollen ja alle die Gleichen sein.

Beitrag "Re: TEKWAY DST1xx2B Oszilloskop"

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke, aber wie sollte ich auf den Stick zugreifen wenn ich im 
Startbildschirm hängen bleibe und keine der Tasten funktioniert?

Michael

von pegel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sollte eigentlich schon beim Boot Vorgang passieren.
Probier doch mal ob es sich mit dem Stick anders verhält.

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hatte ich sogar schon mal probiert, ob ein Stick mit Firmware hilft.
Leider negativ.

von pegel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Dann bleibt wohl, sofern du weiter machen willst, nur noch JTAG.

Es ist in Grunde erst mal nur ein Linux System.
Falls der Prozessor passt, ist das vielleicht ein Startpunkt:

https://github.com/Tamagotono/Hantek_MSO5074FG_Recovery_Utility

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Merci,
ja, das glaube ich auch so langsam.

Ah, diese Seite hatte ich noch nicht gefunden, das Board sieht genau aus 
wie meines, also die "neue" Version (?) mit dem UART vorne.
Die Belegung des JTAG ist natürlich hilfreich.

Danke  sehr :)

Einen günstigen Adapter hatte ich inzw. auf der Bucht gefunden, den 
werde ich mal gleich bestellen.

Michael

von pegel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Na dann, viel Glück.

Ich habe es in der Vergangenheit tatsächlich schon ein paar mal 
geschafft über JTAG den "Bricks" neues Leben einzuhauchen.

Als es noch den guten alten Parallelport gab, waren als Adapter 
lediglich ein paar Widerstände nötig.

von Cerberus (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Da kauft sich einer Schrott für Lau, der ihn aber locker
überfordert und wir sollen die Suppe auslöffeln.
Für so was sollte man hier mal eine Spendendose einführen,
meinetwegen für Brot für die Welt.

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja, vielen Dank, bis demnächst auf diesem Bildschirm. :-)

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@pegel:
Ich habe zwar inzwischen ca. 20 Bookmarks dazu gesammelt, aber nirgends 
ist zu finden wie man unter einem Windows System ein "gebricktes" DSO 
über JTAG wieder zum Leben erweckt.


Das von dir genannte

Hantek_MSO5074FG_Recovery_Utility


ist ja nur für Linux.


Wie löst du das unter Windows?

Ich habe schon mal OpenOCD installiert und warte auf den "ST Link V2 
On-Chip Debugger".

Nochmals tausend dank für deine Hilfe!

Michael

von Gustav K. (hauwech)


Bewertung
0 lesenswert
nicht lesenswert
Michael F. schrieb:
> ich habe mir bei eBay für kleines Geld ein o.g. DSO gekauft.
> Leider zeigt sich (lt. Anbieter nach einem Firmwareupdate)   auf dem
> Display nach dem Einschalten nur "Voltcraft DSO-1062D Digital
> Oscolloscope".

Da hilft wohl nur eine teuere Reparatur.

: Bearbeitet durch User
von holger (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Ich habe schon mal OpenOCD installiert und warte auf den "ST Link V2
>On-Chip Debugger".

Der ST-Link programmiert nur Controller von ST.

von Thomas S. (doschi_)


Bewertung
0 lesenswert
nicht lesenswert
Michael F. schrieb:
..
> ist ja nur für Linux.
>
>
> Wie löst du das unter Windows?
..

Das einfachste ist wahrscheinlich, dafür einen Linux-USB-Stick zu 
erstellen.

von Michael F. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
> Der ST-Link programmiert nur Controller von ST.

Lt. Artikelbeschreibung kann der ST-Link NAND-Speicher flashen, das ist 
doch genau das was ich tun muß?

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> Michael F. schrieb:
> ..
>> ist ja nur für Linux.
>>
>>
>> Wie löst du das unter Windows?
> ..
>
> Das einfachste ist wahrscheinlich, dafür einen Linux-USB-Stick zu
> erstellen.

z.B. Knoppix

von Marc T. (bobbyhh)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich hatte das gleich Problem nach einem Update entsprechend der 
Anleitung bekommen und gefühlte 42 tausend Threads gelesen.

Im bekannten Forum 
https://www.eevblog.com/forum/testgear/hantek-tekway-dso-hack-get-200mhz-bw-for-free/?nowap 
hat der User Konsul auf Seite 120 den für mich entscheiden Link
https://www.eevblog.com/forum/repair/voltcraft-dso-1102d/msg2036896/#msg2036896
veröffentlicht.
Die dort gezeigte Lösung funktioniert! Man muss nur die UART Verbindung 
zum DSO-1062D geschafft haben (z.B. Arduino als USB-Seriel; + Putty; 
hier findet man viel im Netz) und der Anleitung folgen.

Ich hoffe, dass ich anderen Suchenden damit geholfen habe.

Gruß
Bobby

von Beobachter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vermutlich liegt das 1062 vom TO schon lange auf dem Müll.

Vermutlich braucht man nichtmal einen JTAG.
Für den Samsungprozessor gibt es einen USB-Treiber über
den man ihn vermutlich auch booten kann.

von Marc T. (bobbyhh)


Bewertung
0 lesenswert
nicht lesenswert
Hi Gast,

vermutlich hast Du recht, aber ich bin ein großer (bisher nur lesender) 
Fan dieser Seite.

Was ich zur der o.g. Lösung vergessen habe, die Lösung von Kunsul 
funktioniert mit den Linux Bordmitteln (Update-Daten entschlüsseln, 
entpacken, von einem USB-Stick ins Linux-Dateisystem kopieren und ein 
paar Befehle ausführen).

Gruß
Bobby

von Heiko J. (teknoid)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hatte selbiges Problem und hab es nach
https://www.eevblog.com/forum/repair/voltcraft-dso-1102d/msg2036896/#msg2036896 
wieder in Gang gekriegt.

Die UART Schnittstelle befindet sich direkt neben der USB Buchse:

v.l.n.r
0 1 2 3

0 3.3V
1 GND
2 RX
3 TX

Gruß
Heiko

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.