Forum: Analoge Elektronik und Schaltungstechnik LM741CN-Alternative?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Thomas ". (val1dor)


Bewertung
-1 lesenswert
nicht lesenswert
Hallo Mikrocontroller Freunde!

Ich bin sehr neu auf dem Bereich der elektronischen Bauteile und habe 
mich soeben hier im Forum angemeldet um meinen Wissenshorizont zu 
erweitern. :=)

Ich hab ein kleines Projekt mit einem Raspberry 3 das ich schon über 
Monate am Wochenende weiterentwickle. Mir wurde das oben genannte 
Bauteil LM741CN empfohlen, nur bin ich nicht sicher ob es tatsächlich 
meinen anforderungen entspricht. Hier zu den Details:

Ein IO Expander (PCF8574) erwartet einen Eingangsspannung (LOW/HIGH)
Ich habe eine Referenzspannung von 3.3V und falls meine Messspannung 
geringer als 3.3V ist soll das gesuchte Bauteil 0V ausgeben und bei über 
3.3V eben die angelegten 5V. Nun hab ich folgendes Problem, dass der 
LM741CN nur auf 4.7V hoch geht und meinen IO nicht triggert. (Ich denke 
daran liegt es). Könnt ihr mir vielleicht dabei einen Lösungsvorschlag 
nennen, das wäre echt super.

Ich habe aktuell keine negative Spannung nur 5V(Raspb) GND und meine 
Vergleichsspannung

MfG Thomas

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
Thomas ". schrieb:
> Mir wurde das oben genannte Bauteil LM741CN empfohlen

Wie alt ist dein Opa ?

Thomas ". schrieb:
> falls meine Messspannung geringer als 3.3V ist soll das gesuchte
> Bauteil 0V ausgeben und bei über 3.3V eben die angelegten 5V.

Klingt wie Komparator, nicht wie OpAmp.

Ein LM393 kann nicht über 3.5V messen wenn er mit 5V versorgt wird. 
Dafür verträgt er es, an den Eingängen (bis 32V) zu bekommen selbst wenn 
seine eigene Versorgung ausgeschaltet ist, ohne dass Querströme 
fliessen.
Keine Ahung ob das bei dir wichtig ist.

Modern und passend für 0V bis 5V Eingangsspannung (und Ausgangsspannung) 
wäre ein LMV331, aber nichts für Opas Grabbelhände.

Vorausgesetzt du hast die 3.3V irgendwo als Vergleichsspannung.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Thomas ". schrieb:
> Ich habe eine Referenzspannung von 3.3V und falls meine Messspannung
> geringer als 3.3V ist soll das gesuchte Bauteil 0V ausgeben und bei über
> 3.3V eben die angelegten 5V. Nun hab ich folgendes Problem, dass der
> LM741CN nur auf 4.7V hoch geht und meinen IO nicht triggert. (Ich denke
> daran liegt es). Könnt ihr mir vielleicht dabei einen Lösungsvorschlag
> nennen, das wäre echt super.

5V Versorgung und LM741 passen nicht zusammen. Und dass der dann am 
Ausgang 4.7V ausgibt ist höchstens Zufall bei einem einzelnen Exemplar. 
Zudem: wenn tatsächlich 4.7V ausgegeben werden, muss ein IO sicher ein 
HIGH erkennen, egal welche CMOS-Technologie der IO hat. Es sieht also 
nach mehreren Problemen aus. Welche, wäre durch eine Schaltskizze 
leichter erkennbar.

Da du nur das Über- bzw. Unterschreiten der 3.3V-Schwelle detektieren 
willst, wäre ein Komparator (z.B. LM393) die bessere Wahl.

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert

von Thomas Hager (Gast)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
haha okay, ich wusste nicht, dass es sich um ein so altes Bauteil 
handelt. Hab hier einmal eine Schaltung vom aktuellen Status. (OP27= das 
Bauteil das ich suche) Der Poti ist einfach eine Art und weise meine 
Referenzspannung für die Schaltlogik ändern zu können.

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
Thomas Hager schrieb:
> OP27= das Bauteil das ich suche

Ein OP27 funktioniert auch nicht an 5V.

Und ohne Abblockkondensatoren spielen OP27 und PCF8574 manchmal 
verrückt.

Deine ganze Bastelkiste stammt wohl vom Opa.

von Nils (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jo, der alte 741 wird das nicht machen. Mit einem Komparator wird das 
sowieso besser funktionieren als mit einem OpAmp.

Der LM311 ist ein Wald und Wiesen Komparator, billig, gutmütig und gut 
verfügbar. Der läuft auch mit 5V, kann allerdings an den Eingängen im 5V 
Betrieb nur mit Spannungen bis 3V arbeiten.

Daher sitzt vor den Eingängen jeweils ein Spannungsteiler, der die 
Signale um auf die Hälfte reduziert. 1.65V. Das ist im ganz dunkelgrünen 
Bereich.

R5 sorgt für etwas Hysterese, damit der Ausgang nicht anfängt zu 
flattern falls dein Eingangssignal so eben gerade bei 3.3V liegt. Damit 
schaltet der Comparator auf High, wenn Vin etwas über 3.3V liegt und 
wieder aus, wenn Vin etwas unter 3.3V liegt.

Pack noch einen 100nF Kondensator parallel zur Spannungsversorgung 
direkt am Chip und gut.

von Thomas ". (val1dor)


Bewertung
0 lesenswert
nicht lesenswert
Ergänzung: Die beiden Reed-Schalter sind nur zum Testen des IO_Expanders 
(diese funktionieren, über I2C)

von Thomas ". (val1dor)


Bewertung
0 lesenswert
nicht lesenswert
Ergänzung: Die beiden Reed-Schalter sind nur zum Testen des IO_Expanders 
(diese funktionieren, über I2C)

Nils schrieb:
> Jo, der alte 741 wird das nicht machen. Mit einem Komparator wird das
> sowieso besser funktionieren als mit einem OpAmp.
>
> Der LM311 ist ein Wald und Wiesen Komparator, billig, gutmütig und gut
> verfügbar. Der läuft auch mit 5V, kann allerdings an den Eingängen im 5V
> Betrieb nur mit Spannungen bis 3V arbeiten.
>
> Daher sitzt vor den Eingängen jeweils ein Spannungsteiler, der die
> Signale um auf die Hälfte reduziert. 1.65V. Das ist im ganz dunkelgrünen
> Bereich.
>
> R5 sorgt für etwas Hysterese, damit der Ausgang nicht anfängt zu
> flattern falls dein Eingangssignal so eben gerade bei 3.3V liegt. Damit
> schaltet der Comparator auf High, wenn Vin etwas über 3.3V liegt und
> wieder aus, wenn Vin etwas unter 3.3V liegt.
>
> Pack noch einen 100nF Kondensator parallel zur Spannungsversorgung
> direkt am Chip und gut.

Danke an euch Alle, werde ich mir anschauen und die Teile bestellen :=)

: Bearbeitet durch User
von Thomas ". (val1dor)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Nils schrieb:

> R5 sorgt für etwas Hysterese, damit der Ausgang nicht anfängt zu
> flattern falls dein Eingangssignal so eben gerade bei 3.3V liegt. Damit
> schaltet der Comparator auf High, wenn Vin etwas über 3.3V liegt und
> wieder aus, wenn Vin etwas unter 3.3V liegt.
>
> Pack noch einen 100nF Kondensator parallel zur Spannungsversorgung
> direkt am Chip und gut.

Ich hab jetzt mal die von Ihnen gezeichnete Schaltung nachgebaut und 
diese Funktioniert auch... Ich habe allerdings noch eine 
Verständnisfrage wieso diese einfache Schaltung nicht funktioniert 
(orangene markierte Elemente weglassen und am ende direkt verbinden.

von Lurchi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der LM311 wie viele andere Komparatoren hat einen open Kollektor 
Ausgang. D.h. er schaltet nur nach Masse. den Widerstand zu den 5 V oder 
3.3. V braucht er damit am Ausgang auch was ankommt. Der 470 K 
Widerstand in der Rückkopplung sorgt für etwas Hysterese per 
Mitkopplung. Da sollte es auch ohne gehen, nur halt so dass man ggf. 
unsauerbere Zwischenwerte haben kann man sich leicht Störungen (z.B. 50 
Hz) einfangen kann.


Ein einfacher OP für die Benutzung bei nur 5 V Versorgung wäre ein 
MCP6001 - den gibt es als DIP8 Version.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.