mikrocontroller.net

Forum: PC Hard- und Software xp in Virtuallbox usb geht nicht


Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,
ich stehe vor dem Problem das ich eine Abgespeicherte Virtuelle Maschine 
mit Xp habe und ich diese unbedingt brauche.
In dieser Virtuellen Maschine läuft ein Win XP wo eine alte 
Entwicklungsumgebung läuft.
Habe mir VirtualBox von Oracle installiert und diese Virtuellemaschine 
eingebunden.
Xp fährt hoch die Entwicklungsumgebung funktioniert.
Das Problem ist das ich auch das Programmiergerät über USB betreiben 
muss.
Ich schaffe es nicht irgend ein USB Gerät in Xp zu betreiben. Wenn ich 
einen Usb STick einhänge dann ist keine Reaktion, wenn ich es dann ein 
zweites mal machen möchte bekomme ich die Fehlermeldung das dieses Usb 
Gerät bereits eingehängt ist.
Hat jemand Wertvolle Tipps?

Liebe Grüße
Otto

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du auch das VM VirtualBox Extension Pack installiert?

https://www.virtualbox.org/wiki/Downloads

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht denn Dein in der VM laufenden XP einen USB-Host-Controller?

Wenn nicht, musst Du gegebenenfalls entsprechende VirtualBox-Treiber 
nachinstallieren, oder XP dazu bringen, daß es das von selbst macht.

Vielleicht hilft ja das hier:

https://forums.virtualbox.org/viewtopic.php?f=35&t=82639

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich betreibe VirtualBox seit etlichen Jahren und habe u.a. auch WXP 
Gäste drin. Normalerweise erkennt die WXP-VM die USB-Geräte selbständig, 
sofern das Extension Pack installiert ist UND entweder im USB-Menue 
oeder über das pop-down Geräte -> USB das USB-Gerät aktiviert ist.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Hast Du auch das VM VirtualBox Extension Pack installiert?
>
> https://www.virtualbox.org/wiki/Downloads

Sorry den hatte ich bereits installiert da ansonsten die VM nicht 
gestartet ist.

Rufus Τ. F. schrieb:
> Sieht denn Dein in der VM laufenden XP einen USB-Host-Controller?
>
> Wenn nicht, musst Du gegebenenfalls entsprechende VirtualBox-Treiber
> nachinstallieren, oder XP dazu bringen, daß es das von selbst macht.
>
> Vielleicht hilft ja das hier:
>
> https://forums.virtualbox.org/viewtopic.php?f=35&t=82639

Das muss ich gleich kontrollieren.

bingo schrieb:
> UND entweder im USB-Menue
> oeder über das pop-down Geräte -> USB das USB-Gerät aktiviert ist.

Was genau meinst du damit?

Danke

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
otto_l schrieb:
> Was genau meinst du damit?

Hast Du noch nie mit VirtualBox gearbeitet???

Das Programm VirtualBox starten (nicht gleich die VM!) -> VM aussuchen 
-> rechts sind die Einstellungen -> USB, Geräte aktivieren mit Häkchen

oder

bei gestarteter VM in der Titelzeile -> "Geräte" -> USB, Geräte 
aktivieren mit Häkchen

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Hast Du noch nie mit VirtualBox gearbeitet???
>
> Das Programm VirtualBox starten (nicht gleich die VM!) -> VM aussuchen
> -> rechts sind die Einstellungen -> USB, Geräte aktivieren mit Häkchen
>
> oder
>
> bei gestarteter VM in der Titelzeile -> "Geräte" -> USB, Geräte
> aktivieren mit Häkchen

Ist schon länger her.
Genau das geht nicht.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
4 lesenswert
nicht lesenswert
Kann Dein Betriebssystem keine Screenshots erstellen? Auf diesen 
Händiebildchen erkennt man irgendwie ... nix.

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.png
    1.png
    391 KB, 208 Downloads
  • preview image for 2.png
    2.png
    53,1 KB, 186 Downloads

Bewertung
1 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Kann Dein Betriebssystem keine Screenshots erstellen? Auf diesen
> Händiebildchen erkennt man irgendwie ... nix

Ja kann es. Entschuldige bitte.
hier die besseren Bilder.

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:
  • preview image for 3.png
    3.png
    71,8 KB, 168 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hier noch die USB Einstellungen.

Autor: MAD (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich hatte auch schon des öfteren Probleme mit USB3 Ports und Virtuellen 
Maschinen. Probier mal, das Programiergerät an einem USB2 Port 
anzuschließen falls du es noch nicht getan hast.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MAD schrieb:
> Hallo
>
> Ich hatte auch schon des öfteren Probleme mit USB3 Ports und Virtuellen
> Maschinen. Probier mal, das Programiergerät an einem USB2 Port
> anzuschließen falls du es noch nicht getan hast.

Bekomme ja nicht mal einen USB- Stick zu laufen in der VM.

Autor: 900ss D. (900ss)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
otto_l schrieb:
> Bekomme ja nicht mal einen USB- Stick zu laufen in der VM.

Ja an USB3 Ports kann es auch damit Probleme geben. Deshalb versuche, 
wie MAD oben schon schrieb, einen USB2 Port zu nehmen.

Autor: Wolfgang S. (wsm)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
... oder kaufe dir einen echten XP-Rechner.

Beitrag "[V] Siemens Fujitsu Notebook C1020 parallele Schnittstelle"

Autor: Arno (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
otto_l schrieb:
> Rufus Τ. F. schrieb:
>> Kann Dein Betriebssystem keine Screenshots erstellen? Auf diesen
>> Händiebildchen erkennt man irgendwie ... nix
>
> Ja kann es. Entschuldige bitte.
> hier die besseren Bilder.

Das heißt, du kannst in dem ersten Bild 1.png nicht auf das Gerät 
klicken? Bzw. wenn du darauf klickst, passiert nichts?

Muss man das Gerät eventuell im Host-Betriebssystem irgendwie freigeben? 
Manche/Viele Linux-Hosts mounten Datenträger automatisch, dann kann 
VirtualBox nicht mehr darauf zugreifen - ich weiß nicht, ob etwas 
vergleichbares auch für Windows-Hosts gilt. Eventuell muss auch 
irgendein VirtualBox-Treiber oder Dienst auf dem Hostsystem gestartet 
werden? Unter Linux gibt es hierzu Kernelmodule...

Die verschiedenen Einstellungen für den USB-Hostcontroller hast du 
ausprobiert? Evtl. funktionieren Geräte an USB3-HCs nur, wenn VirtualBox 
auch einen USB3-HC emuliert?

MfG, Arno

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
otto_l schrieb:
> Hier noch die USB Einstellungen.

Da kannst Du mit dem grünen Plus-Zeichen die angeschlossenen USB-Geräte 
aktivieren, erst dann werden sie in Windows angezeigt.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Da kannst Du mit dem grünen Plus-Zeichen die angeschlossenen USB-Geräte
> aktivieren, erst dann werden sie in Windows angezeigt.

Hatte das so verstanden das die Geräte die in den Filtern reinkommen von 
der echten Maschine entkoppelt werden und nur mehr in der VM laufen.

Auf jeden Fall funktioniert das auch nicht.
Werde mir einen Usb Hub kaufen und ausprobieren.
Habe kein solches Ding.

Autor: bingo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wenn beim Anklicken des grünen Plus nichts passiert, hast Du 
möglicherweise das Extension Pack nicht (richtig) installiert, es sollte 
dann so aussehen wie in der Anlage

Autor: Frank K. (fchk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
otto_l schrieb:
> bingo schrieb:
>> Da kannst Du mit dem grünen Plus-Zeichen die angeschlossenen USB-Geräte
>> aktivieren, erst dann werden sie in Windows angezeigt.
>
> Hatte das so verstanden das die Geräte die in den Filtern reinkommen von
> der echten Maschine entkoppelt werden und nur mehr in der VM laufen.

Ja. Anders geht es nicht.

> Auf jeden Fall funktioniert das auch nicht.

Dann hast Du ein Problem. Schau nochmal nach, ob Dein Rechner reine 
USB2-Ports ohne USB3-Funktionalität hat. Oder wenn Du das nicht peilst, 
dann poste ein Bild vom Gerätemanager des Hostsystems, wo die 
USB-Controller zu sehen sind. Wenn Virtualbox auf USB2 eingestellt ist, 
kann es selber nur EHCI-Ports verwenden (reine USB2-Ports), aber keine 
XHCI-Ports (USB2+3).

Wenn Deine Maschine nur XHCI-Ports hat wie alle aktuellen Intel-System 
der Generation 6 bis 8, dann musst Du VirtualBox auf USB3 stellen und 
dann einen XP-Treiber für einen NEC/Renesas USB-Controller installieren. 
Den braucht XP dann nämlich, aber den liefert Windows nicht mit, den 
musst Du separat organisieren und installieren.

Sorry, dass das so kompliziert ist. Beschwerden bitte an Intel senden.

> Werde mir einen Usb Hub kaufen und ausprobieren.
> Habe kein solches Ding.

Das hilft Dir hier nix.

Ein alter XP-tauglicher PC wäre für Dich vielleicht doch das einfachere.

fchk

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jetzt bring den armen TE doch nicht durcheinander, er muss es erst mal 
schaffen, den USB-Port in die VM zu bringen, erst dann ist der 
XP-Treiber interessant.

Post mal genaue Infos über deinen Host: welches MB, welches OS.

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Frank K. schrieb:
> Dann hast Du ein Problem. Schau nochmal nach, ob Dein Rechner reine
> USB2-Ports ohne USB3-Funktionalität hat. Oder wenn Du das nicht peilst,
> dann poste ein Bild vom Gerätemanager des Hostsystems, wo die
> USB-Controller zu sehen sind. Wenn Virtualbox auf USB2 eingestellt ist,
> kann es selber nur EHCI-Ports verwenden (reine USB2-Ports), aber keine
> XHCI-Ports (USB2+3).
>
> Wenn Deine Maschine nur XHCI-Ports hat wie alle aktuellen Intel-System
> der Generation 6 bis 8, dann musst Du VirtualBox auf USB3 stellen und
> dann einen XP-Treiber für einen NEC/Renesas USB-Controller installieren.
> Den braucht XP dann nämlich, aber den liefert Windows nicht mit, den
> musst Du separat organisieren und installieren.
>
> Sorry, dass das so kompliziert ist. Beschwerden bitte an Intel senden.
>
>> Werde mir einen Usb Hub kaufen und ausprobieren.
>> Habe kein solches Ding.
>
> Das hilft Dir hier nix.
>
> Ein alter XP-tauglicher PC wäre für Dich vielleicht doch das einfachere.

Ich habe ein Bild gemacht von meinem Geräte Manager.
Kannst du mir für den Treiber einen Link geben?
Ich habe keinen Xp Rechner und war der Meinung wenn diese VM schon 
vorbereitet ist kann ich die alte Entwicklungsumgebung schnell verwenden 
und diese kleine Änderung machen.
Die Vm hat mein Vorgänger eingerichtet und hat anscheinend damals 
funktioniert.

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist denn da Dein Gerät zu sehen ???

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Ist denn da Dein Gerät zu sehen ???

das ist der Host Rechner.

Danke und guten Morgen.

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:
  • preview image for vm.png
    vm.png
    46,5 KB, 86 Downloads

Bewertung
0 lesenswert
nicht lesenswert
und jetzt fehlt im GeräteManager der VM der Treiber.

Hat jemand eine Link dafür

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erste Hürde genommen, das heisst ja, dass VirtualBox den USB-Port jetzt 
durchleitet. Was für ein Gerät hängt denn da jetzt dran, hat das evtl. 
einen FTDI-Chip o.ä drin, dann wäre das easy.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Erste Hürde genommen, das heisst ja, dass VirtualBox den USB-Port jetzt
> durchleitet. Was für ein Gerät hängt denn da jetzt dran, hat das evtl.
> einen FTDI-Chip o.ä drin, dann wäre das easy.

Ich habe ja noch das Problem das der Usb COntroller in der Vm nicht 
läuft somit geht ja nicht mal ein USB Stick.

Autor: Walter K. (walter_k488)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich so meine Erfahrungen mit Virtual Box mit Parallels vergleiche, 
muss ich im Nachhinein sagen, dass VirtualBox schlicht und einfach 
Schrott ist!
Ich habe unter MacOS ein virtuelles Win10 laufen.
Klicke ich im MacOS auf z.B. auf ne exceldokument, dann fährt im 
Hintergrund Win10 hoch und Excel startet in der virtuellen Maschine.
Wenn ich an n USB n Stick oder sonstwas einstecke, kommt sofort n 
Fenster und ich werde gefragt, ob MacOS oder Windows den Stick mounten 
soll!
So macht arbeiten mit virtuellen Maschinen Spaß - und nicht tagelang 
wegen USB oder LAN rumfrickeln - wie es bei VirtualBox immer der Fall 
war

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Walter K. schrieb:
> Klicke ich im MacOS auf z.B. auf ne exceldokument, dann fährt im
> Hintergrund Win10 hoch und Excel startet in der virtuellen Maschine.

Will man sowas?

Ich nicht.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nun mal VirtualBox;),
und leider weiß ich nicht wo ich den Treiber für den USB controller für 
die VM Downloaden kann.
Lg

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Normal sollte der in den Gasterweiterungen dabei sein, die man auf dem 
Gast System installiert. Installiere die doch mal drüber.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian R. schrieb:
> Gasterweiterungen

Was ist das?

Autor: andreasgf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: andreasgf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Walter K. schrieb:
> muss ich im Nachhinein sagen, dass VirtualBox schlicht und einfach
> Schrott ist!

> wegen USB oder LAN rumfrickeln - wie es bei VirtualBox immer der Fall
> war

Das ist Blödsinn, was Du da absonderst. Ich nutze VirtualBox weil es 
ganz besonders einfach zu handhaben ist, für alle OS geeignet ist und es 
läuft hier seit 2010 völlig problemlos, ich habe sogar noch ein altes 
W2k drauf, für das es keine Hardware mehr gibt, einige WXP und W7 und 2 
alte Versionen von Ubuntu. Diverse USB-Hardware (auch FTDI und PICs) 
integriert sich sofort beim einstecken, wenn das konfiguriert ist.

otto_l schrieb:
> Christian R. schrieb:
>> Gasterweiterungen
>
> Was ist das?

Die brauchst Du natürlich, siehe 2. Link von andreasgf, vielleicht 
hättest Du Dich etwas besser einlesen sollen.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Die brauchst Du natürlich, siehe 2. Link von andreasgf, vielleicht
> hättest Du Dich etwas besser einlesen sollen.

So habe ich jetzt auch installiert. Habe aber immer noch das gelbe 
Fragezeichen im Gerätemanager.
Habe versucht diesen Treiber 
https://de.softonic.com/download/renesas-electroni...

zu installieren wird zwar ohne Fehler installiert aber das Fragezeichen 
bleibt.

Ich verzweifle. Wo kann ich mich einlesen?
Wer hat noch rat?

Autor: Thomas (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Es tut mir leid das sagen zu müssen... Wenn du Treiber bei softonic 
runter laden willst ist eine VM nicht das richtige für dich. Das kann ja 
nur schiefgehen.
Treiber sucht man über vid/pid.

Thomas

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Es tut mir leid das sagen zu müssen... Wenn du Treiber bei softonic
> runter laden willst ist eine VM nicht das richtige für dich. Das kann ja
> nur schiefgehen.
> Treiber sucht man über vid/pid.
>
> Thomas

Also meines Wissen ist vid/pid die Kennung von Usb Geräten.
Ich suche den Treiber für den Usb Kontroller.
Danke

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Problem ist immer noch das ich keinen USB Controller installiert 
bekomme.

Autor: Thomas (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Vid und pid gibt es immer..... Schau halt Mal bei dem Fragezeichen nach 
was XP von dir will.
Kann es sein dass du überhaupt nicht weißt was du tust?
Es gibt da wunderbare Eigenschaftsdialoge die dir alles sagen.
Du kannst nicht irgendeinen Treiber installieren das muss ein Treiber 
für XP sein.

Thomas

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:
  • preview image for 4.PNG
    4.PNG
    29,5 KB, 67 Downloads
  • preview image for 5.PNG
    5.PNG
    48,8 KB, 56 Downloads
  • preview image for 6.PNG
    6.PNG
    39,4 KB, 55 Downloads
  • preview image for 7.PNG
    7.PNG
    39,8 KB, 65 Downloads

Bewertung
1 lesenswert
nicht lesenswert
Thomas schrieb:
> Vid und pid gibt es immer..... Schau halt Mal bei dem Fragezeichen
> nach
> was XP von dir will.
> Kann es sein dass du überhaupt nicht weißt was du tust?
> Es gibt da wunderbare Eigenschaftsdialoge die dir alles sagen.
> Du kannst nicht irgendeinen Treiber installieren das muss ein Treiber
> für XP sein.
>
> Thomas

Ich möchte einfach die exportierte VM auf diesen Rechner wieder 
verwenden.
Dachte nicht das es dazu Zauberkünste braucht.

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Vid und pid gibt es immer..... Schau halt Mal bei dem Fragezeichen nach
> was XP von dir will.
> Kann es sein dass du überhaupt nicht weißt was du tust?

Ich sehe nur das ich einen Treiber installieren soll weiß jedoch nicht 
welchen.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
6.PNG zeigt PCI\VEN_8086&DEV_1E31

Und das ist ein USB3-Hostcontroller von Intel.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun den Treiber würdest du auch bei einer nativen XP Installation 
brauchen.
Ich habe das mal für dich gegoogelt:

https://driverpack.io/de/hwids/PCI%5CVEN_8086%26DEV_1E31

Thomas

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Vid und pid gibt es immer..... Schau halt Mal bei dem Fragezeichen nach
> was XP von dir will.
> Kann es sein dass du überhaupt nicht weißt was du tust?

Ich sehe nur das ich einen Treiber installieren soll weiß jedoch nicht 
welchen.

Thomas schrieb:
> Nun den Treiber würdest du auch bei einer nativen XP Installation
> brauchen.
> Ich habe das mal für dich gegoogelt:
>
> https://driverpack.io/de/hwids/PCI%5CVEN_8086%26DEV_1E31
>
> Thomas

Beim Download von dieser Seite springt mein Antivirus an.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> 6.PNG zeigt PCI\VEN_8086&DEV_1E31
>
> Und das ist ein USB3-Hostcontroller von Intel.

https://www.intel.de/content/www/de/de/support/art...
sagt:
Intel® USB 3,0 Extensible Host Controller-Treiber wird in Windows XP * 
oder Windows Vista nicht unterstützt

Das ist also eine Sackgasse. Du musst wohl wirklich USB 2.0 einstellen, 
aber ohne echte 2.0 Ports am Rechner wirds dann auch wieder schwierig.

Autor: Thomas (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Soll ich jetzt auch dein Händchen halten? Wenn der XP Download (was du 
vermutlich gar nicht ausprobiert hast) nicht geht muss du halt 
weitergoogeln. Eine andere Alternative wäre noch zu jemandem zu gehen 
der eine Ahnung von sowas hat.

Thomas

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@chris

Intel bietet tatsächlich keinen XP Support für diesen Chipsatz
Das ist richtig aber nur insofern ein Problem dass man nichts direkt bei 
Intel runterladen kann.
Ich habe bei mir auch erfolgreich in einer XP VM einen Intel usb3 
Treiber installiert.
Google führt in jedem Fall zum Ziel.

Thomas

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Soll ich jetzt auch dein Händchen halten? Wenn der XP Download (was du
> vermutlich gar nicht ausprobiert hast) nicht geht muss du halt
> weitergoogeln. Eine andere Alternative wäre noch zu jemandem zu gehen
> der eine Ahnung von sowas hat.
>
> Thomas

ich komme nicht weiter

Autor: dernichtversteher (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
otto_l schrieb:
> ich komme nicht weiter

Kein Wunder, Google ist ja auch seit Monaten offline.

Autor: Thomas (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Also hier wie ich vorgehen würde:
1 Virenscanner ausschalten und die XP Version des Treibers runterladen
2 exe in keinem Fall starten um zu verhindern dass irgendwelche Software 
installiert wird
3 exe mit 7zip öffnen
4 inf Datei und cat Datei aus dem Archiv kopieren
5 die inf manuel über System Steuerung Hardware installieren
6 Virenscanner wieder einschalten

Das sollte mindestens eine Kiste Hopfenkaltschale wert sein

Thomas

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stell in virtualbox auf USB3 (xHCI)

Die USB2-Implementierung von Virtualbox ist buggy, hohe Latenzen, manche 
Anwendungen mit USB2 Geräten (zum Beispiel RS232-Adapter) an 
USB2-Buchsen gehen damit einfach nicht gescheit oder gar nicht.

Der virtuelle USB3-Controller von VirtualBox scheint grundlegend anders 
oder neu implementiert worden zu sein und funktioniert problemlos auch 
mit USB2-Geräten an USB2 Anschlüssen. Damit betreibe ich problemlos den 
J-Link (USB2), ein selbstgebautes HID-Device (USB1) und den seriellen 
Adapter (USB2) and USB2-Buchsen des Hosts und obige Probleme treten 
reproduzierbar nicht mehr auf. Damit man das aktivieren kann muss der 
Extension-Pack installiert sein.

: Bearbeitet durch User
Autor: Farin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bernd K. schrieb:
> Die USB2-Implementierung von Virtualbox ist buggy, hohe Latenzen, manche
> Anwendungen mit USB2 Geräten (zum Beispiel RS232-Adapter) an
> USB2-Buchsen gehen damit einfach nicht gescheit oder gar nicht.

Woher hast du denn das?

USB2 läuft auf VB völlig problemlos, RS232-Adapter ebenfalls, zum Beleg 
füge ich mal die USB-Einstellungen von VB und die dazugehörige 
System-Darstellung von Windows an. Es ist eine Microchip-Device mit 
PIC18F2550, ein FT232, ein FT2232 und sogar ein CH340.

Autor: otto_l (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Also hier wie ich vorgehen würde:
> 1 Virenscanner ausschalten und die XP Version des Treibers runterladen
> 2 exe in keinem Fall starten um zu verhindern dass irgendwelche Software
> installiert wird
> 3 exe mit 7zip öffnen
> 4 inf Datei und cat Datei aus dem Archiv kopieren
> 5 die inf manuel über System Steuerung Hardware installieren
> 6 Virenscanner wieder einschalten
>
> Das sollte mindestens eine Kiste Hopfenkaltschale wert sein
>
> Thomas

Also ich konnte den Treiber extraieren und installieren.
Allerdings ist im Gerätemanager der VM kein Usbcontroller mehr sichtbar.
Ich kann immer noch nicht einen Simplen UsbStick in der Vm einhängen 
weder mit noch ohne Filter.

Autor: Farin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
google doch mal nach dem Fehlercode

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Farin schrieb:
> Wsoher hast du denn das?

Aus persönlicher Erfahrung, wie ich bereits schrieb. Messbare Symptome 
sind Latenzen im hohen zweistelligen Millisekunden Bereich wo keine sein 
sollten, Protokolle laufen in Timeouts oder die Datenrate geht in den 
Keller. Ich weiß nicht welche Umstände zusammenkommen müssen um es 
auszulösen aber umstellen auf USB 3 hilft jedes Mal nachhaltig. 
Mittlerweile das erste was ich einstelle bei einer neuen vm.

OP sollte das mal probieren, kostet schließlich nichts.

Autor: Erik D. (erikms5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Otto,

Der Benutzer, der die VM startet muss Mitglied in der Gruppe "vboxusers" 
sein.

viel Glück Erik

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erik D. schrieb:
> Hallo Otto,
>
> Der Benutzer, der die VM startet muss Mitglied in der Gruppe "vboxusers"
> sein.
>
> viel Glück Erik

ISt das bei Windows 10als Host auch so?

Autor: Erik D. (erikms5)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
otto_l schrieb:
> ISt das bei Windows 10als Host auch so?

keine Ahnung, Windows ME war meine letzte Version. Zu der Zeit war 
VitualBox noch kein Thema für mich.

Beitrag #5556116 wurde vom Autor gelöscht.
Autor: RTFM (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
otto_l schrieb:
> ISt das bei Windows 10als Host auch so?

Es gibt für Virtualbox auch eine Internet-Seite 
https://www.virtualbox.org/ da gibt es in der linken Spalte den Link 
Dokumentation

RTFM !!!

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich warte auf den Usb2 Hub.
Mal sehen ob das hilft.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Hub wird Dir nicht helfen, wenn Dein Wirts-PC nur einen 
USB3-Controller hat.

Eine simple USB2-PCI-Karte dürfte Dich weiterbringen.

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Ein Hub wird Dir nicht helfen, wenn Dein Wirts-PC nur einen
> USB3-Controller hat.

Jeder USB-3 Controller hat auch huckepack einen USB-2 Controller 
eingebaut. USB-2 Geräte kann man auch an blauen Buchsen betreiben.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gewiss, nur scheint das hier ja aus irgendwelchen Gründen nicht zu 
funktionieren, das XP in der VM sieht entweder nur einen XHCI- oder gar 
keinen USB-Controller.

(Was auch immer der Threadstarter für diese Änderung auch irgendwo 
geändert haben mag).

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> das XP in der VM sieht entweder nur einen XHCI- oder gar
> keinen USB-Controller.

Dann soll er doch mal zum Spaß eine andere VM starten (mit anderem OS) 
um zu sehen ob er dann immer noch nichts sieht, dann weiß er wenigstens 
obs an seinem XP liegt und dessen Treibern oder nicht.

Autor: Walter K. (walter_k488)
Datum:

Bewertung
-3 lesenswert
nicht lesenswert
bingo schrieb:
>> Walter K. schrieb:
>> muss ich im Nachhinein sagen, dass VirtualBox schlicht und einfach
>> Schrott ist!
>
>> wegen USB oder LAN rumfrickeln - wie es bei VirtualBox immer der Fall
>> war
>
> Das ist Blödsinn, was Du da absonderst. Ich nutze VirtualBox weil es
> ganz besonders einfach zu handhaben ist, für alle OS geeignet ist und es
> läuft hier seit 2010 völlig problemlos, ich habe sogar noch ein altes
> W2k drauf, für das es keine Hardware mehr gibt, einige WXP und W7 und 2
> alte Versionen von Ubuntu. Diverse USB-Hardware (auch FTDI und PICs)
> integriert sich sofort beim einstecken, wenn das konfiguriert ist.
>

Absondern?

Wenn ich mir diesen Thread so durchlese, dann bekommt man den Eindruck, 
dass VB „ besonders einfach zu handhaben ist“ ?

Lach!

Autor: otto_l (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Also bis vor kurzen war ich der Meinung das wenn man sich einmal ein 
Virtuelles System gebaut hat, man dieses dann so auf jeder Hardware 
wieder in Virtualbox verwenden kann. Genau darin sah ich den Sinn. Im 
Meinem Fall lief diese VM auf einem Laptop der jetzt den Akku kaputt 
hat. Nun auf meinem Laptop funktioniert genau diese VM nicht mehr.
Wenn ich jetzt wieder die Entwicklungsumgebung auf dem neuen Laptop 
einrichten muss für eine Zeile Code abändern ist dies sehr ärgerlich.

Wie kann ich für die Zukunft vorsorgen? Es sollte doch möglich sein auch 
noch in 20 Jahren so eine Änderung ohne großen Aufwand machen zu können.
Ist das ein Irrglauben?

Lg

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
otto_l schrieb:
> Wie kann ich für die Zukunft vorsorgen? Es sollte doch möglich sein auch
> noch in 20 Jahren so eine Änderung ohne großen Aufwand machen zu können.
> Ist das ein Irrglauben?

Nein, das geht normalerweise. VirtualBox funktioiert eigentlich immer 
zuverlässig, das ist meine Erfahrung. Archivierte Maschinen laufen Jahre 
später immer noch problemlos auf neuen/anderen Hosts, sogar wenn ich 
zwischenzeitlich auf Hostseite von Windows zu Linux gewechselt bin, die 
alten VMs laufen wie am ersten Tag. Und die benutzen alle USB weil ich 
mindestens jedesmal den J-Link und zusätzlich auch einen speziellen 
Prüfadapter mit USB2 anschließen können muß.

Auf Deinem neuen Laptop wird irgendwas grundsätzliches fundamental 
zerschossen sein oder irgendwelche Treiber fehlen. Mach in platt und 
installiere ein sauberes funktionierendes System (das ist die empfohlene 
Standard-Windows-Problemlösungsprozedur), danach versuche es erneut.

: Bearbeitet durch User
Autor: Frank K. (fchk)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Bernd K. schrieb:
> Rufus Τ. F. schrieb:
>> Ein Hub wird Dir nicht helfen, wenn Dein Wirts-PC nur einen
>> USB3-Controller hat.
>
> Jeder USB-3 Controller hat auch huckepack einen USB-2 Controller
> eingebaut. USB-2 Geräte kann man auch an blauen Buchsen betreiben.

Mit dem Unterschied, dass es nicht mehr wie früher ist, wo ein 
EHCI-COntroller für High Speed noch einen UHCI/OHCI Controller für 
Full/Low-Speed dabei hatte. Bei allein neuen Rechnern geht USB 1-3 
ausschließlich über XHCI, und genau das ist das Problem. Die alten 
Interfaces sind weg.

fchk

Autor: otto_l (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernd K. schrieb:
> Auf Deinem neuen Laptop wird irgendwas grundsätzliches fundamental
> zerschossen sein oder irgendwelche Treiber fehlen. Mach in platt und
> installiere ein sauberes funktionierendes System (das ist die empfohlene
> Standard-Windows-Problemlösungsprozedur), danach versuche es erneut.

Nein der Preis ist definitiv zu hoch.
Unter Win10 läuft bis auf VB ja alles ohne Probleme.

Frank K. schrieb:
> Mit dem Unterschied, dass es nicht mehr wie früher ist, wo ein
> EHCI-COntroller für High Speed noch einen UHCI/OHCI Controller für
> Full/Low-Speed dabei hatte. Bei allein neuen Rechnern geht USB 1-3
> ausschließlich über XHCI, und genau das ist das Problem. Die alten
> Interfaces sind weg.
>
> fchk

Das heißt also XP ist auch in der VM gestorben?

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
2 lesenswert
nicht lesenswert
otto_l schrieb:
> Das heißt also XP ist auch in der VM gestorben?

Solange nicht jemand einen virtuellen EHCI-Adapter in VirtualBox 
reinhäkelt, der auf der Wirtsseite mit dem für USB2-Geräte zuständigen 
XHCI -Teil redet, oder solange Du nicht eine physikalische 
USB-2-Schnittstelle in Deinen Wirt reinsteckst, ja.

Theoretisch könntest Du auch eine Lösung wie VirtualHere einsetzen, das 
ist eine USB-Virtualisierung übers Netzwerk, aber das unterstützt schon 
seit einiger Zeit kein XP mehr.



Vielleicht ist Dein Problem aber auch mit dem neuen ExtensionPack für 
VirtualBox gelöst, das es erst seit Mitte August gibt:

https://www.techworld.com/download/system-desktop-...

Da wird explizit auf einen neuen EHCI-Controller hingewiesen.

Autor: otto_l (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Solange nicht jemand einen virtuellen EHCI-Adapter in VirtualBox
> reinhäkelt, der auf der Wirtsseite mit dem für USB2-Geräte zuständigen
> XHCI -Teil redet, oder solange Du nicht eine physikalische
> USB-2-Schnittstelle in Deinen Wirt reinsteckst, ja.
>
> Theoretisch könntest Du auch eine Lösung wie VirtualHere einsetzen, das
> ist eine USB-Virtualisierung übers Netzwerk, aber das unterstützt schon
> seit einiger Zeit kein XP mehr.
>
> Vielleicht ist Dein Problem aber auch mit dem neuen ExtensionPack für
> VirtualBox gelöst, das es erst seit Mitte August gibt:
>
> 
https://www.techworld.com/download/system-desktop-...
>
> Da wird explizit auf einen neuen EHCI-Controller hingewiesen.

Ja USB2 Karte in einem Laptop rein stecken ist schwierig.

den neusten Extensionpack habe ich installiert.

Ist doof sowas.
Danke Schönen Sonntag

Autor: Frank K. (fchk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der USB-Support bei VirtualBox ist bekanntermaßen schlecht. Am 
Arbeitsplatz mussten wir einige VirtualBox-Instanzen durch physikalische 
Maschinen (kleine Shuttle Mini-PCs) ersetzen, weil sonst das Flashen 
unserer ARM64-Boards fehlschlägt.

An den Fragesteller: Nimm VMWare. Das kostet zwar, hat aber den deutlich 
besseren Hardwaresupport. Bei VirtualBox ist ein Kommandozeilentool 
dabei, das VDI-Images (VirtualBox) nach VMDK-Images (VMWare) umwandeln 
kann.

fchk

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Frank K. schrieb:
> Der USB-Support bei VirtualBox ist bekanntermaßen schlecht. Am
> Arbeitsplatz mussten wir einige VirtualBox-Instanzen durch physikalische
> Maschinen (kleine Shuttle Mini-PCs) ersetzen, weil sonst das Flashen
> unserer ARM64-Boards fehlschlägt.

Den Haken bei USB3 setzen hätte gereicht. Bin ich auch schon durch, 
seither geht das Flashen und alles andere.

Autor: otto_l (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
So der USB2 Hub ist da und oh großes Wunder der Usb Stick wird jetzt in 
der VM eingebunden. Das Programmiergerät auch.
Ob es funktioniert muss ich erst testen.

Werde noch Feedback geben.

Danke allen die hier mit geholfen Haben.
Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.