mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Differenz-OP LM324 invers?!


Autor: Bahner (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag alle,

Forum sollte passen denke ich.


Ich möchte für unsere Clubanlage einen Rückmelder bauen für die 
Modellbahn.
Ganz einfaches Gerät eigentlich, ich bringe Abschnittsweise in eine 
Leitung des Gleises 2 Dioden antiparallel (da Digitaler Wechselstrom) 
ein, sodass der Strom auf einer Seite immer über die Dioden muss.

Meine Idee war nun, um Dioden zu sparen, halt nur 2 antiparallele zu 
nehmen, nicht wie einige das machen 4 und dann einen Optokoppler (um auf 
1,2V zu kommen).

Ich nutze SK84C/SS84 also Shottkys. Über die Dioden habe ich einen 
Differenzverstärker gebaut aus einem LM324.

Jetzt habe ich folgenden komischen Effekt (Schaltplan siehe Anhang).

Fließt kein Strom (Differenz = 0, nachgemessen mit Multimeter), habe ich 
am OP 5V. Fängt ein Strom an zu fließen, dann sinkt die Spannung, das 
passt mehr oder weniger proportional zum Stromfluss.



Der erste Schritt sollte eigentlich sein: Kein Strom OP-Ausgang 0V. 
Strom (egal wie viel) OP-Ausgang steigt bzw. >= 3V um den Mosfet zu 
schalten (einfachste Rückmeldung).

Später wollte ich das erweitern mit einem Controller der die Spannung 
misst und daraus den Stromverbrauch berechnet.


Meine Frage: Warum läuft das hier invers? Normalerweise bei Differenz 0 
sollte der Ausgang 0 sein und nicht max. Spannung.

Dann habe ich einen THS24 genommen als OP. 0A Stromfluss 0V Ausgang.
Fließt ein Strom (egal welcher) habe ich 1,7V. Zum Melden reicht das 
zwar, aber ist doch auch nicht korrekt, das muss sich doch je Stromfluss 
verändern?! Außerdem sind mir die THS24 zu teuer.

Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Verbraucher hängt dann übrigends zwischen VDC1 und Ln

Autor: Andrew T. (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Fließt kein Strom (Differenz = 0, nachgemessen mit Multimeter), habe ich
> am OP 5V. Fängt ein Strom an zu fließen, dann sinkt die Spannung, das
> passt mehr oder weniger proportional zum Stromfluss.

Dann solltest Du die OPV als Komparator beschalten, nicht wie jetzt als 
Differenzverstärker.

kurz: works as designed.

Autor: Dergute W. (derguteweka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Die Eingangsspannungen, die der OpAmp sieht, purzeln doch jenseits 
seiner  Versorgungsspannungen 'rum.

Und was ist an:

Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen.

so schwer zu verstehen?

Gruss
WK

Autor: Christian S. (roehrenvorheizer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Du hast 20 kHz Wechselspannung mit 0 Grad am Eingang. Und Du erwartest, 
daß der invertierende OPV, der von einer positiven Sättigung in die 
negative getrieben wird, das mit macht bei Verstärkung 10?

Vielleicht wäre für jeden Zweig eine Einweggleichrichtung, Glättung und 
Komparator dahinter eher geeignet. Dann macht es auch der LM324 oder ein 
LM339, LM2901.

MfG

: Bearbeitet durch User
Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Jetzt habe ich folgenden komischen Effekt

Deine Schaltung misst nicht galvanisch getrennt von der auswertung, 
sondern Masse deines OpAmp ist manchmal positiver und manchmal negativer 
als die zu messende Differenzspannung und VCC sowieso zu gering, ein mit 
5V betriebener LM324 kann nur bis 3.56V messen.

Es hat schon einen Grund, warum andere Leute den Aufwand treiben und 
einen Optokoppler spendieren und den höheren Spannungsabfall in Kauf 
nehmen.

Ausserdem hat deine Schaltung keinen Schmit-Trogger effekt und keine 
Impulsverlängerung sondern liefert analoge 20000Hz. 20000Hz sind für 
einen um 10 verstärkenden LM324 jedoch zu viel.

Bahner schrieb:
> Dann habe ich einen THS24 genommen als OP.

Der ist Rail-To-Rain und schneller.

Die Schaltung ist also eh Murks, das Problem beginnt mit der aus der 
Schienenspannung gewonnenen Stromversorgung. Hättet ihr eine eigenen 
Stromversorgung, die nur mit einem Pol der Wechselspannugsquelle 
verbunden ist und zwar dem an dem alle Dioden hängen, dann wäre die 
Schaltung einfacher.
     
                     +----+
  +-------+--|>|--+--|7805|--+----+-------+----+
  |       |       |  +----+  |   4k7      |    |
  |    Schiene  Elko    |  100nF  +---+   |   10k
20kHz     |       |     |    |   330R |   |    |
  |       |       +-----+----+----+   |   |    |
  +--|>|--+       |                   +--|+\   |  ______
  |       |       |                 LM393|  >--+--belegt
  +--|<|--+-------(----------10k---------|-/   |
  |       |       |                       |    |
  +--100R-+       |                       |   1uF
  |               |                       |    |
  +---------------+-----------------------+----+--

: Bearbeitet durch User
Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Der ist Rail-To-Rain und schneller.
>
> Die Schaltung ist also eh Murks, das Problem beginnt mit der aus der
> Schienenspannung gewonnenen Stromversorgung. Hättet ihr eine eigenen
> Stromversorgung, die nur mit einem Pol der Wechselspannugsquelle
> verbunden ist und zwar dem an dem alle Dioden hängen, dann wäre die
> Schaltung einfacher.

Das DCC Signal ist verändert die Polarität. Du machst nur eine 
Halbwellengleichrichtung um eine gemeinsame Masse zu haben, richtig?

Wie ist das denn später wenn ich dort noch einen Prozessor (ATtiny) 
eingabue, mag der das auch?! Du nutzt ja jetzt eine 
Halbwellengleichrichtung und bist als Gegenpol am DCC Signal dran, was 
24V haben kann.


Brauche ich die 100R dann überhaupt noch parallel zu den Dioden?
Ab welcher Schwelle würde denn der LM393 dann schalten? Kann man das 
einstellen, dass man das zu einem Strom hat (bspw. erst ab 10 mA 
schaltet er)?

Autor: Bahner (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmals,

meinst du das dann quasi so?
Ich habe das mal getestet, dass summt ganz schön.
Da liegen doch dann auch am Elko 24V am - Pol an kurzzeitig.


Was bringt das, dass das jetzt png statt jpeg ist?

Autor: Dergute W. (derguteweka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Was bringt das, dass das jetzt png statt jpeg ist?

<resignier>
Natuerlich nix, wenn man das jpeg als png verpackt.
wk [ ~/Downloads ]$ file ruckmelder.png 
ruckmelder.png: JPEG image data, JFIF standard 1.01
</resignier>

Ansonsten besteht Hoffnung, dass man bessere Bildqualitaet mit kleineren 
Dateien zustandebringt.

SCNR,
WK

Autor: offtopic (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
[OT]

Dateigroesse wenn mans richtig macht aber so dramatisch ist nicht mehr 
seit die Telekom Analoganschluesse stillegt und 14.4er Modems aus der 
Mode kamen.

convert ruckmelder.png -colors 255 -quality 90  rueck2.png

vlt. gehts auch kleiner, k.A.

[/OT]

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Ich habe das mal getestet, dass summt ganz schön.

Wenn es wirklich eine 1N6095 iast, schlägt die durch.
Ansonsten ist die Stromversorgung ok, ob 1uF reicht, hängt von der 
Strombelastung ab.
Die Auswerteschaltung habe ich aber nicht ohne Grund auf LM393 
Komparatiren umgebaut. Die 1uF am Ausgang habe ich aber für 50Hz 
ausgelegt, bei 20kHz reichen da 220nF.

> Da liegen doch dann auch am Elko 24V am - Pol an kurzzeitig.

Nein. Wenn kein Strom fliesst (durch die Diode) liegt nichts an.

Autor: Forist (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> ruckmelder.png

Was ist jetzt der Unterschied zwischen den um U1A, U1B, U1C und U1D 
aufgebauten Schaltungen - oder wofür zeigst du das alles?

offtopic schrieb:
> vlt. gehts auch kleiner, k.A.

Wenn man sich den ganzen Punktsalat spart und die unteren zwei Drittel 
ganz weg lässt, stehen die Chancen dazu nicht schlecht.
Es wird übersichtlicher und inhaltlicht verliert man absolut gar nichts. 
Und wie man von VDC1 über VDD zu VCC kommt, scheint für die Frage auch 
nicht sonderlich relevant zu sein, i.e. spielt auch keine Rolle.

Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Bahner schrieb:
>> Ich habe das mal getestet, dass summt ganz schön.
>
> Wenn es wirklich eine 1N6095 iast, schlägt die durch.
> Ansonsten ist die Stromversorgung ok, ob 1uF reicht, hängt von der
> Strombelastung ab.
> Die Auswerteschaltung habe ich aber nicht ohne Grund auf LM393
> Komparatiren umgebaut. Die 1uF am Ausgang habe ich aber für 50Hz
> ausgelegt, bei 20kHz reichen da 220nF.
>
>> Da liegen doch dann auch am Elko 24V am - Pol an kurzzeitig.
>
> Nein. Wenn kein Strom fliesst (durch die Diode) liegt nichts an.

Nein, die Diode war jetzt eben schnell eine gewählt. Würde dann eine 
SS36 werden.

Ich habe dann einen Schienenstrang als "Masse" verwertet. Bei mir summt 
dann alles. Ist das korrekt?!


Kann ich nicht, da der LM393 OC ist, einfach LM7805 weglassen und den 
direkt an die Spannung hängen, einfach eine Diode in den + Strang (1. 
schiene), Masse die 2. Schiene nehmen. Dann so aufbauen wie du meinst 
mit anderem Spannungsteiler.

Dann habe ich nur halt keine Strommessung mehr.

Autor: Günter Lenz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
>Brauche ich die 100R dann überhaupt noch parallel zu den Dioden?
>Ab welcher Schwelle würde denn der LM393 dann schalten?

Mit 100 Ohm Widerstand, bei etwa 3,3mA.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Ich habe dann einen Schienenstrang als "Masse" verwertet. Bei mir summt
> dann alles. Ist das korrekt?!

Vermutlich ncht.

Mein Schaltplan ist korrekt, aber die erzeugten 5V sind auch nirgendwo 
sonst angeschlossen ausser an der Auswerteschaltung.

Wenn du nun die "Masse" der 5V mit "Masse" aus irgendwas anderem (des 
Boosters?) deiner Anlage verbunden hast, baust du einen Kurzschluss.

Bahner schrieb:
> Kann ich nicht, da der LM393 OC ist, einfach LM7805 weglassen und den
> direkt an die Spannung hängen, einfach eine Diode in den + Strang (1.
> schiene), Masse die 2. Schiene nehmen. Dann so aufbauen wie du meinst
> mit anderem Spannungsteiler.

Da nach dem Gleichrichter am Elko ca. 20V entstehen, könnte man den 
LM383 direkt daraus versorgen. Was dein 1. Schiene und 2. Schiene 
bedeuten soll, weiss ich nicht, die Sprache der Elektroniker ist der 
Schaltplan und keine Prosa.

Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Da nach dem Gleichrichter am Elko ca. 20V entstehen, könnte man den
> LM383 direkt daraus versorgen. Was dein 1. Schiene und 2. Schiene
> bedeuten soll, weiss ich nicht, die Sprache der Elektroniker ist der
> Schaltplan und keine Prosa.


Okay ich drücke mich nochmal anders aus:

Woher beziehst du deine Masse?


Ich habe nur die Spannung aus dem Gleis zur Verfügung, also das 
hochfrequente Wechselstromsignal. Mehr nicht. Also muss ich das 
anzapfen. Korrekt so? Meinst du das bei deiner Schaltung auch so?

Ich habe es nämlich so gemacht, das surrt und summt mit der 
Einweggleichrichtung.

Autor: Günter Lenz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du mußt mal erklären wie dein "Digitaler Wechselstrom"
überhaupt aussieht. Ist das eine 50Hz Wechselspannung
mit einer überlagerten 20kHz Wechselspannung? Oder
eine 24V Gleichspannung mit überlagerter 20kHz
Wechselspannung, also praktisch 24V Gleichspannung
die mit 20kHz ein und ausgeschaltet wird?

Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Günter Lenz schrieb:
> Du mußt mal erklären wie dein "Digitaler Wechselstrom"
> überhaupt aussieht. Ist das eine 50Hz Wechselspannung
> mit einer überlagerten 20kHz Wechselspannung? Oder
> eine 24V Gleichspannung mit überlagerter 20kHz
> Wechselspannung, also praktisch 24V Gleichspannung
> die mit 20kHz ein und ausgeschaltet wird?


Nein, dass ist ein DCC Signal.

Das wird mit einer H-Brücke erzeugt, die ein symmetrisches Signal 
erzeugt.
Also ein gehacktes Gleichstromsignal?! Keine Ahnung wie man das nennen 
soll.

log 1 ist 56 us, log 0 116us. Und dann wird das symm erzeugt das es egal 
ist wie man was anschließt ans Gleis. Man hat also am Gleis wechselende 
Polarität von GND/+24V und +24V/GND.

Schau mal nach DCC Signal.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Woher beziehst du deine Masse?

Es gibt nicht "eine" Masse.

Der Booster wird seine Masse haben, die eventuell der Rest der 
Modelleisenbahn verwendet,

und die gleichgerichtete Boosterspannung hat eine andere "Masse" und 
beide darf man nicht verbinden.

Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Bahner schrieb:
>> Woher beziehst du deine Masse?
>
> Es gibt nicht "eine" Masse.
>
> Der Booster wird seine Masse haben, die eventuell der Rest der
> Modelleisenbahn verwendet,
>
> und die gleichgerichtete Boosterspannung hat eine andere "Masse" und
> beide darf man nicht verbinden.

Aber auf dem Gleis gibt es keine Masse, da das Signal permanent die 
Polarität wechselt. Das ist ja der Booster-Ausgang, der entspricht dem 
Gleis.

Wenn ich das also ans Gleis anschließe (also am Booster-Ausgang) habe 
ich keine Masse in meinem Sinn. Der Gegenpol hat mal GND mal +24V. Daher 
kommt das Surren. Deswegen bin ich aktuell etwas ratlos, wie ich das 
verdrahten soll.

Autor: Bahner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Günter Lenz schrieb:
> Bahner schrieb:
>>Brauche ich die 100R dann überhaupt noch parallel zu den Dioden?
>>Ab welcher Schwelle würde denn der LM393 dann schalten?
>
> Mit 100 Ohm Widerstand, bei etwa 3,3mA.

Wie hast du das berechnet?

Autor: der schreckliche Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bahner!
Spendiere Deinen Operationsverstärkern ein eigenes Netzteil mit 
symmetrischer Spannung, dann funktionierts.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bahner schrieb:
> Wenn ich das also ans Gleis anschließe (also am Booster-Ausgang) habe
> ich keine Masse in meinem Sinn.

Aber dem Massenanschluss des 5V Reglers.
Schon richtig, der ist nicht "Masse im eigentlichen Sinn", zumidnest 
nicht identisch mit Basse vom Booster.

> Der Gegenpol hat mal GND mal +24V.

Nein, mal +24V und mal -24V .

Es klingt also doch, als ob du es richtig verdrahtest hast, Masse nicht 
noch woanders angeschlossen hast,

Dann ist vielleicht deine Diode keine Schottky sondern zu langsam für 
20kHz, nur eine 1N4001 ?

Es weiss ja kein Mensch was du wirklich hast, weil du keinen Schaltplan 
lieferst, und zu faul bist die richtigen Bauteilwerte dranzuschreiben, 
da kann man nur raten und nicht helfen.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.