Forum: Mikrocontroller und Digitale Elektronik CMOS 40193 Datenhaltung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Volkmar N. (toni_20)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Hallo Elektronikergemeinde,
ich benötige zum CMOS 40193 euere Hilfe.
Nach Abschaltung der Betriebsspannung von 12V soll der 40193 weiter mit 
Spannung versorgt werden und den vorhandenen Zählerstand bis zum 
erneuten Anlegen der Betriebsspannung halten und dann der restlichen 
Schaltung den Wert zur Verfügung stellen. Dazu habe ich einen 7805 zur 
Speisung eines Goldcaps vorgesehen. Diese Betriebsspannung von 5,0V habe 
ich fein säuberlich von den restlichen Betriebsspannungen getrennt. Die 
Spannungshaltung durch den Goldcape funktioniert einwandfrei und auch 
sehr lange Zeit (mehrere Tage).
Jedoch wird trotz anliegenden 5,0V der Zählerstand nicht gehalten. 
Folgende Beschaltung der 40193er Pins:
- Pin 1, 9, 10, 15 direkt an GND
- Pin 4, 5 mit 12k-Widerstand als Pull-up an Vcc (+5,4V). Die Vcc liegt 
am Ausgang des 7805 an vor der Shottky-Diode zum Goldcap. Das Ein- und 
Auszählen erfolgt mittel Hallsensoren TLE 4905. Diese sind aus 
verdrahtungstechnischen Gründen an +12V angeschlossen. Mit größerem 
Aufwand lässt sich auch Vcc anschließen.
- Pin 11, 13 verbunden
- Pin 12 offen
- Pin 14 mit Pull-down-Widerstand von 3,3k an GND. Reset mit Vcc.
- Pin 2, 3, 6, 7 direkt an den Eingängen eines OR 4072. Dieses OR liegt 
an +12V, da extern Einiges zu steuern ist.
Die Prüf-LED´s sind nur zeitweise aufgesteckt. Ob vorhanden oder nicht, 
hat keinen erkennbaren Einfluss auf den Pegel an den Ausgängen QA-QD.
Kann mir jemand einen Tipp geben?
Viele Grüße
Toni_20

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Funktioniert es nie? Oder mal ja...mal nein?
Können die 40193 ggf. beim Anlegen der 12 Volt durch S1 bzw. S2 resetet 
werden? Hast Du die Möglichkeit die Cleareingänge mit einem Oszi zu 
messen? Und zwar sowohl beim Abschalten, wie auch beim Einschalten der 
12 Volt?

Schön gezeichneter Plan?

: Bearbeitet durch User
von fast (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Kann mir jemand einen Tipp geben?

Abblockkondensatoren fehlen

von Jens G. (jensig)


Bewertung
1 lesenswert
nicht lesenswert
fast (Gast) schrieb:

>Abblockkondensatoren fehlen

Das wäre Nummer 1.

Weiterhin denke ich, die Beschaltung der Up/Down-Eingänge an 5V (die 
ihrerseits abschaltbar ist) ist sicherlich sehr unglücklich. Denn das 
Abschalten der 5V geschieht ja vermutlich rel. langsam (wegen der 
Kondensatoren um den 7805), so daß beide Eingänge zwischendurch 
gleichzeitig in undefinierbarem Zustand sind. Damit möglicherweise 
intern ebenfalls undefiniert, bzw. kann intern zu Schwingungen führen, 
die gezählt werden.
Du müsstest die Pullups also am besten über den Goldcap dauerversorgen.

: Bearbeitet durch User
von georg (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> - Pin 2, 3, 6, 7 direkt an den Eingängen eines OR 4072. Dieses OR liegt
> an +12V, da extern Einiges zu steuern ist.

Wenn die Gatter IC4 nicht ebenfalls mit Notstrom versorgt sind, 
schliessen sie die Ausgänge der ICs 2 und 3 kurz.

Georg

von toni_20 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo miteinander,
erst einmal herzlichen Dank für euere Hinweise. Ich werde diese jetzt 
testen und dann ein Resultat bekanntgeben.
Tschüß
toni_20

von Jörg R. (solar77)


Bewertung
1 lesenswert
nicht lesenswert
georg schrieb:
> Volkmar N. schrieb:
>> - Pin 2, 3, 6, 7 direkt an den Eingängen eines OR 4072. Dieses OR liegt
>> an +12V, da extern Einiges zu steuern ist.
>
> Wenn die Gatter IC4 nicht ebenfalls mit Notstrom versorgt sind,
> schliessen sie die Ausgänge der ICs 2 und 3 kurz.

Ich denke nicht dass die Ausgänge kurzgeschlossen werden. Sie werden 
allerdings dadurch belastet weil IC4 über die Schutzdioden an den 
Eingängen mit Strom versorgt wird.


Jens G. schrieb:
> Weiterhin denke ich, die Beschaltung der Up/Down-Eingänge an 5V (die
> ihrerseits abschaltbar ist) ist sicherlich sehr unglücklich. Denn das
> Abschalten der 5V geschieht ja vermutlich rel. langsam (wegen der
> Kondensatoren um den 7805), so daß beide Eingänge zwischendurch
> gleichzeitig in undefinierbarem Zustand sind. Damit möglicherweise
> intern ebenfalls undefiniert, bzw. kann intern zu Schwingungen führen,
> die gezählt werden.
> Du müsstest die Pullups also am besten über den Goldcap dauerversorgen.

Wichtiger Hinweis:-)

von toni_20 (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hallo,
ich habe experimentiert und bekomme folgendes Ergebnis:
-fast: habe allen 3 IC einen C mit 100nF spendiert -> kein Erfolg, 
bleiben aber trotzdem drin
-georg: habe IC4 (4072) entfernt, aber die Prüf-LED mit Vorwiderstand 
belassen (muss ja den Zählerstand sehen) -> kein Erfolg
LED`s ausgebaut -> keine Wirkung bzgl. Zählerstand-Sicherung. Im 
Gegenteil, nach jedem Wiederanschließen der Betriebsspannung ändert sich 
der Zählerstand am 40193
-jörg: bzgl. der Beschaltung IC4 scheint der Hinweis zu stimmen.

Es ist schon eine verflixte Kiste. Wie sagt man so schön?: Elektronen 
gehen manchmal seltsame Wege.
- jens: Pull-ups über Goldcap versorgt -> auch kein Erfolg
- jörg: ich habe ein Oszilloskop, keinen echten Oszi. Ich werde es 
morgen mal hervorkramen und mir das Bild an den clear-Eingängen ansehen.

Ich danke allen ganz herzlich, die mir hier ihre Unterstützung angeboten 
haben. Die Lösung wird schon noch zu finden sein. Ist auch ein bisschen 
vertrackt mit meinen Wünschen. Bleibt bitte zu diesem Thema auf Sendung. 
Ich melde mich bald wieder.
Tschüß

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Weshalb hast Du den Eingang PE (Preset Enable, Pin11) mit dem Ausgang 
Borrow (Pin13) verbunden. PE übernimmt mit H auf L die Daten der 
J-Eingänge. Die liegen bei Dir auf L, womit dann auch die Ausgänge auf L 
gesetzt werden. Ich würde PE (Pin11) fest auf H legen. Borrow (Pin13) 
bleibt offen. Der Ausgang ist eigentlich dafür um die Chips zu 
kaskadieren.

: Bearbeitet durch User
von toni_20 (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hallo Jörg, da muss ich mal tiefer in die Trickkiste greifen. Die 
Schaltung soll zur Prüfung der Belegung und der Freimeldung eines 
Gleisabschnittes auf meiner Modellbahnanlage dienen. Mit der Verbindung 
von Pin 11 mit 13 wird bei einer fehlerhaften Einzählung oder nicht 
vollzogener Einzählung  eine Rücksetzung bei der Auszählung auf 0000 
erreicht. Denn, wenn 2 Achsen eingezählt wurden und 3 Achsen ausgezählt 
werden, spricht man von Minusachsen. Und die will ich mit der Verbindung 
vermeiden, denn sonst müsdte ich einen Generalreset ausführen was dann 
zum Chaos ausartet.
Ich hoffe, dass ich mich verständlich ausgedrückt habe.
Volkmar

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Volkmar,

kannst Du trotzdem zum testen Pin11 auf H legen? Ich vermute das Pin11 
beim Einschalten kurz auf L gezogen wird und dadurch der gespeicherte 
Zählerstand überschrieben wird.

von toni_20 (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hallo Jörg, mache ich. Hart auf Goldcap-Spannung oder über 
Pull-up-Widerstand?  Muss aber erstmal ins Reich der Träume 
verschwinden.

von toni_20 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Georg, ich habe falsch geantwortet. Bitte Beitrag von 20.06 Uhr 
lesen.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
toni_20 schrieb:
> Hallo Jörg, mache ich. Hart auf Goldcap-Spannung oder über
> Pull-up-Widerstand?  Muss aber erstmal ins Reich der Träume
> verschwinden.

Direkt an den Goldcap.

PS: Du schreibst unter 2 Accounts....

: Bearbeitet durch User
von Jens G. (jensig)


Bewertung
1 lesenswert
nicht lesenswert
@ Volkmar N. (toni_20)

>LED`s ausgebaut -> keine Wirkung bzgl. Zählerstand-Sicherung. Im
>Gegenteil, nach jedem Wiederanschließen der Betriebsspannung ändert sich
>der Zählerstand am 40193

Wie sieht denn das Layout der Platine aus? Nicht daß Du die Masse vom 
12-Anschluß vorm 470µ quer über die Platine gelegt hast, und 
zwischendurch schon irgendwelche CMOS-Eingänge mit der Masse verbunden 
hast. Kannste mal ein Foto der Platine vorn/hinten zeigen?

Mal ein Test: entferne mal den 470µ am 12V-Anschluß, evtl. durch einen 
ganz kleinen ersetzen (1µ oder so), und/oder auch mal einen Serien-R in 
die 12V-Leitung legen, um die Stromspitze durch den C beim Anlegen der 
12V zu reduzieren.
Tritt das Problem eigentlich auch auf, wenn die Sensoren nicht dran 
sind? Da die ja wohl auch an den 12V hängen, kann es ja evtl. sein, daß 
die beim Einschwingen erstmal kurz unkoordiniert hin-und herschlackern. 
Also dort auch mal oszilloskopieren.

von Sebastian S. (amateur)


Bewertung
0 lesenswert
nicht lesenswert
Hast Du mal versucht Rückschlüsse aus dem Zählerstand, nach einem 
Aus-Ein-Zyklus, zu gewinnen.
0         Könnte aus einem fehlerhaften Reset resultieren.
+/-1      Aus fehlerhaften Ticks an den zugehörigen Eingängen.
Fahrkarte Könnten sich aus langsamen Pegeländerungen ausbilden.

Darüber hinaus kann ich den Ansatz: Steuereingänge über den 
Speicherkondensator fixieren, nur unterstützen. Auch können ein paar 
Kondensatoren, an strategisch Wichtigen Punkten nicht schaden. Wurde 
aber bereits, von Anderen, gesagt.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Dieses OR liegt an +12V, da extern Einiges zu steuern ist.

Hier habe ich ein Verständnisproblem. IC4 (CD4072) steuert doch nur 2 
Transistoren an, das kann er doch auch wenn er mit 5 Volt versorgt wird.

Da er derzeit mit 12 Volt versorgt wird kann er H-Pegel von IC2 bzw. IC3 
eigentlich nicht erkennen. H-Pegel von diesen ICs haben unter 5 Volt, 
was für IC4 als H zu wenig ist.

von Volkmar N. (toni_20)


Bewertung
0 lesenswert
nicht lesenswert
Jörg R. schrieb:
> toni_20 schrieb:
>> Hallo Jörg, mache ich. Hart auf Goldcap-Spannung oder über
>> Pull-up-Widerstand?  Muss aber erstmal ins Reich der Träume
>> verschwinden.
>
> Direkt an den Goldcap.
>
> PS: Du schreibst unter 2 Accounts....

Hallo Jörg, Fehler mit account bemerkt. Hatte mich versehentlich 
abgemeldet.
Pin 11 an Goldcap-H bringt keine Verbesserung. Beim Anlegen der 12V 
kommt jedesmal ein anderer Zählerstand. Ich verbinde wieder 11 mit 13.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Jörg R. schrieb:
>> toni_20 schrieb:
>>> Hallo Jörg, mache ich. Hart auf Goldcap-Spannung oder über
>>> Pull-up-Widerstand?  Muss aber erstmal ins Reich der Träume
>>> verschwinden.
>>
>> Direkt an den Goldcap.
>>
>> PS: Du schreibst unter 2 Accounts....
>
> Hallo Jörg, Fehler mit account bemerkt. Hatte mich versehentlich
> abgemeldet.
> Pin 11 an Goldcap-H bringt keine Verbesserung. Beim Anlegen der 12V
> kommt jedesmal ein anderer Zählerstand. Ich verbinde wieder 11 mit 13.

Ich würde Pin 11 noch auf H lassen und auf den Kommentar von Jens 
verweisen.

Beitrag "Re: CMOS 40193 Datenhaltung"

Die Up/Down Zähleingabge sind H-aktiv. Daher würde ich sie auch nicht 
mit Pull-Up Widerständen versehen. Ggf. müsste die Ansteuerung angepasst 
werden.

Volkmar N. schrieb:
> Dieses OR liegt an +12V, da extern Einiges zu steuern ist.

Den Leds die von den Transistoren geschaltet werden reichen auch 5 Volt. 
Das was noch über die Transistoren geschaltet/signalisiert wird erkenne 
ich jetzt nicht, aber diese Signale werden ja nach GND geschaltet. Sind 
die 12 Volt überhaupt notwendig?

Fragen über Fragen....

Vermutlich muss doch mal mit einem Oszi gemessen werden, es muss ja 
einen Grund geben wodurch der Zählerstand verändert wird.

Wie testest Du aktuell? Ist die Schaltung auf einem Breadboard? Zeige 
doch mal einige Fotos von der Testschaltung.

: Bearbeitet durch User
von Volkmar N. (toni_20)


Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> @ Volkmar N. (toni_20)
>
>
> Wie sieht denn das Layout der Platine aus? Nicht daß Du die Masse vom
> 12-Anschluß vorm 470µ quer über die Platine gelegt hast, und
> zwischendurch schon irgendwelche CMOS-Eingänge mit der Masse verbunden
> hast. Kannste mal ein Foto der Platine vorn/hinten zeigen?
>
Das Layout ist noch nicht fertig. Habe die Schaltung auf einem 
Steckboard aufgebaut. Die Masse ist wie in der Schaltung ersichtlich 
gelegt; also Masse ist für alle Spannungsbereiche gleich, da alles von 
den 12V ausgeht.


> Mal ein Test: entferne mal den 470µ am 12V-Anschluß, evtl. durch einen
> ganz kleinen ersetzen (1µ oder so), und/oder auch mal einen Serien-R in
> die 12V-Leitung legen, um die Stromspitze durch den C beim Anlegen der
> 12V zu reduzieren.
> Tritt das Problem eigentlich auch auf, wenn die Sensoren nicht dran
> sind? Da die ja wohl auch an den 12V hängen, kann es ja evtl. sein, daß
> die beim Einschwingen erstmal kurz unkoordiniert hin-und herschlackern.
> Also dort auch mal oszilloskopieren.

1my und 47R eingebaut. Keine Verbesserung. Zählerstand weiterhin bei 
Anlegen der 12V verschieden. Problem tritt auch auf wenn TLE ohne 
Spannung sind oder auch an Vcc anliegen. Mit dem Oszi geht es nachher 
los. Ich möchte nur mal alles beantworten.
Volkmar

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Ich möchte nur mal alles beantworten.

Da ist noch einiges an Fragen unbeantwortet?

von Volkmar N. (toni_20)


Bewertung
0 lesenswert
nicht lesenswert
Jörg R. schrieb:
>
> Hier habe ich ein Verständnisproblem. IC4 (CD4072) steuert doch nur 2
> Transistoren an, das kann er doch auch wenn er mit 5 Volt versorgt wird.
>
> Da er derzeit mit 12 Volt versorgt wird kann er H-Pegel von IC2 bzw. IC3
> eigentlich nicht erkennen. H-Pegel von diesen ICs haben unter 5 Volt,
> was für IC4 als H zu wenig ist.

Auswertung mittels 4072 klappt einwandfrei. Somit muss auch H-Pegel 
erkannt werden. Ich könnte nur die Vcc für die Betriebsspannung 
verwenden, sonst ist der Goldcap in kurzer Zeit leer. Wurde unfreiwillig 
getestet. Die schnellere Entladung (ca. 12h) passiert auch, wenn ich die 
Pull-up-Widerstände am Goldcap anlege. Ist deshalb vorerst zurückgebaut, 
aber ich könnte notfalls damit leben, muss eben meine Betriebsführung 
anpassen.
Volkmar

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Auswertung mittels 4072 klappt einwandfrei. Somit muss auch H-Pegel
> erkannt werden.

Es spricht gegen die Specs, daher ist es wohl Zufall das es 
funktioniert.


> Ich könnte nur die Vcc für die Betriebsspannung
> verwenden, sonst ist der Goldcap in kurzer Zeit leer. Wurde unfreiwillig
> getestet. Die schnellere Entladung (ca. 12h) passiert auch, wenn ich die
> Pull-up-Widerstände am Goldcap anlege. Ist deshalb vorerst zurückgebaut,

Dann sind die Eingänge bei abgeschalteter Versorgungsspannung offen, was 
bei CMOS IC zu undefinierten Zuständen führen kann.

Welche Zeit soll/muss durch den Goldcap überbrückt werden? Die gibt es 
auch größer als 1F, oder du nimmst 2 von den 1F.

Die PullUp sind mit 12K relativ klein bemessen.


> aber ich könnte notfalls damit leben, muss eben meine Betriebsführung
> anpassen.

Ich vermute mittlerweile eher das die Schaltung komplett überarbeitet 
werden muss.

: Bearbeitet durch User
von Volkmar N. (toni_20)


Bewertung
0 lesenswert
nicht lesenswert
Erst einmal vielen Dank an alle, die hier mitgewirkt haben.
Die Transistoren müssen an 12V bleiben, da sie 12V-Relais steuern. 
Aufbau ist schon fertig. Die Vcc dient nicht nur als Vorausspannung für 
den Goldcap, sondern speist eine Reflexlichtschranke. Den 4072 habe ich 
auf Vcc gesetzt. Hat leider auch nichts gebracht.
Jörg, noch eine Bitte. Ich denke Änderungsbedarf besteht hauptsächlich 
in der Verbindung der 40193 zum 4072 und das Setzen der 
Pull-up-Widerstände. Wäre noch etwas sehr wichtig?
Volkmar

von Jens G. (jensig)


Bewertung
1 lesenswert
nicht lesenswert
Volkmar N. (toni_20) schrieb:

>Das Layout ist noch nicht fertig. Habe die Schaltung auf einem
>Steckboard aufgebaut. Die Masse ist wie in der Schaltung ersichtlich
>gelegt; also Masse ist für alle Spannungsbereiche gleich, da alles von
>den 12V ausgeht.

In der Schaltung sieht man nicht, wie die Massen verbunden sind, sondern 
nur, daß die Massen verbunden sind.
Gut, wenn es ein Steckbrett ist, würde mich der Aufbau des Steckbretts 
interessieren, ...

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Den 4072 habe ich auf Vcc gesetzt.

Ich würde den trotzdem parallel zu den 40193 betreiben. Ansonsten wird 
er über seine Eingänge mit Strom versorgt, wie weiter oben geschrieben.

> Hat leider auch nichts gebracht.

Es ist aber auch nicht schlechter geworden...

> Jörg, noch eine Bitte. Ich denke Änderungsbedarf besteht hauptsächlich
> in der Verbindung der 40193 zum 4072 und das Setzen der
> Pull-up-Widerstände. Wäre noch etwas sehr wichtig?

Ja, die anderen offenen Fragen, z.B. das die Eingänge der 40193 offen 
sind wenn die Versorgungsspannung fehlt. Das kann gravierende 
Auswirkungen auf die Schaltung haben.

Jens G. hat das gut beschrieben, leider gehst Du darauf nicht ein.

Ich würde die Chips auch nicht mit den open Collector aus den TLE 
ansteuern. Es gibt vermutlich auch Halksensoren die postive Impulse 
ausgeben. Ansonsten würde ich die Signale invertieren, z.B. mit einem 
CD4093.


Jens G. schrieb:
> Gut, wenn es ein Steckbrett ist, würde mich der Aufbau des Steckbretts
> interessieren, ...

Mich auch;-)

: Bearbeitet durch User
von holger (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Ich würde den trotzdem parallel zu den 40193 betreiben. Ansonsten wird
>er über seine Eingänge mit Strom versorgt, wie weiter oben geschrieben.

Dann entlädt der 4072 bei high am Ausgang über den Basistrom
den Goldcap. Das könnte man umgehen wenn man BS170 statt BC547 nimmt.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
>>Ich würde den trotzdem parallel zu den 40193 betreiben. Ansonsten
> wird
>>er über seine Eingänge mit Strom versorgt, wie weiter oben geschrieben.
>
> Dann entlädt der 4072 bei high am Ausgang über den Basistrom
> den Goldcap. Das könnte man umgehen wenn man BS170 statt BC547 nimmt.

Ja, stimmt. Ich hatte an den IRLML2502 gedacht, ist allerdings SMD.

von Volkmar N. (toni_20)


Bewertung
0 lesenswert
nicht lesenswert
Der 4072 und die Pull-ups sind auf Goldcap-Spannnung. Ich hatte das 
schon ausprobiert, aber vergessen Jens G. zu antworten. Pull-ups auf 
390k ausgetauscht und sind damit erheblich höher als vorher (12k). Die 
Idee mit dem 4093-er Schmidt-Trigger ist gut. Probiere es nachher aus. 
Ich bin jetzt auch soweit, dass es die TLE sind, die Unfug machen. Ich 
kann Zudtände simulieren, bei denen die Zustände erhalten bleiben und 
bei anderem Zählerstand falsch anzeigen.
Das Foto vom Board kommt gleich. Muss noch auf den Auslöser drücken.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Jörg R. schrieb:
> holger schrieb:
>>>Ich würde den trotzdem parallel zu den 40193 betreiben. Ansonsten
>> wird
>>>er über seine Eingänge mit Strom versorgt, wie weiter oben geschrieben.
>>
>> Dann entlädt der 4072 bei high am Ausgang über den Basistrom
>> den Goldcap. Das könnte man umgehen wenn man BS170 statt BC547 nimmt.
>
> Ja, stimmt. Ich hatte an den IRLML2502 gedacht, ist allerdings SMD.

Das macht der 4072 allerdings auch wenn er parallel zu den 40193 liegt.


Volkmar N. schrieb:
> Probiere es nachher aus. Ich bin jetzt auch soweit, dass es die TLE sind, > die 
Unfug machen.

Kann es passieren das mehrere TLE gleichzeitig! Signale liefern?

Wenn 4093 müssen die Eingänge mit PullUp beschaltet werden, aber auch 
recht hochohmig. Der 4093 kommt mit seiner Versorgungsspannung auch 
parallel zu den anderen Chips.

Die PullUp an den 40193 können dann entfallen.

von Volkmar N. (toni_20)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Danke für euere Unterstützung.
Anbei das Foto vom Board. Ich weiß, was jetzt kommt. Aber auch auf einer 
Platine gibt es Rennbahnen für Elektronen.
Das Experiment mit dem BS170 will ich gern machen. Habe aber keinen da 
und mein Elektronikhändler hat gestern für immer geschlossen. Ich habe 
jedoch noch nie mit MOSFETs gearbeitet. Auch solche Leute muss es geben. 
Was entsprechen DGS den EBC? Sind diese so einfach austauschbar? Diese 
Baustelle kann ich erstmal vor mir herschieben, da es sich "nur" um die 
Entladezeit geht.
Jetzt teste ich mit dem 4093.

von Volkmar N. (toni_20)


Bewertung
1 lesenswert
nicht lesenswert
Hallo miteinander,
die Schaltung funktioniert jetzt einwandfrei. Ich habe ganz konsequent 
alles was zum 40193 gehört auf Goldcap-Spannung geholt, auch die TLE. 
Und siehe da, es funzt. Ich hatte bisher immer nur Einzeltests gemacht, 
die dann mit dem nächsten Versuch sich nicht unbedingt vertragen haben.
Den Versuch mit dem 4093 und dem BS170 werde ich auf jeden Fall noch 
machen.

Dank eures Fachwissens wurde schlussendlich alles so, wie ich es mir 
vorgestellt habe. DANKE!
Ich wünsche euch ein schönes Weihnachtfest.
Jörg bitte ich noch um Beantwortung meines Beitrags von 16.41 Uhr. Dann 
wäre ich ein zufriedener Mensch.
Danke nochmals.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Hallo miteinander, die Schaltung funktioniert jetzt einwandfrei.

Glückwunsch, und schön dass mal jemand eine Rückmeldung gibt?


> Ich habe ganz konsequent alles was zum 40193 gehört auf Goldcap-Spannung
> geholt, auch die TLE.

Hier muss ich Deine Freude etwas trüben. Der TLE hat lt. DB einen 
relativ hohen Eigenverbrauch von mindestens 3mA. Der Wert kann daher 
auch etwas höher liegen. Das ist abhängig von der Betriebsspannung, dem 
Schaltzustand und natürlich von Exemplarstreuungen.
Der 1F Goldcap wird daher nicht lange zur Überbrückung reichen. Wenn Du 
ein Multimeter anschließt kannst Du dabei zusehen wie schnell die 
Spannung sinkt.

Daher würde ich versuchen die TLE wieder anders zu versorgen. Mal sehen 
wie es sich verhält wenn der 4093 zum Einsatz kommt.

Alternativ zum TLE könntest Du auch Reedkontakte verwenden.

Vorteil: Keine Eigenstromaufnahme
Nachteil: deutlich langsamer als der TLE


> Den Versuch mit dem 4093 und dem BS170 werde ich auf jeden Fall noch
> machen.

Wenn auch der CD4072 an dem Goldcap hängt (so würde ich es machen) kommt 
der BS170 nicht in Frage. Vgs ist für einen definierten Rdson lt. DB mit 
10 Volt spezifiziert. Im TO92 Gehäuse käme der BS108 in Frage, den gibt 
es nur leider nicht mehr zu kaufen. Als SMD Version ginge der IRLML2502, 
falls Du das löten kannst. In TO220 kämen einige in Frage. Die wären 
zwar überdimensioniert, aber wen stört es?


> Jörg bitte ich noch um Beantwortung meines Beitrags von 16.41 Uhr. Dann
> wäre ich ein zufriedener Mensch.


Meinst Du diesen Punkt?

Volkmar N. schrieb:
> Was entsprechen DGS den EBC? Sind diese so einfach austauschbar? Diese
> Baustelle kann ich erstmal vor mir herschieben, da es sich "nur" um die
> Entladezeit geht.

Deine Reihenfolge ist nicht ganz korrekt. Grob vergleichbar ist es so:

„Normaler“ Transistor: EBC - Emitter-Basis-Collector
Mosfet:                SGD - Source-Gate-Drain

Einen Vorwiderstand wie bei dem BC547 benötigt man nicht. Das Gate kann 
direkt mit dem Ausgang des 4072 verbunden werden. Das IC wird nicht 
durch den Mosfet belastet, außer ganz kurz während des Schaltvorgangs.

Source (Emitter) geht auf GND und an Drain (Collector) kommt die Last.

Siehe auch:
https://www.mikrocontroller.net/articles/Transistor
https://www.mikrocontroller.net/articles/Relais_mit_Logik_ansteuern


> Ich wünsche euch ein schönes Weihnachtfest.

Das wünsche ich Dir und den anderen Usern auch⭐️⭐️⭐️

: Bearbeitet durch User
von Volkmar N. (toni_20)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antwort. Jetzt der Reihe nach meine Kommentare.
Der TLE hat den entscheidenten Vorteil, dass er nicht prellt. Die 
Reaktionszeit des Reed ist nicht ausschlaggebend, Modellbahn geht 
langsam.
Es macht keine Freude der schnell sinkenden Goldcap-Spannung zuzusehen. 
Ich werde es nochmal mit Vcc oder 12V testen. Aber richtige Funktikn 
hatte ich erst mit den TLE an Goldcap-Spannung. Letztendlich bleibt mir 
der Reed, den ich eben dann entprellen muss. Ist ein Kompromiss, aber 
ein guter.
Den Test mit dem 4093 werde ich noch machen, aber es wird ein bißchen 
dauern, da sich Weihnachten mit seinen Freuden und Verpflichtungen mit 
großen Schritten nähert. Bleibe bitte auf Empfang.
Vielen dank für die beiden Links. Werde ich in Ruhe studieren.
Tschüß

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Volkmar N. schrieb:
> Der TLE hat den entscheidenten Vorteil, dass er nicht prellt.
> Letztendlich bleibt mir der Reed, den ich eben dann entprellen muss.

Der 4093 ist ja ein Schmitt-Trigger. Daher würde eine RC-Kombination zur 
Entprellung wohl reichen.

Alternativ zum 4093 ginge auch der 40106. Der hat 6 Inverter, ebenfalls 
mit Schmitt-Trigger-Charakteristik.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.