mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LTspice LM4041 Texas Modell will nicht mit K an GND


Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:
Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Wer findet den Fehler in der LM4041_002.asc ?

Sonnst schiebe ich das Modell nach Texas, grrr.

LG
old.

Nota: Die 12V Quelle besitzt 1KOhm Innenwiderstand.

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
Es gibt im Modell LM4041.cir eine Zeile in der auf das Netz GND(0) 
referenziert wird, V(Q20B). Das muss V(Q20B,V-) heißen. Dann gehts.

Alt:
E_Estart         N30465 V- VALUE { max(0.4*(1-V(VB_Q2, VB_Q3)/.05), 
0)+V(Q20B)
+  }

Neu:
E_Estart         N30465 V- VALUE { max(0.4*(1-V(VB_Q2, VB_Q3)/.05), 
0)+V(Q20B,V-)
+  }


Im Anhang die korrigierte Datei LM4041.cir.


Nachtrag:
> Sonst schiebe ich das Modell nach Texas, grrr.

Das könntest du ja trotzdem machen und denen gleich schreiben was sie 
ändern sollen.

: Bearbeitet durch User
Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Jahahahah, Du bist genial! Danke.

Ich hatte das Ding voll Zuversicht in meine Schaltung
eingebaut und stundenlang den Fehler gesucht.

In meiner Not habe ich mir schon ein Modell mit opamp gebastelt.

Helmut S. schrieb:
> Das könntest du ja trotzdem machen und denen gleich schreiben was sie
> ändern sollen.

Will mich ja nicht mit fremden Federn schmücken.

LG
old.

: Bearbeitet durch User
Autor: Helmut S. (helmuts)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Ich habe jetzt mal in einem TI-Forum das Problem beschrieben und die 
Lösung gleich dazu. Mal sehen ob die das korrigieren.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wäre nett, wenn Du mich dem Laufenden hältst.

Komisch.
Das würde ja bedeuten, die hätten noch nie eine negative
Spannung mit dem Modell stabilisiert, oder?

LG
old.

: Bearbeitet durch User
Autor: Helmut S. (helmuts)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Aus der W. schrieb:
> Wäre nett, wenn Du mich dem Laufenden hältst.
>
> Komisch.
> Das würde ja bedeuten, die hätten noch nie eine negative
> Spannung mit dem Modell stabilisiert, oder?
>
> LG
> old.

Die haben ja encrypted Modelle für TINA-TI und PSPICE. Diese Modelle 
sind intern vermutlich mit der realen Schaltung aus Transistoren und 
Widerständen aufgebaut. Deshalb haben die das Problem nicht.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Die haben ja encrypted Modelle für TINA-TI und PSPICE. Diese Modelle
> sind intern vermutlich mit der realen Schaltung aus Transistoren und
> Widerständen aufgebaut. Deshalb haben die das Problem nicht.

Der Fehler wurde wohl nur deshalb nicht erkannt, weil keiner mit der 
Sonderlocke rumspielt.

Autor: Mark S. (voltwide)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch es gibt einen. In einem unbeugsamen Dorf im Westen Germaniens.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Aus der W. schrieb:
>> Wäre nett, wenn Du mich dem Laufenden hältst.
>>
>> Komisch.
>> Das würde ja bedeuten, die hätten noch nie eine negative
>> Spannung mit dem Modell stabilisiert, oder?
>>
>> LG
>> old.
>
> Die haben ja encrypted Modelle für TINA-TI und PSPICE. Diese Modelle
> sind intern vermutlich mit der realen Schaltung aus Transistoren und
> Widerständen aufgebaut. Deshalb haben die das Problem nicht.

Kurze Rückmeldung
TI hat reagiert und die wollen sich das mal anschauen. Sie haben aber 
auch geschrieben, dass sie mit TINA-TI testen und nicht garantieren 
können, dass das auch mit anderen Simulatoren immer funktioniert.

Ich habe gerade mal deren TINA-TI-Beispiel mit TINA-TI getestet. Ja es 
funktioniert mit floating supply, aber nur mit positiver 
Betriebsspannung. Wenn man eine negative Betriebsspannung nimmt, dann 
versagt auch deren encrypted model. Da gehen bei denen wohl 
Substratdioden an die in dem encrypted Modell an Netz 0 hängen. Das 
werde ich denen aber erst berichten nachdem sie die nicht encrypted 
Modelle repariert haben.

Autor: Falk B. (falk)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Es gibt im Modell LM4041.cir eine Zeile in der auf das Netz GND(0)
> referenziert wird, V(Q20B). Das muss V(Q20B,V-) heißen. Dann gehts.

Wie kann man denn in einem Modell ein ABSOLUTES Potential referenzieren? 
Das ist doch ein totale NO-GO!!! An sich muss doch jedes Bauteil auf 
beliebigem Potential funktionieren.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Falk B. schrieb:
> Helmut S. schrieb:
>> Es gibt im Modell LM4041.cir eine Zeile in der auf das Netz GND(0)
>> referenziert wird, V(Q20B). Das muss V(Q20B,V-) heißen. Dann gehts.
>
> Wie kann man denn in einem Modell ein ABSOLUTES Potential referenzieren?
> Das ist doch ein totale NO-GO!!! An sich muss doch jedes Bauteil auf
> beliebigem Potential funktionieren.

Mann muss ihnen zugutehalten, dass sie die Absicht hatten das Modell 
potentialfrei zu machen. Sie haben nur eine einzige Stelle vergessen. 
Das kann ja mal passieren.

Autor: ArnoR (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Das hier diskutierte Problem haben auch andere. Beispielsweise die 
Mosfet-Treiber-ICs TC1410/11 von Microchip. Hab mich das auch schon 
schwarz geärgert.

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Mann muss ihnen zugutehalten, dass sie die Absicht hatten das Modell
> potentialfrei zu machen. Sie haben nur eine einzige Stelle vergessen.
> Das kann ja mal passieren.

ACK, das kommt immer mal wieder vor. Für einen ausführlichen Test der 
Modelle ist halt meistens kein Geld da.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Für einen ausführlichen Test der
> Modelle ist halt meistens kein Geld da.

Das machen wir dann, und helmuts repariert das Modell.

Wenn genug Teile zusammen kommen, bestelle ich die LM4041
nächste Woche bei RS und hoffe, dass es real so arbeitet
wie im korrigierten Modell.

LG
old.

: Bearbeitet durch User
Autor: Dieter (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Fuer das Erkennen und Verbesserungsvorschlag waere es fair, wenn TI ein 
paar Muster spendieren wuerde.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meinst Du, die bauen die noch in TO92?

Beitrag "Re: suche eine Spannungsreferenz wie TL431."

LG
old.

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Aus der W. schrieb:
> Meinst Du, die bauen die noch in TO92?

http://www.ti.com/product/LM4041-N/samplebuy

Autor: hinz (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Aus der W. schrieb:
> Das machen wir dann, und helmuts repariert das Modell.

http://www.moronisamerica.com/wp-content/uploads/2017/04/someone2Bis2Bwrong_zpsncnzkixr.png


Ich sicher nicht.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Ich sicher nicht.

Ja wie auch?

Du und deine Freunde hier, wussten bis vor
Kurzem nicht, dass dieses Bauteil existiert,
geschweige denn wie es arbeitet,
noch wozu man es brauchen könnte.

Wer das nicht glaubt, kann das noch halbwegs
in dem zu hinz Gunsten, leider kräftig durchmoderierten,
Nachbarthread nachlesen:
Beitrag "suche eine Spannungsreferenz wie TL431."

Autor: hinz (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Aus der W. schrieb:
> hinz schrieb:
>> Ich sicher nicht.
>
> Ja wie auch?
>
> Du und deine Freunde hier, wussten bis vor
> Kurzem nicht, dass dieses Bauteil existiert,
> geschweige denn wie es arbeitet,
> noch wozu man es brauchen könnte.

Deine Megalomanie ist wieder ganz groß.



> Wer das nicht glaubt, kann das noch halbwegs
> in dem zu hinz Gunsten, leider kräftig durchmoderierten,
> Nachbarthread nachlesen:
> Beitrag "suche eine Spannungsreferenz wie TL431."

Man hat nur deinen Müll entfernt.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wiege Dich nicht in Sicherheit, Rumpelstilzchen!
Möglicherweise macht ein Moderator mit Gewissen
die letzte Löschaktion rückgängig.
Beitrag "Re: Freundlichkeit neuerdings ein Muss für Beiträge"

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus der W. schrieb:
> Wiege Dich nicht in Sicherheit, Rumpelstilzchen!

Im Gegensatz zu dir verwende ich meinen bürgerlichen Namen.


> Möglicherweise macht ein Moderator mit Gewissen
> die letzte Löschaktion rückgängig.

Du kapierst nicht weshalb gelöscht wurde.


> Beitrag "Re: Freundlichkeit neuerdings ein Muss für Beiträge"

Ja, bei dir ist das chronisch. Man kann das in deinem eigenen Blog 
bestens nachlesen.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Man kann das in deinem eigenen Blog
> bestens nachlesen.

Nicht ganz in deinem Sinne, aber ja, man kann es jetzt im
Blog nachlesen.

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus der W. schrieb:
> hinz schrieb:
>> Man kann das in deinem eigenen Blog
>> bestens nachlesen.
>
> Nicht ganz in deinem Sinne, aber ja, man kann es jetzt im
> Blog nachlesen.

Ja, so sieht jeder wie paranoid du doch bist.

Autor: Aus der W. (Firma: oldeuropesblogs.blogspot.de) (oldeurope)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Aus der W. schrieb:
> Wenn genug Teile zusammen kommen, bestelle ich die LM4041
> nächste Woche bei RS und hoffe, dass es real so arbeitet
> wie im korrigierten Modell.

Endlich sind die LM4041 da. Kleiner Drahtigel zum testen.
Schaut gut aus. :-) Als nächstes wird die Schaltung da
Beitrag "Ich han Fun (mit der Badlüftersteuerung)"
auf LM4041 umgebaut. Ich fange mit der Z-Diode unten mittig
im Bild an. Mache dann im Nachbarthread weiter.

LG
old.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.