Forum: Analoge Elektronik und Schaltungstechnik Low Side Mosfet Schalter Problem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Volker (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich möchte gerne mit meinem Mikrocontroller größere Lasten per PWM 
steuern.

Nach etwas Recherche bin ich zu obiger Schaltung gelangt, einem Low Side 
Switch. Aufgebaut auf einer Lochrasterplatine, Datenblätter sind am Ende 
zu finden.

Einen 12V Lüfter (<10W) habe ich so mit einer 20kHz PWM regeln können, 
auch wenn das EMV technisch nicht mehr wirklich toll aussieht am Oszi.

Jetzt wollte ich so auch mal eine Heizung regeln. Daten des Heizdrahtes 
sind 10A @ 24V.

Allerdings raucht mir hier schon ab ca. 50% PWM (1kHz) und 20V 
Versorgung statt 24V der MOSFET ab. Müsste ca. bei 4A passiert sein.

Woher kommt das?

Statische Verlustleistung:
Der Mosfet hat einen maximalen Rdson von 2,7mOhm ab Vgs > 10V und der 
Gatetreiber hat 12V. Bei einer maximalen Belastung von 10A ergibt das 
eine Verlustleistung von 0,27W. Mit der Thermal Resistance, 
Junction-to-ambient: 62°C/W ergibt das knapp 17°C Temperaturerhöhung.

Mit den Schaltverlusten tue ich mir etwas schwer, aber ich befürchte, 
dass das der Grund ist. Kann mir hier jemand helfen? Ich habe diverse 
Ansätze gefunden und bin mir einfach unsicher.
Mein nächster Ansatz wäre die PWM Frequenz auf ca 1-5 Hz zu setzen, aber 
da ich nicht mehr sonderlich viele MOSFETs habe, hatte ich kurz auf 
Input von euch gehofft, bevor mein Vorrat zur Neige geht.


Datenblätter sind folgende:
Gatetreiber: http://www.ti.com/lit/ds/symlink/ucc37321.pdf
N MOSFET: 
https://www.infineon.com/dgdl/Infineon-IRL40B215-DS-v01_00-EN.pdf?fileId=5546d4625b3ca4ec015b5a5945a3335f

von Sven S. (schrecklicher_sven)


Bewertung
-2 lesenswert
nicht lesenswert
Volker schrieb:
> Allerdings raucht mir hier schon ab ca. 50% PWM (1kHz) und 20V
> Versorgung statt 24V der MOSFET ab. Müsste ca. bei 4A passiert sein.
>
> Woher kommt das?

Nach heftiger Diskussion mit meiner Kristallkugel haben wir uns auf 
folgendes Szenario geeinigt:
Du hast mit den Zuleitungen zum Heizelement eine große Luftspule 
gebildet, und da der Mosfet mangels Freilaufdiode die in der Luftspule 
gespeicherte Energie verheizen musste, ist er den Hitzetot gestorben, 
der Arme.

von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
Ist der Transistor denn vor dem Ausfall heiss geworden?

von Jens M. (schuchkleisser)


Bewertung
-2 lesenswert
nicht lesenswert
Ernst?
Bei 1kHz bringt eine Luftspule den FET um? Als Zuleitung an einer 
niederohmigen Widerstandslast?

Liegt nahe, weil es die Schaltverluste eher nicht sind, die sind ja von 
der Anstiegs/Abfallzeit und zudem der Frequenz abhängig, und die ist ja 
klein.

Vorstellen kann ich mir's trotzdem nicht.

von Michel M. (elec-deniel)


Bewertung
0 lesenswert
nicht lesenswert
....
Beitrag "Re: ltspice MOSFET- Model funktioniert nicht"
viel Spaß beim simulieren :-)

von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
Spulen induzieren hohen Spannungen. Ideale spulen mit idealen 
Schaltvorgängen induzieren unendlich hohe Spannungen.

Da du deinem MOSFET einen starken Treiber spendiert hast, hast du einen 
fast idealen Schalter. Nur verträgt der leider keine hohen Spannungen 
und du hast keinerlei Gegenmassnahmen in der Schaltung.

Wenn er vor dem Kaputt-gehen nicht heiss wurde, kann nur Überspannung 
die Ausfallursache sein.

: Bearbeitet durch User
von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Stefanus F. schrieb:
> Spulen induzieren hohen Spannungen.

Da ist aber keine. Die paar Mikrohenry Zuleitungsinduktivität kann man 
da vergessen.

Es bleibt allerdings zu befürchten, dass man sowas nicht in Ferndiagnose 
herausfinden wird, sondern es wenigstens mal paar Messungen mit einem 
Oszi bedarf, dem näher auf den Grund zu gehen. Um den Transistor nicht 
zu riskieren, würde es ja genügen, wenn der steuernde Controller die PWM 
nur für kurze Zeit einschaltet - der Trigger des Oszis kann das dann 
fangen. Wenn es ein Digitaloszi ist, bleibt das Bild danach stehen, bei 
einem analogen müsste man halt schnell fotografieren. ;)

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
> Stefanus F. schrieb:
>> Spulen induzieren hohen Spannungen.

Jörg W. schrieb:
> Da ist aber keine.

Weisst du wie die Heizung aufgebaut ist?

von Sven S. (schrecklicher_sven)


Bewertung
-1 lesenswert
nicht lesenswert
Jens M. schrieb:
> Ernst?
> Bei 1kHz bringt eine Luftspule den FET um?

Nur der TO weiß, wieviel Meter Durchmesser die hat.

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
Also die "Spule" müsste schon recht groß sein, und/oder der Strom auch, 
um den Mosfet mittels Einzelüberspannungsimpuls killen zu können, denn 
der Mosfet verträgt schon einiges an Avalanche-Energy.
Eher könnte es zum Problem werden durch die dabei freigesetzte Energy, 
wenn man das 1kHz schnell macht. D.h., der stirbt dabei nicht einen 
Überspannungstod, sondern einen Übertemperaturtod.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Stefanus F. schrieb:

>> Da ist aber keine.
>
> Weisst du wie die Heizung aufgebaut ist?

Eine Heizung hat in erster Linie die Aufgabe, elektrische in thermische 
Energie umzuwandeln. Dazu ist es wenig hilfreich, wenn man sie als 
tollen Elektromagneten aufbaut, der unwahrscheinlich viel Energie in 
seinem Magnetfeld speichern könnte …

Aber wie ich oben schon schrieb, ohne Oszi wird das Kaffesatzleserei.

von Achim S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Allerdings raucht mir hier schon ab ca. 50% PWM (1kHz) und 20V
> Versorgung statt 24V der MOSFET ab. Müsste ca. bei 4A passiert sein.

Wenn alles richtig angeschlossen ist, müsste dein Aufbau das locker 
schaffen. Und es müsste schon ein wirklich exotischer Heizungsanschluss 
sein, wenn es tatsächlich die parasitäre Induktivität sein sollte, die 
deinen FET killt.

Hast du schon mal nachgeprüft, dass die Lastversorgung nicht 
versehentlich falsch gepolt angeschlossen ist.

von Michel M. (elec-deniel)


Bewertung
0 lesenswert
nicht lesenswert
ein Bild des Aufbaus könnte hilfreich sein?

von Axel S. (a-za-z0-9)


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Jetzt wollte ich so auch mal eine Heizung regeln. Daten des Heizdrahtes
> sind 10A @ 24V.
>
> Allerdings raucht mir hier schon ab ca. 50% PWM (1kHz) und 20V
> Versorgung statt 24V der MOSFET ab. Müsste ca. bei 4A passiert sein.

"müsste" reicht hier nicht. Miß den Strom besser.

Für welche Temperatur ist dein Heizdraht denn spezifiziert? Kann es 
sein, daß er im kalten Zustand deutlich niederohmiger ist?

Und wie kommst du auf 4A? 10A @ 24V macht 2.4Ω, An 20V wären das 8.33A. 
Den MOSFET interessiert nicht der Mittelwert.

von Volker (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Anregungen.

Das verwendete Heizelement ist ein Heizkreuz und damit wohl schon als 
ordentliche Luftspule zu bezeichnen. Die beiden Oszi-Bilder bestätigen 
eure Hinweise in diese Richtung denke ich.

Das Heizkreuz wurde für den Test nur mit 12V und 30% PWM betrieben, aber 
der MOSFET wurde schon hier recht heiß. Geschätzt ca. 80-100°C

Die Oszibilder zeigen die Drain-Source Spannung bei der Zeitbasis 1ms 
und 1µs. Der MOSFET  erreicht immer die Breakdown Voltage von 40V.

Das dritte Bild ist das Heizkreuz alleine bei 24V beim Ausschalten.

Was würdet ihr mir zur Vermeidung raten? Ist eine Zehner- oder TVS-Diode 
am MOSFET zu empfehlen oder eher eine Freilaufdiode am Heizkreuz? Mit 
einer Lösung direkt an meiner Schaltung und nicht an der Last wäre ich 
etwas flexibler.
Wie müsste ich diese auslegen, besonders mit Blick auf die Leistung an 
der Diode?

von ACDC (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Die Oszibilder zeigen die Drain-Source Spannung bei der Zeitbasis 1ms
> und 1µs. Der MOSFET  erreicht immer die Breakdown Voltage von 40V.

Der Fehler ist, dass du da eine PWM Frequenz von 5MHz hast und nicht 
20kHz.

von Jens M. (schuchkleisser)


Bewertung
-1 lesenswert
nicht lesenswert
Die Diode muss den Spulenstrom halten, weil die Spule eben diesen 
aufrechthalten will.
Also 10A Schottky als Freilauf an die Klemmen in der Nähe des 
Transistors und fertig.
Die Leistung der Diode ist dann auch relativ klein, da ja kleine 
Spannung an ihr liegt.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:

> Das verwendete Heizelement ist ein Heizkreuz und damit wohl schon als
> ordentliche Luftspule zu bezeichnen.

Viel Energie kann die in ihrem Magnetfeld trotzdem nicht speichern, und 
so extrem hoch ist deine Ansteuerfrequenz ja auch nicht.

> Die beiden Oszi-Bilder bestätigen
> eure Hinweise in diese Richtung denke ich.

Was mich am linken Bild stört, sind die „ausgemalten“ Rechtecke. Das ist 
doch eine hochfrequente Schwingung, oder? Jedenfalls keine PWM mit 1 
kHz.

von Achim S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> st eine Zehner- oder TVS-Diode
> am MOSFET zu empfehlen

Damit kannst du dann die Schutzdiode verheizen

Volker schrieb:
> oder eher eine Freilaufdiode am Heizkreuz

Freilaufdiode wäre bei induktiven Lasten das Mittel der Wahl.

Volker schrieb:
> Die beiden Oszi-Bilder bestätigen
> eure Hinweise in diese Richtung denke ich.

Denke ich nicht. Eine Induktionsspitze würde ein mal je PWM-Puls 
auftreten. In deiner ersten Messung sieht man, dass  du eine PWM mit 
1kHz versuchst.

Du hast aber während der gesamten Off-Phase ein Spannungsgezackere im 
Bereich mehrerer MHz. Überprüfe mal dein Netzteil, das die Heizung 
versorgt.

von ACDC (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bitte Messung mit Oszi an Gate vom Fet und am Pin 2 = In und Pin 3 = 
ENBL vom ucc

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
ACDC (Gast) schrieb:

>Volker schrieb:
>> Die Oszibilder zeigen die Drain-Source Spannung bei der Zeitbasis 1ms
>> und 1µs. Der MOSFET  erreicht immer die Breakdown Voltage von 40V.

>Der Fehler ist, dass du da eine PWM Frequenz von 5MHz hast und nicht
>20kHz.

Genau so ist das. Der TO "übertaktet" seinen Mosfet, ohne daß er es 
offensichtlich merkt. Damit bekommt man ohne weitere Vorkehrungen jeden 
0815-Mosfet gebraten.
Prüfe also die Ansteuerschaltung.

: Bearbeitet durch User
von Willi S. (ws1955)


Bewertung
0 lesenswert
nicht lesenswert
Leistungsfähige Gate-Treiber können ihren Zweck natürlich nur erfüllen, 
wenn auch deren Versorgung den Strom liefern kann und dies ist in der 
Schaltung vom TE nicht der Fall. Direkt an den VDD gehört ein 100uF low 
esr Elko plus 1uF Kerko, letzerer wegen dem DC-Derating mindestens 25V. 
Siehe auch Datenblatt Fig. 25/26, sozusagen als "Beweis". Natürlich 
kommt es darauf an, woher die 12V kommen und was da noch dran hängt. 
Oder man schaltet gleich noch eine Schottky-Diode rein, damit die 
Energie der Stützkondensatoren dem Gate-Treiber vollständig zur 
Verfügung steht, egal was sonst noch an die 12V verdrahtet ist.

Suppressordiode wurde oben schon genannt, richtig! Vermutlich stirbt der 
Mosfet an Überspannung. Messen lässt sich diese mit normalen Mitteln 
meist nicht. Die Suppressordiode gehört einfach hin und basta.

Natürlich schadet ein Elko/Kerko direkt am Lastausgang/24V nicht...

Schon aus Gründen der EMI gehört an jeden Schaltausgang ein Filter, im 
einfachsten Fall wenigstens ein Kerko mit 1-100nF.

10A ist ja kein hoher Strom, warum eigentlich ein solcher Mosfet Prügel 
? Das hat nur Nachteile. Lieber ein paar Milliohm RDSon mehr und nur 1/4 
der Gateladung bzw Kapazität und dadurch weniger Schaltverluste und 
weniger Störungen durch irre Gate-Ströme. Niemand sonst baut für 10A 
einen 150A Mosfet ein, schon gar nicht bei PWM.

von Sven S. (schrecklicher_sven)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> so extrem hoch ist deine Ansteuerfrequenz ja auch nicht.

Ich finde das schon extrem.

Ich schlage eine Verringerung der Frequenz auf 0,1Hz vor.
Weitere Maßnahmen sind nicht nötig.

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> eine Verringerung der Frequenz auf 0,1Hz

Nachdem ich "Heizkreuz" gegugelt habe, erhöhe ich die Frequenz auf 10Hz, 
wegen fehlender thermischer Trägheit.

von Volker (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal,

zuerst mal peinlicher Fehler. Ich hatte die 24V vorne am Netzteil 
abgegriffen und der Ausgang ist auf 3A begrenzt. Jetzt bin ich am 
hinteren Anschluss, der kann 30A und plötzlich ändert sich auch (oh 
Wunder) das Bild am Oszi.

Die letzten drei Pulse auf dem Bild sind dann denke ich wie erwartet mit 
dem Überschwinger durch Abschalten der induktiven Last zu erklären -> 
Freilaufdiode/Suppressordiode.

Die hochfrequenten "Balken" links im Bild nach dem Ausschalten der Last 
kommen durch den Breakdown des MOSFETs zu Stande?





Die Anmerkung zur MOSFET Wahl kann ich nachvollziehen. Ich hatte mich da 
zu sehr auf den Rdson versteift und werde bei Gelegenheit nach einer 
Alternative suchen.

von ACDC (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und jetzt geht es?

Ohne das der Mosfet heiss wird?

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Außer einer Freilaufdiode könnte auch ein Snubber helfen.

https://de.wikipedia.org/wiki/Snubber

Den kannst du dann über den FET anschalten, damit er die 
Spannungsspitzen ein bisschen reduziert.

Trotzdem nicht wirklich ganz klar, warum das bisschen Induktivität so 
viel Energie speichern soll, dass das einem fetten FET gefährlich wird.

von Volker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe keine Diode zur Hand und muss erst welche bestellen.

Wenn ich das Heizkreuz frisch mit Spannung versorge, dann habe ich erst 
nur Impulse mit dem Überschwinger beim Ausschalten und der MOSFET bleibt 
kühl. Sobald die Schaltung einige Sekunden in Betrieb ist, dann häufen 
sich die hochfrequenten Balken und er wird wieder warm und ich schalte 
ab.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Dann solltest du klären, was da zu dieser HF-Schwingung führt. Das ist 
alles andere als normal.

Passiert das auch, wenn du das Heizelement direkt an die Versorgung 
klemmst?

Passiert das auch, wenn du den FET dauerhaft durchschaltest?

von Willi S. (ws1955)


Bewertung
0 lesenswert
nicht lesenswert
Ein Wunder, dass der 40V Mosfet die 56V HF überhaupt aushält.

von Jens M. (schuchkleisser)


Bewertung
0 lesenswert
nicht lesenswert
Ich vermute mal, das die Regelung des NT durch das ständige ein/aus der 
doch recht großen Last etwas aus dem Tritt kommt.

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
Willi S. (ws1955) schrieb:

>Ein Wunder, dass der 40V Mosfet die 56V HF überhaupt aushält.

Avalanche-Betrieb. Die Mosfets wirken bei Überspannung eben wie eine 
Z-Diode (in dem Fall bei um die 56V), und halten dabei die im DB 
angegebene Avalanche-Energy aus. Man kann das auch als regulär nutzbaren 
Betrieb betrachten, solange man sich an die Noten (lt. DB) hält.

von Εrnst B. (ernst)


Bewertung
0 lesenswert
nicht lesenswert
Willi S. schrieb:
> Ein Wunder, dass der 40V Mosfet die 56V HF überhaupt aushält.

Warum?
Infineon wirbt mit

>> Improved Gate, Avalanche and Dynamic dV/dt Ruggedness

==> Datenblatt ab Seite 6 + IRF Appnote zu Repeated Avalance ...

Muss schon eine sehr potente Heiz-Induktivität sein, wenn sie die D-S 
Strecke per Überspannung schmelzen will...

Foto vom Aufbau wäre hilfreich, ich vermute eher ein Problem mit der 
Ansteuerung. (ellenlange Gate/GND-Leitungen, keine Kondensatoren am 
Treiber usw.)

: Bearbeitet durch User
von Volker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Anregungen und allgemein alle Kommentare zum Thema.

Ich werde im nächsten Schritt eine Freilaufdiode einbauen und dann ein 
Update geben. Lieferung erst Anfang nächster Woche...

von Axel S. (a-za-z0-9)


Bewertung
0 lesenswert
nicht lesenswert
Εrnst B. schrieb:
> Foto vom Aufbau wäre hilfreich, ich vermute eher ein Problem mit der
> Ansteuerung

Das hat sich doch nun geklärt. Sein Netzteil konnte den Strom nicht 
liefern und deshalb ist nicht nur die Spannung an der Last, sondern auch 
die Gatespannung ständig fluktuiert (anscheinend im MHz-Bereich, muß ein 
tolles Netzteil sein).

Damit war der MOSFET praktisch immer am ein- und ausschalten, was die 
Schaltverluste natürlich beträchtlich erhöht.

Wie ein Vorredner schon sagte, ist es sinnvoll, zusätzlich zu den 
regulären Abblockkondensatoren am Gate-Treiber auch noch eine Diode 
vorzusehen, damit die Energie in den Kondensatoren auch ausschließlich 
für den Gatetreiber bereitsteht und nicht in die Last fließen kann. Im 
Idealfall verwendet man eine separate Versorgung für den Steuerkreis.

von Willi S. (ws1955)


Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Willi S. (ws1955) schrieb:
>
>>Ein Wunder, dass der 40V Mosfet die 56V HF überhaupt aushält.
>
> Avalanche-Betrieb. Die Mosfets wirken bei Überspannung eben wie eine
> Z-Diode (in dem Fall bei um die 56V), und halten dabei die im DB
> angegebene Avalanche-Energy aus. Man kann das auch als regulär nutzbaren
> Betrieb betrachten, solange man sich an die Noten (lt. DB) hält.

Danke!
Man wird älter als ne Kuh und lernt immer noch dazu...

Die Schwingung muss irgendwie weg, durch was auch immer.
Anscheinend stirbt der Mosfet letztlich doch den HITZE-Tod.
Bei 56V müssten es über 200°C auf dem Chip sein, aber nicht lange...

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
Εrnst B. schrieb:
> Foto vom Aufbau wäre hilfreich, ich vermute eher ein Problem mit der
> Ansteuerung. (ellenlange Gate/GND-Leitungen, keine Kondensatoren am
> Treiber usw.)

Genau! Denn über den Aufbau wurde auch noch garnicht gesprochen. Neben 
dem oben genannten ist auch wichtig, wie der Leistungspfad verdrahtet 
ist bzw. ob der GND von Ansteuerung und Last sich auch sternförmig an 
der Source des MOSFETs treffen.

von Michel M. (elec-deniel)


Bewertung
0 lesenswert
nicht lesenswert
... genau deshalb wäre ein Photo sicherlich aufschlußreicher :-)

von Volker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der Gesamtaufbau ist schwierig aufs Bild zu bekommen. Ich bin über das 
Wochenende nicht zu Hause, aber Anfang der Woche schaue ich, was ich da 
machen kann.

Gate-Treiber und Heizung haben getrennte Netzteile, GND verbunden. Der 
Gate-Treiber immer 12V und die Heizung testweise zwischen 12V und 24V.
Die Schaltung aus Post Nr.1 ist recht kompakt auf einer 
Lochrasterplatine untergebracht (8x12).

Mal schauen, ob der Avalanche Effekt mit der Freilaufdiode komplett 
verschwindet. Zusätzlich werde ich die Frequenz der PWM auf 10Hz setzen 
und möglichst alle Leitungen kürzen.

Update dann wahrscheinlich am Dienstag.

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Gate-Treiber und Heizung haben getrennte Netzteile, GND verbunden.

Die wesentliche Frage ist: wo verbunden? Können Spannugsabfälle an der 
GND-Leitung Potenzialunterschiede erzeugen, die die Ansteuerung des 
MOSFET beeinflussen? Wie schon geschrieben: die Verbindung sollten an 
der Source des MOSFEts sein.
Zu den Spannungsabfällen: hier geht es in erster Linie nicht um 
Spannungen auf Grund der ohmschen Widerstände der Leitungen, sondern um 
die Induktivität der Leitungen. Hier kann ein schneller Gate-Treiber 
sogar eine negative Wirkung haben: die Leitungsinduktivität erzeugt 
einen höheren Spannungsabfall. Je nach Layout kann das Durchschalten des 
MOSFETs eine Gegenkopplung bewirken und die Ansteuerung des MOSFETs 
behindern, d.h. "abwürgen".

von Volker (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mein größtes Problem war/ist wohl wie viele von euch ja auch gesagt 
haben die Ground Führung.

Ich habe mal Bilder des Aufbaus und meiner kleinen Platine gemacht. Die 
Grüne Leitung ist das PWM Signal vom Mikrocontroller. Das untere 
Netzteil steht konstant auf 12V. Oben bis 24V.

Zusätzlich ein Bild des aktuellen Drain Source Spannungsverlaufs. 
Ursprünglich war unter anderem der Ground meines Mikrocontrollers mit 
dem Netzteil verbunden und nicht mit der Platine. Allein das hat das 
Signal so weit verbessert, dass selbst bei 24V Betriebsspannung der 
Heizung kein Avalanche Effekt mehr aufgetreten ist und der MOSFET 
absolut kalt bleibt. Vorher ist der Avalanche Effekt trotz Freilaufdiode 
ab ca. 16V Betriebsspannung der Heizung passiert.
Spannungsspitzen bis knapp unter 50V treten noch sporadisch auf, wobei 
ich gehofft hatte, dass diese mit der Freilaufdiode komplett 
verschwinden.

Der Ground der beiden Netzteile ist aktuell ja noch nicht ideal, da die 
Verbindung nicht in der Nähe des Source, sondern an den Netzteilen 
direkt stattfindet. Das werde ich jetzt noch anpassen.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Zusätzlich ein Bild des aktuellen Drain Source Spannungsverlaufs.

Herzlichen Glückwunsch!  So würde ich mir ein PWM-Signal auch 
vorstellen.

von Jens M. (schuchkleisser)


Bewertung
1 lesenswert
nicht lesenswert
Volker schrieb:
> Spannungsspitzen bis knapp unter 50V treten noch sporadisch auf

Ich denke die treten immer auf, werden aber von der Samplingrate ab und 
an verschluckt.
Es könnte sein, das die vom Netzteil kommen, weil da erst stark Leistung 
nachgelegt wird und "digital" ist die Last auf einmal weg.
Manche Netzteile können das, manche nicht.

von Volker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jens M. schrieb:
> Es könnte sein, das die vom Netzteil kommen,

Ist das nicht sogar wahrscheinlich? Käme die Spannungspitze durch 
Abschalten der induktiven Last, dann müsste das ja die Diode abfangen?

von Achim S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Ist das nicht sogar wahrscheinlich? Käme die Spannungspitze durch
> Abschalten der induktiven Last, dann müsste das ja die Diode abfangen?

Die Spitze durch die induktiven Eigenschaften der Last werden durch die 
Freilaufdiode abgefangen.

Die Spitze durch die parasitäre Induktivität der Zuleitung vom Netzteil 
aber nicht. Dagegen hilft ein Kondensator, der an deinem Schalter 
zwischen 24V und GND montiert wird.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Achim S. schrieb:
> Dagegen hilft ein Kondensator, der an deinem Schalter zwischen 24V und
> GND montiert wird.

Sinnvollerweise ein kompletter Snubber: Kondensator und Widerstand in 
Reihe.

Ein Kondensator speichert lediglich Energie, liefert sie aber danach in 
den (Schwing-)Kreis zurück. Mit dem Widerstand in Reihe wird dagegen 
Energie „vernichtet“ (also in Wärme umgesetzt).

Ich würde mit 10 Ω und 10 oder 100 nF ins Rennen gehen.

von Christian U. (chriull)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Volker schrieb:
> Ich habe mal Bilder des Aufbaus und meiner kleinen Platine gemacht.

Ist hoffentlich nur eine Kleinigkeit - sieht man auch nicht so genau auf 
deinem Bild - ist die Diode und die Drahtbrücke auch (ordentlich) 
angelötet? (rote Kreise)

von Achim S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Ich würde mit 10 Ω und 10 oder 100 nF ins Rennen gehen.

Ein Snubber in der Versorgungsleitung?

An den Kontakten des Schalters wäre er denkbar - aber da ist er nicht 
nötig, da bereits die alternative Freilaufdiode wirkt.

In der Versorgungsleitung (also zwischen 24V und GND) gehört aus meiner 
Sicht ein deutlich größerer Kondensator (der die Spannung lokal 
stabilisiert und der die Schaltflanken auf den Zuleitungen entschärft. 
Ein ganz klein bisschen Dämpfung darf der dann haben (und bringen viele 
Kondensatoren über ihren ESR von Haus aus mit). Aber 10Ohm wären bei den 
hier geschalteten Strömen (10A) viel zu hoch - damit stiege die Spannung 
trotz Snubber weiter über die Durchbruchschwelle des FET.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Achim S. schrieb:
> Ein Snubber in der Versorgungsleitung?

Nein, natürlich nicht. :-)

> An den Kontakten des Schalters wäre er denkbar - aber da ist er nicht
> nötig, da bereits die alternative Freilaufdiode wirkt.

… oder eben nicht, es sind ja noch Spannungsspitzen zu sehen. Die 
Freilaufdiode hilft nur gegen die Lastinduktivität, der Snubber über 
Drain-Source hilft gegen alle möglichen Peaks.

Aber OK, die Versorgung hinreichend niederimpedant abzublocken, gehört 
genauso mit dazu.

: Bearbeitet durch Moderator
von Achim S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> … oder eben nicht, es sind ja noch Spannungsspitzen zu sehen.

Die Freilaufdiode lässt garantiert keine Vorwärtspannungen von >25V zu, 
wie sie in der Messung zu sehen sind. Wenn die Freilaufdiode wirkt (wenn 
sie nicht falsch angeschlossen ist oder eine kalte Lötstelle hat), dann 
kommt diese Spitze nicht aus dem Lastkreis.

Sie kann aber durchaus aus aus der Induktivität der Zuleitung stammen. 
Nach dem Bild zu schätzen vielleicht 50cm Leitung mit 
größenordnungsmäßig 500nH Induktivität. Die Spitze dieser Induktivität 
sieht die Freilaufdiode nicht, darauf hat sie keinen Einfluss.

Das ergibt ein paar Dutzend µJ, die irgendwo hin müssen. Mit einem 
Kondensator im zweistelligen µF-Bereich oder größer lässt sich das gut 
wegpacken.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.