Forum: Analoge Elektronik und Schaltungstechnik MOSFET Überschwinger


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von user391034 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

für eine Anwendung muss ich einen MOSFET im us Bereich schalten, genauer 
gesagt Pulse mit einer Breite von 1 us.
Es gibt bei uns bereits einen MOSFET mit dem das gut klappt 
(PSMN027-100XS). Allerdings ist dieser abgekündigt worden und kein SMD, 
daher brauchts was neues.
Ich habe hier bereits einige MOSFETs da, um diese Testen zu können. Da 
ich das ganze zunächst auf einem Steckbrett mache, habe ich mir einzelne 
Stiftleisten auf die Kontakte der MOSFETs gelötet (siehe Bild 1).
Wenn ich mir jetzt die Drain Spannung ansehe, sehe ich einige 
Überschwinger (siehe Bild 2). Das blaue Signal ist der Eingang am MOSFET 
Treiber (also das Steuersignal), das gelbe Signal die Drainspannung.

Wenn ich die Schaltung mittels LTspice simuliere und jeweils am Gate, 
Drain und Source eine Induktivität einsetze, erhalte ich ziemlich genau 
das gleiche Bild. Daher nehme ich an, das liegt an den Stiftleisten und 
am Aufbau im Lochraster.

Meine Frage nun, wie kann ich am Steckbrett das ganze verbessern? Die 
Leitungen sind schon alle so kurz wie möglich.

Danke.

: Verschoben durch Moderator
von Kalle (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Lass dir eine Platine fräsen, insbesondere wenn das für den 
professionellen Einsatz ist, würde ich mich gar nicht erst mit solchem 
Lochraster-Pfusch aufhalten.
Dein Ziel ist es ja, praxisrelevante Daten zu extrahieren aus deinen 
Versuchen, also brauchst du auch einen richtigen Aufbau, ansonsten 
kannst du auch einfach ins Datenblatt schauen.

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Überleg Dir mal, welche "Überschwinger" physikalisch überhaupt möglich 
sind.
Daß beim Abschalten des Mosfet am Drain -3 Volt erscheinen, gehört nicht 
dazu.

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Überleg Dir mal, welche "Überschwinger" physikalisch überhaupt möglich
> sind.

Hilf mir mal bitte auf die Sprünge ...

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> Hilf mir mal bitte auf die Sprünge ...

Das ist ein Messproblem: zu lange GND-Klemme am Tastkopf z.B. Miss mal 
mit der hoffentlich mitgelieferten GND-Feder.

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
HildeK schrieb:
> Miss mal
> mit der hoffentlich mitgelieferten GND-Feder

Die Messung ist bereits mit Masse Feder durchgeführt. Die Spitze vom 
Tastkopf steckt direkt im Steckbrett, die Feder direkt daneben in die 
Ground Leitung.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gut, dann wäre der häufigste Messfehler schon mal ausgeräumt :-).
Bleiben noch die kapazitiven Kopplungen zwischen G-S-D vom Steckbrett, 
ev. auch die internen.

von user391034 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal die Messung mit dem alten MOSFET, welcher im TO-220 Package 
ist.
Der Aufbau ist ansonsten komplett identisch.

von Gumbel (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Wieso lötest du nicht auf Lochraster?

von Ingo Less (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Das Problem beim Steckbrett sind die nicht überschaubaren parasitären 
Induktivitäten als auch Kapazitäten. Deswegen hast du solche lustigen 
Überschwinger überall.

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gumbel schrieb:
> Wieso lötest du nicht auf Lochraster?

Um die MOSFETs einfacher zu wechseln.

Ingo Less schrieb:
> Das Problem beim Steckbrett sind die nicht überschaubaren parasitären
> Induktivitäten als auch Kapazitäten. Deswegen hast du solche lustigen
> Überschwinger überall.

Würde ein Lochrasteraufbau das ganze etwas verbessern?

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> Hier mal die Messung mit dem alten MOSFET, welcher im TO-220 Package
> ist.

Aha, du hast ein Problem mit dem Unterschwinger, nicht mit dem 
Überschwinger? Weil, der Überschwinger sieht ja eher schlechter aus.
Sieht dann doch nach einer kapazitiven Kopplung G-D aus.
Nimm mal einen kleinen R direkt vor dem Gate.

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
HildeK schrieb:
> Aha, du hast ein Problem mit dem Unterschwinger, nicht mit dem
> Überschwinger?

Ja stimmt, war falsch ausgedrückt von mir, sorry.

Widerstand mit 6 Ohm ist bereits vorm Gate.

von Bernd K. (prof7bit)


Bewertung
0 lesenswert
nicht lesenswert
Bau mal den Tastkopf aus Bild 3 auf (Z0-Probe):

http://www.sigcon.com/Pubs/straight/probes.htm

GND (und auch alles andere) so nah und so kurz wie möglich anschließen.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert

von Ingo Less (Gast)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> Würde ein Lochrasteraufbau das ganze etwas verbessern?
Vermutlich, da die Steckbrettkontakte untereinander eine beachtliche 
Kapazität haben. Ich lasse bei nem µC auf Steckbrett die obligatorischen 
22-27pf schon weg und der Quarz wird oft immer noch verstimmt...

von Ingo Less (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ingo Less schrieb:
> user391034 schrieb:
>> Würde ein Lochrasteraufbau das ganze etwas verbessern?
> Vermutlich, da die Steckbrettkontakte untereinander eine beachtliche
> Kapazität haben. Ich lasse bei nem µC auf Steckbrett die obligatorischen
> 22-27pf schon weg und der Quarz wird oft immer noch verstimmt...
Bzw. ist beim nem STM32 auf Adapter die Programmierung garnicht nicht 
möglich, wenn die Programmierstifte zu weit weg vom µC sind, hier 
reichen schon 4cm Entfernung und schon gehts nicht mehr.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> für eine Anwendung muss ich einen MOSFET im us Bereich schalten, genauer
> gesagt Pulse mit einer Breite von 1 us.

Das kann bei passender Ansteuerung jeder 08/15 MOSFET.

> Ich habe hier bereits einige MOSFETs da, um diese Testen zu können. Da
> ich das ganze zunächst auf einem Steckbrett mache, habe ich mir einzelne
> Stiftleisten auf die Kontakte der MOSFETs gelötet (siehe Bild 1).

Vergiss es!

> Wenn ich mir jetzt die Drain Spannung ansehe, sehe ich einige
> Überschwinger (siehe Bild 2). Das blaue Signal ist der Eingang am MOSFET
> Treiber (also das Steuersignal), das gelbe Signal die Drainspannung.

Wie sieht deine Gesamtschaltung, der physische Aufbau (Layout) und deine 
Meßwertaufnahme aus? Zeig uns ein paar gescheite Bilder.

> Meine Frage nun, wie kann ich am Steckbrett das ganze verbessern?

Steckbrett wegwerfen.

 Die
> Leitungen sind schon alle so kurz wie möglich.

Ach sooo kurz? ZAHLEN!!! Und Bilder.

von Ingo Less (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Falk B. schrieb:
> Steckbrett wegwerfen.
Naja, Steckbrett kann man bei weniger kritschen Sachen schon nutzen, 
wenn man weiss mit welchen "Problemen" man rechnen muss.

von user391034 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bernd K. schrieb:
> Bau mal den Tastkopf aus Bild 3 auf (Z0-Probe):

Falk B. schrieb:
> https://www.mikrocontroller.net

Habe jetzt den Z0 nachgebaut, jeweils für beide Signale.
Tastköpfe sind TPP0100, mit 10 MOhm und 12 pF für bis 100 Mhz 
Bandbreite.

von Ingo Less (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Überschwinger resultieren aus der parasitären Induktivität deines 
Aufbaus. Mit dem Messaufbau gemäß Forum lutscht du das Signal einfach 
nur schön, aber die tatsächlichen Überschwinger sieht man ja trotzdem 
noch (nur ohne den HF-Anteil)

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> Bernd K. schrieb:
>> Bau mal den Tastkopf aus Bild 3 auf (Z0-Probe):
>
> Falk B. schrieb:
>> https://www.mikrocontroller.net
>
> Habe jetzt den Z0 nachgebaut, jeweils für beide Signale.
> Tastköpfe sind TPP0100, mit 10 MOhm und 12 pF für bis 100 Mhz
> Bandbreite.

Häää? Das ist irgendwie Unsinn! Wenn man einen Z0-Tasktopf hat, dann hat 
man KEINERLEI 10M 10:1 oder sonstwas! Hast du 50 Ohm Termninierung am 
Oszieingang? Intern oder Extern ist egal.

Zeig ein paar gescheite Bilder deines Aufbaus!

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Ist wenigstens ein adäquater Lastwiderstand am Drain?

von Olaf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> Würde ein Lochrasteraufbau das ganze etwas verbessern?

Ich wuerde schaetzen das man auf Lochraster bei sorgfaeltign Aufbau 
bis etwa 500Mhz zu brauchbaren Ergebnissen kommt. Jedenfalls hab ich das 
schon geschafft.

Sorgfaeltig: eine Seite des Lochraster komplett mit Kupferfolie beklebt, 
alle Bauteile 0603 oder kleiner, Masse wird von unten von der Folie 
geholt. Gut ueber die Verteilung der Bauteile nachgedacht.

Olaf

von user391034 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Falk B. schrieb:
> Zeig ein paar gescheite Bilder deines Aufbaus!

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Links sind 24 Volt für die Last, rechts sind die 10 Volt für den 
Treiber.

von HildeK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Jaja, du hast zwar eine Massefeder verwendet, aber dich auf eine Masse 
bezogen, die meilenweit weg vom Geschehen ist! Also doch:
HildeK schrieb:
> Das ist ein Messproblem: zu lange GND-Klemme am Tastkopf

Miss mal direkt über dem FET! Links Masse, rechts Drain.

von Falk B. (falk)


Bewertung
1 lesenswert
nicht lesenswert
user391034 schrieb:

Du bist süß ;-)

Du glaubst wirklich, daß man mit DEM Aufbau schnell und sauber schalten 
kann?

Wo ist denn die Last? Wo sind die Entkoppelkondensatoren? Wie langs sind 
die Verbindungen, vbor allem die zur Masse? Wohin gehen die Drähte nach 
unten?

von Michel M. (elec-deniel)


Bewertung
0 lesenswert
nicht lesenswert

von HildeK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Michel M. schrieb:
> zur Diskussion

Das ist zwar für viele hilfreich - danke dafür - aber wir hatten oben 
schon geklärt, dass er eine GND-Feder benutzt. Das kann man auch an dem 
Foto gerade noch so erkennen.

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Falk B. schrieb:
> Du glaubst wirklich, daß man mit DEM Aufbau schnell und sauber schalten
> kann?

Ich weiß es nicht. Ich habe mit sowas bisher überhaupt keine Erfahrung. 
Deswegen wende ich mich ja auch hier ans Forum.

Falk B. schrieb:
> Wo ist denn die Last? Wo sind die Entkoppelkondensatoren? Wie langs sind
> die Verbindungen, vbor allem die zur Masse? Wohin gehen die Drähte nach
> unten?

Die Last hängt an den zwei Leitungen die nach unten weg geht. Die 
Leitungen vom Netzteil zum Steckbrett sind jeweils ca. 25 cm lang.

Wie sollte der Aufbau aussehen, damit es besser wird? Könnt ihr mir da 
helfen?

von Εrnst B. (ernst)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> rechts sind die 10 Volt für den
> Treiber.

Wo sind die Kondensatoren für die 10V? Da wird dein Mosfet-Treiber doch 
sicher recht exakte Anforderungen haben, Kerko/Tantal, welcher ESR, wie 
weit max. vom Treiber-IC entfernt usw. Ein 08/15 Elko in der 
Versorgungschiene zählt da eher nicht.

Mit etwas Glück kriegst du einen SMD-Kerko unten auf die Adapter-Platine 
gelötet.

von EMV geplagt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wo das Gerödel herkommt:
Stichwort Induktivitäten. Und ja, die hat man da. Die Zuleitungen, die 
Pins und so weiter. Ein paar hundert nH hast du schnell beieinander.

Du hast viel Strom durch eine Spule, und drehst (schnell) zu. Was wird 
wohl passieren? Genau.Das was du siehst. Falls du richtig gemessen hast 
;-)

Da wären wir schon beim ersten Punkt: Du musst dir klar sein: Zu welchem 
Bezug misst du was? Was bedeuten die steilen Stromänderungen und hohen 
Ströme für die Messung? Hebt es dir den GND-Bezug aus? Musst du 
korrigieren! Wir reden hier von zig MHz (siehst du an der Frequenz des 
Gerödels). Das ist HF von der unfeinen Sorte, was beim Messen zu 
berücksichtigen wäre.

Wenn du sicher bist, richtig gemessen zu haben:
Versuche, die Induktivitäten klein zu halten. Das heißt: Lochraster oder 
Steckbrett spielt sich nicht. Zeichne dir im Schaltplan ein, wo die 
Stromänderungen auftreten, da wo sie fließen, muss die Schleife (Strom 
fließt immer im  Kreis ;-)) so kurz wie möglich sein. Da ist GND 
mitzubetrachten.

Wenn du das gemacht hast, und es reicht nicht, kann man immer noch 
langsamer schalten - das dI/dt reduzieren. Dazu kann man einen 
Serienwiderstand in die Ansteuerung einfügen. Das ist aber immer ein 
Kompromiss, weil das die Verluste erhöht.

Und dann wären dann noch Snubber, also ein RC-Glied parallel zum FET. 
Das auszuegeln ist nicht ganz einfach, aber schau dir die 
Einschwingfrequenz, und bau was rein mit R = XC bei der Schwingfrequenz. 
Irgenwas mit 10-100Ohm. Auch das ist ungünstig, weil es Verluste macht.

von HildeK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
user391034 schrieb:
> Wie sollte der Aufbau aussehen, damit es besser wird? Könnt ihr mir da
> helfen?

Mach deine Messung erst mal über dem FET, zwischen Sourcepin und Drain 
bzw. Source und Gate. Und lege die Kondensatoren nicht meilenweit vom 
Treiber weg.
Dann wird es schon viel besser aussehen, weil es eigentlich auch besser 
ist, als du misst.

Was ist eigentlich mit der Tastkopfmassefeder, die in der Brettreihe 11 
angeschlossen ist - ich sehe da keinen weiteren Anschluss an GND - 
gleichstrommäßig ist da nur über die Massefedern der Tastkopfkabel eine 
GND-Verbindung?

von Falk B. (falk)


Bewertung
1 lesenswert
nicht lesenswert
user391034 schrieb:

> Die Last hängt an den zwei Leitungen die nach unten weg geht.

Ja wo denn? Wie lang ist die Zuleitung? Was ist das für eine Last? 
Schaltplan?

> Die
> Leitungen vom Netzteil zum Steckbrett sind jeweils ca. 25 cm lang.

Das ist egal, wenn der Entkoppelkondensator für die Versorgungsspannung 
HF-tauglich ist. Dort gehört ein Keramik- oder Folienkondensator hin. Je 
nach Anwendung um die 100-1000nF, ggf. mehr.

https://www.mikrocontroller.net/articles/Kondensator#Entkoppelkondensator

> Wie sollte der Aufbau aussehen, damit es besser wird? Könnt ihr mir da
> helfen?

Siehe Treiber. Das gibt nicht nur für den, sondern auch für den 
Lastkreis. Last, MOSFET und Entkoppelkondensator müssen SEHR nah 
zusammen rücken bzw. sehr induktionsarm verbunden sein. D.h. kurze, 
möglichst flächige Verbindungen. Auf jeden Fall NICHT 5cm Klingeldraht 
oder mehr! Das gleiche gilt für den Masseanschluß des Oszis. Der gehört 
20mm oder weniger an Source vom MOSFET hin.

von Falk B. (falk)


Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
HildeK schrieb:
> Was ist eigentlich mit der Tastkopfmassefeder, die in der Brettreihe 11
> angeschlossen ist - ich sehe da keinen weiteren Anschluss an GND -
> gleichstrommäßig ist da nur über die Massefedern der Tastkopfkabel eine
> GND-Verbindung?

Ist verbunden, aber mit ner Wäscheleine!

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
EMV geplagt schrieb:
> Zeichne dir im Schaltplan ein, wo die
> Stromänderungen auftreten, da wo sie fließen, muss die Schleife (Strom
> fließt immer im  Kreis ;-)) so kurz wie möglich sein. Da ist GND
> mitzubetrachten.

Jetzt wo du es schreibst, ist es mir sofort klar geworden das der Aufbau 
so in der Form Mist ist. Manchmal sieht man den Wald vor lauter Bäumen 
nicht :/

Falk B. schrieb:
> Ja wo denn? Wie lang ist die Zuleitung? Was ist das für eine Last?
> Schaltplan?

Die Last ist eine LED-Beleuchtung (24V, 2,86 W). Leitung ist hier etwa 
40cm lang, aber das ist noch kurz. Später wird die Leitung noch länger 
sein und die Spannung wird bis zu 60 V betragen.

Wie eben schon geschrieben, ist mir jetzt auch klar, dass mein Aufbau so 
Mist ist. Ich werde den nochmal zerlegen, und versuchen beser 
aufzubauen.

Danke für eure HIlfe soweit, ich Melde mich dann wenn es Neues gibt.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:

>> Ja wo denn? Wie lang ist die Zuleitung? Was ist das für eine Last?
>> Schaltplan?
>
> Die Last ist eine LED-Beleuchtung (24V, 2,86 W). Leitung ist hier etwa
> 40cm lang, aber das ist noch kurz. Später wird die Leitung noch länger
> sein und die Spannung wird bis zu 60 V betragen.

Und warum willst da damit 1us Pulse erzeugen?

von user391034 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Falk B. schrieb:
> Und warum willst da damit 1us Pulse erzeugen?

Weil es dafür (ob du es glaubst oder nicht) eine Anwendung gibt.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Falk B. schrieb:
> Ist verbunden, aber mit ner Wäscheleine!

Ja, den hatte ich oben auch bemängelt.
Ich meinte den Pfade der Masse vom 2. Tastkopf - vielleicht ist das aber 
auch ein Draht in Reihe 11 rechts, das ist nicht gut zu erkennen.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
user391034 schrieb:
> Falk B. schrieb:
>> Und warum willst da damit 1us Pulse erzeugen?
>
> Weil es dafür (ob du es glaubst oder nicht) eine Anwendung gibt.

Meinetwegen. Aber die Grundlagen gelten trotzdem. Und wenn die 
LED-Leiste weit weg ist, sollte man die Zuleitungsinduktivität 
minimieren, indem man die Drähte verdrillt. Minimale Fläche -> minimale 
Induktivität.

Beitrag #5790727 wurde vom Autor gelöscht.
von Nop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Falk B. schrieb:

> Und warum willst da damit 1us Pulse erzeugen?

Wahrscheinlich eine PWM, die auch im untersten Helligkeitsbereich und 
aus den Augenwinkeln noch absolut flackerfrei sein soll.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.