mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Warum hat mein invertierender Schmitt-Trigger nur 1.9V am Ausgang?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Dan B. (treki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Gemeinde
Habe einen invertierenden Schmitt-Trigger mit einem LM324N realisiert.
Speisespannung ist 3.3V.
Der Ausgang geht auf einen CMOS NAND-Tor. Also sehr hochohmig.
Laut Datasheet sollte bei diesem High mind 2.3V sein.
In der Simulation gibt mein Schmitt-Trigger 2.3V im High-Zustand aus.
In der Praxis aber nur 1.9V. Siehe dazu auch den Printscreen.
Warum das?

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du versorgst den 4011 nur mit 3,3V?
Welchen 4011 setzt du da ein?

: Bearbeitet durch Moderator
Autor: Dan B. (treki)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Achso. Danke Dir.
Wüsstest mir etwa einen Ersatztyp, der das gleiche Pinout hat wie der 
LM324 im DIP-14 Gehäuse?

Autor: Dan B. (treki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Du versorgst den 4011 nur mit 3,3V?
> Welchen 4011 setzt du da ein?

CD4011B. Laut Datasheet funzt der von 3V bis 18V


Der obige Beitrag wurde durch Moderator geändert.
Ist den nicht der OPA Typ der Übeltäter?

: Bearbeitet durch User
Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast du mit den unbenutzten Gattereingängen gemacht? Hoffentlich 
alle auf definiertes Potential gelegt?

Dan B. schrieb:
> Laut Datasheet funzt der von 3V bis 18V
Er ist bei 5, 10 und 15V spezifiziert.

Aber teste doch einfach mal, ob der 4011 prinzipiell funktioniert, wenn 
du an beiden  Gattereingängen High oder low anlegst.

Der OP ist ungünstig bei dieser niedrigen Spannung, weil er kein 
richtiges High ausgeben kamn.

: Bearbeitet durch Moderator
Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Gatter funzt mit 3.3V.
Die anderen bzw leeren Eingänge sind natürlich auf GND.
Die leeren OPAs: out auf - und + auf GND.
Die Schaltung macht nur zwischendurch Probleme.
Diese geht auf den RST eines ESP8266.
Meistens nachts (Temperatur?). Dachte zuerst an eine kalte Lötstelle. 
Aber wenn ich nun das "schlechte" High-Signal des OPA anschaue.....

: Bearbeitet durch User
Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Dan B. schrieb:
> Aber wenn ich nun das "schlechte" High-Signal des OPA anschaue.....
Ich dachte, am Ausgang des 4011 sei die Spannung so niedrig.
Aber wenn das der High Pegel des OP ist, dann passt das zum Datenblatt.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich schrieb ja:
"In der Simulation gibt mein Schmitt-Trigger 2.3V im High-Zustand aus.
In der Praxis aber nur 1.9V. Siehe dazu auch den Printscreen."
Wahr wohl ein kleines Missverständnis ^^

Muss ich den nun einen anderen OPA-Typ verwenden?

: Bearbeitet durch User
Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Sieh mal  ob der LMC6484 passt.
Und da gibt's sicher noch andere... 😉

: Bearbeitet durch Moderator
Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Pinout würde passen.
Soll ich mal solche besorgen?
OPA bin ich nicht so der Platzhirsch :(

Autor: Mani W. (e-doc)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Vielleicht kann der TO mal seinen ganzen Schaltplan posten?

Autor: Dan B. (treki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Warum?
Ist ziemlich gross ^^
Aber bitte.

@Lothar M.:
Hab mir mal solche OPAmps bestellt.

: Bearbeitet durch User
Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R14 ist, dass der NAND nicht gebraten wird, wenn der Reset-Taster am 
nodeMCU gedrückt wird.
X2b und X2c mit R13 und D4 ist ein Monoflop, damit nur ein, immer gleich 
langer Impuls gesendet wird.
IC3 ist klar. Grund der Diskussion.
T1, T2 und T3 schalten die Lasten (2 verschiedene Spannungen).
Und diese werden im Plus geschaltet. Darum PNP Transistoren.
Das Anemometer funzt mit 7-24V. Ausgang von diesem ist 0.4-2V. Wenn ich 
dem die Masse weg schalte....ESP gute Nacht
Intern und extern sind die Sensoren. Hier siehst nur das Mainboard.
Es existiert noch ein zweites. Das ist im Wetter (beim Anemometer, Regen 
und Licht Sensor).
Die Datenübertragung läuft per I2C von dem zum Mainboard.
Mit einem Cat6 Kabel sind da 2m problemlos.

: Bearbeitet durch User
Autor: Axel S. (a-za-z0-9)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Dan B. schrieb:

> Ist den nicht der OPA Typ der Übeltäter?

Doch. Der LM324 kommt laut Datenblatt mit dem Ausgang typisch bis 1.5V 
an die positive Rail, garantiert sind sogar nur 1.7V (das sind die Werte 
aus dem Datenblatt von ON Semi für Vcc=5V)

Das reicht nicht, um einen sauberen CMOS H-Pegel für Vcc=3.3V 
auszugeben. Nimm einen R2R OPV. Oder gleich einen Komparator. Als 
Frickel-Lösung kannst du dem OPV einen Pullup-Widerstand am Ausgang 
spendieren.


Dan B. schrieb:
> In der Simulation gibt mein Schmitt-Trigger 2.3V im High-Zustand aus.
> In der Praxis aber nur 1.9V

"Der Unterschied zwischen Theorie und Praxis ist, daß es in der Theorie 
keinen Unterschied zwischen beiden gibt. In der Praxis aber schon."

Abgesehen davon war deine Schaltung schon sehr auf Kante genäht, wenn 
der OPV selbst in der Simulation nur gerade so den notwendigen H-Pegel 
von 2.3V ausgegeben hat.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Info:
Das Schema ist nicht wie die meisten mit der gratis Version von Eagle, 
sondern mit Target3001 V20 medium gezeichnet (von welcher ich die Lizenz 
gekauft habe)

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Axel S. schrieb:
> Dan B. schrieb:
>
>> Ist den nicht der OPA Typ der Übeltäter?
>
> Doch. Der LM324 kommt laut Datenblatt mit dem Ausgang typisch bis 1.5V
> an die positive Rail, garantiert sind sogar nur 1.7V (das sind die Werte
> aus dem Datenblatt von ON Semi für Vcc=5V)
>
> Das reicht nicht, um einen sauberen CMOS H-Pegel für Vcc=3.3V
> auszugeben. Nimm einen R2R OPV. Oder gleich einen Komparator. Als
> Frickel-Lösung kannst du dem OPV einen Pullup-Widerstand am Ausgang
> spendieren.
>
>
> Dan B. schrieb:
>> In der Simulation gibt mein Schmitt-Trigger 2.3V im High-Zustand aus.
>> In der Praxis aber nur 1.9V
>
> "Der Unterschied zwischen Theorie und Praxis ist, daß es in der Theorie
> keinen Unterschied zwischen beiden gibt. In der Praxis aber schon."
>
> Abgesehen davon war deine Schaltung schon sehr auf Kante genäht, wenn
> der OPV selbst in der Simulation nur gerade so den notwendigen H-Pegel
> von 2.3V ausgegeben hat.

Jou.
Danke.. Wie gesagt bin ich nicht der OPA Heini ^^
Hab mir nun die LMC6484 auf Rat von Lothar M. bestellt.
Hoffe, sieht dann besser aus. Weil meine Schaltung ist nicht sooo 
falsch. Oder?

Bin froh, das Problem nach Tagen/Wochen wenigstens erkannt zu haben.
Zuerst verzweifelt man immer. Dann viel später kommen die Ideen.

Das Verhalten wie ein offener Eingang war eig typisch. Es bootete 
manchmal, wenn ich mit dem Finger in die Nähe kam.
Eben wie ein undefinierter Pegel so tut bei CMOS ^^.

Danke Jungs.
Werde Rückmeldung geben.
Ihr habt mir sehr geholfen!

: Bearbeitet durch User
Autor: Wolfgang (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Axel S. schrieb:
> Doch. Der LM324 kommt laut Datenblatt mit dem Ausgang typisch bis 1.5V
> an die positive Rail, garantiert sind sogar nur 1.7V (das sind die Werte
> aus dem Datenblatt von ON Semi für Vcc=5V)

Wie passt das zur Ausgangskennlinie (z.B. Fig.10 bei TI)?
https://www.ti.com/lit/ds/symlink/lm324-n.pdf

Die Ausgangsspannung vom LM324 einfach nachzumessen, wäre vielleicht zu 
einfach. Auch gibt es keinen wirklichen Grund, den OP derartig 
niederohmig zu beschalten.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verstehe jetzt Bahnhof, aber trotzdem ein Danke.
Habe zwar Elektronik Module nachstudiert.
Aber OPA war immer ein Buch mit 7 Siegeln für mich.
Bin da sehr dankbar für Belehrungen.
Was ist der Unterschied vom 324 zum R2R?
Nun bin ich schon fast sicher, das Problem gelöst zu haben, ohne 
ausprobieren.

PS:
Warum höre ich nix mehr von Mani W.

: Bearbeitet durch User
Autor: HildeK (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Dan B. schrieb:
> Danke.. Wie gesagt bin ich nicht der OPA Heini ^^

An der Stelle ist auch ein OPA nicht die 1. Wahl, sondern ein 
Komparator.
Da die meisten open-Collector-Ausgänge haben, ist die Anpassung an einen 
beliebigen Logikpegel unproblematisch.
Ein weiterer Punkt ist: ein OPA ist deutlich langsamer in der Slew-Rate 
am Ausgang, das mag manchmal bereits die maximal zulässige Anstiegszeit 
am Eingang eines Gatters übersteigen.
Viele Komparatoren arbeiten auch mit noch deutlich kleineren 
Versorgungsspannungen, so z.B. der LM339 (leider nicht pinkompatibel zu 
324) noch mit 2V. Einige kommen unter 1V für VCC. Mit OPAs wird es da 
sehr eng.

Ich weiß jetzt nicht auswendig, ob es einen zum LM324 pinkompatiblen 
gäbe, mein erster Gedanke, der LM339, ist es jedenfalls nicht.

Nur als Hinweis für die Zukunft:
Da du aber eh nur 1/4 davon nutzt: OPAs und Komparatoren gibt es auch im 
8pol. Gehäuse mit nur zwei Einheiten (beim OPA statt LM324 z.B. den 
LM358).
Und als SMD im SOT23 sicher auch einzeln.

Hier ein Link auf die Angebote von TI: 
http://www.ti.com/de-de/amplifier-circuit/comparators/products.html?pqs=paqs&familyid=81#p480=1;4&p358max=5;31.47

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Frage sah ich erst nach meinem Beitrag.
Dan B. schrieb:
> Was ist der Unterschied vom 324 zum R2R?

Der Ausgang eines R2R kommt konstruktionsbedingt (fast) an die Rails VCC 
und GND heran. Bis auf wenige zig mV.
'Normale' OPAs haben meist zu beiden Rails einen Abstand mit 1.5V ... 
2.5V, der LM324 bzw. LM358 ist eine Ausnahme, da er immerhin an die 
untere Rail (GND) herankommt.
Der nicht nutzbare Bereich um den Rails ist normalerweise kein Problem, 
viele OPAs vertragen meist ±18V oder mehr, werden in den meisten 
Schaltungen auch symmetrisch versorgt und so kann man sich die 2V-3V 
Abstand zu den Rails auch erlauben. Wegen der symmetrischen Versorgung 
ist der Bereich um 0V überhaupt kein Problem.
Seit einigen Jahren gibt es für Schaltungen, die mit 5V oder weniger 
versorgt werden, die R2R-OPAs, die es dann erlauben, auch mit einfacher 
5V-Versorgung fast den ganzen Bereich von 0V-5V an Ein- und Ausgang zu 
nutzen.

Autor: Crazy H. (crazy_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der TS914 ist pinkompatibel

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HildeK schrieb:
> Ich weiß jetzt nicht auswendig, ob es einen zum LM324 pinkompatiblen
> gäbe, mein erster Gedanke, der LM339, ist es jedenfalls nicht.

Der TLV3494 könnte wohl passen

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:

> Habe einen invertierenden Schmitt-Trigger mit einem LM324N realisiert.
> Speisespannung ist 3.3V.
> Der Ausgang geht auf einen CMOS NAND-Tor.

Warum nimmst Du nicht gleich ein Nand-Gatter mit Schmitt-Trigger-
Eingang?

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab welche bestellt.
Danke Jungs :)
Wenn's nicht klappt, kann ich die Schaltung immer noch ändern. Zwar 
ungern, da PCB bereits fertig gefräst und bestückt.
http://www.ltspiceusers.ch/showthread.php?t=392

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Harald W. schrieb:
> Dan B. schrieb:
>
>> Habe einen invertierenden Schmitt-Trigger mit einem LM324N realisiert.
>> Speisespannung ist 3.3V.
>> Der Ausgang geht auf einen CMOS NAND-Tor.
>
> Warum nimmst Du nicht gleich ein Nand-Gatter mit Schmitt-Trigger-
> Eingang?

Sind unterwegs. Aber ich brauche einen einstellbaren Schmitt-Trigger.

Autor: Dietrich L. (dietrichl)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Auch gibt es keinen wirklichen Grund, den OP derartig
> niederohmig zu beschalten.

Also für mich sind 10kΩ am Ausgang nicht wirklich niederohmig ...

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dietrich L. schrieb:
> Also für mich sind 10kΩ am Ausgang nicht wirklich niederohmig ...

Fast 1mA Querstrom am Eingangsspannungsteiler ist IMHO bei 500nA Input 
Bias Current und Solarspeisung 'ne ganze Menge. Wozu?
Wenn der Mitkopplungswiderstand für die passende Hysterese bei 100kΩ 
läge, wäre das kein Beinbruch.

Evtl. sollte man dem Spannungsteiler R5/R7 noch einen Kondensator zur 
Beruhigung spendieren. Auf nicht ausreichend abgeblockte Spikes soll der 
Komparator vermutlich nicht reagieren.

Autor: Dan B. (treki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem "beruhigungs Kondensator" ist eine gute Idee!
Wobei ist das von Nutzen nach einem Step-down?

Den angehängten Widerstand und die hängenden Akkus nicht beachten. Ist 
ja ein Test.
Genau so die fliegende Klemme. Hatte nicht bedacht, dass ich den USB 
sonst  nicht mehr einstecken kann ^^
Ist ein Prototyp. Wenn's mal sauber läuft, werd ich das PCB sauber 
herstellen lassen. Momentan selber gefrästes PCB.

: Bearbeitet durch User
Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Wobei ist das von Nutzen nach einem Step-down?

Wie schon geschieben, um Spikes auf der Versorgung abzublocken.
In Digitalschaltungen solltest du auf Grund der Eigeninduktivität der 
Versorgungsspannungsleitungen immer damit rechnen.
Es kommt natürlich drauf an, welche Aufgabe der Komparator hat. 
Vielleicht zeigst du mal ein Schaltbild, aus dem die Gesamtzusammenhänge 
klar ersichtlich sind (nicht so ein so verkrumseltes und unvollständiges 
Ding wie oben, k.A. was der Komparator sich da anguckt).

Autor: Dan B. (treki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
"verkrumseltes" LOL
Unveränderter Printscreen von LTspice.
Wobei R7 dann noch ein Trimmpoti hat.
R3 ist der RST dummy.
GPIO16 ist hardcoded im ESP. GPIO13 sagt, ob der ESP läuft.
Dies werde ich in Zukunft aber nicht mehr benötigen.
ASC und LIBs von LTspice auch noch angehängt.

: Bearbeitet durch User
Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum werden 4011 und OPA nicht mit 12V betrieben?

Der Reset des ESP ist low aktiv und hat vermutlich einen internen 
Pullup?

Dann könnte man den RST vom 4011 durch eine Diode entkoppeln (Kathode am 
4011 Ausgang, Anode am RST Eingang. Dann wäre auch der parallele 
Resettaster kein Problem.

Für den Betrieb des OPA Schmitt-Triggers sollte die höhere 
Spannungsversorgung keine  Problem sein. Der Eingang des ESP RST nimmt 
danke der Entkopplungsdiode (Schottkydiode) maximal 3,3V ein. Der Reset 
über den 4011 zieht über die Diode den RST Eingang auf <0,3V.
Sollte kein interner Pullup vorhanden sein, dann müsste man einen 
externen Pullupwiderstand vorsehen.

Die Schaltungsänderungen wären minimal. R14 könnte durch die 
Schottkydiode ersetzt werden.

Autor: Ach Du grüne Neune (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn es schnell gehen muss, könnte man am Ausgang des LM324 eine 
Schottkydiode in Sperrrichtung schalten (Minusseite an den Ausgang) und 
dahinter einen 10k Widerstand nach Plus. Dafür muss dann aber der 
Mitkopplungswiderstand tatsächlich 100k groß sein, so wie Wolfgang das 
oben schon geschrieben hat, damit das dann auch funktioniert.

Durch diese Maßnahme werden dann zwangsläufig am Ausgang Spannungen von 
0,3V (low) und 3V (high) ausgegeben.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GEKU schrieb:
> Warum werden 4011 und OPA nicht mit 12V betrieben?
>

Interessante Idee. Allerdings habe ich keine 12V. Das ist eher 
"virtuell" ^^
2 LI-ION Akkus in serie sind max 7.4V

Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> max 7.4V

sind auch noch besser als 3,3V.

Das Verhalten ist in der Simulation leicht zu überprüfen.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GEKU schrieb:
> Dan B. schrieb:
>> max 7.4V
>
> sind auch noch besser als 3,3V.
>
> Das Verhalten ist in der Simulation leicht zu überprüfen.

Da kann ich jetzt nicht ganz folgen.
Willst den ESP mit 5 oder 7V betreiben?...viel Erfolg ^^

Ich sehe, viele gute Ideen. So soll es sein :D

: Bearbeitet durch User
Autor: VerstãrkerOperator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> leeren Eingänge sind natürlich auf GND.

Ich hab das so gelernt und es bewährt sich:

+Eingang auf Gnd, - Eingang auf Ausgang. Das ist ein Folger an einer 
definierten Spannung. Also 0 V.

Wenn du beide auf gnd legst, ist das ein Komparator in einem 
undefinierten Zustand.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ja das genau so gemacht, wie Du sagst. Lies es nochmal genau!
Ich schrieb:
Die leeren OPAs: out auf - und + auf GND.

: Bearbeitet durch User
Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Willst den ESP mit 5 oder 7V betreiben?...viel Erfolg ^^

Nein, nicht den ESP, der soll weiterhin mit 3,3V versorgt werden.

Es geht nur um die Resetlogik, bestehend aus OPA und  4011.

Die Schottkydiode am Ausgang des 4011 bildet einen OC Ausgang, der den 
ESP Reseteingang nur auf LOW ziehen kann.
Soweit ich in der Schaltung gesehen habe gibt es keine anderen Ausgänge 
von der Resetlogik in Richtung 3,3V Welt.

Der Spannungsteiler an OPA+ kann weiterhin an 3,3V liegen, dann ändert 
sich nichts an der Dimensionierung.

Ich betreibe den ESP8266, ohne Probleme, direkt an einer 
Lithiumbatterie , die bis zu 3,7V liefern kann.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok. Gecheckt^^
Ich brauche die höhere Spannung, weil das Anemometer nur mit 7-24V 
funktioniert.
Wegen dem ist auch das ganze Theater nötig.
Stell dir vor, Du steuerst eine Markise mit diesen Daten und der Wind 
frischt in der Deepsleep-Phase auf.
Der OPA soll den ESP aufwecken, wenn das Anemometer eine gewisse 
Schwelle übersteigt (diese kann ich mit dem Trimmer einstellen).

: Bearbeitet durch User
Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GEKU schrieb:
> Ich betreibe den ESP8266, ohne Probleme, direkt an einer
> Lithiumbatterie , die bis zu 3,7V liefern kann.

Wie viel Spannung geben diese Akkus eigentlich kurz nach dem Aufladen 
ab? Oder meintest du eine Einwegbatterie?

: Bearbeitet durch User
Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessante Frage. Ich hab gedacht, er rede von Akkus.

Ich selber habe die (Panasonic) NCR18650B mit Schutzelektronik verbaut.
Gibt's auch beim Chinesen: 
https://www.aliexpress.com/item/33008626097.html?spm=a2g0s.9042311.0.0.27424c4dKyjKZf

Kleiner Stolz; im https://componiverse.com/app habe ich die KF141V
Steckklemmen erstellt.

: Bearbeitet durch User
Autor: GEKU (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stefanus F. schrieb:
> Wie viel Spannung geben diese Akkus eigentlich kurz nach dem Aufladen
> ab? Oder meintest du eine Einwegbatterie?

Es sind Einwegbatterien bzw. Li-Primärzellen.

ACHTUNG : bei hoher Stromaufnahme nach längerer Pause kommt es zu 
einem kurzen Spannungseinbruch. Daher wird ein paralleler Kondensator 
empfohlen (LS14500DB.png). Ich verwende einen 2oF LIC.

Autor: Dan B. (treki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ah, nicht ganz das Gleiche.
Habe die genannten Li-Ion Akkus.
Anbei die ersten Tests der Solarpanels. Das PCB habe ich schon vorher 
erstellt.
Ich staune immer wieder, was für geiles Zeug man mit dieser billigen 
China-Fräse (100-180$) machen kann.

: Bearbeitet durch User
Autor: VerstãrkerOperator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Habe ja das genau so gemacht, wie Du sagst. Lies es nochmal genau!
> Ich schrieb:
> Die leeren OPAs: out auf - und + auf GND.

Stimmt, das habe ich falsch gelesen.

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kein Problem.
Aber ich wünsche mir hier weitere Erfahrungswerte.
Ist immer lehrreich.
Genau jetzt kommen die Panels ins Sonnenlicht.
Komme fast nicht nach mit Messpunkten aufzunehmen/aufzuschreiben nach.

: Bearbeitet durch User
Autor: Rainer V. (a_zip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Die Ausgangsspannung vom LM324 einfach nachzumessen, wäre vielleicht zu
> einfach. Auch gibt es keinen wirklichen Grund, den OP derartig
> niederohmig zu beschalten.

Und der LM324 arbeitet sicher nicht an 3,3V oder so....wäre wirklich ein 
Wunder.
Gruß Rainer

Autor: Maxim B. (max182)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Habe einen invertierenden Schmitt-Trigger mit einem LM324N realisiert.
> Speisespannung ist 3.3V.
> Der Ausgang geht auf einen CMOS NAND-Tor. Also sehr hochohmig.
> Laut Datasheet sollte bei diesem High mind 2.3V sein.
> In der Simulation gibt mein Schmitt-Trigger 2.3V im High-Zustand aus.
> In der Praxis aber nur 1.9V. Siehe dazu auch den Printscreen.
> Warum das?

Laut Datenblatt hat LM324 Ausgang, wo "oben" zwei npn-Transistoren 
stehen (für jeden rechnen sich ca. 0,65 V ) und noch Stromquelle (noch 
dazu 0,1 - 0,3 V). 3,3 V - 1,9 V = 1,4 V. So sollte auch sein mit LM324. 
Die Schaltung arbeitet richtig.

: Bearbeitet durch User
Autor: Axel S. (a-za-z0-9)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rainer V. schrieb:
> der LM324 arbeitet sicher nicht an 3,3V oder so

<seufz>

Statt den TE mit solchem Unsinn zu verunsichern, solltest du besser mal 
ins Datenblatt schauen. Da steht drin, ab welcher Spannung der LM324 
funktioniert. Hint: es sind weniger als 3.3V.

Autor: Maxim B. (max182)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt viele OP und Komparatoren, die an dieser Stelle viel besser 
passen. Manche sind auch leicht zugänglich, z.B. bei Reichelt.

Wenn Platine schon fertig gemacht und man braucht pintreuen Ersatz, dann 
könnte ich MCP 6004 empfehlen, sie gibt es bei Reichelt. Sie ist 
wahrscheinlich sogar ein bißchen schneller als LM324. Wichtiger aber, 
sie hat Ausgänge, die von GND bis Vcc gehen (Differenz ohne Last nur ein 
paar mV).

Besser wäre aber hier, statt OP einen Komparator zu verwenden. So wie 
MCP 6544 (auch pingleich zu LM324 und auch gibt es bei Reichelt).

Autor: Dan B. (treki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Sieh mal  ob der LMC6484 passt.
> Und da gibt's sicher noch andere... 😉

Die LMC6484 funzen perfekt!
Vielen Dank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.