mikrocontroller.net

Forum: Platinen KiCad zoomt nicht an den Rand


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Glutenfreier Veganer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn ich einen wirklich großen Schaltplan habe weit rausgezoomt habe und 
Bauteile an den Rand des Bildschirms positioniere - wenn ich dann wieder 
reinzoomen will zu genau diesem Bauteil springt der Bildschirm immer von 
dem Rand weg.

Das ist, als ob KiCad dort irgendeine unsichtbare Begrenzung setzt. 
Dabei ist mein Schaltplan gar nicht mal überdimensional groß.

Wie kann man das umgehen/verhindern/anpassen?

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Beim Zoomen setzt KiCad generell den Mauszeiger (d.h. da wo die Maus 
vorher war) in das Zentrum.

von Glutenfreier Veganer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andreas B. schrieb:
> Beim Zoomen setzt KiCad generell den Mauszeiger (d.h. da wo die
> Maus
> vorher war) in das Zentrum.

Ok, dann setzt KiCad eben halt beim reinzoomen - sobald ich eine Grenze 
überschreibe - den Mauszeiger während des zoomens immer wieder an diese 
unsichtbare Linie.

Ich kann auch nicht über diesen gewissen Bereich mit der Scrollbar 
wandern.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
deaktiviere mal mal bei "Einstellungen" "Allgemein":
Cursor beim Zoomen nicht zentrieren und umpositionieren.

ich habe leieder keine großen Schaltpläne zum austesten.

von Glutenfreier Veganer (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bringt nichts. Ich kann nicht ausserhalb eines bestimmten Bereichs 
scrollen/zoomen, obwohl dort Bauteile liegen.

Anbei der angefangene Schaltplan.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Hmm, bei mir verhält sich das normal (V 5.1.5 unter Debian bullseye 
KDE). Wenn ich in Deiner Schaltung zoome, gehen auch die Randbauteile in 
die Mitte.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Glutenfreier Veganer schrieb:

> Anbei der angefangene Schaltplan.

Hier kein Problem, ich kann alles erreichen (wenngleich mein Kicad deine 
Bauteile nicht kennt, ich bekomme also nur Kästchen mit Fragezeichen).

von HolgerT (Gast)


Bewertung
0 lesenswert
nicht lesenswert
KiCAD 5.1.4: Kann das Fehlverhalten bestätigen.

Rechte/linke untere Ecken verhalten sich normal.
Bauteile an den oberen Ecken und der oberen Kante kann ich ab einer 
bestimmten Zoomstufe auch nicht mehr erreichen.

von Bernd W. (berndwiebus) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg.

Jörg W. schrieb:

>> Anbei der angefangene Schaltplan.
>
> Hier kein Problem, ich kann alles erreichen (wenngleich mein Kicad deine
> Bauteile nicht kennt, ich bekomme also nur Kästchen mit Fragezeichen).

Gleiches hier - kein Problem. Mit KiCad Version Version: 5.0.2+dfsg1-1, 
release build unter Debian 10 mit Xfce Fenstermanager

Für unbedarfte Mitleser: Die Kästchen mit Fragezeichen sind 
Dummyschaltplansymbole die KiCad behelfsmäßig für Schaltplansymbole 
einsetzt, die Eeschema nicht zuordnen kann, weil die Bibliothek nicht 
Vorhanden ist, der Link darauf nicht stimmt oder die passende Bibliothek 
nicht im Bibliotheksverzeichnis eingetragen ist. Um dieses Problem am 
einfachsten zu lösen, müsste vom Schaltplanerszeller dem Schaltplan die 
passene "Projektname-cache.lib" beiseitegestellt werden und diese zur 
Benutzung dann im Bibliotheksverzeichnis eingetragen werden.

Wenn ich zuhause bin, probiere ich es mit aktuelleren KiCad Versionen.

Es wäre interessant, welche Version der TO und andere mit ähnlichem 
Problem verwenden.


Die KiCad Version im Detail:

Application: kicad
Version: 5.0.2+dfsg1-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.64.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.0.5 
libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-6-686-pae i686, 32 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 
2.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.62.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON


Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

: Bearbeitet durch User
von Gert (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bernd W. schrieb:
> Debian 10 mit Xfce Fenstermanager

Um ein bisschen klugzuscheißen, Xfce ist eine Desktop-Umgebung kein 
Fenstermanager. Der übliche Fenstermnager unter Xfce ist Xfwm, der 
eigens für Xfce entwickelt wurde. Unter Xfce laufen auch andere 
Fenstermanager, bei mir auf meinem uralten Laptop z.B. Fluxbox.

von Glutenfreier Veganer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Seite von A4 auf A1 geändert, nun funktionierts.. bzw. die 
magische Grenze ist lediglich verschoben.

von Bernd W. (berndwiebus) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Hallo Gert.

Gert schrieb:

> Bernd W. schrieb:
>> Debian 10 mit Xfce Fenstermanager
>
> Um ein bisschen klugzuscheißen, Xfce ist eine Desktop-Umgebung kein
> Fenstermanager. Der übliche Fenstermnager unter Xfce ist Xfwm, der
> eigens für Xfce entwickelt wurde. Unter Xfce laufen auch andere
> Fenstermanager, bei mir auf meinem uralten Laptop z.B. Fluxbox.

Du hast Recht. Ich vergesse es immer wieder.

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

von Bernd W. (berndwiebus) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:

Bernd W. schrieb:

> Wenn ich zuhause bin, probiere ich es mit aktuelleren KiCad Versionen.

Nun mit aktuellerer KiCad-Eeschema Version: 5.1.5+dfsg1-2, release 
build, ebenfalls Debian 10 und Xfce Desktop Umgebung.
Die aktuelle KiCad Version ist aber aus dem Testing, weil in Debian 10 
nur 5.1.4 vorhanden ist und bleibt.
Im Anhang: "KiCad-Eeschema_GrosserSchaltplan_11Jan2020.png" Ich habe 
jeweils einmal von allen vier Ecken und allen vier Kanten einmal von 
weitem und einmal von nahem ein Bauteil gegriffen und weggeschoben.

Funktioniert problemlos.

Die Version im Detail:
Application: Eeschema
Version: 5.1.5+dfsg1-2, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.64.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.0.5 
libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-6-686-pae i686, 32 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 
3.24
    Boost: 1.67.0
    OpenCASCADE Technology: 7.3.0
    Curl: 7.66.0
    Compiler: GCC 9.2.1 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=ON
    KICAD_SPICE=ON




Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

von Andreas B. (bitverdreher)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
HolgerT schrieb:
> KiCAD 5.1.4: Kann das Fehlverhalten bestätigen.
>
> Rechte/linke untere Ecken verhalten sich normal.
> Bauteile an den oberen Ecken und der oberen Kante kann ich ab einer
> bestimmten Zoomstufe auch nicht mehr erreichen.

Ich muß mich korrigieren: Bei mir ist es genauso.
Die unteren Ecken funktionieren, die oberen nicht.
Version 5.1.5 sowohl unter Mint 19.3 Gnome 2 als auch Debian 10, KDE

Am angehängten Bild sieht man auch wie das aussieht, wenn man die 
Zoomgröße an den Bildschirm anpasst. Die virtuelle Mitte stimmt nicht.
Es sieht für mich ganz so aus daß KICAD als Mitte nicht die Zeichnung 
als Ganzes, sondern das definierte Blatt sieht. (Bug oder feature? ;-))

So oder so: Es empfiehlt sich nicht, Bauteile außerhalb des definierten 
Blattes zu platzieren.

An den TO: Schau Dir mal das Konzept der hierarchischen Schaltpläne an. 
Dann rennst Du nicht in solche Probleme rein. In Deinem Fall reicht es 
auch aus, den Schaltplan einfach auf mehrere Seiten aufzuteilen.

von Bernd W. (berndwiebus) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Hallo Andreas.

Andreas B. schrieb:

>> KiCAD 5.1.4: Kann das Fehlverhalten bestätigen.
>>
>> Rechte/linke untere Ecken verhalten sich normal.
>> Bauteile an den oberen Ecken und der oberen Kante kann ich ab einer
>> bestimmten Zoomstufe auch nicht mehr erreichen.
>
> Ich muß mich korrigieren: Bei mir ist es genauso.
> Die unteren Ecken funktionieren, die oberen nicht.
> Version 5.1.5 sowohl unter Mint 19.3 Gnome 2 als auch Debian 10, KDE

Ein Bekannter hat das umgedrehte Problem: Die oberen Ecken 
funktionieren, aber die unteren nicht. ;O)

Bei ihm deutet sich auch an, das es ein Problem der Grafikarte bzw. 
deren Zusammenspiel mit openGL ist.
Wenn er in den Fallbackmodus (F12) schaltet, ist das Problem weg.

Falls sich einer wundert: In neueren Versionen gibt es diese Umschaltung 
auch für Eeschema.

> So oder so: Es empfiehlt sich nicht, Bauteile außerhalb des definierten
> Blattes zu platzieren.

Abgesehen vom Fallbackmodus:
Anfassen und Bewegen kann mein Bekannter sie immer noch. Auch im 
Standardmodus. Wenn er sehr weit rauszoomt, kann er sehen, dass das 
Bauteil nur extrem weit weg vom Cursor ist. Es wird irgendwie nicht mehr 
im Bauteilursprung angefasst. Er kann es aber trotzdem in die Mitte 
plazieren, und dann damit ganz normal weiterarbeiten.


>
> An den TO: Schau Dir mal das Konzept der hierarchischen Schaltpläne an.
> Dann rennst Du nicht in solche Probleme rein. In Deinem Fall reicht es
> auch aus, den Schaltplan einfach auf mehrere Seiten aufzuteilen.

Das kommt hinzu.

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

von Bernd B. (bbrand)


Bewertung
0 lesenswert
nicht lesenswert
Bernd W. schrieb:
> Wenn er in den Fallbackmodus (F12) schaltet, ist das Problem weg.

Also bei mir besteht das Problem sowohl im Fallback als auch im 
Accelerated Modus. Ich überlege, ob es möglicherweise an der verwendeten 
Version von wxWidgets oder GTK+ liegt...

Gruß,
Bernd


Application: Eeschema
Version: 5.1.5, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.58.0 OpenSSL/1.1.0f zlib/1.2.8 librtmp/2.3
Platform: Linux 3.2.4 i686, 32 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 
2.24
    Boost: 1.57.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.58.0
    Compiler: GCC 4.9.2 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

von Bernd W. (berndwiebus) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd.

Bernd B. schrieb:

> Also bei mir besteht das Problem sowohl im Fallback als auch im
> Accelerated Modus. Ich überlege, ob es möglicherweise an der verwendeten
> Version von wxWidgets oder GTK+ liegt...

Mmmmh.....hast Du KiCad aus dem Repository oder hast Du das frisch 
compiliert?
Weil auch etliche der anderen Schalter stehen bei mir (s.o.) anders.

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Bei mir hat der Fallbackmodus auch nicht geholfen. Ich denke, es ist 
definitv so, daß KiCad für die Mitte der Zeichnung die Blattgröße als 
Maßstab nimmt und als Größe der Zeichnung eben die ganze Zeichnung.
So läßt sich das ganze Verhalten zwangslos erklären. Ich hatte das auch 
bei der neuesten Version von 2020 (6.0.x) und auf 2 völlig verschiedenen 
Rechnern.

von Bernd B. (bbrand)


Bewertung
0 lesenswert
nicht lesenswert
Bernd W. schrieb:
> Mmmmh.....hast Du KiCad aus dem Repository oder hast Du das frisch
> compiliert?

Frisch compiliert.
Ich werde es später auf der Arbeit mal auf einem Windows Laptop testen.

Gruß,
Bernd

von Walter T. (nicolas)


Bewertung
0 lesenswert
nicht lesenswert
Andreas B. schrieb:
> In Deinem Fall reicht es
> auch aus, den Schaltplan einfach auf mehrere Seiten aufzuteilen.

Wenn Du da eine saubere Anleitung zu findest, wäre ich auch 
interessiert.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Walter T. schrieb:
> Wenn Du da eine saubere Anleitung zu findest, wäre ich auch
> interessiert.

An der Quelle vielleicht?
https://docs.kicad-pcb.org/5.1.5/de/eeschema/eeschema.pdf

von Walter T. (nicolas)


Bewertung
0 lesenswert
nicht lesenswert
Andreas B. schrieb:
> Walter T. schrieb:
>> Wenn Du da eine saubere Anleitung zu findest, wäre ich auch
>> interessiert.
>
> An der Quelle vielleicht?
> https://docs.kicad-pcb.org/5.1.5/de/eeschema/eeschema.pdf

In der Anleitung ist der Anwendungsfall "Schaltplan für fertig 
geroutetes Board auf mehrere Seiten aufteilen" nicht berücksichtigt. 
Dazu gab es schon einen Thread:

Beitrag "KiCAD: Auf andere Schaltplanseite verschieben ohne Neu-Annotation"

: Bearbeitet durch User
von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Hast Du den Vorschlag von Mampf mal ausprobiert?

Ansonsten bin ich in diese Situation noch nicht reingelaufen. Das ist 
aber auch schon sehr speziell, das Pferd so von hinten (PCB) 
aufzuzäumen.

von Bernd B. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
So, habe es jetzt auch unter Windows getestet.
Der Fehler tritt auch hier sowohl mit Accelerated als auch Fallback 
Toolset auf.

Gruß,
Bernd

Application: Eeschema
Version: (5.1.5)-2, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 
libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, 
wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.71.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.66.0
    Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

von W.S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> (wenngleich mein Kicad deine
> Bauteile nicht kennt, ich bekomme also nur Kästchen mit Fragezeichen)

Ach herrje. Die Bauteile sind also nicht im Projekt enthalten und damit 
sind Projekte an die jeweilige Installation gebunden?

Bemerkenswert.


Andreas B. schrieb:
> Ich denke, es ist
> definitv so, daß KiCad für die Mitte der Zeichnung die Blattgröße als
> Maßstab nimmt und als Größe der Zeichnung eben die ganze Zeichnung.

Ich hatte mich damals schon beim Ausprobieren gewundert, warum Kicad so 
penetrant auf diesen albernen Zeichnungsrahmen besteht. Das ist ja 
genauso gruselig wie das Schematics bei der ISE von Xilinx.

Eigentlich sollte man doch einen ausreichend großen Canvas und dort 
einen simplen Nullpunkt haben (z.B. +/- 2x2 Meter sollte für alle LP 
wohl ausreichen!) und alles dort frei positionieren können, ohne einen 
Zeichnungsrahmen als Korsett übergestülpt zu kriegen.

W.S.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
W.S. schrieb:
> Ach herrje. Die Bauteile sind also nicht im Projekt enthalten und damit
> sind Projekte an die jeweilige Installation gebunden?
>
> Bemerkenswert.

Der Schaltplan enthält nur die Referenzen zu den Bauteilen. In dem 
Projekt selbst sind sie alle drin. Der TO hat aber nur die 
Schaltplandatei geliefert.

W.S. schrieb:
> Eigentlich sollte man doch einen ausreichend großen Canvas und dort
> einen simplen Nullpunkt haben (z.B. +/- 2x2 Meter sollte für alle LP
> wohl ausreichen!) und alles dort frei positionieren können, ohne einen
> Zeichnungsrahmen als Korsett übergestülpt zu kriegen.

Und wie druckst Du das dann aus? Auf dem 2x2m Drucker?
Wenn Du das bevorzugst, steht es Dir frei, ein 2x2m Blatt zu definieren.

von W.S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andreas B. schrieb:
> Und wie druckst Du das dann aus? Auf dem 2x2m Drucker?

Und dann das viele blanke Papier mit der Nagelschere wegschneiden?

Schreib keinen Unsinn.

Man druckt nur den tatsächlich benutzten Platz darauf. Wenn ich z.B. nur 
den Platz eines A4 Blattes final drauf benutze, dann kann dieser 
direkt 1:1 gedruckt werden. Ansonsten eben entweder ausschnittsweise 
oder skaliert.

Zwischenzeitlich kann ich jedoch Zeichnungs- oder Layout-Teile beliebig 
außerhalb mal zwischenplazieren, das ist nach meiner Erfahrung eine sehr 
nützliche Sache.

W.S.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
W.S. schrieb:
> Zwischenzeitlich kann ich jedoch Zeichnungs- oder Layout-Teile beliebig
> außerhalb mal zwischenplazieren

Dann definiere halt 2x2m während der Entwicklung und verkleinere das 
Blatt später. Wo ist das Problem?
Ich weiß normalerweise vorher wie groß der Schaltplan in etwa wird.
Wie schon erwähnt, macht man größere Schaltplane sinnvollerweise 
hieraschisch.

von Bernd W. (berndwiebus) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd.

Bernd B. schrieb:
> So, habe es jetzt auch unter Windows getestet.
> Der Fehler tritt auch hier sowohl mit Accelerated als auch Fallback
> Toolset auf.

~~~~
~~~
~~
~

> Build settings:
>     USE_WX_GRAPHICS_CONTEXT=OFF
>     USE_WX_OVERLAY=OFF
>     KICAD_SCRIPTING=ON
>     KICAD_SCRIPTING_MODULES=ON
>     KICAD_SCRIPTING_PYTHON3=OFF
>     KICAD_SCRIPTING_WXPYTHON=ON
>     KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
>     KICAD_SCRIPTING_ACTION_MENU=ON
>     BUILD_GITHUB_PLUGIN=ON
>     KICAD_USE_OCE=ON
>     KICAD_USE_OCC=OFF
>     KICAD_SPICE=ON

Du hast aber immer noch die gleichen Schalter in cmake aktiviert.

Bei mir sind es andere .

Siehe:

Bernd W. schrieb:

> Build settings:
>     USE_WX_GRAPHICS_CONTEXT=OFF
>     USE_WX_OVERLAY=ON
>     KICAD_SCRIPTING=ON
>     KICAD_SCRIPTING_MODULES=ON
>     KICAD_SCRIPTING_PYTHON3=ON
>     KICAD_SCRIPTING_WXPYTHON=ON
>     KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
>     KICAD_SCRIPTING_ACTION_MENU=ON
>     BUILD_GITHUB_PLUGIN=ON
>     KICAD_USE_OCE=OFF
>     KICAD_USE_OCC=ON
>     KICAD_SPICE=ON

Ausserdem gibt es noch Unterschiede bei Boost und OpenCascade .



Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

von Bernd B. (bbrand)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd,

Bernd W. schrieb:
> Du hast aber immer noch die gleichen Schalter in cmake aktiviert.
> Bei mir sind es andere.

> Ausserdem gibt es noch Unterschiede bei Boost und OpenCascade.

das mag ja sein, die Windows-Version habe ich aber nicht selbst 
übersetzt, sondern den fertigen Installer von kicad-pcb.org verwendet.

Boost und OpenCascade haben vermutlich auf das Rendering eher weniger 
Einfluss.

Gruß,
Bernd

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.