Forum: Analoge Elektronik und Schaltungstechnik LTspice LT1009 will nicht.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von LT1009 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich mehre eben an einer Konstantstromquelle rum, die bei etwa bei 100V 
umschalten soll.
Das macht sie auch in der Praxis. Nun wollte ich eine Hysterese mit R10 
einbauen, und bin bei der Simulation völlig aufs Maul gefallen.
Mit ~35 µA durch R1 muss ich nicht weiter nachdenken.
Da ich davon ausgehe, dass das Problem hier vor dem Rechner sitzt, mit 
der Bitte um , wie ich das halbwegs selber lösen kann.

Danke und Grüße

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
LT1009 schrieb im Beitrag #6231860:
> ich mehre eben an einer Konstantstromquelle rum, die bei etwa bei 100V
> umschalten soll.

Dunkel ist deiner Rede Sinn.

von Helmut S. (helmuts)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Deine Schaltung hat zwei große Fehler.

1. Du musst einen TL431 oder den LT1431 als Regler nehmen.

2. Der Mosfet M1 muss mindestens für 600V geeignet sein.

Im Anhang ist die korrigierte Schaltung für LTspiceXVII. Der obere 
Kurvenzug zeigt die Hysterese deutlicher.
Vielleicht sollte man den Steuereingang des TL431 noch etwas gegen 
Spannungsspitzen schüzen.

Helmut

: Bearbeitet durch User
von LT1009 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> LT1009 schrieb im Beitrag #6231860:
>> ich mehre eben an einer Konstantstromquelle rum, die bei etwa bei 100V
>> umschalten soll.
>
> Dunkel ist deiner Rede Sinn.

Hast recht, soll eine Konstantstromsenke werden, die sich selber je nach 
Betriebsspannung umschaltet. Ist als Grundlast fuer ein SNT mit 
Weitbereichsausgang gedacht (50 - 500V). Das Dingens funktioniert 
prinzipiell ...  (UCC3895)
2009 oder 2010 hat es beim Roehrenbudenstammtisch alle CD-Player und 
Uhren im Umkreis eines Meters (war offen) ausgemacht. 2014 ist 
Hr.Reinhoefer leider gestorben. War ein gemeinsames Projekt ohne 
Prioritaeten oder Zeitzwang. Nun fasse ich es wieder an.

von LT1009 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Deine Schaltung hat zwei große Fehler.
>
> 1. Du musst einen TL431 oder den LT1431 als Regler nehmen.
>
> 2. Der Mosfet M1 muss mindestens für 600V geeignet sein.
>
> Im Anhang ist die korrigierte Schaltung für LTspiceXVII. Der obere
> Kurvenzug zeigt die Hysterese deutlicher.
> Vielleicht sollte man den Steuereingang des TL431 noch etwas gegen
> Spannungsspitzen schüzen.
>
> Helmut

Vielen Dank, Helmut, fuer Deine Arbeit.

1. Wusste ich nicht
2. ist in Wirklichkeit ein D3S080N65B-U , der kann 650V ab und lt. SOAR 
sogar noch nennenswerten Strom bei DC.
3. der BSP99 ist in Wirklichkeit ein BS170.

Auch Dir nochmal ein extra Dank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.