Forum: Analoge Elektronik und Schaltungstechnik LTspice Balance zwischen zwei OPs


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Black D. (blackdice)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Moin zusammen, ich möchte gerne in LTspice die Schaltung auf dem Bild 
realisieren. Mit der Schaltung möchte ich zwischen einem rechten und 
einem linken Kanal hin und her schalten. Ich bin mir aber nicht so 
sicher wie ich das am einfachsten aufbaue. Das Poti R69 hat zwei 
Anschlüsse und ist so angeschlossen dass ich beim rechts Anschlag nur 
den rechten Kanal verstärken und beim links Anschlag nur den verstärke. 
Diesen Vollausschlag bekomme ich auch hin indem ich einfach die Leitung 
von Pluseingang auf Masse setzte. Wenn ich aber bei dem einen 9k und bei 
dem anderen 1k kommt hinten trotzdem das gleich raus.

Ich hoffe mir kann da jemand helfen

BlackDice

von Achim B. (bobdylan)


Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> Wenn ich aber bei dem einen 9k und bei
> dem anderen 1k

Zeichne das mal auf. Das verhindert, dass man sich hier einen Wolf 
schreibt, weil dein Text an den entscheidenden Stellen nicht 
verständlich ist.

von Black D. (blackdice)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so wie das jetzt geschaltet ist müsste nach meinem Verständnis müsste 
der obere OP ein größeres Signal als bei dem unteren OP raus kommen.

von ArnoR (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> so wie das jetzt geschaltet ist müsste nach meinem Verständnis müsste
> der obere OP ein größeres Signal als bei dem unteren OP raus kommen.

Nee, aus beiden OPV kommt das gleiche raus, die Widerstände R69A und 
R69B bewirken nichts und ansonsten sind die OPV ja gleich beschaltet und 
bekommen das gleiche Eingangssignal.

von Achim B. (bobdylan)


Bewertung
0 lesenswert
nicht lesenswert
ArnoR schrieb:
> die Widerstände R69A und R69B bewirken nichts

So siehts aus. Nun erkläre ihm noch, warum das so nicht funktioniert, 
und was er machen müsste, damit es funktioniert. @TO: Das Zauberwort 
heißt Spannungsteiler.

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Du müsstest R69A bzw. R69B auch so verschalten:
1
   100R                    100R
2
    ___                     ___
3
  -|___|-----.            -|___|---
4
             |                     |
5
            .-.                    |
6
            | |                    |
7
        9k  | |  1k               .-.
8
            '-'                   | |<--
9
             o----            10k | |
10
             |.                   '-'
11
            .-.                R69 |
12
            | |                    |
13
        1k  | |  9k                |
14
            '-'                    |
15
       R69B  |  R69A               |
16
             |                     |
17
            ===                   ===
18
            GND                   GND
19
(created by AACircuit v1.28.6 beta 04/19/05 www.tech-chat.de)
Links, was du ändern musst und dem Teil rechts entspricht das dann.
Schleifer weit unten - wenig Signal; Schleifer weit oben - viel Signal.
Das Ganze jeweils vor U2A und U2B.
In deiner Zeichnung ist es (fast) egal, wie groß die Widerstände sind. 
Der Eingangswiderstand von den beiden U2 ist sehr hoch, damit bewirken 
die so nichts.

Übrigens: in LTSpice gibt es auch ein Poti. Siehe Bild. Mit w1 [0...1] 
gibt man die Potistellung an.

von Sven D. (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ein Beispiel wie du Panning mit nur einem Poti realisieren kannst.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> so wie das jetzt geschaltet ist müsste nach meinem Verständnis müsste
> der obere OP ein größeres Signal als bei dem unteren OP raus kommen.

Abgesehen von dem beschriebenen Fehler: warum hast du an den Knoten n009 
und n017 nur 2V Pegel, wenn die OPAs mit ±12V versorgt werden? Ich hätte 
ca. 10V erwartet. Und dann noch Rechteck?
Außerdem: dein Eingangssignal mit 10V Amplitude ist eh viel zu hoch, 
denn du verstärkst ja in den U2-OPAs mit v=3. Deshalb wird trotzdem dein 
Sinus zu einem Rechteck.
Also: reduziere zuerst mal den Eingang auf z.B. 1V Amplitude.

Hinweis: bei solchen Fragen ist es kein Fehler, den LTSPICE .asc-File 
anzuhängen.

von Black D. (blackdice)


Bewertung
0 lesenswert
nicht lesenswert
Danke, auf die Idee mit den Spannungsteiler hätte ich auch selber drauf 
kommen können -.-

Wo finde ich das Poti? Ich habe zwar grad ein Versucht selber zusammen 
zu bauen allerdings funktioniert 0% und 100% nicht da gibt es eine 
Fehlermeldung von LTspice.

Die 2V haben sich auch erledigt hatte da noch einen anderen Fehler 
entdeckt. Die Amplitude habe ich auch auf 1V runtergeschraubt und das 
passt alles schon etwas besser. Normale Audiosignale liegen so bei 
maximal 2V?

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
> Wo finde ein Poti?

In der angehängten zip-Datei im Beitrag 02.05.2020 15.04Uhr
Beitrag "diode UF4007"

von Achim B. (bobdylan)


Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> Normale Audiosignale liegen so bei maximal 2V?

Jo.

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> Wo finde ich das Poti?
Ich mache das Menü Komponentenmenü auf (F2), schreibe 'pot' und schon 
kommt es. Kann natürlich sein, dass ich das im Laufe der Jahre mal 
selber hinzugefügt hatte.
Ich hänge die beiden Files mal an. *.sub im sub-Verzeichnis und *.asy im 
sym-Verzeichnis ablegen.

> Ich habe zwar grad ein Versucht selber zusammen
> zu bauen allerdings funktioniert 0% und 100% nicht da gibt es eine
> Fehlermeldung von LTspice.
Das kann sein. Spice mag keine Widerstände mit dem Wert 0, im *.sub 
steht da auch eine Begrenzung auf 0.1% und 99.9% drin.

von Black D. (blackdice)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bin jetzt mal dazu gekommen das auszuprobieren. Wenn ich das 
Potentiometer aber teste bekomme ich folgenden Fehler: "xu n001 0 n002 
potentiometer rtot = 10k wiper = .5"

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> bekomme ich folgenden Fehler

Sorry, vergessen zu sagen: du musst die Spice-Directive
.lib potentiometer.sub
hinzufügen.

von Black D. (blackdice)


Bewertung
0 lesenswert
nicht lesenswert
Danke, das hat geklappt.

von Black D. (blackdice)


Bewertung
0 lesenswert
nicht lesenswert
Eine Kleinigkeit habe ich noch. Warum steht da Rtot und wie kann ich das 
ändern?

von HildeK (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Fab H. schrieb:
> Warum steht da Rtot und wie kann ich das
> ändern?

Das wird im potentiometer.sub als Variable für den Gesamtwiderstand 
genutzt. Und ist auch im *.asy als Vorgabe drin.

Wenn dir die Bezeichnung Rtot nicht gefällt, dann ändere das in den 
beiden Files. Da dieser File *.sub vermutlich von vielen anderen 
Personen auch verwendet wird, bist du dann allerdings nicht mehr 
kompatibel, wenn du einen File weitergibst oder einen erhältst.

Wenn du nur einen anderen Wert nehmen willst: rechte Maustaste auf das 
Poti, dann die in der Zeile mit "Rtot=10K wiper=.5" den Wert 10k 
und/oder den Abgriff (0...1) anpassen.
Für 'Rtot' und für 'wiper' kannst du auch Variablen eintragen und dann 
über .param  oder .step param die Wirkung verändern. Das ist besonders 
sinnvoll für den Abgriff - siehe Anhang.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.