Forum: Mikrocontroller und Digitale Elektronik Schaltplan überprüfen gerne auch Verbesserungen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Raoul N. (raoul_n)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

einmal kurz die Hintergrundgeschichte. Hab noch eine alte Brio Bahn (so 
eine kleine Modellbahn die auf Holzschienen fährt) die aus meiner 
Kindheit ist, die ich jetzt für meine kleinen Brüder fertig machen 
wollte. Das Problem ist nur leider, dass der Motor nur mit 1.5V 
funktioniert. Also Akku wird damit leider nichts. Nun wollte ich die 
Bahn auf Liion Akku umbauen. Hab noch aus so einer kleinen kaputten 
Drohne einen Akku mit 3.7V und 150mAh den ich dafür verwenden wollte.

So jetzt zum eigentlich wichtigen Teil. Bin gerade dabei einen 
Schaltplan dazu zu erstellen. Aufgeladen soll der mit USB C. Die Bahn 
soll ja auf dem modernsten Stand der Technik sein :-). Hab bei Conrad 
den MAX1551 gefunden, der mir dafür zu passen scheint. (Bzw. Wenn jemand 
einen besseren Chip weiß gerne rein schreiben. Kann auch gerne von einem 
anderen Lieferanten kommen. Also Mouser.de oder so). Kommen wir dann 
schon mal zu meinem ersten Problem. Der Chip, so weit ich das Datenblatt 
richtig verstanden habe, bietet ja die Möglichkeit über den 3. Pin zu 
signalisieren ob der Akku noch geladen wird oder nicht. Der Zug hatte 
vorher vorne eine Lampe gehabt die beim fahren beleuchtet hat. Jetzt 
wollte ich da eine RGBW Led rein machen. Also wenn der Akku geladen wird 
soll die dann halt leuchten. Eine LED hab ich dazu schon gefunden. 
Allerdings benötigt die 5V. Dafür hab ich dann den zweiten Chip 
gefunden. Was mir nur gerade aufgefallen ist, der Connector für den 
Akku, den hab ich noch nicht eingefügt und da muss dann auch noch ein 
Schalter hin. Die sollen zwischen die beiden li_ion Verbindungen kommen. 
An den J3 soll dann der Motor kommen.

Also kurz zusammen gefasst wie kann ich die Led an den MAX1551 ansteuern 
bzw. kann der den Ladestatus überhaupt ausgeben? Und habt Ihr noch 
Verbesserungen für die schematic?

In den Anhängen hab ich mal die Datenblätter angefügt für die ICs und 
der Led. Und auch den Kicad Project Ordner.

: Verschoben durch Moderator
von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Raoul N. schrieb:
> Akku mit 3.7V und 150mAh

Na hoffentlich kann der den Strom lange genug.
Erste Aufgabe: Stromaufnahme der Bahn ermitteln, insbesondere beim 
Anfahren oder wenn der Junior die festhält.

> Aufgeladen soll der mit USB C. Die Bahn
> soll ja auf dem modernsten Stand der Technik sein :-).

Kasperkram, für 150 mA Ladestrom nimmt man ein TP4056-Chinamodul und 
ersetzt den 1k2 Widerstand durch ca. 9kOhm. Wer den China-4056 nicht 
mag, kauft von STM STC4054, der verhält sich sehr ähnlich.

Du darfst gerne USB-C mit PowerDelivery machen, 20 Volt, diese per 
Buckregler wieder heruntersetzen, das wäre dann die Krönung des 
Schwachsinns hoch drei.

von Raoul N. (raoul_n)


Bewertung
0 lesenswert
nicht lesenswert
Manfred schrieb:
> Erste Aufgabe: Stromaufnahme der Bahn ermitteln, insbesondere beim
> Anfahren oder wenn der Junior die festhält.

Na ja, ich dachte jetzt, wenn die vorher mit einer normalen AA Batterie 
fahren konnte, dann sollte der Akku eigentlich ausreichen oder nicht?

Manfred schrieb:
> Kasperkram, für 150 mA Ladestrom nimmt man ein TP4056-Chinamodul und
> ersetzt den 1k2 Widerstand durch ca. 9kOhm. Wer den China-4056 nicht
> mag, kauft von STM STC4054, der verhält sich sehr ähnlich.

Der STC4054 verhält sich doch genau so wie der MAX1551 oder nicht? Ich 
sehe da jetzt nicht so die großen Unterschiede. Der MAX1551 läd nur mit 
90 mAh der STC4054 mit 100 mAh. da würde ich den MAX1551 ja eher 
bevorzugen, da er etwas mehr den Akku schont.

Manfred schrieb:
> Du darfst gerne USB-C mit PowerDelivery machen, 20 Volt, diese per
> Buckregler wieder heruntersetzen, das wäre dann die Krönung des
> Schwachsinns hoch drei.

Wie meinst du das denn jetzt?

von Horst72 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Raoul N. schrieb:
> Na ja, ich dachte jetzt, wenn die vorher mit einer normalen AA Batterie
> fahren konnte, dann sollte der Akku eigentlich ausreichen oder nicht?

Hier ist nun 'mal Technik, da ist es immer angebracht,
erst real zu messen (!) und dann zu denken...
:-) ;-)

Eine AA-Batterie hat (je nach Last/Art/Qualität)
durchaus so ca. 1200mAh bis ca. 2400mAh...

von Alexander K. (pucki)


Bewertung
-2 lesenswert
nicht lesenswert
Mal eine selten dumme Frage von mir.

Wieso läuft das Teil nicht mit ein Norm-AA-Akku-Batterie.
Braucht das Echt 1.5 Volt. (Akkus haben i.d.R. 1.2 Volt)


Gruß

  Pucki

von Raoul N. (raoul_n)


Bewertung
0 lesenswert
nicht lesenswert
Alexander K. schrieb:
> Mal eine selten dumme Frage von mir.
>
> Wieso läuft das Teil nicht mit ein Norm-AA-Akku-Batterie.
> Braucht das Echt 1.5 Volt. (Akkus haben i.d.R. 1.2 Volt)

Eine gute Frage... So weit ich noch weiß, hat selbst die Batterie früher 
nicht lange gehalten und der Motor scheint die 1.5V zu brauchen um zu 
fahren. Da ist keine Elektronik drinnen. Nur die Batterie, ein Schalter 
eine Glühlampe und der Motor.

von Raoul N. (raoul_n)


Bewertung
-1 lesenswert
nicht lesenswert
Horst72 schrieb:
> Hier ist nun 'mal Technik, da ist es immer angebracht,
> erst real zu messen (!) und dann zu denken...
> :-) ;-)

Also ich hab nachgemessen, die Stromaufnahme liegt so bei 120mAh bei 
1.8V.

von Max G. (l0wside) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Raoul N. schrieb:
> Also Akku wird damit leider nichts. Nun wollte ich die
> Bahn auf Liion Akku umbauen.

Hast du einen 1,2V-Akku mal getestet?

> Der Chip [MAX1551], so weit ich das Datenblatt
> richtig verstanden habe, bietet ja die Möglichkeit über den 3. Pin zu
> signalisieren ob der Akku noch geladen wird oder nicht. Der Zug hatte
> vorher vorne eine Lampe gehabt die beim fahren beleuchtet hat. Jetzt
> wollte ich da eine RGBW Led rein machen. Also wenn der Akku geladen wird
> soll die dann halt leuchten.

Das kannst du machen, aber fummle da doch irgendeine weiße LED rein. 
RGBW = vier LEDs (rot, grün, blau, weiß) in einem Gehäuse, das brauchst 
du nicht. Und das von dir ausgesuchte Modul hat fertige Vorwiderstände 
drauf, um an 5V betrieben werden zu können.
Nimm irgendeine andere LED, z.B. Conrad 1526822. Der reichen 3,1V 
Vorwärtsspannung, das passt doch zu deinem Akku.

Den Ansatz finde ich gut, mein Sohn verbraucht bei einmal Spielen pro 
Lok eine Batterie :(

von Raoul N. (raoul_n)


Bewertung
-1 lesenswert
nicht lesenswert
Ja hab einen 1.2V Akku getestet gehabt. Da leuchtete nur die Lampe 
vorne. Mir ist eben noch was eingefallen. Wenn ich einen 10 Ohm 
Widerstand zwischen den lipo Akku mache geht der Motor auch nicht mehr. 
Und wenn ich dann 10 Ohm*0.15 A nehme bekomme ich 1.5V raus. Also mehr 
als ein Akku hat. Und das nur an dem Motor. Da ja vorher eine Glühlampe 
drinnen war fällt an der ja auch etwas Spannung ab.

Und zu der Led, ich hatte halt gehofft, dass ich vielleicht mehrere 
Farben leuchten lassen kann. Also wenn der Akku geladen wird, dass der 
zug halt mit der roten sagt das noch geladen wird, und halt eine grüne 
wenn der Akku voll ist. Und die weiße dann, wenn der zug fährt. Vorne, 
wo die Glühlampe vorher war, ist noch nicht mal platzt für eine 5mm Led. 
Also der Krantz der an einer normalen Led ist passt nicht durch. Wenn 
ich natürlich den Rand abschleifen würde es passen. Daher dachte ich die 
Led. Und die Led gab es bei Conrad einzeln. Nur in dem Datenblatt ist 
die auf der Platine.

Das hier wäre die Led bei 
Conrad:https://www.conrad.de/de/p/thomsen-smd-led-mehrfarbig-5050-rgbw-1575770.html

Bzw. das hier wäre die selbe nur schon 
aufgelötet:https://www.conrad.de/de/p/thomsen-smd-led-mehrfarbig-rgbw-0-30-w-8-lm-120-5-1575772.html

Edit: Oder war die Led 3 mm dick. Weiß ich gerade nicht mehr.

: Bearbeitet durch User
von Max G. (l0wside) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Die LED, die ich dir rausgesucht habe, hat 3mm.

Ansonsten: mache erst mal eine kleine Lösung. Wenn die Lok lädt und 
fährt, kannst du immer noch aufrüsten. Im Moment willst du zu viel auf 
einmal.

von Raoul N. (raoul_n)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So ich hab es jetzt etwas überarbeitet. Allerdings bin ich mir bei den 
Dioden nicht sicher. Gibt es vielleicht eine Diodeneinheit, wo vier in 
einem Chip sind? Die Betriebsspannung sollte so zwischen 0.6V - 0.7V 
liegen. Hab auf Mouser so was nicht gefunden. Weiß nicht ganz wie ich 
danach suchen muss.

von Max G. (l0wside) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
D3 wird nur dann leuchten, wenn du sie umdrehst.
R3 schließt den Akku kurz, wieso? Das soll wohl eine Polwendeschaltung 
werden, aber zum einen ist die Darstellung maximal verwirrend gestaltet, 
zum anderen musst du wohl auch an die Schaltung noch mal dran.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Raoul N. schrieb:
> So ich hab es jetzt etwas überarbeitet

Besorge dir eine FERTIGE LiIon Ladeschaltung (aus irgendeinem Gerät, per 
eBay, wieauchimmer), das ist schlauer als einen SMD Ladechip 
zusammenzufummeln.

Raoul N. schrieb:
> Da leuchtete nur die Lampe vorne. Mir ist eben noch was eingefallen.
> Wenn ich einen 10 Ohm Widerstand zwischen den lipo Akku mache geht der
> Motor auch nicht mehr

Klingt als ob der Motor recht viel Strom braucht, deine 150mA nicht 
reichen. Eine Mignon hat immerhin 3000mAh.

Egal, nimm halt einen grösseren Akku.

Bleibt der 1.5V Motor an 2.5 bis 4.2V Akkuspannung und die für LiIon 
notwendige Unterspannungsabschaltung unter 2.5V, denn dein Akku wird 
kein Schutz-PCB enthalten.

Linearregler für hohe Ströme verballern 2/3 bis 1/2 der Leistung, mit 
Enable-Eingang schalten sie aber gleich ab. Besser wären Buck step down 
Regler mit Unterspannungsabschaltung. Ein
AIC2833B schaltet irgendwo zwischen 3.0 und 3.5V ab, bloss ob man eine 
fertige Platine mit ihm findet ist zweifelhaft. Man muss wohl umgekehrt 
fertige Platinen nach der UVLO Abschaltspannung untersuchen.

von Raoul N. (raoul_n)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Max G. schrieb:
> D3 wird nur dann leuchten, wenn du sie umdrehst.

Ah stimmt danke dir.

So und nun zum Schalter. Auf dem Photo hab ich das mal gezeichnet wie 
der Schalter funktioniert. Also, ich habe einen Schlater der drei 
Positionen hat. Rückwarts, stehen und Vorwärts fahren. Die kleinen 
U.Schalter in dem Schalter sind die beiden schalter für vor und zurück. 
Also wenn ich den oberen Schalter betätige, dreht der Motor in eine 
Richtung, bei dem unterm in die andere Richtung. Da der Schalter aber 
nicht auf der Platine ist, hab ich dafür J4 und J5 reingesetzt. Ich 
hoffe das war verständlich? Sonnst gerne nachfragen.

von Raoul N. (raoul_n)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Besorge dir eine FERTIGE LiIon Ladeschaltung (aus irgendeinem Gerät, per
> eBay, wieauchimmer), das ist schlauer als einen SMD Ladechip
> zusammenzufummeln.

Das Problem ist nur, dass ich den entsprechenden Platz nicht dafür habe. 
Anbei sind ein paar Bilder von den Maßen die ich zur Verfügung habe.

von Max G. (l0wside) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Raoul N. schrieb:
> Da der Schalter aber
> nicht auf der Platine ist, hab ich dafür J4 und J5 reingesetzt. Ich
> hoffe das war verständlich? Sonnst gerne nachfragen.

Hallo Raoul,

doch, doch, das hatte ich schon verstanden. Aber male mal (gerne von 
Hand) den Schalter an einen Ausdruck deines Schaltplans und dann die 
Stromflüsse für Vorwärts- und Rückwärtsbetrieb. Dein aktueller 
Schaltplan passt meines Erachtens nicht, sondern schließt den Akku über 
R3 kurz.
Du solltest auch noch überlegen, wie du die LED an POK anschließt. Im 
Moment dürfte der Pin im Layout nicht angeschlossen werden.
@"MaWin": der MAX1551 ist, wenn ich das recht verstehe, genau für 
Anwendungsfälle wie den von Raoul gedacht: LiIon ohne großes Nachdenken 
einbauen zu können.

Max

von Raoul N. (raoul_n)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Max G. schrieb:
> Dein aktueller
> Schaltplan passt meines Erachtens nicht, sondern schließt den Akku über
> R3 kurz.

Ah jetzt hab ich es glaube ich gesehen. Da wo ich Kurzschluss 
geschrieben habe, da meinst du oder? Aber bei dem R5 dann ja auch...

Edit: Dann muss ich da eine Diode zwischen machen oder? Oder gibt es 
eine andere Möglichkeit?

: Bearbeitet durch User
von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Raoul N. schrieb:
> Gibt es vielleicht eine Diodeneinheit, wo vier in einem Chip sind?

Solche "Diodeneinheit" ist als Brückengleichrichter bekannt.

Wird aber nichts, weil die Spannung nicht genügt, mit Glück könnte es 
gerade so für eine rote LED reichen. Zwei LEDs antiparallel, weg mit den 
4 Dioden.

Mich wundert etwas, dass noch kein Hinweis auf den fehlenden 
Vorwiderstand zur LED gekommen ist.

Weitere Details suche ich nicht, der Stromlauf ist mir zu 
unübersichtlich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.