Forum: Mikrocontroller und Digitale Elektronik Timer Delay mit PNP


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Samuel (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Hallo, ich suche eine simple Schaltung um mittels HIGH +12VDC einen PNP 
Transistor
beim Herstellen der Stromversorgung zum Trennen einer 12VDC Leitung 
bewegt und nach 5 Sekunden die Verbindung wieder herstellt. Transistor, 
weil ich kein Relais klackern haben möchte. PMOS würde natürlich auch 
gehen.

von Thomas S. (thomas_s72)


Bewertung
0 lesenswert
nicht lesenswert
Was ist denn das Problem genau? Wie man einen P-Kanal MOS FET in der 12V 
Leitung steuert?
Oder wie man die 5s erzeugt? Das kann wohl ein 555 wenn es nicht allzu 
genau sein muss. Aber wie soll das angestoßen werden? Mit einem 
Tastendruck?
Ist alles etwas unklar.

: Bearbeitet durch User
von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> Ist alles etwas unklar.

Eigentlich schon klar: er will eine Einschaltverzögerung.
Was aber unklar ist: welche Ströme will er schalten? Solch einfachste 
Schaltungen (Transistor und RC-Glied), die ihm da vorschweben, haben den 
großen Nachteil, dass sie einen langsamem Übergangsbereich von AUS nach 
EIN haben, mit dem großen Nachteil, dass währenddessen viel 
Verlustleistung im Schalttransistor entsteht. Auch gibt es Probleme mit 
der Wiederholgenauigkeit, wenn nur kurz ausgeschaltet wurde.

Da solche Dinge hier x-fach diskutiert worden, empfehle ich dem TO mal 
eine ausführliche Recherche in den Forumsbeiträgen. Dann sieht er auch 
gleich, was da schon bezüglich der Nachteile diskutiert wurde.

von Samuel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo, es geht um maximal 100mA.

Eine - einfache - Einschaltverzögerung ist es ja meines Achtens nicht 
(siehe Beitrag "Einschaltverzögerung CD4011").

Ein Relais geht jetzt übrigens doch, da ich den Einbauort abseits 
erledigen kann, das sollte es einfacher machen.

Es soll beim Herstellen der Stromversorgung das Relais anziehen 
(Verbindung kappen) und nach 5 Sekunden das Relais abfallen (Verbindung 
wiederherstellen).

Wie müsste ich die einfache Einschaltverzögerung (siehe 
http://www.circuitdiagram.org/simple-time-delay-switch-using-cd4011.html) 
verändern, dass nach dem Einschalten der selbe Ausgang Pin 3 anzieht und 
nach 5 Sekunden wieder abfällt?

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
Samuel schrieb:
> Es soll beim Herstellen der Stromversorgung das Relais anziehen
> (Verbindung kappen) und nach 5 Sekunden das Relais abfallen (Verbindung
> wiederherstellen).

Nennt sich Monoflop.

von Samuel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich finde keine passende Schaltung dafür

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Samuel schrieb:
> Wie müsste ich die einfache Einschaltverzögerung (siehe
> http://www.circuitdiagram.org/simple-time-delay-switch-using-cd4011.html)
> verändern, dass nach dem Einschalten der selbe Ausgang Pin 3 anzieht und
> nach 5 Sekunden wieder abfällt?

R und C vertauschen, den Schalter überbrücken. Und auf jeden Fall einen 
Basisvorwiderstand einbauen. Schon dass dieser hier fehlt, 
disqualifiziert deine Quelle! Der arme IC ...
Ob es 5 Sekunden werden, musst du mit den Werten von R und C festlegen.
Richtig wäre aber anstatt eines CD4011 direkt den pinkompatiblen CD4093 
nehmen.

Oder einen CD40106, 6 Inverter mit Schmitt-Triggereingang. Pin 1 an R 
und C, Pin 2 über Widerstand an die Basis; die Pins 3, 5, 9, 11 und 13 
(unbenutzte Eingänge) auf GND oder VCC legen.

Samuel schrieb:
> Eine - einfache - Einschaltverzögerung ist es ja meines Achtens nicht

Warum nicht? Ist doch nur die Frage, welchen Kontakt am Relais du 
nimmst, NO oder NC.

von Sascha W. (sascha-w)


Bewertung
0 lesenswert
nicht lesenswert
Nimm ein Relais (möglichst kleiner Spulenstrom) und schalte die Spule in 
Reihe mit einem Elko an die 12V. Solange der Elko nach dem Einschalten 
aufgeladen wird zieht das Relais an.

Sascha

von Axel S. (a-za-z0-9)


Bewertung
1 lesenswert
nicht lesenswert
Samuel schrieb:
> Es soll beim Herstellen der Stromversorgung das Relais anziehen
> (Verbindung kappen) und nach 5 Sekunden das Relais abfallen
> (Verbindung wiederherstellen).

Und warum muß es ausgerechnet diese Schaltlogik sein, mit einem Öffner 
als Arbeitskontakt? Die meisten Leute würden das genau anders herum 
bauen, mit einem Schließer und das Relais verzögert anziehen lassen.

Das ist so oder so eine Einschaltverzögerung. Und ich finde es grob 
unhöflich von dir, daß du hier mehrere Threads zum gleichen Thema 
aufmachst, ohne einen Hinweis auf den jeweils anderen Thread. Und auch 
noch unter verschiedenen Namen.

von Samuel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Beide Themen haben miteinander NICHTS zu tun.
Wäre es in einem gemeinsamen Thread gelandet, würde man auch nur 
meckern. Also ist eigentlich alles paletti und behindert doch niemanden 
(außer vielleicht Denunzanten). Hier geht es doch aber um Elektronik 
oder?

Ich muss eine 12VDC führende Leitung trennen. Das direkt nach dem 
Einschalten, und nach 5 Sekunden muss diese wieder hergestellt werden.

Ich verstehe es nicht, deswegen frage ich ja hier.
Mit einer Einschaltverzögerung wie aus dem anderen Thema kann ich zwar 
ein Relais über den NC verbinden, und nach 5 Sekunden öffnen lassen, 
dann bleibt es aber die ganze Zeit so. Das ist unnötiger Stromverbrauch.

@HildeK
Basisvorwiderstand vor Pin14 des CD4011 oder vor den NPN an Pin3?

Ich frage, weil ich es nicht weiss. Ist das verboten?

von Samuel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sascha W. schrieb:
> Nimm ein Relais (möglichst kleiner Spulenstrom) und schalte die
> Spule in Reihe mit einem Elko an die 12V. Solange der Elko nach dem
> Einschalten aufgeladen wird zieht das Relais an.
>
> Sascha

Mit 4700uF zieht das Relais in Reihe direkt an.
Ist der C in der Minus Leitung des Relais, lädt der C aber das Relais 
zieht nicht an.???

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Samuel schrieb:
> Basisvorwiderstand vor Pin14 des CD4011 oder vor den NPN an Pin3?
Die Basis hängt direkt an Pin 3, also zwischen Pin 3 und die Basis muss 
ein Widerstand und weil der zwischen dem Ausgang und der Basis 
angeschlossen ist, nennt man ihn Basisvorwiderstand oder 
Basiswiderstand.

> Ich frage, weil ich es nicht weiss. Ist das verboten?
Hatte ich mich über deine Fragen beschwert?

von Samuel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke HildeK, für die Erklärung.
Mein Kommentar galt nicht dir, sorry.

Habe nun mit 100uF und 100k (C und R getauscht) sowie 1k 
Basisvorwiderstand vor dem PNP meine Zeit hinbekommen. Doch irgendwie 
grillt es spätestens nach dem 5. Testlauf meine CD4011er.
Ich setze als PNP SB550 ein und dazu ein herkömmliches Songle 
SRD-12VDC-SL-C Relais.

von Sascha W. (sascha-w)


Bewertung
0 lesenswert
nicht lesenswert
Samuel schrieb:
> Sascha W. schrieb:
>> Nimm ein Relais (möglichst kleiner Spulenstrom) und schalte die
>> Spule in Reihe mit einem Elko an die 12V. Solange der Elko nach dem
>> Einschalten aufgeladen wird zieht das Relais an.
>>
>> Sascha
>
> Mit 4700uF zieht das Relais in Reihe direkt an.
> Ist der C in der Minus Leitung des Relais, lädt der C aber das Relais
> zieht nicht an.???
Hat das Relais vielleicht eine interne Freilaufdiode und du hast es 
falsch herum angeschlossen?
Ansonsten ist es doch egal an welcher Seite der C ist.

Sascha

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
>Habe nun mit 100uF und 100k (C und R getauscht) sowie 1k
>Basisvorwiderstand vor dem PNP meine Zeit hinbekommen. Doch irgendwie
>grillt es spätestens nach dem 5. Testlauf meine CD4011er.

Wie üblich vermutlich unbenutzte Eingänge einfach offen gelassen, und 
Abblockkondensator über Betriebsspannung nicht dran.

: Bearbeitet durch User
von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Samuel schrieb:
> Habe nun mit 100uF und 100k (C und R getauscht) sowie 1k
> Basisvorwiderstand vor dem PNP meine Zeit hinbekommen. Doch irgendwie
> grillt es spätestens nach dem 5. Testlauf meine CD4011er.
> Ich setze als PNP SB550 ein und dazu ein herkömmliches Songle
> SRD-12VDC-SL-C Relais.

Vielleicht solltest du uns mal einen genauen Plan aufzeichnen von dem, 
was du verschaltet hast. Mit allem, Stromversorgung, Bauteilwerte, 
Blockkondensatoren usw.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
Du verwendest noch immer den 4011?
Ich hatte dir bewusst den CD4093 oder den CD40106 empfohlen. Grund:
Normale Gattereingänge mögen keine langsam ansteigenden Signale, das ist 
den Schmitt-Trigger-Eingängen vorbehalten. Und hier hast du mit 
100µ/100k einen extrem langsamen Anstieg!
So kann es insbesondere bei höheren Versorgungsspannungen passieren, 
dass es einen nicht unerheblichen Stromfluss und damit eine relativ hohe 
Leistungsaufnahme gibt, wenn gerade die Eingangsspannung bei etwa der 
Hälfte der Versorgungsspannung sich befindet.
Das könnte ein Grund sein ...

von Samuel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja, nutze noch immer den CD4011, da ich hier dutzende liegen habe und es 
damit ja von der Logik her zu funktionieren scheint.
Werde jetzt aber CD4093 besorgen und dann weiter schauen.

Es geht hier um einen Universal Regensensor fürs Auto.
Ja ich weiß, Spannungsspitzen und so.

Das Ding schaltet halt 12VDC an den Wischermotor und hat eine Leitun, 
wenn diese 12VDC anliegen hat, ist der Regensensor eingeschaltet.
Wenn der Motor läuft, man ihn stoppt und direkt wieder die Zündung 
anmacht (fürs Radio zB) bekommt der Wischer leider direkt erstmal 
sinnlos ein Signal zum Wischen. Das möchte ich unterbinden, indem ich 
die Leitung zum Wischer für 5 Sek. unterbreche.

Steinigung in 3...2...1...

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Samuel schrieb:
> Ja ich weiß, Spannungsspitzen und so.

Ok, 'Auto' war bisher nicht bekannt und dann ist auch das das Problem.
Ohne Schutz können im Auto über 100V auftreten, in beiden Richtungen, 
und das killt jeden solchen IC, auch den 4093.

von Virtuell (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Super! 17 Antworten zu einer Schaltungsfarge ohne einen einzigen 
Schaltplan. Spezielle Spezialisten.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.