Forum: HF, Funk und Felder Fehlersuche VCO Regelkreis anhand von Schaltplan


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Georg Müller (Gast)


Angehängte Dateien:

Lesenswert?

Hallo Zusammen,

ich habe schon in einem anderen Thread "Funktion VCO Regelkreis" 
versucht die Funktion überhaupt abzuschätzen, dabei kamen viele gute 
Ideen und Erklärungen zu Stande:
Beitrag "Re: Funktion VCO Regelkreis"

Ich hatte den alten Thread ein bisschen offtopic missbraucht um die 
Fehlersuche voranzutreiben, naja zum Teil kamen da auch noch 
Erkenntnisse, die mit dem eigentlichen Thema indirekt zu tun hatten, 
jetzt aber würde ich mich komplett entfernen und habe deshalb einen 
neuen Thread aufgemacht.

Ich wollte damit die Schaltung verstehen um einem sehr komischen Fehler 
näher auf die Sprünge zu kommen:

Ich habe das Gerät mit einen anderen PLL IC versehen, um das Gerät um 
die weiteren Kanäle 41-80 zu erweitern. (Neuer Frequenzbereich liegt 
zwischen 26.565MHz -26.955MHz, der alte zwischen 26.9652 MHz – 
27.405MHz)
Diese neue Platine beinhaltet einen Prozessor und ist Pin kompatibel.
Nun habe ich das Problem dass auf niedriger Sendeleistung alles 
funktioniert wie es soll, aber auf 4-facher Leistung scheint der VCO 
nicht mehr richtig mit der Prozessorplatine gekoppelt zu sein.
Das äußert sich so, dass das Gerät auf völlig anderen Frequenzen sendet, 
als eingestellt sind, auch außerhalb seines Frequenzrasters!

Wenn man dann an dem VCO Sendekern L16 dreht, dann kann man die 
Sendefrequenz mit dem verstellen des Sendekerns beeinflussen, bis auf 
die Frequenzen, wo der VCO scheinbar einrastet.
Ich habe es nun geschafft den Kern so einzustellen, dass das Gerät auf 
allen vorgesehen Frequenzen mit niedriger Sendeleistung einrastet.

Frequenzen, die mit hoher Sendeleistung eher nicht funktionieren sind 
eher die, die auf den neuen Bereichen liegen, aber auch wenige einfach 
so dazwischen im alten Frequenzbereich.

Ich habe alles wie im Schaltplan weitestgehend original belassen, nur 
den C39 (nähe Pin17 IC2) habe ich entfernt (war ein Tipp der Herstellers 
der neuen Prozessorplatine) , das hat aber aus meiner Sicht nichts 
verbessert noch verschlechtert, da frage ich mich wozu der dann 
überhaupt da ist.
Das Schleifenfilter wurde auch noch auf C100nF und 68kOhm angepasst.

Die große Frage ist nun, kann man durch wenige Bauteiletausch oder durch 
hinzufügen von zB. Abblockkondensatoren das ganze stabilisieren kann?
Abschirmen der neuen PLL Schaltung und auf Masse legen habe ich schon 
versucht.

Grüße Georg

von Nautilus (Gast)


Lesenswert?

Die Erweiterung des Frequenzbereichs eines Senders ist kein Projekt, 
dass ein Anfänger in der HF-Technik stemmen kann. Selbst ein Profi wird 
sich ohne den Zugriff auf die einschlägige Messtechnik nicht daran 
wagen. Und bedenke: Ein wild gewordener Sender stört nicht nur Dich, 
sondern auch die anderen Nutzer im CB-Funknetz.
Der Sender deines Gerätes ist mit Bandfilter gekoppelt.
Die Optimierung dürfte der Hersteller auf den ursprünglich vorgesehenen 
Frequenzbereich vorgenommen haben. Hier wäre ein Neuabgleich, wenn nicht 
gar eine Umuimensionierung erforderlich.
Bitte beachte die rechtlichen Bestimmungen. Und nicht das Bußgeld ist 
das teuerste, sondern Kosten für die Ermittlung der Störquelle. Für das 
Geld kann man sehr viele Funkgeräte kaufen.

von Belehrbär (Gast)


Lesenswert?

@ Nautilus
Gut dass wir mal darüber geredet haben.....

von Georg Müller (Gast)


Lesenswert?

Alles gut, ich sehe ja auf dem Spektrumanalyzer was abgeht, natürlich 
versuche ich nicht sinnlose Störungen zu produzieren.
Last but not least, das ist ein Hobbyprojekt, kein Mensch will eine 
Handfunke (mit Batterien)  zum Funken benutzen, die Zeiten sind komplett 
vorbei.

Hierzu habe dazu meine fertigen Geräte, die auch für den Bereich 
zugelassen sind.

Aber schön zu hören, dass ich mich nicht komplett blöd dranstelle, ich 
dachte schon dass sowas einfaches nur ich nicht hinbekomme :-)
Ist also doch gar nicht so einfach...

Das schlimmste an so einer Fehlersuche finde ich, dass man mit dem Oszi 
so gut wie nichts messen kann, da immer ein Signal irgendwie einstreut 
und was verfälscht.
Auch die Funktion vom VCO im ursprünglichen Bereich ist kaum zu 
überprüfen.

Ich hoffe dass jetzt der Thread an dem Punkt beendet ist, bevor er 
angefangen hat.

von Georg Müller (Gast)


Lesenswert?

Georg Müller schrieb:
> Punkt nicht beendet ist

von Kurt (Gast)


Lesenswert?

Georg Müller schrieb:
>
> Frequenzen, die mit hoher Sendeleistung eher nicht funktionieren sind
> eher die, die auf den neuen Bereichen liegen, aber auch wenige einfach
> so dazwischen im alten Frequenzbereich.
>

Wenn die korrekte Funktion von der Sendeleistung abhängt dann liegt es 
doch wohl auf der Hand das es damit etwas zu tun hat und nicht an der 
PLL liegt.


 Kurt

von Georg Müller (Gast)


Lesenswert?

Ja vermutlich, daher ja die Frage ob man da irgendwie etwas abblocken 
kann, aber an vielen Pins  kann ich nicht einfach einen Kondensator 
anbringen, das es sich ja hier um HF handelt und alles was ich tue auch 
eine HF Auswirkung hat...

von Kurt (Gast)


Lesenswert?

Georg Müller schrieb:
> Ja vermutlich, daher ja die Frage ob man da irgendwie etwas
> abblocken
> kann, aber an vielen Pins  kann ich nicht einfach einen Kondensator
> anbringen, das es sich ja hier um HF handelt und alles was ich tue auch
> eine HF Auswirkung hat...

Kleine Kondensatoren bei den Pins die keine HF führen, so bei 4,7 .. 30 
PF, schaden meistens nicht. Auch sog "Ferritperlen" helfen da manchmal.

Die Grundursache dürfte aber eher im Sender selber liegen, z.B. durch 
nicht mehr passende Filter usw.
Heisst: das/die Filter sind zu schmalbandig für den nun neuen 
Frequenzbereich und deswegen schwingt der Sender wild oder es koppeln 
Oberwellen usw. auf die PLL ein.

Versuchs mal mit parr-Widerständen zu dem Filter das zur Antennenbuchse 
geht.
Diese machen es breitbandiger.

 Kurt

von Kurt (Gast)


Lesenswert?

.
Nochwas fällt mir ein:
Es könnte auch sein das die HF-Leistung die vom Sender kommt, also der 
Istwert, bei hoher Sendeleistung zu gross ist und die PLL überfährt 
(bedingt durch Fehlanpassung der Sendeendstufe an die Antenne.
Hier hilft vill ein kapazitiver Spannungsteiler  (einige wenige PF).

Das aber wäre wiederum ein Hinweis das mit der Anpassung der Endstufe 
zur Antennenbuchse etwas nicht passt.


 Kurt

von Georg Müller (Gast)


Lesenswert?

Kurt schrieb:
> schwingt der Sender wild oder es koppeln
> Oberwellen usw. auf die PLL ein.

Ist das dann so vergleichbar, wie wenn die Leistung durch stehende 
Wellen reflektiert werden?

Kurt schrieb:
> parr-Widerständen zu dem Filter das zur Antennenbuchse
> geht.

Meinst Du über L6 C74 und was meinst Du mit parr Widerständen, parallel 
Widerstände? Welchen Widerstandswert sollte ich da mal anfangen?

Übrigens die Spulen am Ausgang kann man abstimmen

von Georg Müller (Gast)


Lesenswert?

Kurt schrieb:
> Hier hilft vill ein kapazitiver Spannungsteiler

Langsam Langsam ich bin kein HF Techniker :-)  wo soll der 
Spannungsteiler genau hin, wie berechne ich ihn, oder kann ich auch 
einen Dreko von einem alten Radio mal testweise einsetzen.

von Kurt (Gast)


Lesenswert?

Georg Müller schrieb:
> Kurt schrieb:
>> schwingt der Sender wild oder es koppeln
>> Oberwellen usw. auf die PLL ein.
>
> Ist das dann so vergleichbar, wie wenn die Leistung durch stehende
> Wellen reflektiert werden?
>

Eigentlich nicht.
Ich gehe immer mehr davon aus das du bei hoher Leistung mit parasitären 
Schwingungen konfrontiert bist.

> Kurt schrieb:
>> parr-Widerständen zu dem Filter das zur Antennenbuchse
>> geht.
>
> Meinst Du über L6 C74 und was meinst Du mit parr Widerständen, parallel
> Widerstände? Welchen Widerstandswert sollte ich da mal anfangen?
>

Das ist so einfach nicht zu sagen, fang mit 10 k an und gehe nach unten.
> Übrigens die Spulen am Ausgang kann man abstimmen

Diese müssen auf die (neue) Bandmitte abgestimmt werden.

 Kurt

von Kurt (Gast)


Lesenswert?

Georg Müller schrieb:
> Kurt schrieb:
>> Hier hilft vill ein kapazitiver Spannungsteiler
>
> Langsam Langsam ich bin kein HF Techniker :-)  wo soll der
> Spannungsteiler genau hin, wie berechne ich ihn, oder kann ich auch
> einen Dreko von einem alten Radio mal testweise einsetzen.

Das geht schief, der hat viel zu viel "Fläche" und fängt dir allerhand 
ein.

Du hast dir da aber einen dicken Brocken angelacht.
Da geht ohne Messgeräte wohl garnichts.
Für den Anfang würde wohl ein SDR und ein Umsetzer in den 
Frequenzbereich von diesem reichen.

Ein Gedanke:
Merke dir die Stellung des VR3 (LOW-Sendeleistung), schalte auf geringe 
Sendeleistung und drehe diesen Regler langsam hoch bis das Problem 
auftritt.
Jetzt müsstest du nur noch erkennen können ob das Ausgangssignal noch 
gut ist oder ob es nun parasitäre Schwingungen gibt.
Soweit ich sehe wird die Istfrequenz vom Oszillator abgenommen und nicht 
so wie ich es Anfangs vermutet habe (das mit der Spannungsteilung), 
abhängig von der Sendeleistung. Bringt also nichts.

 Kurt

von Georg Müller (Gast)


Lesenswert?

Danke für die Tipps, ein SDR habe ich in der Tat und habe damit auch 
schon Analysen gemacht.
Im Grunde sieht der Output (auch im Fehlerfall) immer gut aus, eine 
Grundschwingung und ein passenden Abstand die harmonischen Ober und 
Unterbänder, genau wie bei einem vergleichbar gekauften Gerät.

Nur ist die Frequenz in Abhängigkeit der Einstellung  des VCO-Sendekerns 
eben da wo man sie hindreht, das kann vom 25,5MHz bis ca. 28.5MHz sein, 
darüber und darunter bricht sie dann zusammen und es kommt kein Output 
mehr zustande.
Nur wenn man den passenden Bereich am Kern erwischt, dann rastet der VCO 
ein.
Bei zu viel Sendeleistung ist das aber kaum, bis gar nicht schaffbar.
Kann das sein, dass hier nun das Bandfilter zuschlägt, denn Regelbereich 
am VCO-Kern habe ich noch?

von Axel R. (axlr)


Lesenswert?

Da pfeift Dir die HF über die Masse zurück.
Der Treiber und die Endstufe arbeiten rein im C-Betrieb, leidglich der 
Vortreiber (Q14) und der Verdoppler(Q15) arbeiten halbwegs linear, wenn 
man das so nennen mag. Du müsstest mal die HF an den verschiedenen 
Punkten (C90, C85) messen.
Was ist denn im Moment für eine Antenne am Funkgerät angeschlossen?
Sicher die 2,50Meter lange Teleskop-Antenne , grins.
(Ja - ich hatte seinerzeit auch mal so'n Teil, müsste ich mal nachsehen, 
wo das abgeblieben ist :) ).
Bevor du an den Spulen drehst (L14 1/4tel Umdrehung rein, L13, L12 
auch),
klemm mal an den Minus -Anschluss einen kurzen flexiblen Draht und such 
dir an der Heizung ne stelle ohne farbe und schließe das dort an. nach 
möglichkeit nicht gerade 2.40M lang, sondern länger oder kürzer.
Mal sehn, ob es dann besser geht.
Frage aus Interesse: wie ist das mit dem Drehschalter jetzt gelöst?
Und: machst Du uns bitte ein scharfes Foto vom PLL-Ersatz und dessen 
Verbau?
C79 und L11 bilden einen Serienschwingkreis, den man auch etwas nach 
unten korrigieren sollte oder etwas(!) breitbandiger macht, nachdem man 
ihm auf Kanal 1 ( neue Bandmitte! Echt ungewöhnlich, das die Kanäle so 
blöd aneinander gehangen wurden) abgeglichen hat.
Wie groß ist den die VCO Abstimmspannung bei tiefster und höchster 
Frequenz.
Ist denn da nocht etwas Luft nach oben und unten? (Wurde ja schon 
angesprochen)

von Axel R. (axlr)


Lesenswert?

>ist das aber kaum, bis gar nicht schaffbar.
Weil der PLL-Schaltkreis 13.xyMhz sehen will und nicht 26.xy.
Die sieht er aber nun, weil es von allen Seiten reinpfeifft.
Abschirmung hattest Du schon probiert?

von Axel R. (axlr)


Lesenswert?

bin mal "auf die Suche" gegangen:
http://funkservice.at/cb_frequenz.htm
das Teil?
http://funkservice.at/dokus/PLL-Modul%20Einbau%20V3.pdf

daraus:
1
Bei allen anderen PLLs und Modulen niedriger als Version 3e sollte man einen 
2
Serienwiderstand von ca. 470 Ohm in die F-in Leitung hängen, um unerwünschte 
3
Kopplungen zu verhindern. 
4
LC7132 / LC7131: Pin 19

: Bearbeitet durch User
von Georg Müller (Gast)


Lesenswert?

Hey danke für deine Antworten:

ich fange mal von hinten an..

-Ja es ist das Modul, die Kanäle sind durchgängig aneinandergereiht, die 
LED der Stabo habe ich einen zusätzlichen Widerstand eingebaut und 
diesen ziehe ich bei Kanälen über 40 gegen Masse, so wird die LED dann 
heller zu Kanälen unten 41.
Die Pins sind umgebogen und das Modul ist quasi einfach in einen Sockel 
eingesteckt.
Ein Schrumpfschlauch drum und Klebealufolie drüber, die auf Masse direkt 
am Modul gelegt ist.
-Wieso will der PLL 13MHz sehen, wie kommst Du darauf, irgendwie habe 
ich gerade mal wieder das Gefühl ich hab gar nix verstanden :-(
-VCO Spannung bewegt sich von 1,5V bis ca. 4V (die 1,5V sind ca. 
äquivalent zu dem original IC, aber der Spannungsverlauf sieht brutal 
anders aus. Während das Modul eine saubere Gleichspannung erzeugt, 
liefert der original IC eine hochfrequente Rippelspannung zwischen 0 und 
1,5V)
-Die Antenne ist eine verkürzte 1/4 Lambda, mit Kabel als Gegengewicht, 
alternativ habe ich schon eine 1/4 Lambda Antenne mit Magnetfuss auf dem 
Autodach dran, die wirklich einen sauberen Abschluss darstellt.
-Messen wird sehr schwierig musste ich feststellen, irgendwie misst man 
hier nur Müll, vermutlich weil alles nur rumstreut.
Ich kann mal versuchen mit einer Dummy Load zu messen, ich habe ja einen 
externen Antennenanschluss mit Masse ran gebaut.

Ebenso das verdrehen der Spulen kann ich mal testen, da kann man ja auch 
wieder zurück falls nötig.

Was mich aber extrem Fuchst,  wenigstens die alten Kanäle sollten mit 
dem neuen Modul ohne rumdrehen funktionieren, daher habe ich eher den 
Eindruck, dass das neue Modul irgendwie viel mehr gegen Einstreuung 
empfindlich ist als das originale PLL.
Hier müsste man mal wissen, was die damals IC- intern gegen 
Einstreuungen gemacht haben.

Wenn man sich ein bisschen besser auskennen würde, wäre das ein extrem 
cooles Projekt, so ne alte Kiste auf einen aktuellen Stand zu ziehen:-)

von Kurt (Gast)


Lesenswert?

Georg Müller schrieb:

> Ein Schrumpfschlauch drum und Klebealufolie drüber, die auf Masse direkt
> am Modul gelegt ist.

Nimm das mal weg, das könnte nämlich ein Tor sein das dir was 
unerwünschtes reinbringt.
Besonders dann wenn das Band nicht flächig an Masse liegt/verlötet ist.

 Kurt

von Georg Müller (Gast)


Lesenswert?

Kurt schrieb:
> Nimm das mal weg, das könnte nämlich ein Tor sein das dir was
> unerwünschtes reinbringt.

Ich hatte zuvor ohne die Masse dran getestet, aber das half so gut wie 
gar nichts.
Dann habe ich es mit einem HF-Dichtschwamm (großflächig) mit an das 
Massegehäuse daneben überbrückt (ca. 5mm), das half ganz gut, aber mit 
nur einem Kabel zum Massepin der Moduls war bisher am besten.
Da ich aber inzwischen an dem VCO Kern rumgespielt habe, probiere ich 
das auf jeden Fall nochmals neu aus, da kann sich viel geändert haben.

von Axel R. (axlr)


Lesenswert?

Georg Müller schrieb:
> -Wieso will der PLL 13MHz sehen, wie kommst Du darauf, irgendwie habe
> ich gerade mal wieder das Gefühl ich hab gar nix verstanden :-(

Naja - weil das eben so ist, grins
der VCO erzeugt genau die halbe Sendefrequenz. Erst im "Doubler" Q15 
wird diese 'Verzerrt' und am Kollektor die erste oberwelle ausgesiebt. 
Das ist dann deine eigentliche Sendefrequenz, die dann im "Pred-Amp"Q14, 
"TX-Driver"Q13 und "TX-PA"Q12 Auf Leistung gebracht wird. Dabei arbeitet 
Q13 und Q12 ohne Ruhestrom. Die erzeugten Rechteckschwingungen werden 
mit dem Tiefpassfilter am Antennenausgang gefiltert. Wenn jetzt eine 
Teil dieses tollen Wellensalats auf die PLL am "FIN" (PIN19) 
"reinkracht", kommt der Proz komplett durcheinander.
Sieh Dir mal auch den Serienschwingkreis C79 und L11 zwischen Treiber 
und Endstufe an. Der wird noch auf "alter bandmitte" stehen. nur, weil 
das so ist, wird das überhaupt funktionieren. Gerade bei Kanal 35 
aufwärts wird der schön in Resonanz geraten und die Endstufe so richtig 
aussteueren.
Ich weiß von hier aus der Ferne auch nicht, wie ich sonst helfen könnte.
Nebenbei: ich find' das nicht schlecht, sich mit dem Kram zu 
beschäftigen. hab das früher, Anfang der 90er auch gemacht. Ich hatte 
Glück und 'nen Spezi, den Fred DL1RON an meiner Seite...
---
Wie sieht denn der Weg vom C58 zum PIN19 aus? mach mal den Kondensator 
auf 47pF und den beworbenen 740R in Reihe zum PIN 19... Ach, na wenn du 
nix richtig messen kannst, bringt das ja auch nichts.

Was steht denn GENAU auf dem Ersatzmodul drauf, was wurde denn dort 
konkret verbaut? Vielleicht kommen wir dort weiter, mich interessiert 
das.

von Georg Müller (Gast)


Lesenswert?

Ach Du lieber Gott, ich weiß ja gar nix :-)
Danke für die Erklärung, HF Technik ist wirklich eine ganz andere Welt 
wie NF.
Ich frag mich wo man sich das halbwegs etwas beibringen kann, ohne ne 
komplette Ausbildung zu durchlaufen?
Darf man fragen was Du Ausbildungsmäßig gemacht hast?

Den Serienwiderstand zu P19 habe ich schon drin, der wurde auf dem Modul 
höher V3 oder V0.3 verbaut.

Aber mal von alle dem, was hältst Du denn von den Idee vor dem P19 einen 
Bandfilter im gewünschten Bereich einzubauen, da komme platzmäßig ich 
auch noch zwischen Platine und PLL rein.
Bei der Frequenz sollte das auch recht kompakt sein.
Ich probiere auch mal die Ferritdrosseln, die Kurt beschrieb.

Deine Tipps kann ich mal durchprobieren, aber vor dem We komme ich da 
leider nicht dazu.
Auch was für Atmega da genau verbaut ist, kann ich dann erst 
nachschauen.

von Axel R. (axlr)


Lesenswert?

Georg Müller schrieb:
> ich weiß ja gar nix :-)

Du weißt, denke ich, andere Sachen, wo wir hier alle nur staunen würden.
Der eine kann eben dieses, der andere jenes.
Ich bin damit buchstäblich groß geworden. Noch zu Zeiten, wo die 
Leistung auf den Kurzwellenbändern für Funkamateure nicht auf 750Watt 
beschränkt war. Da wurde kräftig auf AM gefunkt. Da klapperten vom 
Wirbelstrom der NF-Modulation die Alubleche vom Chassis. Das ist 
beeindruckend, wenn Du sowas quasi als erstes im Leben zu Gesicht 
bekommst.
man braucht nicht alles können oder wissen. Aber das, was man macht, 
sollte man versuchen, mit Herzblut und Hingabe zu machen.
Es gibt hier im Forum sehr wohl einige, deren Expertise ich sehr zu 
schätzen weiß.

von Axel R. (axlr)


Lesenswert?

Georg Müller schrieb:
> vor dem P19 einen
> Bandfilter im gewünschten Bereich einzubauen,

Na, das wird nicht viel bringen. Das wird über die Masseleitung 
reinkommen Dazu müsste man sich dann doch mal das Layout ansehen. Ich 
habe meine Stabo (Ich hatte tatsächlich son Teil) leider entsorgt. Sonst 
würde ich selbst mal nachsehen... Die originale Ersatzantenne habe ich 
gefunden. hat mal 23,- DMark gekostet ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.