Forum: Analoge Elektronik und Schaltungstechnik Schalter welcher bei 4 Volt bei einer Spannung von 0.75 -4V schaltet bauen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Walter (gery41)


Lesenswert?

Hallo zusammen!

Ich hoffe das mir hier jemand helfen kann.
Ich greife am Schleifer von einem Potentiometer eine Spannung von 0,75 
bis 4 Volt ab.
Nun benötige ich eine Schaltung welche mir bei Erreichen von 4 Volt 
einen Kontakt schliesst über welchen 12 Volt durchgeschaltet werden.
Ich habe bereits einen Versuch mit einer 3,9V Zenerdiode und einem 
Relais unternommen.
Leider klappt es nicht weil die Relaisspule mit ca. 150 Ohm zu wenig 
Strom zieht um den Durchbruch der Zenerdiode zu erreichen.
Der Durchbruch der Zenerdiode wird erst bei einem Widerstand von ca. 2 
Ohm wobei ein Strom con ca. 0,1 Ampere gezogen wird erreicht.
Also unbrauchbar für mein Vorhaben.
Nun wäre ein Vorschlag dieser Community für eine solche Schaltung wenn 
möglich kontaktlos und als Sahnehäubchen vielleicht mittels Trimmer 
feinjustierbar super.
Vielen Dank im Voraus.

von H. H. (Gast)


Lesenswert?


von Michael B. (laberkopp)


Lesenswert?

Walter schrieb:
> Ich habe bereits einen Versuch mit einer 3,9V Zenerdiode und einem
> Relais unternommen.
> Leider klappt es nicht weil die Relaisspule mit ca. 150 Ohm zu wenig
> Strom zieht um den Durchbruch der Zenerdiode zu erreichen.
> Der Durchbruch der Zenerdiode wird erst bei einem Widerstand von ca. 2
> Ohm wobei ein Strom con ca. 0,1 Ampere gezogen wird erreicht.

Klingt falsch.
2 Ohm an 12V macht, selbst wenn man 3.9V abzieht, 4 Ampere, da ist eher 
zweifelhaft ob das Poti nicht in Rauch aufgeht. Die Z-Diode sicherlich, 
die hat ihre 3.9V eher bei 0.01A, nicht 4A. Und wenn das Poti auf 4V 
steht, von dort eine 3.9V Z-Diode an das Relais geht und dieses an 12V, 
dann bekommt das Relais gerade mal 4.1V ab, das reicht sicher nicht 
damit es anzieht.

Walter schrieb:
> bis 4 Volt ab.
> bei Erreichen von 4 Volt

Ebenso zweifelhaft. Wenn dein Poti am obersten Anschlag nur 3.999V 
liefert und das Relais erst bei 4.001V schaltet, bleibt es aus. Wobei 
eine 3.9V Z-Diode keineswegs ab genau 3.9V zu leiten beginnt, sondern 
das eher ein weicher Übergang bei dem irgendwo zwischen 3.7 und 4.1V 
halt 10mA fliessen, dadrunter weniger, dadrüber mehr.

H. H. schrieb:
> TL431
> 
https://dmohankumar.wordpress.com/2012/09/19/tl431-shunt-regulator-switch-design-trick-4/

Sicherlich die passende Lösung, allerdings kostet der TL431 1.8V fur das 
Relais, das bekommt nur noch 10.2V ab, sollte bei der Spannung aber noch 
sicher anziehen.

von H. H. (Gast)


Lesenswert?

Michael B. schrieb:
> allerdings kostet der TL431 1.8V

Nicht mit zusätzlichem Schalttransistor, so wie im Link.

von Enrico E. (pussy_brauser)


Angehängte Dateien:

Lesenswert?

Ihr dürft die Hysterese nicht vergessen, sonst gibt das eine Zitterparty 
und ebenfalls noch einen vorgeschalteten Tiefpass nicht vergessen, falls 
das Poti mal kratzt!

Ein nachgeschalteter Transistor erzeugt exakt 12V für das Relais.

von H. H. (Gast)


Lesenswert?

Enrico E. schrieb:
> Hysterese nicht vergessen

Deshalb schrieb ich:

H. H. schrieb:
> Schaltung noch verbesserungswürdig

von Walter (gery41)


Lesenswert?

Klingt falsch.
2 Ohm an 12V macht, selbst wenn man 3.9V abzieht, 4 Ampere, da ist eher
zweifelhaft ob das Poti nicht in Rauch aufgeht. Die Z-Diode sicherlich,
die hat ihre 3.9V eher bei 0.01A, nicht 4A. Und wenn das Poti auf 4V
steht, von dort eine 3.9V Z-Diode an das Relais geht und dieses an 12V,
dann bekommt das Relais gerade mal 4.1V ab, das reicht sicher nicht
damit es anzieht.

Es handelt sich hierbei um ein kleines Missverständniss. Die 12 Volt 
sollten extern (galvanisch getrennt) betrachtet werden.
Ich habe ein 4 Volt Relais mit ca. 150 Ohm Spulenwiderstand verwendet.
Dabei kam kein Stromfluss mit der Zenerdiode zustande.Und selbst wenn 
ich Plus und Minus verbunden habe nur ein Strom von ca. 0,1 A bei 3,9 
Volt.
Aber egal, funktioniert ja sowieso nicht so.

Das mit dem TL431 sieht ganz gut aus, aber es scheint mir das damit 
meine zu schaltende Spannung von 12 Volt nicht galvanisch getrennt ist, 
oder?
Ich darf absolut keine Verbindung von der geschalteten Spannung zur 
Potentiometerspannung haben.
Einfach gesagt bei 4 Volt soll meine 12 Voltspannung über einen 
Schliesser durchgeschaltet werden, bei 3,9 Volt unterbrochen werden.

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Das mit dem TL431 sieht ganz gut aus, aber es scheint mir das damit
> meine zu schaltende Spannung von 12 Volt nicht galvanisch getrennt ist,
> oder?
> Ich darf absolut keine Verbindung von der geschalteten Spannung zur
> Potentiometerspannung haben.



Welche Versorgungsspannung steht denn primär zur Verfügung?

von Walter (gery41)


Lesenswert?

https://dmohankumar.wordpress.com/2012/09/19/tl431-shunt-regulator-switch-design-trick-4/
Habe erst hier gesehen das eine Trennung durch ein Relais gegeben ist.
Einziger Haken, ich habe ja nur die Eingangsspannung von 4 Volt von 
meinem Poti womit ich dann mein 4 Volt Relais schalte.
Würde das mit der dargestellten Schaltung mit höherer Eingangsspannung 
funktionieren oder müssten Widerstandswerte etc. angepasst werden?

von H. H. (Gast)


Lesenswert?

Erzähl doch einfach um was es wirklich geht.

von Walter (gery41)


Lesenswert?

Welche Versorgungsspannung steht denn primär zur Verfügung?

Wie schon gesagt 4 Volt vom Poti.
Unter 4 Volt Relais aus, 4 Volt Relais an.
Oder auch kontaktlos ohne Relais über Halbleiter?

von H. H. (Gast)


Lesenswert?

Walter schrieb:
>> Welche Versorgungsspannung steht denn primär zur Verfügung?
>
> Wie schon gesagt 4 Volt vom Poti.

Das ist keine Versorgungsspannung.

von Michael B. (laberkopp)


Lesenswert?

Enrico E. schrieb:
> Ihr dürft die Hysterese nicht vergessen

Jein, Relais haben eine Hysterese.

Die simple Schaltung
1
4V ---+          +-------+
2
      |          |       |
3
    Poti---+   Relais    |
4
      |    |     | 1N914 |
5
      |   150k   +--|>|--+
6
      |    |     |       |
7
      |    +--TL431      | +
8
      |    |     |      12V
9
      |   250k   |       | -
10
      |    |     |       |
11
GND --+----+-----+-------+
tut es schon, sie schaltet bei einer geringfügig (wegen der Verstarkung 
des TL431) hoheren Spannung ein als aus, weil viel mehr Spulenstrom und 
somit Magnetkraft notig ist den Relausanker anzuziehen als spater ihn am 
Joch zu halten.

Aber wenn die Spannung einen Brumm hat, dann hört man das Relais 
vielleicht auch brummen, ohne dass es sich aber bewegt.

von Walter (gery41)


Lesenswert?

Erzähl doch einfach um was es wirklich geht.

OK, also von vorne.
Habe einen Elektroroller IO Vienna XE.
Bei diesem wird die Geschwindigkeit über den "Gasgriff" mittels 
Potentiometer von 4 Volt (Stillstand) auf 0,75 Volt (volle Fahrt) 
geregelt.
Die Rekuperation bzw. elektrische Bremsung kann aber nur mittels 
Bremssignal von den Handbremshebeln eingeleitet werden.Dabei wird eben 
eine Spannung von 12 Volt durch einen Mikroschalter an die Steuerung 
durchgeschaltet.
Ich will aber das die Rekuperation wie bei vielen anderen Fahrzeugen 
schon bei Nullstellung des "Gasgriffs" einsetzt.
Dazu will ich eben mit dem 4 Volt Potentiometersignal einen Kontakt 
schliessen welches mir die 12 Volt Spannung an die Steuerung 
durchschaltet.
Im Prinzip wie ein zusätzlicher Bremsschalter halt.
Wenn ich wieder "Gas" gebe fällt die Potientiometerspannung unter 4 Volt 
und das Bremssignal somit wieder weg.
Hoffe das ich das somit verständlich erklären konnte.
Danke jedenfalls schon für Eure Bemühungen.

von H. H. (Gast)


Lesenswert?

Du kannst die Steuerspannung nicht als Versorgungsspannung nehmen. Es 
gibt da sicherlich an anderer Stelle eine Möglichkeit.

von Enrico E. (pussy_brauser)


Lesenswert?

Michael B. schrieb:
> Relais haben eine Hysterese.

Aber nur wenn sie mit einer schwellenden Spannung angesteuert werden! 
Bei einem vorgeschalteten Komparator mit hoher Verstärkung klappern die 
Relais im Grenzfall trotzdem.

von Walter (gery41)


Lesenswert?

H. H. schrieb:
> Du kannst die Steuerspannung nicht als Versorgungsspannung nehmen. Es
> gibt da sicherlich an anderer Stelle eine Möglichkeit.

Als Versorgungsspannung hätte ich auch die 12 Volt vom Bremssignal zur 
Verfügung.
Wie würde dann eine Schaltung aussehen wenn ich die 4 Volt vom Poti 
verwende ohne dieses zu beeinflussen?
Das Potisignal wird von der Fahrsteuerung generiert und hat auch einen 
eigenen unabhängigen Ground als die anderen Fahrzeugsegmente.
Ich selbst bin jahrzehntelang in der Staplerbranche tätig. Daher sind 
mir auch diverse Fahrsteuerungen (Zapi, Sevcon, Curtis,etc...)nicht ganz 
unbekannt.
Mein Roller hat z.b eine österreichisch - slovenische Piktroniksteuerung 
verbaut.
Es ist halt schade das diese nicht wie viele andere bei Nullstellung 
keinen Rekuperationsprozess einleiten können.
Ich besitze auch das Programm für das Notebook und das dazugehörige Can 
Interface und habe damit schon versucht durch einige Parameteränderungen 
zum Ziel zu kommen.
Habe es aber nur zumindest mit dem externen Bremssignal welches auch 
ursprünglich erst zu parametrieren war soweit geschafft.
Nächster Schritt wäre eben die besprochene Schaltung.

: Bearbeitet durch User
von H. H. (Gast)


Lesenswert?

Dein Gasgriff ist mit an Sicherheit grenzender Wahrscheinlichkeit kein 
Poti, sondern ein analoger Hallsensor.


Und jetzt wirds noch abstruser:

Walter schrieb:
> 12 Volt vom Bremssignal



Lass die Bastelei besser sein, du hast doch nicht die geringste Ahnung 
von solcherlei Elektronik.

von Walter (gery41)


Lesenswert?

H. H. schrieb:
> Dein Gasgriff ist mit an Sicherheit grenzender Wahrscheinlichkeit kein
> Poti, sondern ein analoger Hallsensor.
>
>
> Und jetzt wirds noch abstruser:
>
> Walter schrieb:
>> 12 Volt vom Bremssignal
>
>
>
> Lass die Bastelei besser sein, du hast doch nicht die geringste Ahnung
> von solcherlei Elektronik.

Du wirst es nicht glauben, aber Hallsensoren sind in unserer Branche 
gang und gebe. Daher scheint es mir egal ob das Signal über einen 
Hallsensor oder mittels Poti generiert wird.
Was soll daran abstrus sein das schon vorhandene Bremssignal von bereits 
2 vorhandenen Mikroschaltern an den Handbremshebeln um noch einen 
weiteren mittels Relais zu erweitern?
Ist es wirklich so schwer eine Schaltung die bei 4 Volt einen Kontakt 
schliesst und bei 3,9 Volt wieder öffnet zu bauen?

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Ist es wirklich so schwer eine Schaltung die bei 4 Volt einen Kontakt
> schliesst und bei 3,9 Volt wieder öffnet zu bauen?

Ohne Versorgungsspannung?

von Walter (gery41)


Lesenswert?

H. H. schrieb:
> Walter schrieb:
>> Ist es wirklich so schwer eine Schaltung die bei 4 Volt einen Kontakt
>> schliesst und bei 3,9 Volt wieder öffnet zu bauen?
>
> Ohne Versorgungsspannung?

OK, dachte das ein paar Milliampere vom Potisignal für die 4 Volt 
Miniaturrelaisspule nicht so weltbewegend sein würden.
Aber wenn es ohne Versorgungsspannung nich wirklich geht... Hätte dazu 
wie schon weiter oben angeführt von woanders her 12 Volt für die 
Versorgung zur Verfügung und um das Potisignal wirklich nur zur 
Steuerung zu verwenden.
Es darf halt nur keine "Rückkopplung" auf das Potisignal stattfinden um 
das ja nicht irgendwie zu beeinflussen.
Auch der Ground vom Poti und der Versorgung haben verschiedenes 
Potential.
Poti plus und minus werden getrennt aus der Steuerung generiert.
Daher wie könnte man solch eine Schaltung mit meinen Anforderungen 
realisieren?
Zur Ahnung bezüglich Elektronik, ich bin Anwender der sich oft mit 
diversen Problemen in diesem Bereich herumzuschlagen hat.
Schaltungen zu konstruieren gehört aber nicht dazu, dafür hoffe ich ja 
von den Spezialisten hier Unterstützung zu erhalten.

von H. H. (Gast)


Lesenswert?

Finde die 5V Versorgung für den Hallsensor...

von H. H. (Gast)


Lesenswert?

Finde die 5V Versorgung für den Hallsensor...

Messe wieviel Strom die Bremsschalter schalten müssen...

von Stefan F. (Gast)


Angehängte Dateien:

Lesenswert?

Ich würde versuchen, es auf die gezeigte Art anzugehen.

Wahrscheinlich wird der Gasgriff mit 5V versorgt. Selbst wenn nicht, wir 
die Spannung aber auf jeden Fall innerhalb der 12V Versorgung liegen.

Die Stromversorgung des Potis teile ich mit einem Spannungsteiler auf 
3,9 Volt. Wenn das Poti eine höhere Spannung liefert, geht der Ausgang 
des OP-Amp auf LOW und der Transistor schaltet ein.

R4 bestimmt die Hysterese (wie groß der Bereich zwischen ein- und wieder 
aus-schalten ist). Er sorgt dafür, dass das Ding im Bereich der Schwelle 
nicht flattert.

Alle Widerstandswerte habe ich nur grob geschätzt. Als OP-Amp würde ich 
einen MC34071 nehmen. Als MOSFET einen IRF4905. Was da noch auf jeden 
Fall fehlt, ist ein Filter mit Überspannungsschutz für die 12V 
Versorgung.

von Walter (gery41)


Angehängte Dateien:

Lesenswert?

H. H. schrieb:
> Finde die 5V Versorgung für den Hallsensor...
>
> Messe wieviel Strom die Bremsschalter schalten müssen...

Durchgeführt!
Der Fahrgeber besitzt lt. Bild 3 Anschlüsse.
schwarz gegen rot gemessen 5V, wird wohl Versorgungsspannung sein.
blau gegen rot Nullstellung 4,09V
Blau gegen rot Vollgas 0,75V
schwarz gegen blau Nullstellung 0V
schwarz gegen blau Vollgas    160 Millivolt
blau gegen externen Ground 5V ändert sich nicht, egal welche 
Fahrgeberstellung

12V über Bremsschalter werden 1,7A gezogen. Dürfte wohl nur das 
Bremslicht welches Strom zieht relevant sein, das Signal in die 
Steuerung für die Einleitung der Bremsung kann leistungsmässig wohl 
ausser acht gelassen werden.
Also 1,7A über Bremsschalter

Beitrag #7461100 wurde von einem Moderator gelöscht.
Beitrag #7461103 wurde von einem Moderator gelöscht.
von Stefan F. (Gast)


Lesenswert?

Walter schrieb:
> Durchgeführt! ...

Die gemessenen Spannungen passen nicht zusammen.

Vermutlich wird eine Leitung immer 5V haben und eine immer Null Volt 
(GND). Identifiziere diese beiden Leitungen (welche Farbe?).

Messe dann an der dritten Leitung die Spannung gegenüber GND in 
Nullstellung und bei Vollgas.

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> 12V über Bremsschalter werden 1,7A gezogen. Dürfte wohl nur das
> Bremslicht welches Strom zieht relevant sein,

Ist das noch eine Glühlampe?


Und am Sensor hast du sicher Mist gemessen.

von Stefan F. (Gast)


Lesenswert?

Zur Spannungsmessung: Dein Poti oder Hall-Sensor hat drei Anschlüsse:
1
   1           2           3
2
   O           O           O
3
4
   |----U1-----|----U2-----|
5
6
   |----------U3-----------|

U1 und U2 variieren je nach Stellung des Dreh-Griffes. U3 muss konstant 
sein (die vermuteten 5V). U1 + U2 = U3.

In deinem Fall geht die Gleichung nicht auf, daher die Annahme, dass du 
nicht richtig gemessen hast.

von Walter (gery41)


Lesenswert?

Stefan F. schrieb:
> Zur Spannungsmessung: Dein Poti oder Hall-Sensor hat drei Anschlüsse:
>
>
1
> 
2
>    1           2           3
3
>    O           O           O
4
> 
5
>    |----U1-----|----U2-----|
6
> 
7
>    |----------U3-----------|
8
>
>
> U1 und U2 variieren je nach Stellung des Dreh-Griffes. U3 muss konstant
> sein (die vermuteten 5V). U1 + U2 = U3.
>
> In deinem Fall geht die Gleichung nicht auf, daher die Annahme, dass du
> nicht richtig gemessen hast.

Sind mir eh auch komisch vorgekommen die Spannungswerte. Habe ich sonst 
auch immer wie von Dir beschrieben gehabt. Wahrscheinlich in der Eile 
gemurkst. Werde ich morgen nochmals genau messen.
Deine von Dir vorgeschlagene Schaltung sieht jedenfalls super aus. Danke 
vorerst einmal.

Ist das noch eine Glühlampe?
Ja, ist noch eine normale Glühlampe

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Ja, ist noch eine normale Glühlampe

Dann fließen da im Einschaltmoment weit mehr als 1,7A.

von Walter (gery41)


Lesenswert?

Stefan F. schrieb:
> Ich würde versuchen, es auf die gezeigte Art anzugehen.
>
> Wahrscheinlich wird der Gasgriff mit 5V versorgt. Selbst wenn nicht, wir
> die Spannung aber auf jeden Fall innerhalb der 12V Versorgung liegen.
>
> Die Stromversorgung des Potis teile ich mit einem Spannungsteiler auf
> 3,9 Volt. Wenn das Poti eine höhere Spannung liefert, geht der Ausgang
> des OP-Amp auf LOW und der Transistor schaltet ein.
>
> R4 bestimmt die Hysterese (wie groß der Bereich zwischen ein- und wieder
> aus-schalten ist). Er sorgt dafür, dass das Ding im Bereich der Schwelle
> nicht flattert.
>
> Alle Widerstandswerte habe ich nur grob geschätzt. Als OP-Amp würde ich
> einen MC34071 nehmen. Als MOSFET einen IRF4905. Was da noch auf jeden
> Fall fehlt, ist ein Filter mit Überspannungsschutz für die 12V
> Versorgung.
https://www.mikrocontroller.net/attachment/604865/2023-07-23_17-43.png

Hallo Freunde!

Die Schaltung von Stefan habe ich soweit verstanden.
Ich habe nur noch ein Problem mit dem Transistor.
Habe das vorhin einmal mit einem IRF4905 nachgestellt.
12V Spannungsquelle, den Minus an eine Glühlampe 12V/5 Watt.
Plus an den mittleren Anschluss vom Transistor.
Rechter Anschluss an Lampe - Lampe leuchtet.
Nun mein Problem, nach meinem Verständniss sollte die Lampe ja ausgehen 
wenn ich an den linken Anschluss (Gate) Plus anlege.
Habe das mittels eines 1,5KOhm Widerstand vom Plus der 12V 
Spannungsquelle versucht. Tut sich aber gar nichts.
Habe es auch noch mit der eingezeichneten Diode zwischen Out+ und Out- 
probiert. Leider kein Erfolg
Worin besteht mein Denkfehler?
Danke für Eure Hilfe

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Worin besteht mein Denkfehler?

MOSFET nicht verstanden.

von Enrico E. (pussy_brauser)


Lesenswert?

H. H. schrieb:
> MOSFET nicht verstanden.

...und weiter?

von No Y. (noy)


Lesenswert?

IRONIE AN
Ich würde das ganze ja mit einem ATTiny machen..
IRONIE AUS

von Axel R. (axlr)


Lesenswert?

Walter schrieb:
> 12V Spannungsquelle, den Minus an eine Glühlampe 12V/5 Watt.
> Plus an den mittleren Anschluss vom Transistor.
> Rechter Anschluss an Lampe - Lampe leuchtet.

Warum Plus an den mittleren Anschluss vom Transistor?
um in deiner Sprache zu bleiben und ja keinen Schaltplan malen zu 
müssen:
Minus an die Lampe, den anderen von der Lampe an den mittleren vom 
Transistor.
das rechte Bein vom Transistor an die 12Volt löten. am Minus anfassen 
und mit der anderen Hand am linken Fuß vom Transistor anfassen: Lampe 
geht an oder ist schon an. jetzt mit der linken Hand an die 12V greifen 
und mit der anderen an das linke Bein vom Transistor, Lampe geht aus. 
Man kann auch einen Widerstand nehmen: richtig

von Wolf17 (wolf17)


Lesenswert?

Walter schrieb:
> Habe einen Elektroroller IO Vienna XE.
> Bei diesem wird die Geschwindigkeit über den "Gasgriff"

Kann man am Gasgriff keine Nocke anbringen, die auf einen wasserfesten 
Mikroschalter drückt?
Oder einen Magneten ankleben, daneben ein Reedrelais oder kleinen 
Hallsensor?

von H. H. (Gast)


Lesenswert?

Wolf17 schrieb:
> Oder einen Magneten ankleben,

Schlechte Idee, der Griff funktioniert ja magnetisch, mit Hallsensor.

von Walter (gery41)


Lesenswert?

H. H. schrieb:
> Walter schrieb:
>> Worin besteht mein Denkfehler?
>
> MOSFET nicht verstanden.

Bei Null Volt am Gate soll ja Stromfluß zwischen Source und Drain sein.
Bei Plus am Gate kein Durchgang.
Was ist daran falsch?

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> H. H. schrieb:
>> Walter schrieb:
>>> Worin besteht mein Denkfehler?
>>
>> MOSFET nicht verstanden.
>
> Bei Null Volt am Gate soll ja Stromfluß zwischen Source und Drain sein.
> Bei Plus am Gate kein Durchgang.
> Was ist daran falsch?

Entscheiden ist die Spannung zwischen Gate und Source!

Aber du hast ganz einfach Source und Drain vertauscht, so fließt immer 
Strom, wegen der strukturbedingten Bodydiode.

von Walter (gery41)


Lesenswert?

H. H. schrieb:
> Walter schrieb:
>> H. H. schrieb:
>>> Walter schrieb:
>>>> Worin besteht mein Denkfehler?
>>>
>>> MOSFET nicht verstanden.
>>
>> Bei Null Volt am Gate soll ja Stromfluß zwischen Source und Drain sein.
>> Bei Plus am Gate kein Durchgang.
>> Was ist daran falsch?
>
> Entscheiden ist die Spannung zwischen Gate und Source!
>
> Aber du hast ganz einfach Source und Drain vertauscht, so fließt immer
> Strom, wegen der strukturbedingten Bodydiode.

Jetzt wird es schwierig.

Ich habe es natürlich auch umgekehrt versucht.
Plus rechts und Lampe mitte. Wäre mir so auch richtig vorgekommen.
Leider blieb dabei die Lampe immer dunkel, egal ob der plus von der 12 V 
über Widerstand an Gate oder nicht.

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Ich habe es natürlich auch umgekehrt versucht.
> Plus rechts und Lampe mitte. Wäre mir so auch richtig vorgekommen.

Ist es auch.


> Leider blieb dabei die Lampe immer dunkel, egal ob der plus von der 12 V
> über Widerstand an Gate oder nicht.

Gate muss hier an Masse (ggf über einen Widerstand), um den MOSFET 
leitend zu machen! Und unbeschaltet darf es gar nicht sein!

von Walter (gery41)


Lesenswert?

Habe es gerade versucht und funktioniert.
Mein Denkfehler war das ich gedacht habe der Transistor ist leitend wenn 
nichts am Gate anliegt. Er muss aber erst durch den Minus leitend 
gemacht werden.
Dann mit plus ist wieder alles aus. Perfekt!
Wieder etwas dazugelernt.
Mit der Beschaltung ist die Diode am Plan bei Out+ und Out- gemeint?
Danke nochmals.

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Mit der Beschaltung ist die Diode am Plan bei Out+ und Out- gemeint?

Nein, das ist eine Freilaufdiode, falls man eine induktive Last hat. Die 
steckt nicht im MOSFET drin.

von Stefan F. (Gast)


Lesenswert?

Walter, schau dir mal diesen Artikel an: 
http://stefanfrings.de/transistoren/index.html

von Walter (gery41)


Lesenswert?

Ich habe nun versucht die Schaltung von Stefan aufzubauen.
https://www.mikrocontroller.net/attachment/604865/2023-07-23_17-43.png

Komme aber schon beim Spannungsteiler ins stolpern.
Sollte zwischen R1 und R2 lt. Plan ja die 3,9 Volt haben. Wie soll das 
funktionieren wo die beiden Ausgänge ja verbunden sind?
Die 3,9 Volt habe ich zwischen GND und der Verbindung von R1 und R2.
Weiss dadurch auch nicht wo was am Operationsverstärker hin gehört.
Noch etwas - anstatt eines MC34071 habe ich einen LT1224 genommen weil 
dieser in der Schnelle leichter zu bekommen war. Wird hoffentlich egal 
sein.
Freue mich wenn mir wieder etwas unter die Arme gegriffen wird.
Danke!

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> LT1224

Völlig ungeeignet.

von Stefan F. (Gast)


Angehängte Dateien:

Lesenswert?

Walter schrieb:
> Wie soll das funktionieren wo die beiden Ausgänge ja verbunden sind?

Vielleicht ist es so klarer zu erkennen.

von Stefan F. (Gast)


Lesenswert?

H. H. schrieb:
>> LT1224
> Völlig ungeeignet.

Ich hätten jetzt nicht empfohlen, weil hier ein billiger langsamer 
OP-Amp genügt. Aber warum meinst du, er sei völlig ungeeignet?

von H. H. (Gast)


Lesenswert?

Stefan F. schrieb:
> H. H. schrieb:
>>> LT1224
>> Völlig ungeeignet.
>
> Ich hätten jetzt nicht empfohlen, weil hier ein billiger langsamer
> OP-Amp genügt. Aber warum meinst du, er sei völlig ungeeignet?

Kein Single-Supply.

von Stefan F. (Gast)


Lesenswert?

H. H. schrieb:
> Kein Single-Supply.

Wo wolltest du den GND anschließen, wenn eine Dual-Versorgung existieren 
würde?

Ich sehe nur, dass der Input Voltage Range knapp werden könnte.

von H. H. (Gast)


Lesenswert?

Stefan F. schrieb:
> H. H. schrieb:
>> Kein Single-Supply.
>
> Wo wolltest du den GND anschließen, wenn eine Dual-Versorgung existieren
> würde?
>
> Ich sehe nur, dass der Input Voltage Range knapp werden könnte.

Du weißt offensichtlich nicht was Single-Supply bedeutet.

von Stefan F. (Gast)


Lesenswert?

H. H. schrieb:
> Du weißt offensichtlich nicht was Single-Supply bedeutet.

Doch das weiß ich schon. Ich kenne allerdings keinen OP-Amp, der eine 
duale Stromversorgung benötigt. Wie üblich hat auch dieser nur zwei 
Anschlüsse zur Stromversorgung. An beide kommt die 12V Batterie, und gut 
ist.

von H. H. (Gast)


Angehängte Dateien:

Lesenswert?

Stefan F. schrieb:
> H. H. schrieb:
>> Du weißt offensichtlich nicht was Single-Supply bedeutet.
>
> Doch das weiß ich schon. Ich kenne allerdings keinen OP-Amp, der eine
> duale Stromversorgung benötigt. Wie üblich hat auch dieser nur zwei
> Anschlüsse zur Stromversorgung. An beide kommt die 12V Batterie, und gut
> ist.

Du weißt es offensichtlich nicht.

"A single-supply op amp is specifically designed to have a common-mode 
range which extends all the way to the negative supply (ground). Also, 
its output stage is usually designed to swing close to ground."

(Aus dem Anhang)

von Stefan F. (Gast)


Lesenswert?

H. H. schrieb:
> close to ground

Brauchen wir für die Schaltung nicht. Wir haben da noch mehr als 3 Volt 
Abstand.

von H. H. (Gast)


Lesenswert?

Stefan F. schrieb:
> H. H. schrieb:
>> close to ground
>
> Brauchen wir für die Schaltung nicht. Wir haben da noch mehr als 3 Volt
> Abstand.

Eben nicht, der TE hatte ja Murks gemessen.

Und auch sonst sollte man den nicht erlaubten Bereich meiden, da darf 
der Opamp ganz wilde Sachen machen, wie z.B. Phasenumkehr...

von Stefan F. (Gast)


Lesenswert?

H. H. schrieb:
> Eben nicht, der TE hatte ja Murks gemessen.

Stimmt, das war ja noch ziemlich unklar.

von Walter (gery41)


Angehängte Dateien:

Lesenswert?

Ich teste die Schaltung ja mittels eines Labornetzgerätes.
Ich nehme daher die Versorgungsspannung von 5V.
Ich habe nun folgende Spannungen lt. Zeichnung vorliegen.
Wenn ich über R3 eine Plusspannung über 3,9V anlege, sollte doch U1 
Minus ausgeben um den Mosfet leitend zu machen.
Es passiert aber genau das Gegenteil, die Spannung für das Gate steigt 
von 3,73V auf 4,3V.
Die Spannungen in Klammer bei angelegter Spannung Potisignal.
Alle Spannungen immer gegen GND gemessen.
Woher würde eigentlich U1 das Minussignal bekommen um dieses an das Gate 
vom Transistor durchzuschalten?
Es ist mir schon fast ein bisschen peinlich Euch mit meinen Fragen zu 
quälen.

von H. H. (Gast)


Lesenswert?

Woher holst du dir die Versorgungsspannung für den Opamp?

von Walter (gery41)


Lesenswert?

Habe alle lt. Zeichnung gemacht.
Braucht es dazu noch eine externe Spannungsversorgung?
Wenn ja, welche Spannung, welche Anschlüsse?

von Falk B. (falk)


Lesenswert?

Walter schrieb:
> Habe alle lt. Zeichnung gemacht.
> Braucht es dazu noch eine externe Spannungsversorgung?

Ohje!

> Wenn ja, welche Spannung, welche Anschlüsse?

Schon mal ins Datenblatt geschaut?

> anstatt eines MC34071 habe ich einen LT1224 genommen weil
>dieser in der Schnelle leichter zu bekommen war. Wird hoffentlich egal
>sein.

Bist du ein Troll oder wirklich so naiv? Ein 45MHz OPV für einen 
popeligen Schmitt-Trigger. Na hoffentlich schwingt der nicht 
parasitär. Jeder olle LM358 hätte gereicht.

Pin 4 ist V-, das muss an GND, der Minuspul deiner 12V Versorgung.
Pin 7 ist V+, das muss an +12V.

von Stefan F. (Gast)


Lesenswert?

Ich glaube es war ein Fehler  eine Prinzip-Schaltung in den Ring zu 
werfen. Ehrlich gesagt habe ich keinen Bock, das zu einem vollständigen 
Produkt auszuarbeiten. Vielleicht mag das jemand anderes firtführen.

von Axel R. (axlr)


Lesenswert?

Walter schrieb:
> Habe alle lt. Zeichnung gemacht.
> Braucht es dazu noch eine externe Spannungsversorgung?
> Wenn ja, welche Spannung, welche Anschlüsse?

Das ist doch jetzt n Scherz, oder? Scon mal ohne Finger versucht, in der 
Nase zu bohren?
Am Ende fehlt dann noch der Abblock-Kondensator zwischen 4 und 7.
Sollen wir Dir den auch aufzeichnen?
Da ja nichts mehr ohne Jutub geht: bitte
https://www.youtube.com/watch?v=T5f9RuaYzt4&list=PL64WCZAj7X7dNH8SzpoOd71Zf2-A7-330&index=11

von Walter (gery41)


Lesenswert?

Jetzt hatte ich alles soweit mit meinem Netzgerät, Glühbirne leuchtet 
bei 3.98 Volt, geht aus bei 3,89 Volt.
Nun Asche auf mein Haupt, Ihr hattet von Anfang an recht, weil man sehr 
schlecht dazukommt habe ich am Poti Murks gemessen.
Ich habe Versorgungsspannung 4,9 V
Nur am Schleifer kommt 0,8V in Ruhe und 4,1V bei "Vollgas" heraus.
Das heisst genau verkehrt. (Plus gegen Schleifer stimmen ja die von mir 
gemessenen Spannungswerte 4,1V - 0,8V, hilft mir aber nichts)
Der Transistor soll bei 0,8 V durchschalten und darüber öffnen.
Könnte mir bitte noch jemand sagen wie ich das ganze umdrehe.
Ich habe Dank Euch ja viel gelernt und gebe dann Ruhe wenn dieses 
Problem noch gelöst ist.

https://www.mikrocontroller.net/attachment/605197/2023-07-27_16-50.png

von H. H. (Gast)


Angehängte Dateien:

Lesenswert?

Nimm zunächst einen wirklich geeigneten Opamp oder Komparator, z.B. 
LM358 oder LM393.

von Walter (gery41)


Lesenswert?

Danke für die schnelle Antwort.
Im Prinzip ist mir alles klar ausser beim Transistor ist mir der 
Spannungsverlauf nicht ganz klar.
Es werden ja +12V durchgeschaltet und über R7 mit Minus verbunden, wie 
geht das?
Welchen Kanal benötige ich beim IRF7309?
Habe ich nicht gefunden, schafft der IRF7309 meine 12V/21W 
leistungsmässig?

von H. H. (Gast)


Lesenswert?

Walter schrieb:
> Es werden ja +12V durchgeschaltet und über R7 mit Minus verbunden, wie
> geht das?

R7 stellt dein Bremslicht dar.


> IRF7309?

Der ist nur ein Stellvertreter, nimm da ruhig deinen IRF4905.

von Walter (gery41)


Lesenswert?

Es ist vollbracht.
Habe beim Spannungsteiler eine kleine Anpassung gemacht. Anstatt des 
Widerstandes habe ich ein Trimmpoti genommen.
Somit kann ich den Einsatzpunkt punktgenau einstellen.
Roller fährt und bremst wunderbar.
Herzlichen Dank nochmals für Eure Hilfe und Geduld.
Habe auch viel gelernt.
Gruß Walter

von Stefan F. (Gast)


Lesenswert?

Denke daran dass Trimmpotis nach einiger Zeit zu Wackelkontakten neigen. 
Deswegen hatte ich Festwiderstände empfohlen.

von Enrico E. (pussy_brauser)


Lesenswert?

Walter schrieb:
> Anstatt des Widerstandes habe ich ein Trimmpoti genommen.

Deswegen hatte ich schon am 23.07.2023 bereits ein Trimmpoti empfohlen.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.