Forum: Analoge Elektronik und Schaltungstechnik Phasenanschnitt-Steuerung funktioniert nicht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Tim K. (timkl1994)


Angehängte Dateien:

Lesenswert?

Hallo Leute,

ich habe im Moment ein Problem mit der Ansteuerung eines Triac über den 
Optokoppler MOC3052.

Ich habe eine Motorsteuerung, die einen Universalmotor über 
Phasenanschnitt steuern soll.

Ich habe diese Schaltung schon einmal aufgebaut und das hat soweit auch 
funktioniert.

Die Software, die ich verwende, ist auch dieselbe. Ich verwende diesmal 
allerdings einen anderen Controller.

Das Signal vor dem Optokoppler sollte passen. Nach dem Optokoppler messe 
ich kein vernünftiges Signal mehr.

Hat jemand eine Idee, woran das liegen könnte?

von Michael B. (laberkopp)


Lesenswert?

Tim K. schrieb:
> Nach dem Optokoppler messe ich kein vernünftiges Signal mehr

Was kommt denn ? Am 240 Ohm Widerstand entstehen ja nur 
mikrosekundenlange Nadelimpulse. Dein Ansteuerrechteck ist 
synchronisiert mit der Wechselspannungs-Phasenlage ? Im Schaltbild hast 
du einen zero cross Optokoppler, der 3052 ist aber random phase, dafür 
sind 240 Ohm recht knapp, mit Pech zündet der im 325V Scheitel und 
schickt 1.35A ins TRIAC Gate.

von Tim K. (timkl1994)


Lesenswert?

Ja, das Ansteuersignal ist synchron zur Wechselspannungs-Phasenlage.

von H. H. (hhinz)


Lesenswert?

Wo hast du oszi.bmp gemessen? Sinnvoll wäre über R25 zu messen, damit 
man den Strom sieht.

von Tim K. (timkl1994)


Lesenswert?

H. H. schrieb:
> Wo hast du oszi.bmp gemessen? Sinnvoll wäre über R25 zu messen, damit
> man den Strom sieht.

An dem PWM Fähnchen

von Tim K. (timkl1994)


Lesenswert?

Michael B. schrieb:
> Tim K. schrieb:
>> Nach dem Optokoppler messe ich kein vernünftiges Signal mehr
>
> Was kommt denn ? Am 240 Ohm Widerstand entstehen ja nur
> mikrosekundenlange Nadelimpulse. Dein Ansteuerrechteck ist
> synchronisiert mit der Wechselspannungs-Phasenlage ? Im Schaltbild hast
> du einen zero cross Optokoppler, der 3052 ist aber random phase, dafür
> sind 240 Ohm recht knapp, mit Pech zündet der im 325V Scheitel und
> schickt 1.35A ins TRIAC Gate.

Nach der Formel vom Datenblatt ist der Widerstand doch sehr klein?

R = V_peakAC / I_TSM

von H. H. (hhinz)


Lesenswert?

Tim K. schrieb:
> H. H. schrieb:
>> Wo hast du oszi.bmp gemessen? Sinnvoll wäre über R25 zu messen, damit
>> man den Strom sieht.
>
> An dem PWM Fähnchen

Da siehst du nicht ob Strom durch den OK fließt.

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Tim K. schrieb:
> Nach dem Optokoppler messe ich kein vernünftiges Signal mehr.
Dann sollten wir diese Messung nach dem OK sehen, denn es bringt ja 
nichts, eine Spannung zu zeigen, wo alles noch gut ist.

Tim K. schrieb:
> Ja, das Ansteuersignal ist synchron zur Wechselspannungs-Phasenlage.
Kann man dem Oszi-Bild leider nicht entnehmen.

Tim K. schrieb:
> H. H. schrieb:
>> Wo hast du oszi.bmp gemessen?
> An dem PWM Fähnchen
Dann solltest du zusätzlich noch die Spannung am OK messen. Die 
Differenz zwischen diesen beiden Spannungen geteilt durch den R25 ergibt 
dann den Strom durch die OK-LED.

Tim K. schrieb:
> Ich habe diese Schaltung schon einmal aufgebaut und das hat soweit auch
> funktioniert.
Und was funktioniert denn jetz mit dieser Schaltung nicht?
Läuft sie gar nicht, oder immer, oder nur halb, oder zufällig?

Falls sie gar nicht läuft: was passiert, wenn du den Q2 überbrückst? 
Fließt dann überhaupt ein Strom durch die LED (Spannungsabfall am R25)?

: Bearbeitet durch Moderator
von Tim K. (timkl1994)


Lesenswert?

> Tim K. schrieb:
>> Ich habe diese Schaltung schon einmal aufgebaut und das hat soweit auch
>> funktioniert.
> Und was funktioniert denn jetz mit dieser Schaltung nicht?
> Läuft sie gar nicht, oder immer, oder nur halb, oder zufällig?

Der Triac ist permanent durchgesteuert, obwohl ich unterschiedliche PWM 
Signale am OK anliegen habe (das PWM Signal kann ich durch einen Poti 
verändern).

: Bearbeitet durch User
von H. H. (hhinz)


Lesenswert?

Wir können die Messspitzen nicht an die Schaltung halten, wir können dir 
nur sagen was zu messen ist.

von Dietrich L. (dietrichl)


Lesenswert?

Tim K. schrieb:
> Der Triac ist permanent durchgesteuert, obwohl ich unterschiedliche PWM
> Signale am OK anliegen habe (das PWM Signal kann ich durch einen Poti
> verändern).

Auch dann, wenn du den Optokoppler garnicht ansteuerst (Pin 1 und 2 
überbrücken)?
Wenn er dann noch permanent durchgesteuert ist, ist der Optokoppler oder 
der Triac kaputt, oder die reale Schaltung ist anders als der 
Schaltplan.

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Dietrich L. schrieb:
> die reale Schaltung ist anders als der Schaltplan.
Den Verdacht habe ich. Da wäre ein Foto vom realen Aufbau nicht ganz 
schlecht.

Tim K. schrieb:
> obwohl ich unterschiedliche PWM Signale am OK anliegen habe
Hast du denn schon gemessen, ob da ein Strom durch den OK fließt (aka 
eine Spannung am R125 abfällt)?

> obwohl ich unterschiedliche PWM Signale am OK anliegen habe
Wie gesagt: es ist uninteressant, was du am Eingang des OK misst, wenn 
das Problem am Ausgang des OK passiert.

Tim K. schrieb:
> Der Triac ist permanent durchgesteuert
Auch wenn du das Gate offenlässt (mindestens 1 Pin vom R6 auslöten)?

von Tim K. (timkl1994)


Lesenswert?

Dietrich L. schrieb:
> Tim K. schrieb:
>> Der Triac ist permanent durchgesteuert, obwohl ich unterschiedliche PWM
>> Signale am OK anliegen habe (das PWM Signal kann ich durch einen Poti
>> verändern).
>
> Auch dann, wenn du den Optokoppler garnicht ansteuerst (Pin 1 und 2
> überbrücken)?

Nein, dann ist er nicht durchgeschaltet.

von Tim K. (timkl1994)


Angehängte Dateien:

Lesenswert?

Aufbau

von H. H. (hhinz)


Lesenswert?

Dann wird wohl der MOC3052 und/oder der BC817-40 kaputt sein.

von Tim K. (timkl1994)


Lesenswert?

> Tim K. schrieb:
>> obwohl ich unterschiedliche PWM Signale am OK anliegen habe
> Hast du denn schon gemessen, ob da ein Strom durch den OK fließt (aka
> eine Spannung am R125 abfällt)?

An dem Widerstand R25 fallen 0,8 V ab.

von H. H. (hhinz)


Lesenswert?

Tim K. schrieb:
> An dem Widerstand R25 fallen 0,8 V ab.

DMM oder Oszi?

von Tim K. (timkl1994)


Lesenswert?

Multimeter

von H. H. (hhinz)


Lesenswert?

Tim K. schrieb:
> Multimeter

Bei 100% Tastverhältnis? Sonst hast du Mist gemessen.

von Carypt C. (carypt)


Lesenswert?

Wo der Motor ist, sehe ich ja nicht, ich sehe aber einen Snubber 
RC-glied über dem Triac liegen. Kann es sein das induktionsspannungen 
vom Motor kommend über den Snubber den Optokoppler-transistor getötet 
haben. Eine Freilaufdiode am Motor ? Aber ich hab keine Ahnung.

von H. H. (hhinz)


Lesenswert?

Carypt C. schrieb:
> Aber ich hab keine Ahnung.

Dann einfach die Finger still halten.

von Tim K. (timkl1994)


Lesenswert?

H. H. schrieb:
> Tim K. schrieb:
>> Multimeter
>
> Bei 100% Tastverhältnis? Sonst hast du Mist gemessen.

Sorry, bei 100% sind es 2 V. Das wären dann 10mA.

: Bearbeitet durch User
von H. H. (hhinz)


Lesenswert?

Dann ist dein Koppler kaputt, ausgangsseitig.

von Marcel V. (mavin)


Lesenswert?

Tim K. schrieb:
> Sorry, bei 100% sind es 2 V. Das wären dann 10mA.

Das passt! 2V am 120R, 0,1V am BC817 und 1,2V an der Optokoppler-IR-LED.

2V+0,1V+1,2V = 3,3V 👍

Es sind dann aber nicht 10mA sondern 16,7mA.

: Bearbeitet durch User
von Tim K. (timkl1994)


Lesenswert?

Mittlerweile funktioniert die Schaltung. Ich hatte vor dem Motor noch 
einen Gleichrichter geschaltet. Den habe ich nun entfernt.

: Bearbeitet durch User
von H. H. (hhinz)


Lesenswert?

Das kommt nun davon, dass man eben nicht alles gezeigt hat.

von Tim K. (timkl1994)


Lesenswert?

Kann mir einer erklären, warum der Gleichrichter ein Problem ist?

von Michael B. (laberkopp)


Lesenswert?

Carypt C. schrieb:
> . Eine Freilaufdiode am Motor

Bei Wechselspannung ? Besser nicht.

von Wolfgang R. (Firma: www.wolfgangrobel.de) (mikemcbike)


Lesenswert?

Tim K. schrieb:
> Kann mir einer erklären, warum der Gleichrichter ein Problem ist?

Vermutlich gibt es keinen Nulldurchgang mehr, der den Thyristor löscht?
Kann man aber nur bewerten, wenn du die ganze Schaltung zeigst.

von Tim K. (timkl1994)


Angehängte Dateien:

Lesenswert?

Schaltung

von Torsten B. (butterbrotstern)


Lesenswert?

Der Gleichrichter sitzt nach dem Triac (und dem Relais), vor dem Motor.
Jetzt überlege mal, wie der Strom vor und nach dem Gleichrichter 
aussieht.
Du wirst erstaunt sein: das L des Motors versucht, den Strom konstant zu 
halten, daher gibt es auf der AC-Seite eine längere Pause, in der der 
Gleichrichter den Stromfluß übernimmt. Der ACS37002-Stromsensor wird das 
bestätigen.

von Michael B. (laberkopp)


Lesenswert?

Tim K. schrieb:
> Schaltung

Ein Brückengleichrichter direkt um den Motor ist ok, macht Wabeco auch 
so um ihre Waschmaschinenmotoren schneller laufen zu lassen, der TRIAC 
sieht Wechselstrom und schaltet daher ab.

Dass dein Relais beide Adern zum Motor trennt, ist merkwürdig, eine 
reicht eigentlich.

von Tim K. (timkl1994)


Lesenswert?

Michael B. schrieb:
> Tim K. schrieb:
>> Schaltung
>
> Ein Brückengleichrichter direkt um den Motor ist ok, macht Wabeco auch
> so um ihre Waschmaschinenmotoren schneller laufen zu lassen, der TRIAC
> sieht Wechselstrom und schaltet daher ab.

Und wie machen die das?

: Bearbeitet durch User
von Michael B. (laberkopp)


Lesenswert?

Tim K. schrieb:
> Und wie machen die das?

https://www.mikrocontroller.net/attachment/530156/Wabeco_Steuerung.pdf

Warum muss man immer den Leuten, die zu faul zum Suchen sind, die 
Sucharbeit abnehmen, damit sie ihre Faulheit trainieren können ?

von Rainer W. (rawi)


Lesenswert?

Michael B. schrieb:
> https://www.mikrocontroller.net/attachment/530156/Wabeco_Steuerung.pdf

Von einem vernünftigen Schaltplan würde ich erwarten, dass man eindeutig 
erkennen kann, wie die Schaltung aufgebaut ist.
Die vier Anschlüsse des Gleichrichters sind bestimmt nicht beliebig 
vertauschbar.

von Tim K. (timkl1994)


Lesenswert?

Michael B. schrieb:
> Tim K. schrieb:
>> Und wie machen die das?
>
> https://www.mikrocontroller.net/attachment/530156/Wabeco_Steuerung.pdf
>
> Warum muss man immer den Leuten, die zu faul zum Suchen sind, die
> Sucharbeit abnehmen, damit sie ihre Faulheit trainieren können ?

Vom Prinzip her mache ich das ja so. Funktioniert allerdings bei mir 
nicht..

von Michael B. (laberkopp)


Lesenswert?

Rainer W. schrieb:
> Von einem vernünftigen Schaltplan würde ich erwarten, dass man eindeutig
> erkennen kann, wie die Schaltung aufgebaut ist.

Schaltpläne sind für die intelligenteren Leute die die Norm der 
Schaltzeichen schon kennen.

von Tim K. (timkl1994)


Angehängte Dateien:

Lesenswert?

Ist die Größe der Längsdrossel hier entscheidend?

von Mario M. (thelonging)


Lesenswert?

Das ist keine Drossel, das ist die Feldwicklung des Reihenschlussmotors.

von Tim K. (timkl1994)


Lesenswert?

Ich meine Ls

: Bearbeitet durch User
von Mario M. (thelonging)


Lesenswert?

Ach so. Die Drossel verringert die Stromänderungsgeschwindigkeit und ist 
in Abhängigkeit vom Triac zu dimensionieren. Aber warum liest Du nicht 
das Datenblatt, aus dem Du das Bild kopiert hast?
https://www.st.com/resource/en/application_note/an422-improved-universal-motor-drive-stmicroelectronics.pdf

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.