www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit Spannungsdifferenz (OP Schaltung)


Autor: Jakob G. (jakob2)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein, für meine Begriffe etwas komischen Phänomen bei einer 
OP-Schaltung. Aber wahrscheinlich fehlt mir irgendwo das Wissen, was 
dieses erklären kann, daher die Frage.

Also ich habe eine OP Schaltung (siehe Anhang). Ist ja im Prinzip ein 
einfacher Spannungsfolger, das eigentlich interessante ist hier der 
Blockkondensator und der Widerstand.

Wenn ich nun an den Eingang (da wo Sawtooth steht) einen Sinus mit der 
Amplitude 1V anlege, dann kann ich am Ausgang des OP auch wunderschön 
+/-1V (bezogen zu GND) in der Simulation sehen.

Bei einer Dreieckspannung sieht es genauso aus, also auch kein Problem.

Wenn ich nun aber ein Rechteck Signal auf den Eingang lege, dann bekomme 
ich einen Unterschied in der Spannung zwischen vor dem Blockelko und 
nach dem Blockelko.

Auf dem Bild ist das grüne Signal, welches ich generiere +/-1V bezogen 
auf Masse. Nach dem Blockkondensator ist das Signal aber trotz des 10k 
Widerstands um ca. 0.1V nach unten verschoben, sodass ich nurnoch +0.9 
und -1.1V habe.

Lange Rede, aber kurze Frage: Woran liegt das und wie kann ich das 
verhindern?

Ich brauche den Kondensator da unbedingt, weil der Sägezahngenerator auf 
einem anderen Potential liegt (VSS als Masse).

Danke schonmal für Hilfe!

Ach ja, nochwas: Hat jemand von euch einen Tipp für eine Seite, wo mir 
erklärt wird, wie man einen Integrierer diemensioniert? Den brauche ich 
noch für Rechteck --> Dreieck.

Autor: Tom K. (ez81)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jakob,
hat Deine Rechteckspannung einen duty cycle von genau 50%? Über die Zeit 
gemittelt wird rechts von Kondensator die Spannung bei 0V liegen, bei 
ungleichem Verhältnis von Low- und High-Pegel wird deshalb ein DC-Offset 
entstehen.

Grüße

Autor: Jakob G. (jakob2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also laut Spice habe ich genau einen Duty Cycle von 50%, ist zumindest 
so eingestellt..

Wenn ich nun aber den Duty-Cycle etwas verschiebe (die Off-Zeit etwas 
vergrößere; bei 25kHz von 0.00002 auf 0.000022) dann passt es auf 
einmal. Irgendwie scheint der Rechteckgenerator von Spice nicht ganz ein 
Rechteck zu generieren...

Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Jakob,

die Spannung am Opamp-Eingang sollte sich zwar irgendwann symmetrisch um 
GND einstellen, aber erst nach einiger Zeit. Die Zeitkonstante deines 
RC-Glieds liegt bei 10ms. Wenn du wesentlich kürzere Zeiträume 
simulierst, dann erkennst du diese Änderung der mittleren Spannung 
nicht. Zu Beginn "erinnert" sich dieser Knoten noch an die 
Anfangsbedingungen, und am Anfang macht deine Eingangsspannung einen 
Sprung nach unten...

Hast du die Simulation mal für >10ms laufen lassen? In deinem Screenshot 
sieht man die Einteilung der Zeitachse nicht.

schöne Grüße

Achim

Autor: Jakob G. (jakob2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ja klar habe ich die Simulation länger laufen lassen. Der Screenshot ist 
von dem Bereich in dem sich alles eingependelt hat, so bei ca. 100ms.

Autor: Jakob G. (jakob2)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, weiter gehts..

Ich habe mir jetzt mit einem Komparator einen Rechteckgenerator gebaut. 
Soweit kein Problem, funktioniert auch in der Simulation einwandfrei.

Jetzt muss ich daraus ja noch eine Dreieckspannung machen, allerdings 
kann ich doch auch einfach am Kondensator am invertierenden Eingang des 
Komparators ein Dreieck abnehmen, oder?

Was mich daran allerdings etwas stört ist die "bauchige" Form des 
Signals. Kann ich das weg bekommen?

Das gleiche Problem hatte ich auch bei einer Integratorschaltung, die 
ich ausprobiert habe, aber interessanterweise nur dann, wenn das Signal 
eine relativ große Amplitude hat, also wenn der Tiefpass eine recht hohe 
Frequenz hat.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was mich daran allerdings etwas stört ist die "bauchige" Form des
>Signals. Kann ich das weg bekommen?

Das ist eine e-Funktion.

Die entsteht wenn du den zeitbestimmenden Kondensator über einen 
Widerstand auflädst nach folgender Funktion:

Uc(t) = U * (1-exp(-t/R*C))

Wenn du das weghaben willst must du den Kondensator mit einer 
Stromquelle laden b.z.w. entladen.

Dann verläuft die Spannung nach der Funktion:

Uc(t) = I * t /C

I ist dabei der Lade / Entladestrom.

Gruss Gelmi

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Funktionsgeneratorschaltung wo du ein Dreiecksignal abgreifen kannst 
gibt es hier.

Beitrag "signal- bzw. funktionsgenerator mit OPs"

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.