www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PIC steuerung für Relais PIC absturtz


Autor: IGImonster (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten morgen

ich hab mich hier nun mal schlau gemacht im forum aber bisher nix 
vergleichbares gefunden

Ich möchte mit einem PIC ein relais ansteueren das geschiet am ausgang 
über einen Widerstand auf die Basis eines TRansitors der wiederum das 
relais schaltet.

Die ganze schaltung funktioniert einwandfrei der pic arbeitet das relais 
schaltet, sobald wir aber nun Last in ihrgendeiner weise auf die relais 
kontakte geben wird z.b. die lampe mit dem relais zwar angeschaltet und 
auch wieder aus, und wenn wir glück haben  ca 1-5mal aber nicht nach 
programm unentlich der pic kackt regelrecht ab.
kurz nach dem pic abfall können wir wieder ganznormal den pic ansteuern 
und das spiel geht von vorne los.

wir haben unseren pic stromkreis über einen kleinen optokoppler getrennt 
zur ansteuerung von dem relais.

Funktion ist gegeben wenn wir mit dem pic über ein Grosses 
Elektronikleistungsrelais gehen also einen Grossen optokoppler, dier 
wird mit 3,3-12V angesteuert und schaltet 250V 4A.
wenn wir alles darüber laufen haben schaltet nix ab und wir können mit 
unserem testprogramm die lampe zum blinken bringen.

hoffe hier kann mir jemand weiter helfen

Mfg Peter

Autor: HDR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So ganz verstehe ich den Text nicht, da die Grammatik zu wünschen übrig 
lässt.

Aber: Habt ihr eine Freilaufdiode parallel zur Spule des Relais in 
Sperrrichtung geschaltet?

Wenn nein: Wenn das Relai abfällt, entstehen hohe Induktionsspannungen, 
da die Spule versucht den Strom weiterhin fließen zu lassen.
Diese Spannungen bringen im optimal Fall den PIC zum abstürzen. In der 
Regel in den Tod...

Autor: Fabian H. (hdr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ansonsten: Hast Du an den Abblockkondensator vor dem PIC gedacht? (An 
der Versorgungsspannung)

Ist die Spannungen, die die Lampe schaltet, galvanisch von der 
Betriebsspannung des PICs getrennt?

Evtl. hilft ein Kondensator parallel zu den Schaltkontakten.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Das sieht schwer danach aus, als ob die
Schaltkontakte des Relais einen Störfunken
produzieren. Parallel zum Schaltkontakt
ein RC-Glied machen, dann müßte es gehen.

J.K.

Autor: Ditmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
alter Schwede, wenn du deine Schaltungen genauso schlampig baust, wie du 
schreibst, kann das auch nix werden...  kopfschüttel

Autor: IGImonster (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne das sind 2 verschiedene welten rechschreibung und e technik.

also die freilaufdiode ist aufjedenfall drin.

wir haben einen pultaufbau der eben 5v liefert und die netzspannung 230V

wir haben die netzspannung schon durch 2 trenntrafos gejagt und es 
klappt immernoch nicht.

wir haben am ausgang einen kleinen optokoppler gepackt und mit einer 
weiteren galvanisch voneinander getrennten 5V spannung das relais 
angesteuert und es klappt auch nicht.

könnte ich eine genauere beschreibung zum blockkondensator bekommen, 
haben sowas mit kondensatoren angedacht aber haben um ehrlich zu sein 
keine ahnung wie.


ich entschuldige mich für meine schlechte grammatik

Autor: Christine R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Pic kann das Relais schalten, wenn keine Last am Relais hängt? 
Vermutlich Funken am Schalkontakt -> Störung. Versuchs mit dem erwähnten 
RC Glied.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Peter,

der MCLR-Pin der PIC's ist ziemlich empfindlich. Wie ist der bei Dir 
beschaltet?

David

Autor: IGImonster (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab jetzt jedemenge RC glieder eingebaut einmal zwischen Vdd 
und Vss, einmal am zu schaltenden relais.

die schaltung funktioniert bei Ohmscherlast am relais,

bei induktiver last spielt wiedermal alles verrückt.

mein MCLR wird mit einem 10kOhm widerstand auf 5V gezogen.

Danke für die bisherige hilfe Peter

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Macht mehr örtliche Trennung:

1. Optokoppler in der Nähe des PIC.
2. Relais 2 m weg vom PIC.
3. Tantalkondensator 1 uF und 100 nF und Kerakikkondensator direkt 
parallel zum PIC.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Bin der Meinung das das an den Schaltkontakten
des Relais liegt. Hatte bei mir auch Probleme damit.
Habe dann auch ein RC-glied direkt an die Kontakte
gemacht. Brachte zuerst auch nichts. Nachdem ich
dann ein anderes RC-Glied genommen habe, ging es dann.
Bei mir half 100nF + 100 Ohm. Musste mal verschiedene
RC-Glieder ausprobieren.

CU.....

Autor: HDR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber unbedingt auf die Spannungsfestigkeit des Kondensators achten... 
Sonst *PENG!*

Autor: Winne Z. (rugbywinne)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch ein Tip
Beim entstören mit RC-Glied oder Freilaufdioden sind unbedingt kurze 
Leitungen zur Störquelle beachten. Sonst gibt´s ne kleine "Störantenne"

Gegen Störspitzen hilft auch ein Varistor über den Relaiskontakten.

Ist der PIC vernünftig entstört ?
Siebelkos ?
100nF an den Versorgungspins ?
Stabile Stromversorgung ß

Autor: IGImonster (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der PIC ist an den eingängen vernümpftig entstört.
das schalten der relais funktioniert ohne probleme auch das schalten der 
relais mit Ohmscherlast z.B. Lampen.

wollte mit den relais einen motor oder eine Leuchtstofflampe schalten 
und das hat bisher nicht geklappt.

Wollte die stromkreise noch was voneinander trennen und hab mit meinem 
relais ein schütz geschaltet. selbst das klappte nicht, also nahm ich 
ein rc glied und setze es zwischen a1 und a2 und das klappte nun. aber 
auch übers schütz konnte ich bisher keine induktive last schalten.

die spannungsversorgung des pic läuft über ein selbstgebautes 5V 
netzteil was ich aber auchnochmal mit RC gliedern geglättet habe.

Autor: Daniel V. (volte)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du ordentliche Stützkondensatoren bei der Versorgung des PIC?
z.B. 100µ Elko + 100n FolienC


Und wie siehts mit Pull Downs an den Eingängen aus??

Autor: IGImonster (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bin mal hingegangen und hab nur den elko mit 100u und nun läuft es 
bisher am besten. stürtzt nicht ab und die spannung gefällt mir 
mitlerweile auch.

meine eingänge sind mit 10kOhm pulldown widerständen versehen sonst nix.

Autor: Daniel V. (volte)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na optimal, ich nehm immer Elko und FolienC´s zu den PIC´s, dann 
verbleiben so mysteriöse "Aufhänger" :)

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab mir das hier durchgelesen und gleich mal ein paar Fragen:

Wenn ich ein RC Glied parallel zur Schaltspannung hänge und ich hab da 
240V AC... hab ich da dann nicht immer eine Spannung auf der 
Schaltseite? Hab jetzt nicht gerechnet mit den Frequenzen und so aber AC 
geht doch durch den Kondensator.

Was ist an FolienCs falsch?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.