www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRCTRL1.0 Mega32


Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

habe inzwischen mein AVRCTRL Board mit dem Mega32 zu laufen gebracht,
man
muß ja auch erst drauf kommen, dass neben den FUSE bits das JTAG
Interface abgeschaltet werden muß. Unter BASCOM geht dies mit:

'Use the following code to disable JTAG
Mcusr = &H80
Mcusr = &H80

dann geht alles prima.

Ein weiteres Problem. Hat schon mal jemand unter BASCOM versucht den
Inhalt des LCD-Displays zu lesen ? Hat jemand eine SUB um dies zu
realisieren. Wäre für jeden Tip dankbar.

Gruß

Chris

Autor: Jochen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"man muß ja auch erst drauf kommen, dass neben den FUSE bits das JTAG
Interface abgeschaltet werden muß"

Wer lesen kann, muss da nicht drauf kommen. Steht schliesslich im
Datenblatt...

Autor: @Jochen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nett !

Autor: @jochen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ziemlich arrogante Antwort, find ich,
nicht jeder hat Zeit Datasheets auswendig zu lernen ! Außerdem findet
sich beim Anbieter des Boards keinerlei Hinweis darauf. Mache
'Profis' brauch das wohl.

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, dafür wird Doku ja geschrieben, damit man nachlesen kann. Wobei in
deinem Fall es sicher schwer zu finden ist, weil man an sowas gar nicht
denkt.

Aber wenn man das Datenblatt halt mal durchliest, sieht man auch erst,
welche Möglichkeiten man hat (und es fallen einem die Fallstricke auch
auf).

Niemand verlangt von dir das alles auswendig zu lernen, aber wenn du
dich ernsthaft mit dem Mikrocontroller beschäftigst, sollte es doch das
naheliegendste sein, dich im Datenblatt zu informieren.
Ich hab auch erst vor 2 Wochen mit Mikrocontroller angefangen, aber
dank Datenblatt noch alle Probleme lösen können.

Autor: Stefan Kleinwort (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sehe das Problem nicht.

Chris hat beschrieben, was er für Probleme bei der Inbetriebnahme des
mega32 hatte, und wie er sie schliesslich lösen konnte.
Das wird sicher dem ein oder anderen weiterhelfen, nicht über dieses
Problem zu stolpern.

Ich finde solche Postings immer prima. Sie zeigen das Bemühen, andere
von den eigenen Fehlern lernen zu lassen.

Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.