www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AT JTAG ICE mkIIi zerschossen - Garantie?


Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein JTAG ICE mkII hat sich beim Autoupdate der Firmware nach 
Installation des AVR32 Studios V2.1 zerlegt. Habe alles schon probiert 
Linux/Windows USB/COM-Port usw. AVR Studio sagt beim Versuch eines 
Updates immer "failed to write block 39". AVR32 Studio bricht einfach ab 
und neben dem JTAG Icon erscheint ein rotes 
Einbahnstraßen-Verbotssymbol(oder wie das auch immer heisst).
Das Gerät wurde im Jahr 2004 gekauft und die Rechnung finde ich nicht 
mehr. Bei Atmel Deutschland hat man mir gesagt ich soll mich an den 
Distributor wenden. Ich weiß aber nicht mehr welcher das 
war(Wahrscheinlich MSC). Hat irgend jemand Erfahrungen mit dem Support 
von Atmel in so einem Fall oder muss man jetzt 300,- Schleifen für ein 
Neugerät ausgeben?
BTW. Vor dem Zwangsupdate lief das Ding einwandfrei. Sehr ärgerlich da 
über die Feiertage an meinem AVR32-Board basteln wollte...

Danke schonmal und viele Grüße

Autor: vw1701 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Frage nach Garantie kann man wohl eindeutig mit nein beantworten.

wir haben 2008 Ende, und das Board hast du 2004 gekauft - ohne weiteren 
Nachweis, also gute 5 Jahre zurück.

Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm,

wieso Board? Es geht um den mkII. Vielleicht hat ja jemand mit den Atmel 
Reperaturservice Erfahrungen gemacht, falls es so etwas gibt.
Es ist halt super ärgerlich. Das ist ja schließlich ein 
Zwangsupdateprozess bei AVR32 Studio insofern könnte sich Atmel schon 
ein wenig kulant zeigen.

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Das ist ja schließlich ein
> Zwangsupdateprozess bei AVR32 Studio insofern könnte sich Atmel schon
> ein wenig kulant zeigen.

ja, bin der Meinung da soll Atmel was machen es war nicht dein Fehler!
Ich habe sowas gehabt aber nicht mit Atmel sonder mit Dell, habe ein 
BIOS Update gemacht und mein Laptop hat nicht mehr gestartet quasi TOT, 
Dell hat dann neu Board beigestellt da ja nicht mein Fehler war.

Gruß

Autor: Hannes Jaeger (pnuebergang)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weihnachtsmann wrote:
> Bei Atmel Deutschland hat man mir gesagt ich soll mich an den
> Distributor wenden. Ich weiß aber nicht mehr welcher das
> war(Wahrscheinlich MSC). Hat irgend jemand Erfahrungen mit dem Support
> von Atmel in so einem Fall oder muss man jetzt 300,- Schleifen für ein
> Neugerät ausgeben?

Atmel Support halt ... Atmel ist nun mal nicht Microchip.

Aber es mal mit einer älteren Version von Studio (z.B. 4.13 SP2) oder 
der allerneusten Version zu versuchen hätten sie Dir schon mal 
vorschlagen können.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du könntest mal beim AVR-Support nachfragen, ob sie dir das tauschen.

Ansonsten, wir hatten das vor einiger Zeit auch mal bei ein oder zwei
Exemplaren (aus einer allerdings ziemlich großen Gesamtquantität :),
vom Zeitraum her könnten die zu ähnlichen Zeiten produziert worden
sein wie deins.  Dort hat es geholfen, das Teil vor dem Update in den
Kühlschrank zu legen oder kurz mit Kältespray zu bepusten.  Ist der
Firmwareupgrade einmal durch, dann laufen die Teile wieder OK.  Keine
Ahnung, was genau dieses Fehlerbild verursacht hat, die neueren
Versionen scheinen das Problem behoben zu haben, das tauchte später
nie wieder auf.

Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok,

vielen Dank schon mal. Das sind ja schon ein paar Tipps. Werde mich 
morgen mal dran machen. Die Dame von Atmel Support schien mir auch etwas 
überfordert vielleicht erreiche ja im neuen Jahr jemanden der mir ein 
Austauschgerät schickt.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weihnachtsmann wrote:

> Die Dame von Atmel Support ...

Nee, nix Dame.  Nimm den AVR-Email-Support.

Autor: Gerald (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Wenn ich mich nicht täusche, dann hat doch der ISP mkII die Möglichkeit,
eine Grundfirmware einzuspielen, falls mit den Firmware-Updates etwas 
schief geht.
Schau mal bitte ins Handbuch, bzw. auf der Atmelseite, wie das geht.
http://www.atmel.com/dyn/products/tools_card.asp?t...

Ausserdem: Hast du vorher das Communicationsprotokoll upgedated?
>>   AVR067: JTAGICE mkII Communication Protocol (Application Note, 82 pages, 
revision C, updated 04/06)
This document describes the communication protocol used between AVR 
Studio and JTAGICE mkII. <<
Wenn nicht, könnte das vielleicht auch eine Ursache für den Absturz 
sein, zumal du ja deinen MKII seit 2004 hast, und das Protokollupdate im 
Apr/2006 war.
==>> Da sollte es eine Exe Datei im Web geben, downloaden, ausführen, 
und das Ding sollte aktuell werden.

Und jetzt ist sicher schon eine neuere Firmware vorhanden. Suche mal in 
diese Richtung.... :)
Ich denke, zum Zurücksetzen der Firmware wirst das Gerät öffnen 
müssen?!? bin jetzt nicht sicher, und 2 Pins während dem Einschalten 
kurzschliessen um dann das MK-Programm laden zu können. -> Handbuch.


Viel Spass beim Programmieren.
Beste Grüße
Gerald

Autor: Gerald Schwarz (geralds)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Hier ein kleiner Nachtrag:

http://support.atmel.no/bin/customer?=&action=view...

LG
Gerald

Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

den Link zum manuellen Flashen des ISP kenne ich. So etwas habe ich aber 
für den JTAG-ICE nicht gefunden.
Das letzte Update des Adapters war vor ein paar Monaten. Also nicht von 
2004 auf 2008. Ich hatte das Ding ja nicht Jahre in der Schublade liegen 
;)

Trotzdem Danke

Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg,

> Nee, nix Dame.  Nimm den AVR-Email-Support.

Kannst Du mir die Adresse geben. Oder meinst Du damit das 
Kontaktformular auf der Atmel Seite? Da kann man nicht den JTAG ICE mkII 
als Produkt wählen :(

Danke

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Installier doch mal ein altes AVRStudio (nicht für AVR32) und versuch es 
mal zurück downzugraden.

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach ein bißchen nachdenken ist mir auch noch eingefallen, daß 
Widerstanswerte und Kapazitäten auch Temperaturabhängig sind. Sie 
könnten während der Kälteperiode die richtigen Werte erreichte haben. 
Nicht alle aber die Kritischen ... :)

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ups ... falscher Post.

Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nachdem der Atmel-Support mich an meinen Sales-Representative verwiesen 
hat und der sich auch nicht gemeldet hat, habe ich das Teil jetzt 
tatsächlich mal 15min aus dem Fenster gelegt (bei ca. -8°C) und siehe da 
es ging!!!
Habe vorher mindest 20 erfolglose Flashversuche unternommen.

Also Danke nochmal Jörg!

Bugs gibts... 8)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weihnachtsmann wrote:

>> Nee, nix Dame.  Nimm den AVR-Email-Support.
>
> Kannst Du mir die Adresse geben.

avr@

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.