www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Rail-to-Rail will nicht.


Autor: Kaisergollum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal eine Frage an alle Spezialisten unter euch..

Ich habe vor ein Normsignal von 4-20Ma in eine Spannung von 0-10Volt 
umzuwandeln.
Warum? Gute Frage, soll ich für ein Projekt an dem ich arbeite machen 
:-)

Meine Lösung war als erstes einen Strom-Spannungswandler oder auch 
Transimpedanzverstärker einzusetzen.Als Widerstand setzt ich 625 OHM ein 
um hier einen Ausgangsspannungsvereich von -2,5 bis -12,5 Volt zu 
erreichen.

Als nächstes follgt dann ein Differenzverstärker. Der eine Eingang wird 
dabei mit einem  Referenzspannungs- IC (LT1019) beschaltet...und fertig 
sind 0-10Volt.

Eigentlich.

Laut Schaltungssimulation-Software funktioniert das auch, aber in echt 
:-(

Habe bereits schon beim I-U-Wandler das Problem das dieser bei 20mA am 
Eingang gar nicht bis auf -12,5 Volt runterregelt. Komme mit einem LM741 
nur auf etwa 11,5 Volt.

Und nun dachte ich ich bin schlau und habe Rail-to-Rail besorgt und 
eigesetzt (LT1013)......
und was passiert???? Bei etwa -12,2Volt ist Schluß.Sollte der nicht 
eigentlich bis mind. 14 volt runterkommen???

Und nun kommt Ihr. Das doch nicht normal oder?????????

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm wenn ich richtig gelesen habe.

Dann hatt dieser als Kurzschlussstrom 20mA.

Wenn du nun 20mA Strom in den I-U-Wandler schickst muss dieser am 
Ausgang schonmal 20mA zur Verfügung stellen.

Wenn du nun noch ein Strom an den 2ten Op gibts könnte dein erster Op in 
Strombegrenzung gehen kann das sein?

Autor: GB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kriegst Du an deinen 625 Ohm 12,5V? Ansonsten kann dein Stromausgang die 
20mA nicht in 625 Ohm treiben.

1. Ich würde eine niederohmige Bürde verwenden, z.B 250 (bzw 249 Ohm).
2. Bei 249 Ohm 4mA --> 1V, 20mA --> 5V
3. Referenz mit 1 Volt erzeugen
4. Eingangsspannung und Referenz auf einen Subtrahierer --> 0 .. 4V
5. Verstärken um Faktor 2,5.

Autor: kaisergollum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das klingt auch nach einer guten Möglichkeit. Werd ich mal 
ausprobieren...
Der Schaltungsaufwand ist zwar höher, aber wenn die blöden OP's nicht so 
weit runter kommen wie sie sollen, bleibt mir wohl nix anderes übrig....

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann nimm doch statt des ollen LM741 mal was gescheites.
TS912 oder so. Die koennen auch bis an die Versorgungsspannung ran.

Gruss Helmi

Autor: kaisergollum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich dachte eigentlich ich hätte mir schon was gescheites besorgt mit den 
LT1013.......soll laut datenblatt min. an die 14 volt rankommen...aber 
nix is...

und die waren echt teuer.....

Autor: Felix Bonjour (e-b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der LT1013 ist optimal für deine Anwendung! Wenig Offsetspannung und RTR 
und das seit 20 Jahren.

Wird in der Industrie seit langem für deine Anwendung eingesetzt.

Cheers
Felix

Autor: kaisergollum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab ich mir ja auch gedacht, aber wieso kommt das ding dann nicht mal 
annähernd an die 13 volt ran? würd mir ja schon reichen.....

bei einer normalen op-invertierer-schaltung mit 625 ohm -r als 
gegenkopplung muss ich doch mal auf -12,5 volt kommen, bei einem max. 
eingangssrrom von 20mA....

oder hab ich irgendwie die massen falsch? wie verbinde ich den die 
stromquelle richtig mit der schaltung???? vlt liegt auch da mein 
fehler...

Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>das ding dann nicht mal annähernd an die 13 volt ran?
Ich kenne deine Schaltung nicht! Zeig doch mal dein Schema.

Wenn der so wie Datenblatt und den Applicationnotes betrieben wird 
funktioneirt der Einwandfrei.

Autor: senex24 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Woher kommt eigentlich das Gerücht, der LT1013 sei rail-to-rail?

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Schaltungsaufwand ist zwar höher, aber wenn die blöden OP's nicht
> so weit runter kommen wie sie sollen, bleibt mir wohl nix anderes
> übrig....

Wieso ist der Aufwand bei dem Vorschlag von GB größer? Dr braucht doch
auch nur zwei OPV.

Wie hoch sind denn die zur Verfügung stehenden positiven und negativen
Versorgungsspannungen? Sind sie stabilisiert?

Autor: max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
RCV420

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Und nun dachte ich ich bin schlau und habe Rail-to-Rail besorgt und
> eigesetzt (LT1013)......
> und was passiert???? Bei etwa -12,2Volt ist Schluß.Sollte der nicht
> eigentlich bis mind. 14 volt runterkommen???
>
> Und nun kommt Ihr. Das doch nicht normal oder?????????
Jetzt müßtest Du nur noch ne Glaskugel rüberschicken. Ein Schaltplan 
täte es auch. Den hast Du ja schon vorliegen, weil Du ja auch simuliert 
hast.


Gruß,
  Michael

Autor: kaisergollum (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so, nun hier noch mal meine schaltung.....

diie frage ob der lt1013 ein rail-to-rail ist, hab ich mir auch schon 
gestellt, aber er wird als solcher verkauft.
und laut datenblatt soll er im minimum auf 12,5 volt kommen und 
typischerweise sogar auf 14 volt...

bin für jeden hinweis dankbar, aber werd die schaltung von "GB" am 
freitag mal aufbauen zu testzwecken....

ach ja, an dem grün markierten "A" in der schaltung soll ich meine -2,5 
bis -12,5 volt haben......aber auch wenn der rest der schaltung nicht 
dranhängt komm ich da nicht hin...

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> diie frage ob der lt1013 ein rail-to-rail ist, hab ich mir auch schon
> gestellt, aber er wird als solcher verkauft.
Aber nicht von LT  :-/

Das Datenblatt sagt klar, dass schlimmstenfalls 3V bis zur 
Versorgungsspannung fehlen ( +-15V Vcc --> UA min. +-12V  bei 2kOhm 
Last).

> Bei etwa -12,2Volt ist Schluß.
> Und nun kommt Ihr. Das doch nicht normal oder?????????
Doch, exakt im grünen Bereich :-o

Autor: Helmut Lenzen (helmi1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der LT1013 ist kein Rail to Rail OP
Der wird als Single Supply OP verkauft das ist nicht das selbe.
Nur der Eingang kann bei Single Supply bis an GND arbeiten der Ausgang 
nicht.

Aber warum baust du die Schaltung so kompliziert auf ?
Es geht auch einfacher.

Gruss Helmi

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der LT1013 ist kein Rail to Rail OP
> Der wird als Single Supply OP verkauft das ist nicht das selbe.
Es gibt aber auch Single Supply Rail to Rail OPs.  ;-)
(@ Helmi: ich weiß, dass du das weißt)

Wobei man bei Rail to Rail OPs zwischen solchen unterscheiden muß, die 
nur am Eingang oder nur am Ausgang oder an Beiden an die Rails kommen.
Fazit: Datenblatt lesen, und dann nochmal Datenblatt lesen.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Lothar

Full Ack das mit den Datenblaettern.

Wie heist es doch so schoen "wer lesen kann ist eindeutig im Vorteil"

Gruss Helmi

Autor: kaisergollum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also irgend so nen scheiss hab ich mir schon gedacht....

also doch kein reiner rail-to-rail....

werd dann auch mal deinen vorschlag austesten, helmi.....

und erst mal einen vielen, lieben dank an alle für ihre unterstützung 
und hilfe, und schweiss und mühen und ausdauer mit mir :-)

ich werd euch berichten, wie die testläufe gelaufen sind

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Helmut Lenzen:

So ähnlich hätte ich das auch gemacht und evtl. R2+R3 (im Folgenden als
Einzelwiderstand betrachtet und R23 genannt) und die 0,5V-Quelle durch
einen Spannungsteiler zwischen der positiven Versorgungsspannung und
Masse ersetzt. Damit käme man mit 1 OPV und 4 Widerständen aus und
bräuchte kein Referenzspannungs-IC.

Voraussetzung ist natürlich, dass die Versorgungsspannung, die als
Ersatz für die Referenzspannungsquelle dient, ausreichend konstant ist.
Deswegen habe ich weiter oben nachgefragt, ob die Versorgungsspannung
stabilisiert sei.

In deiner Dimensionierung hat sich übrigens ein kleiner Fehler einge-
schlichen (oder ich habe falsch gerechnet): Bei 0mA Eingangsstrom stimmt
alles, bei 20mA komme ich aber nur auf 8V Ausgangsspannung. Folgendes
kam bei meiner Rechnung heraus:

  Uref = (10/21)V = 0,476V
  R4   = 21/4*R23 = 5,25*R23

Mit E12-Widerständen könnte man das in guter Näherung mit R4=33k und
R23=27k||8k2 realisieren.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@yalu

Stimmt du hast recht. Hatte mich da ein klein wenig verrechnet bei der 
Spannungsverstaerkung. Bin von 10V / 2V = 5 ausgegangen. Da aber dort 
noch 0.4V Offset von den 4mA anliegen muss man von einer Verstaerkung 
von 6.25 ausgehen.  10V/(2V-0.4V) = 6.25

Widerstaende und Uref wie du beschrieben hast.
Das mit dem Spannungsteiler und der Betriebsspannung kann man auch 
machen.

Gruss helmi

Autor: kaisergollum (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, hab es endlich geschafft mal ein wenig mit den OP's wieder 
rumzuspielen :-)

Und bevor ihr mir zuvorkommt: ich weiß ja das der Fehler meistens 
zwischen den ohren liegt.
So muss es wohl auch diesmal sein, den ich bekomme deine Schaltung, 
Helmi, nicht zum laufen :-(

Ich weiß nicht wo dran es liegt, aber am Ausgang regelt nix. Ich glaube 
langsam ich mach irgendwas mit den ganzen Massen verkehrt.
Hab ja im Grunde drei:
- die vom Stromwandler (siehe anhang)
- die von dem symetrischen (stabilisierten! ) Netzteil
- Und ne eigene Masse für den Ausgang???? Da mein Fehler???

Bin ja auch noch nicht ganz ab von meiner anderen Schaltung, da die 
andere ja leider nicht läuft :-(

Hab mir zu dem Zweck mal neue, echte, richtige(hoffentlich), 
vollständige usw Rail-to-Rail rausgesucht.
-AD 820
-LT 1490
-LT 1636

Was sagt die Fachschaft hier dazu????

Autor: GB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> - Und ne eigene Masse für den Ausgang???? Da mein Fehler???

Zitat --
Remarks

When generating a voltage bei insertion of R_M, the developed voltage 
will be floating with respect to zero volts. The output terminals must 
therefore not be grounded.

und im Abschnitt Electricla Data

Zitat --

R_Mmax Maximum measuring resistance 200 Ohm

Also im Klartext:

1. Der Ausgang darf bei Anschluss eines Messwiderstands nicht auf Masse 
bezogen werden --> Messung mit Differenzverstärker.

2. Der Messwiderstand muss <= 200 Ohm sein

Autor: kaisergollum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, erst mal Entwarnung.

Die Schaltung mit dem TS912 funktioniert volles rohr, wa :-)

Keine Ahnung wo letztes mal der Fehler lag. Vermute mal an dem ollen 
Steckboard. Hab heute mal ein anderes benutzt. Hab eine Genauigkeit von 
ca.1,5 % am Ende raus - ich denke das geht in Ordnung.

Werd mir trotzdem noch mal so ne anderen Rail's besorgen und meine 
ursprüngliche Schaltung testen damit - läßt mir irgendwie keine ruhe, 
und außerdem will man ja seinen Horizont erweitern :-)

Dennoch, vielen, vielen Dank für all die kompetenten und freundlichen 
Antworten.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ist ja schoen das es funktioniert.

Wenn du nur bis 5V arbeiten willst ist der OPA2340 ein schoener Rail To 
Rail

Aber du willst ja 10 V am Ausgang

Gruss Helmi

Autor: BMK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal den AD822 an.

Gibt's bei Angelika in DIP und SMD und hat durchweg
prima Werte.

Eben wenn man sich bei einem Testaufbau erstmal nicht
um irgendwelche schwachen Parameter kümmern will.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.