www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Taktfrequenz ATmega16-16PU


Autor: Ralph-Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mit welcher internen Frequenz läuft ein Fabrikneuer ATMega16-16PU?

Ich habe zwei Versuchsschaltungen aufbebaut, eine mit einem ATMega8535 
und eine mit einem ATMega16-16PU.
An beide Schaltungen ist ein Display DIP204 angeschlossen und benützen 
das gleiche Programm. Selbstverständlich habe ich im makefile den 
Prozessorname entsprechend geändert.
Leider bekomme ich das Diasplay auf dem ATMega16 nicht zum laufen.
Ich habe die verdrahtung auch schon mehrmal geprüft, konnte aber keinen 
Fehler feststellen.
Meine Vermutung ist, dass der ATMega16-16PU von hausaus mit einer 
anderen internen Frequenz arbeitet als der ATMega8535.

Für Eure Hilfe bedanke ich mich.

Ralph-Uwe

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

laufen beide mit 1MHz.
Beim Mega16 und Display am PortC: JTAG abschalten nicht vergessen...

Gruß aus Berlin
Michael

Autor: Ralph-Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok danke,

das habe ich mit sicherheit nicht gemacht, den das Display ist an PORTC 
angeschlossen.

Mit welchen Programm kann man das am besten machen?
Mit PonyProg und den FuseBits habe ich schon schlechte Erfahrung 
gemacht.
(habe schon 2 µC daduch geschrottet)

Gruß
Ralph-Uwe

Autor: Jean Player (fubu1000)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
geht auch über die Software mit: MCUCSR |= 0x80;
Pinbelegung im Code angepasst ? Poste mal deine Fusebits, dann sagen wir 
dir wie schnell der läuft, bzw. schau selber im Datenblatt nach.

Gruß

Autor: Stefan_KM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit PonyProg kann der Controller eigentlich nicht geschrottet werden.
In den meisten Fällten kann der Controller mit einem 1MHz Rechteck an 
XTAL1 ins Leben zurück geholt werden.

Autor: Ralph-Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bedanke mich für Eure Hilfe,
es hat alles geklappt, das Display läuft.

Ich werde die nächsten Tage mal versuchen die verfusten µC
wieder zum Laufen bringen.

Gruß
Ralph-Uwe

Autor: Ralph-Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dank eines Funktionsgenerator ist es mir gelungen,
die verfusten µC wieder zum laufen zu bringe.
Danke für die Tipps!


Ralph-Uwe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.