www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LM2575/UTC P3596-ADJ Problem mit Ausgangsspannung


Autor: Matthias S. (mat-sche)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin Moin!

Ich habe mir eine Schaltung aufgebaut, die mit einem LM2575 gedacht war 
und ich von Reichelt einen UTC P3596 bekommen habe. Jetzt habe ich das 
Problem, dass meine Ausgangsspannung lastabhängig ist und die 
gewünschten 5V bei unterschiedlichen Lasten nicht gehalten werden kann.
Was kann mein Problem sein?
Ach so: Eingangsspannung 12.5V

Danke und Gruß MAT

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Eingangsspannung ausreichend hoch ist, um auch unter Last die 
geforderte Ausgangsspannung zu liefern, dann dürfte wohl die interne 
Regelung im IC nicht funktionieren.
Es gab schon öfters Probleme mit diesem (oder ähnlichen Regler, 
ebenfalls von Reichelt, ich finde auf die schnelle den Thread aber 
nicht. Auf jedenfall lag es am Ende an dem IC, mit einem echten LM2575 
lief alles so wie es sollte.)

Autor: Matthias S. (mat-sche)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Benedikt,

das konnte ich mir denken, habe schon wie wild im Netz dazu gesucht. 
Werde jetzt Reichelt anschreiben und um Stellungnahme bitten.
Danke schon mal um Deine Antwort!
Werde dann nochmal etwas dazu schreiben.
MAT

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab gerade den anderen Thread gefunden:
Beitrag "Warum stimmt die Spannung nicht?"

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir scheinen die beiden Spulen (L3 und die andere 100uH) recht schwach 
auf der Brust.

Das Layout ist bestenfalls suboptimal (große Stromschleifen vom 
Eingangs-C zum Ausgangs-C). Das Layout im 
Beitrag "Re: Warum stimmt die Spannung nicht?" ist da schon 
wesentlich vielversprechender. I.A. gibt es im Datenblatt eines 
Schaltreglers einen Layoutvorschlag. Je weiter du davon wegkommst, umso 
unwahrscheinlicher ist es, dass dein Schaltregler funktioniert.

Autor: Matthias S. (mat-sche)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für Deine Antwort!
Das war mein erste Schaltung mit einem Schaltregler. Beim nächsten Mal 
werde ich es umdesignen... Nur komisch ist es schon, dass es so sehr vom 
Design ausgehen soll. Ich hatte vorher die Schaltung zum testen auf 
einer Lochrasterplatte aufgebaut und das mit kleinsten Abständen wie im 
Sheet beschrieben. Doch auch dort hatte ich das Problem mit der 
Ausgangsschwankungen.

MAT

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Doch auch dort hatte ich das Problem mit der Ausgangsschwankungen.
Welch Spule(n) hast du verwendet?
Welchen Strom willst du entnehmen?

Autor: Klauli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Schlatplan wäre wesentlich nützlicher als das Layout. Es ist zwar 
nicht wirklich nett von reichelt, die Regler einfach durch andere zu 
ersetzen, aber in Deinem fall liegt der Fehler ganz sicher an anderer 
Stelle!

Poste mal Deinen Schaltplan...

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und was benutzt du als Kondensatoren zum Beispiel?
Die 100µH Drossel ist eigentlich auch nicht dafür
geeignet wird wahrscheinlich eine A77 sein die bei
Reichelt verkauft wird, mit dieser habe ich nur
ganz schlechte Erfahrungen gemacht.


http://roboternetz.de/phpBB2/zeigebeitrag.php?p=424331

Es wäre ganz Angebracht wenn du beim nächsten mal auch
darauf verweisen würdest... .

Wenn du dich um 20mV aufregst dann bist du glaub ich
Verrückt und größenwahnsinnig.
Allein die Ripplespannung wird sehr wahrscheinlich diesen
Wert übersteigen.
Im Roboternetz wurden dazu gute Vorschläge gegeben.

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dem kann ich nur beipflichten! Ohne den Schaltplan oder die Bauteilewahl 
genauer unter die Lupe zu nehmen, kann ich jetzt schon bestätigen, daß 
er einige markante Fehler im Layout gemacht hat.
Das der vorherige Aufbau auf einer Lochrasterplatte kein bißchen besser 
war, kann ich mir durchaus vorstellen.

Autor: Klauli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, aber erst hier wichtig posten...und dann nix mehr von sich hören 
lassen. Nunja, dann eben nicht. Kümmer ich mich lieber um Leute, die 
wirklich Hilfe suchen.

Autor: Matthias S. (mat-sche)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
He Leute,

ganz ruhig! Schön das Ihr mir helft! Ich habe eben eine 14h Schicht 
hinter mir und bei mir auf Arbeit ist gerad die Kacke voll am dampfen!
Werde mich noch mal morgen, wenn ich es schaffe, melden und dann gibt es 
auch einen Schaltplan!
Also bis die Tage

Autor: Matthias S. (mat-sche)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Ihr's,

so da bin ich und gebe weitere Infos:
Als Kondensatoren 1500µF habe ich von Motherboards genommen, glaube das 
sind esr-Typen, für die Spule die von Reichelt High Current 
Funkentstördrossel, 100µ. Ansonsten sind es alles Standartbauteile. Ich 
versuche mal ne andere Spule zu nehmen und dann werde ich mal schauen!

Gruß MAT

Autor: Layouter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Layout ist !Scheisse! Wie dir schon in anderen Treads gesagt wurde.

Zeichne mal mit einem roten Farbstift in deinem Layout wo die Ströme 
fliessen. Beurteile dann wo deine C's sitzen. Wozu brauchst du die CMC?

Auf dem Thread im Roboternetz redest du von  ungefähr 20mV! Ich glaub 
die meisten hier sind zufrieden mit dem.
Bei deinem Layoutout ist das sicher mehr!
Von welchen Strömen redest du den?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Dein Layout ist !Scheisse!
Aus dem geposteten Schaltplan konnte nichts besseres werden :-/

@ Matthias S. (mat-sche)
Mir kämen da ein paar Fragen in den Sinn:
Ich gehe richtig in der Annahme, dass du dir kein Masse- und 
Versorgungskonzept überlegt hast? Warum erzeugst du so viele 
unterschiedliche 5V-Spannungen?

Die Siebelkos C4 und C10 sind für eine Stromentnahme im Bereich um 100mA 
ok (Faustformel: 1000µF pro Ampere). Aber mir scheint, du willst mehr 
:-/

Wozu brauchst du die Gleichtaktdrosseln?

Wieso betreibst du den einen Schalt-Transistor in Kollektor- den anderen 
in Emitterschaltung?

Punkte an Leiterbahnabzweigungen zeigen eine Verbindung an. Bei dir 
fehlen alle Verbindungspunkte an den "T"-Verbindungen. Das macht den 
Schaltplan sehr schlecht lesbar.

Die Reset-Beschaltung um IC2/IC3 könntest du genausogut mit einem 
RC-Glied erschlagen.

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn es tatsächlich nur 20mV bei Last sind
dann ist es doch völlig egal.
Nachdem man sich deinen Schaltplan angeschaut
hat wird klar das du das ganze Konzept noch weiter
überarbeiten musst.

Es ist fraglich wofür die ganzen Regler benötigt werden.
An einigen Stellen überdimensionierst du maßgeblich
und bei den Siebelkos nach den Brückengleichrichtern
wird völlig gespart.

Autor: Matthias S. (mat-sche)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Lothar,

>Mir kämen da ein paar Fragen in den Sinn:
Ich gehe richtig in der Annahme, dass du dir kein Masse- und
Versorgungskonzept überlegt hast? Warum erzeugst du so viele
unterschiedliche 5V-Spannungen?

Also.... die ersten 5V nehme ich zur Versorgung meiner Schaltungen.
Die zweite Spannungsstabilisierung habe ich erst einmal so vorgesehen 
und werde sie im Moment nicht benutzen.

>Die Siebelkos C4 und C10 sind für eine Stromentnahme im Bereich um 100mA
ok (Faustformel: 1000µF pro Ampere). Aber mir scheint, du willst mehr
:-/

Die Elkos habe ich nach dem Datenblatt von National genommen. Vielleicht 
habe ich das nicht so recht verstanden wofür dieser da ist.

>Wozu brauchst du die Gleichtaktdrosseln?

Diese habe ich zur Siebung mit reingenommen. Habe jetzt mal ein Paar 
Bilder oszilloskopiert. Dort habe ich die Schaltung mal unter Last vor 
und hinter der Schaltung aufgenommen.
Habe eine ohmsche Last dran: 670mA, Vout = 4,8V/ 970mA, Vout = 4,6V, 
Lehrlaufspannung 5,05V.

>Wieso betreibst du den einen Schalt-Transistor in Kollektor- den anderen
in Emitterschaltung?

Ups... das wahr ein Fehler von mir....fuk...

>Die Reset-Beschaltung um IC2/IC3 könntest du genausogut mit einem
RC-Glied erschlagen.

Na ja... könnte man(n), hatte hin und her überlegt und das IC hatte ich 
noch da. So brauche ich mir keine weiteren Sorgen machen (wenn es 
funktioniert :) )

@ Layouter:
Danke für Deine derben Worte!
Vielleicht kannst Du hiermit mehr anfangen. Der Schaltregler soll lt. 
Datenblatt 3A bringen, soviel werde ich sicherlich nicht benötigen...

Autor: Matthias S. (mat-sche)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und hier mit Last vor Drossel

Autor: Matthias S. (mat-sche)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier eins mit Last aber ohne die Drossel...

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist doch gar nicht mal so schlecht wobei sich garantiert
sich noch was machen lässt ;)
Du solltest alle Stromwege verkürzen ein neues Layout erstellen
und eine großzügie Masse miteinplanen.
Ersetze die A77 Funktenstördrossel durch einen guten
größeren Ringkernspeicherdrossel.
Selberwickeln ist gar nicht mal so schwer.
Als Filterdrossel nimmst du auch eine gute gewickelte
Drossel wie im Datenblatt von LM empfohlen wird.
Beides lässt sich mit den TO-80-26 Ringkern
von Amidon realiesieren.Wickel mehrere
Drähte parrallel um den Kupferwiderstand kleinzuhalten.
Halte auch die Leistungwege von der Diode - LM2576 Output
und der Spule so klein wie möglich durch einen gezielten aufbau
lassen sich diese Wege sehr klein halten.

Könnte man vielleicht ein Bild von den Aufbau
sehen damit man abschätzen kann wie die mechanische
verarbeitung aussieht?



Zu den Oszi bildern kann ich schlecht was zu sagen
da ich dazu relativ wenig Erfahrung habe
da ich erst seid neusten erst ein Oszi besitze.

Autor: Matthias S. (mat-sche)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ein Bild vom Aufbau.
@Der Gast:
welche Spule meinst Du jetzt? Die für den Schaltregler? Ich habe einige 
Kerne zum selberwickeln da, nur leider habe ich kein Messgerät um die 
Induktivität zu messen. Gib mir mal nen Tip wie ich die Induktivität 
dann heraus bekommen kann?
Ansonsten läuft die Schaltung mit meinen anderen Schaltungen zusammen 
und die Ausgangsspannung bleibt auch stabil.
Bei meiner nächsten Netzteilschaltung werde ich die Hinweise mit 
beachten!

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Schaltregler soll lt. Datenblatt 3A bringen,
Aber deine Speicherdrossel (die 100uH) ist bei 1 A schon am Anschlag.
Wie warm wird/werden die?

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spulen müssen nicht genau sein.
Wichtig ist nur das sie genug Speicherkönnen,
der CuWiderstand klein ist und der Kern nicht
in Sättigung gerät.

Die Elkos sind ja vom Motherboard..wie alt ist den
dieses Motherboard und von was für einen Hersteller
sind diese Elkos? ( tippe auf Teapo )
Die Elkos werden auf PC Motherboards bis oben
hin belastet und es wäre denkbar das diese nicht
mehr die besten sind.

So sehen vernüftige Speicherdrosseln aus:
http://www.bilder-upload.eu/show.php?file=5h0lsmyb...

Oben eine passende Filterspule und rechts und links
eine Speicherdrossel für den Regler.

Damit habe ich in Kombination mit den LM2576 gute Erfahrungen
gemacht.

Googel mal nach "Ringkernrechner" das macht
alles ziemlich einfach.
Ein Messgerät für Induktivität habe ich leider
auch nicht.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bei meiner nächsten Netzteilschaltung werde ich die Hinweise mit
> beachten!
Hast du dein Design mit der WebBench von National Semiconductor 
berechnet? Dort werden dann auch gleich Bauteilvorschläge angegeben. Bei 
mir ist bisher jedes dieser Designs auf Anhieb gelaufen.

Autor: Matthias S. (mat-sche)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  A. K. (prx)

na wie klasse ist denn dieser Beitrag von dir.....
Vielleicht ist es besser du interessierst Dich fürs Thema und nicht für 
Bildchen...
ohne Worte!

Autor: Matthias S. (mat-sche)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Der Gast ,

danke für Deine Tips!
Jup, mit den Elkos hast Du ins Schwarze getroffen! Werden sicherlich 
etwas alt sein. Nächste Woche wird ne Spule gebastelt und aufs neue 
probiert!
Melde MICH DANN ZURÜCK!

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Jup, mit den Elkos hast Du ins Schwarze getroffen!
> Werden sicherlich etwas alt sein.
Ja klar, sicher, was sonst?
Vor allem sind die Eingangselkos zu klein (die 100uF am Eingang)  ;-)
Das solltest du aber selber in deinen Oszi-Bildchen sehen
(Zyklus dort 10ms = 100 Hz = gleichgerichtete 50 Hz).

> Nächste Woche wird ne Spule gebastelt und aufs neue probiert!
Viel Spass, das ist eine Wissenschaft für sich. Speicherdrosseln kaufst 
du am besten fertig z.B. bei Würth, Coilcraft, Coiltronics, TDK...
Oder probiers mit was in der Art: Reichelt FED 100µ :: 
Funk-Entstördrossel, 50 Windungen, 100µ.
Wenn du trotzdem meinst, du kannst das besser, dann nimm einen großen 
Kern, damit der nicht in die Sättigung kommt (besser zu groß, als zu 
klein).

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du müsstest aber nicht nur die Elkos
und die Spulen austauschen sondern auch dein gesamtes Layout viel 
kleiner
machen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.