www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik GPS-Modul Navilock NL-552ETTL (ublox5)


Autor: Der verrückte Professor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich würde mir gerne zum Basteln ein GPS-Modul anschaffen.
Habe mir dazu das Modul NL-552ETTL von Navilock angeschaut.

http://www.navilock.de/produkte/gruppen/13/Boards_...

Habe nun aber eine Frage dazu, werden die Daten Seriell ausgegeben? Bzw. 
kann ich das Modul direkt an den UART des uPCs anschließen? Oder brauche 
ich dazu das RS232 Modul?


Danke

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du noch den Typ deines uPCs verrätst, könnten wir dir auch helfen. 
Mikrocontroller mit TTL-Pegel (5V) kein Problem, fürn richtigen PC 
brauchst du das RS232 Modul.

Autor: Max Power (eizo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steht doch alles unter Technische Details. Im zweifelsfall einfach eine 
Mail an Support schreiben.

Schnittstelleneigenschaften
3,3 Volt TTL Pegel
Baudrate: 38.400 bps
Ausgangsprotokoll: NMEA 0183 GGA, GSA, GSV, RMC, VTG

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

> Bzw. kann ich das Modul direkt an den UART des uPCs anschließen? Oder
>brauche ich dazu das RS232 Modul?

Unter Schnittstelleneigenschaften steht:

3,3 Volt TTL Pegel
Baudrate: 38.400 bps

>Habe nun aber eine Frage dazu, werden die Daten Seriell ausgegeben?

Ja.

> Bzw. kann ich das Modul direkt an den UART des uPCs anschließen? Oder
>brauche ich dazu das RS232 Modul?

Wenn dein Controller mit 3,3V läuft brauchst du gar nichts. Ansonsten 
ist ein Pegelwandler 3,3V nach 5V angebracht.

MfG Spess

Autor: Der verrückte Professor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mahlzeit,
nur falls es jemanden interessiert.
Hab bemerkt dass dass Modul noch garnicht lieferbar ist.
Hab deshalb das da gekauft: Navilock NL-550ERS

ELV-Bestellnummer: 68-825-82 Preis: 34,95Euro.

Das schönste ist, es ist Galileo kompatibel und kann durch ein 
Firmwareupdate upgedatet werden...

MfG
Der verrückte Professor

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>  Das schönste ist, es ist Galileo kompatibel und kann durch ein
>  Firmwareupdate upgedatet werden...

da watte mal drauf   ;-)))

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>>  Das schönste ist, es ist Galileo kompatibel und kann durch ein
>>  Firmwareupdate upgedatet werden...

>da watte mal drauf   ;-)))

Stimmt. Bis dahin ist das Teil wahrscheinlich hoffnungslos veraltet.

MfG Spess

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hab bemerkt dass dass Modul noch garnicht lieferbar ist.
> Hab deshalb das da gekauft: Navilock NL-550ERS

> ELV-Bestellnummer: 68-825-82 Preis: 34,95Euro.

es ist nur ein unterschied in der Bestückung.

ich hätte die USB-Variante gewählt, und könnte zusätzlich an den
Widerständen R19, R20,  das RS232-TTL-Signal abgreifen.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jürgen,

hast du einen Schaltplan zu dem Modul, da du von den beiden Widerständen 
sprechen kannst? Ich habe nur eine einfache Anleitung bezüglich der 
Bestückung gefunden.

Gruß
Christoph

Autor: Peter K. (ucpeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
hat von euch jemand Erfahrung mit der Ansteuerung (Configchange) des 
NL-552ETTL? Das Modul schaltet per Default auf 38k4 und sendet per 4Hz 
GSA, GSV, GLL, RMC, VTG und GGA.
Dennoch möchte ich gern per Config definieren welche Datenstrings es mir 
übermittelt, da ich den "Overhead" nicht wirklich benötige.
Problem:
Auch wenn ich das im U-Blox zu entnehmende Datentelegramm per 
(ebenfalls) 38k4 baudrate absende, erhalte ich keine Reaktion vom 
552ETTL.

Als Referenzinfo verwendete ich neben dem Datenblatt folgenden Link und 
Befehlssequenz:
Beitrag "U-Blox Problem mit UBX CFG-MSG Set"

Egal welche Kombinationen (auch in ASCII od. Hex) ich probiere, das 
Modul antwortet einfach nicht. Hätte wenigstens ein NAK erwartet.
Physikalisch ist alles in Ordnung, 3,3V Pegel per Spannungsteiler vom 
MAX232 liegt am RX IN vom 552. TX seitig alles i.O., das Modul sprudelt 
die Daten an den Host. Nur eben keine Antwort auf eine Request.

Was mache ich falsch?

Grüsse, Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.