www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Komperator-Konstantstromquelle schwingt


Autor: Philipp (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin,
ich habe vor diese: 
http://www.mikrocontroller.net/articles/Konstantst... 
Konstantstromquelle nach zu bauen und habe sie deshalb mit LTSpice 
einmal simuliert.
Die Spannungsquellen liefern folgende Spannungen:
V1 = 0.35V
V2 = 12V
V3 = 5V PWM, 2ms on, 5ms Periode, beginnt 2ms nach Simulationsbeginn

Mein Problem ist nun, dass, wie auf dem Bild zu sehen ist, die Regelung 
anfängt zu schwingen, sobald das PWM Signal einsetzt.
Kann mir jemand erklären, woran das liegen könnte? Und vielleicht auch, 
wie ich das verhindern kann?

philipp

: Verschoben durch Admin
Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Der blaue Graph ist die Stromstärke über R3, der Grüne die 
Spannung von V3

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich wuerd mal den (-) und den (+) Eingang des 1006 vertauschen

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keine Gute Idee, dann hab ich an R3 nur noch so zwischen -20 bis +110pA. 
Gibt aber lustige Muster im Graphen ;)

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komparator ohne Hysterese?
Wie soll damit ein Hystereseregler gebaut werden?
Klar schwingt der, weil er in Analogbetrieb geht.
Der MOSFET ist doch viel zu langsam.

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ding ist auch viel näher an einem schaltregler mit strombegrenzung 
dran als an einer konstantstromquelle.

Autor: Egal (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben, daß ist ja der Sinn.

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist mir schon klar, aber da braucht er sich nicht über die 
schwingung dessen wundern - anders gehts nämlich nicht.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Allerdings nicht DIESE Schwingung.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Philipp,

ich habe deine Schaltung mal mit TINA simuliert und da gibt es keine 
Schwingung. Allerdings ist dem Strom durch R3 ein Sägezahnripple 
überlagert, dessen Amplitude um so kleiner und höherfrequent wird, je 
schneller der OPamp ist. Ich denke mal, daß du einen deutlich 
schnelleren OPamp als den superlangsamen LT1006 ausprobieren solltest, 
besser noch gleich einen Komparator.

Eine Modulation des Stroms durch R3 via Q1 gemäß deiner Schaltung 
scheint allerdings nicht zu funktionieren.

Kai Klaas

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der ripplestrom ist normal bei einer getakteten stromquelle, die ein 
kastriertes schaltnetzteil ist.

einen zu schnellen OP würd ich nicht nehmen, sonst schwingt das ganze zu 
hochfrequent und der opamp könnte glatt an den umladeverlusten der 
gatekapazität des FET sterben.

vielleicht doch einen TL494 für die ganze sache nehmen, den könnte man 
dann wunderbar über seinen zweiten fehlerverstärker abschalten (per PWM 
takten), den ersten braucht man für die stromregelung. und man bekommt 
sogar noch eine feste betriebsfrequenz.

Autor: BMK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sagt mal, bei der genannten Schaltung
http://www.mikrocontroller.net/articles/Konstantst...
scheint ein Fehler drin zu stecken.

Die Z-Diode D6 müsste doch parallel zu G - S liegen,
um Vgs auf max. 12V einzubremsen. Also hier beim P-Kanal
von +Ub nach G und nicht von G nach GND.

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da hat er recht, aber noch optimaler wäre es wenn sie bereits in der 
basis-ansteuerung des treibers liegen würde, damit dieser gar nicht erst 
weiter als 12V unter Ub ziehen kann. bei dieser umsetzung fehlt dann 
aber auch noch ein widerstand am ausgang des OPV sonst zerfetzt es den 
wenn die Z-diode leitend wird.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Ben,

>einen zu schnellen OP würd ich nicht nehmen, sonst schwingt das ganze zu
>hochfrequent und der opamp könnte glatt an den umladeverlusten der
>gatekapazität des FET sterben.

Also, einen Komparator und MOSFET-Treiber des Originals durch einen 
langsamen und schwachen LT1006 zu ersetzen, ist aber auch nicht der 
wahre Jakob...

Kai Klaas

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, danke. Ich werd noch ein paar Bauteile durchprobieren. Mal sehen 
wie's dann klappt.
Mich hat hauptsächlich irritiert, dass die Schwingungen erst anfangen, 
wenn das PWM-Signal einsätzt.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallp Philipp,

>Mich hat hauptsächlich irritiert, dass die Schwingungen erst anfangen,
>wenn das PWM-Signal einsätzt.

Vielleicht sind die Schwingungen ja auch ein Artefakt der Simulation? 
Irgend ein Parameter nicht richtig eingestellt?

Kai Klaas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.